Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
circular dependencies? WTF
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Duplicate Threads
View previous topic :: View next topic  
Author Message
nebula8080
n00b
n00b


Joined: 15 Feb 2005
Posts: 6

PostPosted: Sat Feb 17, 2007 4:26 am    Post subject: circular dependencies? WTF Reply with quote

WTF happened to portage. I knew I should have waited for RHEL5......

Code:
nebula ~ # emerge gnome
Calculating dependencies... done!
!!! Error: circular dependencies:

('ebuild', '/', 'gnome-base/gnome-desktop-2.16.2', 'merge') depends on
   ('ebuild', '/', 'gnome-base/libgnomeui-2.16.1', 'merge') (hard)
   ('ebuild', '/', 'gnome-base/gnome-vfs-2.16.3', 'merge') (hard)
('ebuild', '/', 'mail-client/evolution-2.8.2.1', 'merge') depends on
   ('ebuild', '/', 'gnome-extra/evolution-data-server-1.8.2', 'merge') (hard)
   ('ebuild', '/', 'gnome-base/gnome-vfs-2.16.3', 'merge') (hard)
   ('ebuild', '/', 'gnome-base/libgnome-2.16.0', 'merge') (hard)
   ('ebuild', '/', 'gnome-base/libbonoboui-2.16.0', 'merge') (hard)
   ('ebuild', '/', 'gnome-extra/gtkhtml-3.12.2', 'merge') (hard)
   ('ebuild', '/', 'gnome-base/libgnomeui-2.16.1', 'merge') (hard)
   ('ebuild', '/', 'sys-apps/hal-0.5.7.1-r3', 'merge') (hard)
   ('ebuild', '/', 'app-text/gnome-spell-1.0.7-r1', 'merge') (hard)
('ebuild', '/', 'gnome-base/control-center-2.16.2', 'merge') depends on
   ('ebuild', '/', 'gnome-base/gnome-vfs-2.16.3', 'merge') (hard)
   ('ebuild', '/', 'gnome-base/nautilus-2.16.3', 'merge') (hard)
   ('ebuild', '/', 'gnome-base/libbonoboui-2.16.0', 'merge') (hard)
   ('ebuild', '/', 'gnome-base/libgnome-2.16.0', 'merge') (hard)
   ('ebuild', '/', 'gnome-base/libgnomeui-2.16.1', 'merge') (hard)
   ('ebuild', '/', 'sys-apps/hal-0.5.7.1-r3', 'merge') (hard)
   ('ebuild', '/', 'gnome-base/gnome-desktop-2.16.2', 'merge') (hard)
   ('ebuild', '/', 'gnome-base/gnome-menus-2.16.1', 'merge') (hard)
('ebuild', '/', 'gnome-base/gdm-2.16.4', 'merge') depends on
   ('ebuild', '/', 'gnome-base/libgnome-2.16.0', 'merge') (hard)
   ('ebuild', '/', 'gnome-base/libgnomeui-2.16.1', 'merge') (hard)
   ('ebuild', '/', 'x11-libs/gksu-2.0.0', 'merge') (hard)
   ('ebuild', '/', 'gnome-base/librsvg-2.16.1', 'merge') (hard)
('ebuild', '/', 'gnome-extra/libgsf-1.14.2', 'merge') depends on
   ('ebuild', '/', 'gnome-base/gnome-vfs-2.16.3', 'merge') (hard)
   ('ebuild', '/', 'media-gfx/imagemagick-6.3.0.5', 'merge') (hard)
('ebuild', '/', 'media-video/totem-2.16.4', 'merge') depends on
   ('ebuild', '/', 'gnome-base/gnome-vfs-2.16.3', 'merge') (hard)
   ('ebuild', '/', 'gnome-base/nautilus-2.16.3', 'merge') (hard)
   ('ebuild', '/', 'gnome-base/gnome-desktop-2.16.2', 'merge') (hard)
   ('ebuild', '/', 'gnome-base/libgnomeui-2.16.1', 'merge') (hard)
   ('ebuild', '/', 'media-libs/xine-lib-1.1.3', 'merge') (hard)
   ('ebuild', '/', 'sys-apps/hal-0.5.7.1-r3', 'merge') (hard)
   ('ebuild', '/', 'www-client/mozilla-firefox-2.0.0.1', 'merge') (hard)
('ebuild', '/', 'x11-libs/gtksourceview-1.8.1', 'merge') depends on
   ('ebuild', '/', 'gnome-base/gnome-vfs-2.16.3', 'merge') (hard)
('ebuild', '/', 'gnome-extra/libgda-1.2.3', 'merge') depends on
   ('ebuild', '/', 'app-office/mdbtools-0.5', 'merge') (hard)
('ebuild', '/', 'gnome-base/gnome-2.16.2', 'merge') depends on
   ('ebuild', '/', 'app-arch/file-roller-2.16.2', 'merge') (medium)
   ('ebuild', '/', 'gnome-base/libgnome-2.16.0', 'merge') (medium)
   ('ebuild', '/', 'gnome-base/gnome-desktop-2.16.2', 'merge') (medium)
   ('ebuild', '/', 'gnome-base/gnome-volume-manager-2.15.0-r1', 'merge') (medium)
   ('ebuild', '/', 'gnome-base/control-center-2.16.2', 'merge') (medium)
   ('ebuild', '/', 'net-im/ekiga-2.0.3', 'merge') (medium)
   ('ebuild', '/', 'app-admin/pessulus-2.16.1', 'merge') (medium)
   ('ebuild', '/', 'gnome-base/gnome-menus-2.16.1', 'merge') (medium)
   ('ebuild', '/', 'gnome-base/libbonoboui-2.16.0', 'merge') (medium)
   ('ebuild', '/', 'app-admin/sabayon-2.12.4', 'merge') (medium)
   ('ebuild', '/', 'gnome-base/gnome-applets-2.16.2', 'merge') (medium)
   ('ebuild', '/', 'media-video/totem-2.16.4', 'merge') (medium)
   ('ebuild', '/', 'gnome-extra/fast-user-switch-applet-2.16.0', 'merge') (medium)
   ('ebuild', '/', 'app-text/evince-0.6.1-r1', 'merge') (medium)
   ('ebuild', '/', 'gnome-extra/deskbar-applet-2.16.2-r1', 'merge') (medium)
   ('ebuild', '/', 'x11-libs/gtksourceview-1.8.1', 'merge') (medium)
   ('ebuild', '/', 'gnome-extra/gconf-editor-2.16.0', 'merge') (medium)
   ('ebuild', '/', 'gnome-extra/gnome-media-2.16.1', 'merge') (medium)
   ('ebuild', '/', 'gnome-base/gnome-session-2.16.2', 'merge') (medium)
   ('ebuild', '/', 'gnome-extra/gnome-power-manager-2.16.2', 'merge') (medium)
   ('ebuild', '/', 'app-admin/gnome-system-tools-2.14.0', 'merge') (medium)
   ('ebuild', '/', 'media-sound/sound-juicer-2.16.2', 'merge') (medium)
   ('ebuild', '/', 'gnome-extra/gcalctool-5.8.25', 'merge') (medium)
   ('ebuild', '/', 'app-editors/gedit-2.16.2-r1', 'merge') (medium)
   ('ebuild', '/', 'media-gfx/eog-2.16.2', 'merge') (medium)
   ('ebuild', '/', 'net-analyzer/gnome-netstatus-2.12.0', 'merge') (medium)
   ('ebuild', '/', 'x11-misc/alacarte-0.10.1-r1', 'merge') (medium)
   ('ebuild', '/', 'mail-client/evolution-2.8.2.1', 'merge') (medium)
   ('ebuild', '/', 'gnome-extra/evolution-data-server-1.8.2', 'merge') (medium)
   ('ebuild', '/', 'gnome-base/eel-2.16.3', 'merge') (medium)
   ('ebuild', '/', 'gnome-base/libgnomeui-2.16.1', 'merge') (medium)
   ('ebuild', '/', 'net-print/gnome-cups-manager-0.31-r2', 'merge') (medium)
   ('ebuild', '/', 'gnome-extra/evolution-webcal-2.8.0', 'merge') (medium)
   ('ebuild', '/', 'gnome-extra/gnome-utils-2.16.2-r2', 'merge') (medium)
   ('ebuild', '/', 'gnome-base/gdm-2.16.4', 'merge') (medium)
   ('ebuild', '/', 'www-client/epiphany-2.16.2', 'merge') (medium)
   ('ebuild', '/', 'gnome-base/nautilus-2.16.3', 'merge') (medium)
   ('ebuild', '/', 'net-analyzer/gnome-nettool-2.16.0', 'merge') (medium)
   ('ebuild', '/', 'gnome-extra/gnome-keyring-manager-2.16.0-r1', 'merge') (medium)
   ('ebuild', '/', 'gnome-extra/yelp-2.16.2', 'merge') (medium)
   ('ebuild', '/', 'net-misc/vino-2.16.0-r1', 'merge') (medium)
   ('ebuild', '/', 'gnome-extra/nautilus-cd-burner-2.16.2', 'merge') (medium)
   ('ebuild', '/', 'gnome-extra/bug-buddy-2.16.0', 'merge') (medium)
   ('ebuild', '/', 'gnome-extra/gnome-screensaver-2.16.2', 'merge') (medium)
   ('ebuild', '/', 'gnome-base/gnome-vfs-2.16.3', 'merge') (medium)
   ('ebuild', '/', 'gnome-extra/gtkhtml-3.12.2', 'merge') (medium)
   ('ebuild', '/', 'gnome-base/gnome-panel-2.16.2', 'merge') (medium)
   ('ebuild', '/', 'gnome-extra/gnome-games-2.16.2', 'merge') (medium)
   ('ebuild', '/', 'gnome-extra/gnome-system-monitor-2.16.1', 'merge') (medium)
   ('ebuild', '/', 'gnome-base/librsvg-2.16.1', 'merge') (medium)
   ('ebuild', '/', 'gnome-extra/gucharmap-1.8.0', 'merge') (medium)
   ('ebuild', '/', 'x11-terms/gnome-terminal-2.16.1', 'merge') (medium)
('ebuild', '/', 'gnome-extra/evolution-data-server-1.8.2', 'merge') depends on
   ('ebuild', '/', 'gnome-base/gnome-vfs-2.16.3', 'merge') (hard)
   ('ebuild', '/', 'gnome-base/libgnome-2.16.0', 'merge') (hard)
   ('ebuild', '/', 'gnome-base/libgnomeui-2.16.1', 'merge') (hard)
('ebuild', '/', 'media-gfx/graphviz-2.8-r2', 'merge') depends on
   ('ebuild', '/', 'dev-lang/swig-1.3.31', 'merge') (hard)
('ebuild', '/', 'gnome-base/gnome-session-2.16.2', 'merge') depends on
   ('ebuild', '/', 'gnome-base/gnome-desktop-2.16.2', 'merge') (hard)
   ('ebuild', '/', 'gnome-base/libgnomeui-2.16.1', 'merge') (hard)
   ('ebuild', '/', 'gnome-base/control-center-2.16.2', 'merge') (hard)
('ebuild', '/', 'media-plugins/gst-plugins-gnomevfs-0.10.11', 'merge') depends on
   ('ebuild', '/', 'gnome-base/gnome-vfs-2.16.3', 'merge') (hard)
('ebuild', '/', 'gnome-extra/evolution-webcal-2.8.0', 'merge') depends on
   ('ebuild', '/', 'gnome-extra/evolution-data-server-1.8.2', 'merge') (hard)
   ('ebuild', '/', 'gnome-base/libgnomeui-2.16.1', 'merge') (hard)
('ebuild', '/', 'gnome-extra/nautilus-cd-burner-2.16.2', 'merge') depends on
   ('ebuild', '/', 'gnome-base/gnome-vfs-2.16.3', 'merge') (hard)
   ('ebuild', '/', 'gnome-base/libgnome-2.16.0', 'merge') (hard)
   ('ebuild', '/', 'gnome-base/nautilus-2.16.3', 'merge') (hard)
   ('ebuild', '/', 'app-cdr/dvd+rw-tools-7.0', 'merge') (hard)
   ('ebuild', '/', 'gnome-base/eel-2.16.3', 'merge') (hard)
   ('ebuild', '/', 'app-cdr/cdrkit-1.0', 'merge') (hard)
   ('ebuild', '/', 'sys-apps/hal-0.5.7.1-r3', 'merge') (hard)
   ('ebuild', '/', 'gnome-base/gnome-mount-0.4-r5', 'merge') (hard)
('ebuild', '/', 'net-analyzer/gnome-nettool-2.16.0', 'merge') depends on
   ('ebuild', '/', 'app-admin/gnome-system-tools-2.14.0', 'merge') (medium)
('ebuild', '/', 'gnome-extra/gnome-system-monitor-2.16.1', 'merge') depends on
   ('ebuild', '/', 'gnome-base/gnome-vfs-2.16.3', 'merge') (hard)
   ('ebuild', '/', 'gnome-base/libgnome-2.16.0', 'merge') (hard)
   ('ebuild', '/', 'gnome-base/libgnomeui-2.16.1', 'merge') (hard)
('ebuild', '/', 'dev-python/gnome-python-extras-2.14.0-r1', 'merge') depends on
   ('ebuild', '/', 'gnome-extra/gtkhtml-2.6.3', 'merge') (hard)
   ('ebuild', '/', 'gnome-extra/libgda-1.2.3', 'merge') (hard)
   ('ebuild', '/', 'www-client/mozilla-firefox-2.0.0.1', 'merge') (hard)
   ('ebuild', '/', 'dev-python/gnome-python-2.16.2', 'merge') (hard)
('ebuild', '/', 'media-libs/xine-lib-1.1.3', 'merge') depends on
   ('ebuild', '/', 'gnome-base/gnome-vfs-2.16.3', 'merge') (hard)
   ('ebuild', '/', 'media-sound/pulseaudio-0.9.5-r4', 'merge') (hard)
('ebuild', '/', 'gnome-extra/gtkhtml-3.12.2', 'merge') depends on
   ('ebuild', '/', 'gnome-base/libgnomeui-2.16.1', 'merge') (hard)
   ('ebuild', '/', 'gnome-base/libbonoboui-2.16.0', 'merge') (hard)
('ebuild', '/', 'gnome-extra/gnome-games-2.16.2', 'merge') depends on
   ('ebuild', '/', 'gnome-base/gnome-vfs-2.16.3', 'merge') (hard)
   ('ebuild', '/', 'gnome-base/libgnome-2.16.0', 'merge') (hard)
   ('ebuild', '/', 'gnome-base/libgnomeui-2.16.1', 'merge') (hard)
   ('ebuild', '/', 'gnome-base/librsvg-2.16.1', 'merge') (hard)
('ebuild', '/', 'app-office/mdbtools-0.5', 'merge') depends on
   ('ebuild', '/', 'gnome-base/libgnomeui-2.16.1', 'merge') (hard)
('ebuild', '/', 'app-arch/file-roller-2.16.2', 'merge') depends on
   ('ebuild', '/', 'gnome-base/gnome-vfs-2.16.3', 'merge') (hard)
   ('ebuild', '/', 'gnome-base/libgnome-2.16.0', 'merge') (hard)
   ('ebuild', '/', 'gnome-base/nautilus-2.16.3', 'merge') (hard)
   ('ebuild', '/', 'gnome-base/libbonoboui-2.16.0', 'merge') (hard)
   ('ebuild', '/', 'gnome-base/libgnomeui-2.16.1', 'merge') (hard)
('ebuild', '/', 'gnome-base/libgnome-2.16.0', 'merge') depends on
   ('ebuild', '/', 'gnome-base/gnome-vfs-2.16.3', 'merge') (hard)
('ebuild', '/', 'app-text/gnome-spell-1.0.7-r1', 'merge') depends on
   ('ebuild', '/', 'gnome-base/libgnome-2.16.0', 'merge') (hard)
   ('ebuild', '/', 'gnome-base/libbonoboui-2.16.0', 'merge') (hard)
('ebuild', '/', 'media-gfx/eog-2.16.2', 'merge') depends on
   ('ebuild', '/', 'gnome-base/gnome-vfs-2.16.3', 'merge') (hard)
   ('ebuild', '/', 'gnome-base/gnome-desktop-2.16.2', 'merge') (hard)
   ('ebuild', '/', 'gnome-base/libgnomeui-2.16.1', 'merge') (hard)
('ebuild', '/', 'gnome-base/gnome-menus-2.16.1', 'merge') depends on
   ('ebuild', '/', 'gnome-base/gnome-vfs-2.16.3', 'merge') (hard)
('ebuild', '/', 'media-plugins/libao-pulse-0.9.3', 'merge') depends on
   ('ebuild', '/', 'media-sound/pulseaudio-0.9.5-r4', 'merge') (medium)
('ebuild', '/', 'gnome-extra/gnome-media-2.16.1', 'merge') depends on
   ('ebuild', '/', 'gnome-base/gnome-vfs-2.16.3', 'merge') (hard)
   ('ebuild', '/', 'gnome-extra/nautilus-cd-burner-2.16.2', 'merge') (hard)
   ('ebuild', '/', 'gnome-base/libgnomeui-2.16.1', 'merge') (hard)
('ebuild', '/', 'www-client/epiphany-2.16.2', 'merge') depends on
   ('ebuild', '/', 'gnome-base/gnome-vfs-2.16.3', 'merge') (hard)
   ('ebuild', '/', 'gnome-base/libgnome-2.16.0', 'merge') (hard)
   ('ebuild', '/', 'gnome-base/gnome-desktop-2.16.2', 'merge') (hard)
   ('ebuild', '/', 'gnome-base/libgnomeui-2.16.1', 'merge') (hard)
   ('ebuild', '/', 'www-client/mozilla-firefox-2.0.0.1', 'merge') (hard)
   ('ebuild', '/', 'dev-python/gnome-python-2.16.2', 'merge') (hard)
('ebuild', '/', 'media-sound/sound-juicer-2.16.2', 'merge') depends on
   ('ebuild', '/', 'gnome-base/gnome-vfs-2.16.3', 'merge') (hard)
   ('ebuild', '/', 'gnome-extra/nautilus-cd-burner-2.16.2', 'merge') (hard)
   ('ebuild', '/', 'gnome-base/libgnomeui-2.16.1', 'merge') (hard)
   ('ebuild', '/', 'media-plugins/gst-plugins-gnomevfs-0.10.11', 'merge') (hard)
   ('ebuild', '/', 'gnome-extra/gnome-media-2.16.1', 'merge') (hard)
('ebuild', '/', 'media-sound/pulseaudio-0.9.5-r4', 'merge') depends on
   ('ebuild', '/', 'sys-apps/hal-0.5.7.1-r3', 'merge') (hard)
('ebuild', '/', 'net-analyzer/gnome-netstatus-2.12.0', 'merge') depends on
   ('ebuild', '/', 'gnome-base/libgnomeui-2.16.1', 'merge') (hard)
   ('ebuild', '/', 'gnome-base/gnome-panel-2.16.2', 'merge') (hard)
('ebuild', '/', 'app-admin/sabayon-2.12.4', 'merge') depends on
   ('ebuild', '/', 'dev-python/gnome-python-2.16.2', 'merge') (medium)
('ebuild', '/', 'net-print/gnome-cups-manager-0.31-r2', 'merge') depends on
   ('ebuild', '/', 'gnome-base/libgnomeui-2.16.1', 'merge') (hard)
   ('ebuild', '/', 'gnome-base/libgnome-2.16.0', 'merge') (hard)
   ('ebuild', '/', 'x11-libs/gksu-2.0.0', 'merge') (medium)
('ebuild', '/', 'dev-lang/pike-7.6.86-r1', 'merge') depends on
   ('ebuild', '/', 'gnome-base/librsvg-2.16.1', 'merge') (hard)
('ebuild', '/', 'dev-python/gnome-python-2.16.2', 'merge') depends on
   ('ebuild', '/', 'gnome-base/gnome-vfs-2.16.3', 'merge') (hard)
   ('ebuild', '/', 'gnome-base/libbonoboui-2.16.0', 'merge') (hard)
   ('ebuild', '/', 'gnome-base/libgnome-2.16.0', 'merge') (hard)
   ('ebuild', '/', 'gnome-base/libgnomeui-2.16.1', 'merge') (hard)
('ebuild', '/', 'net-im/ekiga-2.0.3', 'merge') depends on
   ('ebuild', '/', 'gnome-extra/evolution-data-server-1.8.2', 'merge') (hard)
   ('ebuild', '/', 'gnome-base/libgnome-2.16.0', 'merge') (hard)
   ('ebuild', '/', 'gnome-base/libgnomeui-2.16.1', 'merge') (hard)
   ('ebuild', '/', 'gnome-base/libbonoboui-2.16.0', 'merge') (hard)
   ('ebuild', '/', 'gnome-base/gnome-vfs-2.16.3', 'merge') (hard)
('ebuild', '/', 'dev-python/gnome-python-desktop-2.16.0', 'merge') depends on
   ('ebuild', '/', 'gnome-base/gnome-desktop-2.16.2', 'merge') (hard)
   ('ebuild', '/', 'gnome-extra/nautilus-cd-burner-2.16.2', 'merge') (hard)
   ('ebuild', '/', 'media-video/totem-2.16.4', 'merge') (hard)
   ('ebuild', '/', 'x11-libs/gtksourceview-1.8.1', 'merge') (hard)
   ('ebuild', '/', 'gnome-base/gnome-panel-2.16.2', 'merge') (hard)
   ('ebuild', '/', 'gnome-extra/gnome-media-2.16.1', 'merge') (hard)
   ('ebuild', '/', 'dev-python/gnome-python-2.16.2', 'merge') (hard)
   ('ebuild', '/', 'gnome-base/librsvg-2.16.1', 'merge') (hard)
('ebuild', '/', 'dev-lang/swig-1.3.31', 'merge') depends on
   ('ebuild', '/', 'dev-lang/pike-7.6.86-r1', 'merge') (hard)
('ebuild', '/', 'app-admin/pessulus-2.16.1', 'merge') depends on
   ('ebuild', '/', 'dev-python/gnome-python-2.16.2', 'merge') (hard)
('ebuild', '/', 'app-text/evince-0.6.1-r1', 'merge') depends on
   ('ebuild', '/', 'gnome-base/gnome-vfs-2.16.3', 'merge') (hard)
   ('ebuild', '/', 'gnome-base/libgnome-2.16.0', 'merge') (hard)
   ('ebuild', '/', 'gnome-base/nautilus-2.16.3', 'merge') (hard)
   ('ebuild', '/', 'gnome-base/libgnomeui-2.16.1', 'merge') (hard)
('ebuild', '/', 'gnome-extra/deskbar-applet-2.16.2-r1', 'merge') depends on
   ('ebuild', '/', 'gnome-base/gnome-desktop-2.16.2', 'merge') (hard)
   ('ebuild', '/', 'dev-python/gnome-python-extras-2.14.0-r1', 'merge') (hard)
   ('ebuild', '/', 'dev-python/gnome-python-desktop-2.16.0', 'merge') (hard)
   ('ebuild', '/', 'gnome-extra/gnome-utils-2.16.2-r2', 'merge') (hard)
   ('ebuild', '/', 'dev-python/gnome-python-2.16.2', 'merge') (hard)
('ebuild', '/', 'gnome-extra/yelp-2.16.2', 'merge') depends on
   ('ebuild', '/', 'gnome-base/gnome-vfs-2.16.3', 'merge') (hard)
   ('ebuild', '/', 'gnome-base/libgnome-2.16.0', 'merge') (hard)
   ('ebuild', '/', 'app-misc/beagle-0.2.16', 'merge') (hard)
   ('ebuild', '/', 'gnome-base/libgnomeui-2.16.1', 'merge') (hard)
   ('ebuild', '/', 'www-client/mozilla-firefox-2.0.0.1', 'merge') (hard)
('ebuild', '/', 'www-client/mozilla-firefox-2.0.0.1', 'merge') depends on
   ('ebuild', '/', 'gnome-base/gnome-vfs-2.16.3', 'merge') (hard)
   ('ebuild', '/', 'gnome-base/libgnomeui-2.16.1', 'merge') (hard)
('ebuild', '/', 'gnome-extra/gnome-power-manager-2.16.2', 'merge') depends on
   ('ebuild', '/', 'gnome-base/libgnome-2.16.0', 'merge') (hard)
   ('ebuild', '/', 'gnome-base/libgnomeui-2.16.1', 'merge') (hard)
   ('ebuild', '/', 'sys-apps/hal-0.5.7.1-r3', 'merge') (hard)
('ebuild', '/', 'gnome-extra/gconf-editor-2.16.0', 'merge') depends on
   ('ebuild', '/', 'gnome-base/libgnomeui-2.16.1', 'merge') (hard)
   ('ebuild', '/', 'gnome-base/libgnome-2.16.0', 'merge') (hard)
('ebuild', '/', 'gnome-extra/gnome-utils-2.16.2-r2', 'merge') depends on
   ('ebuild', '/', 'gnome-base/gnome-vfs-2.16.3', 'merge') (hard)
   ('ebuild', '/', 'gnome-base/libgnome-2.16.0', 'merge') (hard)
   ('ebuild', '/', 'gnome-base/libbonoboui-2.16.0', 'merge') (hard)
   ('ebuild', '/', 'gnome-base/gnome-desktop-2.16.2', 'merge') (hard)
   ('ebuild', '/', 'gnome-base/libgnomeui-2.16.1', 'merge') (hard)
   ('ebuild', '/', 'gnome-base/gnome-panel-2.16.2', 'merge') (hard)
   ('ebuild', '/', 'sys-apps/hal-0.5.7.1-r3', 'merge') (hard)
('ebuild', '/', 'app-cdr/dvd+rw-tools-7.0', 'merge') depends on
   ('ebuild', '/', 'app-cdr/cdrkit-1.0', 'merge') (hard)
('ebuild', '/', 'app-admin/gnome-system-tools-2.14.0', 'merge') depends on
   ('ebuild', '/', 'gnome-base/nautilus-2.16.3', 'merge') (hard)
   ('ebuild', '/', 'gnome-base/libgnomeui-2.16.1', 'merge') (hard)
('ebuild', '/', 'gnome-base/libgnomeui-2.16.1', 'merge') depends on
   ('ebuild', '/', 'gnome-base/gnome-vfs-2.16.3', 'merge') (hard)
   ('ebuild', '/', 'gnome-base/libgnome-2.16.0', 'merge') (hard)
   ('ebuild', '/', 'gnome-base/libbonoboui-2.16.0', 'merge') (hard)
('ebuild', '/', 'gnome-base/librsvg-2.16.1', 'merge') depends on
   ('ebuild', '/', 'gnome-base/gnome-vfs-2.16.3', 'merge') (hard)
   ('ebuild', '/', 'gnome-extra/libgsf-1.14.2', 'merge') (hard)
('ebuild', '/', 'gnome-extra/fast-user-switch-applet-2.16.0', 'merge') depends on
   ('ebuild', '/', 'gnome-base/gnome-vfs-2.16.3', 'merge') (hard)
   ('ebuild', '/', 'gnome-base/libgnome-2.16.0', 'merge') (hard)
   ('ebuild', '/', 'gnome-base/libbonoboui-2.16.0', 'merge') (hard)
   ('ebuild', '/', 'gnome-base/libgnomeui-2.16.1', 'merge') (hard)
   ('ebuild', '/', 'gnome-base/gnome-panel-2.16.2', 'merge') (hard)
('ebuild', '/', 'gnome-base/nautilus-2.16.3', 'merge') depends on
   ('ebuild', '/', 'gnome-base/gnome-vfs-2.16.3', 'merge') (hard)
   ('ebuild', '/', 'gnome-base/libgnome-2.16.0', 'merge') (hard)
   ('ebuild', '/', 'app-misc/beagle-0.2.16', 'merge') (hard)
   ('ebuild', '/', 'gnome-base/gnome-desktop-2.16.2', 'merge') (hard)
   ('ebuild', '/', 'gnome-base/eel-2.16.3', 'merge') (hard)
   ('ebuild', '/', 'gnome-base/libgnomeui-2.16.1', 'merge') (hard)
   ('ebuild', '/', 'gnome-base/librsvg-2.16.1', 'merge') (hard)
('ebuild', '/', 'net-misc/vino-2.16.0-r1', 'merge') depends on
   ('ebuild', '/', 'gnome-base/libgnomeui-2.16.1', 'merge') (hard)
('ebuild', '/', 'gnome-extra/gnome-screensaver-2.16.2', 'merge') depends on
   ('ebuild', '/', 'gnome-base/gnome-vfs-2.16.3', 'merge') (hard)
   ('ebuild', '/', 'gnome-base/libgnomeui-2.16.1', 'merge') (hard)
   ('ebuild', '/', 'gnome-base/gnome-menus-2.16.1', 'merge') (hard)
('ebuild', '/', 'gnome-base/gnome-mount-0.4-r5', 'merge') depends on
   ('ebuild', '/', 'gnome-base/gnome-vfs-2.16.3', 'merge') (soft)
   ('ebuild', '/', 'gnome-base/libgnomeui-2.16.1', 'merge') (hard)
   ('ebuild', '/', 'sys-apps/hal-0.5.7.1-r3', 'merge') (hard)
('ebuild', '/', 'gnome-base/gnome-volume-manager-2.15.0-r1', 'merge') depends on
   ('ebuild', '/', 'gnome-base/nautilus-2.16.3', 'merge') (hard)
   ('ebuild', '/', 'gnome-base/libgnomeui-2.16.1', 'merge') (hard)
   ('ebuild', '/', 'sys-apps/hal-0.5.7.1-r3', 'merge') (hard)
   ('ebuild', '/', 'gnome-base/control-center-2.16.2', 'merge') (hard)
   ('ebuild', '/', 'gnome-base/gnome-mount-0.4-r5', 'merge') (hard)
('ebuild', '/', 'sys-libs/libcap-1.10-r9', 'merge') depends on
   ('ebuild', '/', 'dev-lang/swig-1.3.31', 'merge') (hard)
('ebuild', '/', 'app-editors/gedit-2.16.2-r1', 'merge') depends on
   ('ebuild', '/', 'gnome-base/gnome-vfs-2.16.3', 'merge') (hard)
   ('ebuild', '/', 'gnome-base/libgnomeui-2.16.1', 'merge') (hard)
   ('ebuild', '/', 'dev-python/gnome-python-desktop-2.16.0', 'merge') (hard)
   ('ebuild', '/', 'x11-libs/gtksourceview-1.8.1', 'merge') (hard)
('ebuild', '/', 'app-misc/beagle-0.2.16', 'merge') depends on
   ('ebuild', '/', 'dev-dotnet/gnome-sharp-2.8.2', 'merge') (hard)
   ('ebuild', '/', 'dev-dotnet/gconf-sharp-2.8.2', 'merge') (hard)
   ('ebuild', '/', 'gnome-base/librsvg-2.16.1', 'merge') (hard)
('ebuild', '/', 'gnome-base/libbonoboui-2.16.0', 'merge') depends on
   ('ebuild', '/', 'gnome-base/libgnome-2.16.0', 'merge') (hard)
('ebuild', '/', 'x11-misc/alacarte-0.10.1-r1', 'merge') depends on
   ('ebuild', '/', 'gnome-base/gnome-menus-2.16.1', 'merge') (hard)
('ebuild', '/', 'x11-libs/gksu-2.0.0', 'merge') depends on
   ('ebuild', '/', 'gnome-base/nautilus-2.16.3', 'merge') (hard)
('ebuild', '/', 'gnome-extra/gcalctool-5.8.25', 'merge') depends on
   ('ebuild', '/', 'gnome-base/libgnomeui-2.16.1', 'merge') (hard)
   ('ebuild', '/', 'gnome-base/libgnome-2.16.0', 'merge') (hard)
('ebuild', '/', 'dev-dotnet/gnome-sharp-2.8.2', 'merge') depends on
   ('ebuild', '/', 'gnome-base/libgnomeui-2.16.1', 'merge') (hard)
   ('ebuild', '/', 'dev-dotnet/gnomevfs-sharp-2.8.2', 'merge') (hard)
   ('ebuild', '/', 'gnome-base/gnome-panel-2.16.2', 'merge') (hard)
('ebuild', '/', 'dev-dotnet/gconf-sharp-2.8.2', 'merge') depends on
   ('ebuild', '/', 'dev-dotnet/gnome-sharp-2.8.2', 'merge') (hard)
('ebuild', '/', 'gnome-extra/gtkhtml-2.6.3', 'merge') depends on
   ('ebuild', '/', 'gnome-base/gnome-vfs-2.16.3', 'merge') (hard)
('ebuild', '/', 'gnome-extra/gnome-keyring-manager-2.16.0-r1', 'merge') depends on
   ('ebuild', '/', 'gnome-base/libgnomeui-2.16.1', 'merge') (hard)
('ebuild', '/', 'media-gfx/imagemagick-6.3.0.5', 'merge') depends on
   ('ebuild', '/', 'media-gfx/graphviz-2.8-r2', 'merge') (hard)
('ebuild', '/', 'sys-apps/hal-0.5.7.1-r3', 'merge') depends on
   ('ebuild', '/', 'sys-libs/libcap-1.10-r9', 'merge') (hard)
('ebuild', '/', 'dev-dotnet/gnomevfs-sharp-2.8.2', 'merge') depends on
   ('ebuild', '/', 'gnome-base/gnome-vfs-2.16.3', 'merge') (hard)
('ebuild', '/', 'gnome-base/gnome-vfs-2.16.3', 'merge') depends on
   ('ebuild', '/', 'sys-apps/hal-0.5.7.1-r3', 'merge') (hard)
('ebuild', '/', 'app-cdr/cdrkit-1.0', 'merge') depends on
   ('ebuild', '/', 'sys-libs/libcap-1.10-r9', 'merge') (hard)
('ebuild', '/', 'gnome-base/eel-2.16.3', 'merge') depends on
   ('ebuild', '/', 'gnome-base/gnome-vfs-2.16.3', 'merge') (hard)
   ('ebuild', '/', 'gnome-base/libgnomeui-2.16.1', 'merge') (hard)
   ('ebuild', '/', 'gnome-base/gnome-desktop-2.16.2', 'merge') (hard)
   ('ebuild', '/', 'gnome-base/libgnome-2.16.0', 'merge') (hard)
   ('ebuild', '/', 'gnome-base/gnome-menus-2.16.1', 'merge') (hard)
('ebuild', '/', 'gnome-extra/bug-buddy-2.16.0', 'merge') depends on
   ('ebuild', '/', 'gnome-extra/evolution-data-server-1.8.2', 'merge') (hard)
   ('ebuild', '/', 'gnome-base/libgnome-2.16.0', 'merge') (hard)
   ('ebuild', '/', 'gnome-base/gnome-desktop-2.16.2', 'merge') (hard)
   ('ebuild', '/', 'gnome-base/libgnomeui-2.16.1', 'merge') (hard)
   ('ebuild', '/', 'gnome-base/gnome-vfs-2.16.3', 'merge') (hard)
   ('ebuild', '/', 'gnome-base/gnome-menus-2.16.1', 'merge') (hard)
('ebuild', '/', 'gnome-base/gnome-applets-2.16.2', 'merge') depends on
   ('ebuild', '/', 'gnome-base/libgnome-2.16.0', 'merge') (hard)
   ('ebuild', '/', 'gnome-base/gnome-desktop-2.16.2', 'merge') (hard)
   ('ebuild', '/', 'gnome-base/libgnomeui-2.16.1', 'merge') (hard)
   ('ebuild', '/', 'sys-apps/hal-0.5.7.1-r3', 'merge') (hard)
   ('ebuild', '/', 'dev-python/gnome-python-2.16.2', 'merge') (hard)
   ('ebuild', '/', 'gnome-base/gnome-vfs-2.16.3', 'merge') (hard)
   ('ebuild', '/', 'gnome-base/gnome-panel-2.16.2', 'merge') (hard)
   ('ebuild', '/', 'gnome-extra/gucharmap-1.8.0', 'merge') (hard)
('ebuild', '/', 'gnome-base/gnome-panel-2.16.2', 'merge') depends on
   ('ebuild', '/', 'gnome-base/gnome-vfs-2.16.3', 'merge') (hard)
   ('ebuild', '/', 'gnome-base/libgnome-2.16.0', 'merge') (hard)
   ('ebuild', '/', 'gnome-base/gnome-desktop-2.16.2', 'merge') (hard)
   ('ebuild', '/', 'gnome-base/libbonoboui-2.16.0', 'merge') (hard)
   ('ebuild', '/', 'gnome-base/libgnomeui-2.16.1', 'merge') (hard)
   ('ebuild', '/', 'gnome-base/gnome-menus-2.16.1', 'merge') (hard)
('ebuild', '/', 'gnome-extra/gucharmap-1.8.0', 'merge') depends on
   ('ebuild', '/', 'gnome-base/libgnomeui-2.16.1', 'merge') (hard)
   ('ebuild', '/', 'gnome-base/libgnome-2.16.0', 'merge') (hard)
('ebuild', '/', 'x11-terms/gnome-terminal-2.16.1', 'merge') depends on
   ('ebuild', '/', 'gnome-base/gnome-vfs-2.16.3', 'merge') (hard)
   ('ebuild', '/', 'gnome-base/libgnomeui-2.16.1', 'merge') (hard)


....and this is with "amd64" in make.conf. geez..hate to see what ~amd64 brings.

BTW -- Before you flame....I've been using gentoo since it was released (I bounce between RH and Gentoo). I know its "YMMV", but this is rediculous....just getting xemacs to install was a pain I'm not willing to relive.
Back to top
View user's profile Send private message
skellr
l33t
l33t


Joined: 18 Jun 2005
Posts: 706
Location: The Village

PostPosted: Sat Feb 17, 2007 4:53 am    Post subject: Re: circular dependencies? WTF Reply with quote

nebula8080 wrote:
BTW -- Before you flame....blahh... blahh...

Yeah this is really going to work when the first thing you do is flame. :roll:
nebula8080 wrote:
WTF happened to portage. I knew I should have waited for RHEL5......
Back to top
View user's profile Send private message
skellr
l33t
l33t


Joined: 18 Jun 2005
Posts: 706
Location: The Village

PostPosted: Sat Feb 17, 2007 5:46 am    Post subject: Reply with quote

Speak of the devil. :twisted:
Code:
tegan ~ # emerge -p postfix

These are the packages that would be merged, in order:

Calculating dependencies  ... done!
!!! Error: circular dependencies:

('ebuild', '/', 'mail-mta/postfix-2.3.7', 'merge') depends on
   ('ebuild', '/', 'net-nds/openldap-2.3.33', 'merge') (hard)
   ('ebuild', '/', 'dev-libs/cyrus-sasl-2.1.22-r2', 'merge') (hard)
('ebuild', '/', 'net-nds/openldap-2.3.33', 'merge') depends on
   ('ebuild', '/', 'dev-libs/cyrus-sasl-2.1.22-r2', 'merge') (hard)
('ebuild', '/', 'dev-libs/cyrus-sasl-2.1.22-r2', 'merge') depends on
   ('ebuild', '/', 'net-nds/openldap-2.3.33', 'merge') (hard)


Edit:Circular dependancies when trying to install gnome
Back to top
View user's profile Send private message
Genone
Retired Dev
Retired Dev


Joined: 14 Mar 2003
Posts: 9014
Location: beyond the rim

PostPosted: Sat Feb 17, 2007 7:53 am    Post subject: Reply with quote

See https://forums.gentoo.org/viewtopic-t-539520.html
Back to top
View user's profile Send private message
mark_alec
Bodhisattva
Bodhisattva


Joined: 11 Sep 2004
Posts: 6066
Location: Melbourne, Australia

PostPosted: Sat Feb 17, 2007 7:58 am    Post subject: Reply with quote

Moved from Portage & Programming to Duplicate Threads.

See thread genone linked.
_________________
www.gentoo.org.au || #gentoo-au
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Duplicate Threads All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum