Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[gd] autoconf plante l'emerge (résolu)
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index French
View previous topic :: View next topic  
Author Message
_tebra_
Guru
Guru


Joined: 12 Nov 2004
Posts: 304
Location: Brussels - Belgium

PostPosted: Thu Feb 15, 2007 9:42 am    Post subject: [gd] autoconf plante l'emerge (résolu) Reply with quote

Bonjour,
j'aimerai installer gd mais la compilation plante au tout début avec autoconf.
Voici le message d'erreur

Code:
100%[====================================>] 587,617       89.33K/s    ETA 00:00

09:05:59 (89.03 KB/s) - `/usr/portage/distfiles/gd-2.0.33.tar.gz' saved [587,617
/587,617]

>>> md5 files   ;-) gd-2.0.33.ebuild
>>> md5 files   ;-) gd-2.0.34_rc2.ebuild
>>> md5 files   ;-) gd-2.0.32.ebuild
>>> md5 files   ;-) files/digest-gd-2.0.34_rc2
>>> md5 files   ;-) files/digest-gd-2.0.32
>>> md5 files   ;-) files/digest-gd-2.0.33
>>> md5 files   ;-) files/gd-2.0.33-overflow-checks.patch
>>> md5 files   ;-) files/gd-2.0.33-iconv.patch
>>> md5 src_uri ;-) gd-2.0.33.tar.gz
>>> Unpacking source...
>>> Unpacking gd-2.0.33.tar.gz to /var/tmp/portage/gd-2.0.33/work
 * Applying gd-2.0.33-overflow-checks.patch ...                           [ ok ]
 * Applying gd-2.0.33-iconv.patch ...                                     [ ok ]
 * Automake used for the package (1.9.2) differs from
 * the installed version (1.10).
 * Running eautoreconf in '/var/tmp/portage/gd-2.0.33/work/gd-2.0.33' ...
 * Running aclocal ...                                                    [ ok ]
 * Running libtoolize --copy --force --automake ...                       [ ok ]
 * Running aclocal ...                                                    [ ok ]
 * Running autoconf ...                                                   [ !! ]

 * Failed Running autoconf !
 *
 * Include in your bugreport the contents of:
 *
 *   /var/tmp/portage/gd-2.0.33/temp/autoconf-12354.out


!!! ERROR: media-libs/gd-2.0.33 failed.
!!! Function autotools_run_tool, Line 219, Exitcode 0
!!! Failed Running autoconf !
!!! If you need support, post the topmost build error, NOT this status message.


Voici le contenu du fichier /var/tmp/portage/gd-2.0.33/temp/autoconf-12354.out

Code:
***** autoconf *****

configure.ac:51: error: possibly undefined macro: AM_ICONV
      If this token and others are legitimate, please use m4_pattern_allow.
      See the Autoconf documentation.

Un indice?
Merci d'avance


Last edited by _tebra_ on Thu Feb 15, 2007 1:19 pm; edited 1 time in total
Back to top
View user's profile Send private message
netfab
Veteran
Veteran


Joined: 03 Mar 2005
Posts: 1725
Location: 127.0.0.1

PostPosted: Thu Feb 15, 2007 10:05 am    Post subject: Reply with quote

Salut,

Tu devrais signaler ce bug. Probablement que gd devrait dépendre de sys-devel/gettext.
Back to top
View user's profile Send private message
_tebra_
Guru
Guru


Joined: 12 Nov 2004
Posts: 304
Location: Brussels - Belgium

PostPosted: Thu Feb 15, 2007 10:55 am    Post subject: Reply with quote

netfab wrote:
Salut,

Tu devrais signaler ce bug. Probablement que gd devrait dépendre de sys-devel/gettext.

Le bug est déjà signalé ici
Back to top
View user's profile Send private message
netfab
Veteran
Veteran


Joined: 03 Mar 2005
Posts: 1725
Location: 127.0.0.1

PostPosted: Thu Feb 15, 2007 11:38 am    Post subject: Reply with quote

Bien vu :wink:

Après avoir emergé gettext, çà passe ?
Back to top
View user's profile Send private message
_tebra_
Guru
Guru


Joined: 12 Nov 2004
Posts: 304
Location: Brussels - Belgium

PostPosted: Thu Feb 15, 2007 1:06 pm    Post subject: Reply with quote

netfab wrote:
Bien vu :wink:

Après avoir emergé gettext, çà passe ?

C'est un peu lourd comme dépendance vu que gettext fait 8~9Mo... mais bon si j'ai pas le choix
Back to top
View user's profile Send private message
_tebra_
Guru
Guru


Joined: 12 Nov 2004
Posts: 304
Location: Brussels - Belgium

PostPosted: Thu Feb 15, 2007 1:19 pm    Post subject: Reply with quote

Bon c'est passé comme une lettre à la poste en utilisant la version 2.0.32
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index French All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum