Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[Supertux] Can't load ... (résolu)
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index French
View previous topic :: View next topic  
Author Message
Nicomero
n00b
n00b


Joined: 06 Feb 2007
Posts: 16

PostPosted: Tue Feb 13, 2007 11:45 am    Post subject: [Supertux] Can't load ... (résolu) Reply with quote

Bonjour a tous,
J'ai installé il y a peu gentoo 2006.1 sur mon pc, avec gnome light et les pilotes proprio d'ATI (athlonxp 1600+ et radeon 9600).Tout semble fonctionner (l'acceleration 3D) et j'aimerai essayer supertux. Après l'emerge, lorsque je veux le lancer à partir du menu gnome, il ne se passe rien. Lorsque je lance la commande "supertux" depuis un xterm utilisateur, apparait ceci :

Code:
Nico@Clik ~ $ supertux
Datadir: /usr/share/games/supertux
Warning: No joysticks are available.

Error: Can't load
/usr/share/games/supertux/images/status/letters-black.png

Abandon



En temps qu'utilisateur, je peux regarder letters-black.png ...

Si quelqu'un a une idée, je suis preneur, ou si il manque des infos, je pourrais les fournirs ...
Merci d'avance


Last edited by Nicomero on Tue Feb 13, 2007 12:42 pm; edited 1 time in total
Back to top
View user's profile Send private message
shakya
n00b
n00b


Joined: 04 Dec 2006
Posts: 40
Location: Somewhere

PostPosted: Tue Feb 13, 2007 12:11 pm    Post subject: Reply with quote

Bonjour,

aucune idée .... mais ton user appartient il bien au groupe games ?
Back to top
View user's profile Send private message
Nicomero
n00b
n00b


Joined: 06 Feb 2007
Posts: 16

PostPosted: Tue Feb 13, 2007 12:16 pm    Post subject: Reply with quote

Oui mon user appartient bien au groupe games... Je débute sous linux, j'ai compris pas mal de chose mais là je vois pas quoi faire...
Back to top
View user's profile Send private message
kwenspc
Advocate
Advocate


Joined: 21 Sep 2003
Posts: 4954

PostPosted: Tue Feb 13, 2007 12:19 pm    Post subject: Reply with quote

Peus-tu afficher un emerge -pv sdl-image
supertux passe par cette lib pour accéder au fichier images (dont png). Et si le USE flags png n'est pas présent pour cette lib alors cette dernière ne sait comment gérer les png. Possible que ce soit ça.
_________________
membre officieux du SAV Ati GEntoo
Back to top
View user's profile Send private message
shakya
n00b
n00b


Joined: 04 Dec 2006
Posts: 40
Location: Somewhere

PostPosted: Tue Feb 13, 2007 12:23 pm    Post subject: Reply with quote

arf... c'est ce que j'allais demander... je crois que ca vient de là...
Back to top
View user's profile Send private message
Nicomero
n00b
n00b


Joined: 06 Feb 2007
Posts: 16

PostPosted: Tue Feb 13, 2007 12:27 pm    Post subject: Reply with quote

Code:
Nico@Clik ~ $ emerge -pv sdl-image

These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild   R   ] media-libs/sdl-image-1.2.5-r1  USE="-gif -jpeg -png -tiff" 0 kB

Total size of downloads: 0 kB


Je vois que l'use flag "png" n'est pas activé. C'est surement ça, je re emerge et vous ferais part du resultat.
En tout cas merci

Edit : Super, tout fonctionne, merci encore !
Back to top
View user's profile Send private message
lmarcini
Guru
Guru


Joined: 21 Jul 2004
Posts: 531
Location: Champagne sur Seine (France)

PostPosted: Tue Feb 13, 2007 12:52 pm    Post subject: Reply with quote

Merci pour l'astuce ! J'avais un problème similaire avec tuxmath : impossible de charger un fichier mid. L'ajout du flag mikmod dans sdl-mixer vient de résoudre le problème !
_________________
umount /dev/brain
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index French All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum