Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Strange revdep-rebuild result [SOLVED]
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Duplicate Threads
View previous topic :: View next topic  
Author Message
roki942
Apprentice
Apprentice


Joined: 18 Apr 2005
Posts: 181
Location: Seattle

PostPosted: Tue Feb 13, 2007 4:25 am    Post subject: Strange revdep-rebuild result [SOLVED] Reply with quote

Every time i run revpde-rebuild I get
Code:
Checking dynamic linking consistency...
  broken /usr/lib/gcc/i686-pc-linux-gnu/4.1.1/libgcjawt.la (requires /usr/lib/lib-gnu-java-awt-peer-gtk.la)
  broken /usr/lib/gcc/i686-pc-linux-gnu/4.1.1/libgij.la (requires /usr/lib/libgcj.la)
 done.
  (/root/.revdep-rebuild.3_rebuild)

Assigning files to ebuilds... done.
  (/root/.revdep-rebuild.4_ebuilds)

Evaluating package order... done.
  (/root/.revdep-rebuild.5_order)

All prepared. Starting rebuild...
emerge --oneshot  =sys-devel/gcc-4.1.1-r3

This is how gcc has been emerged
Code:
[ebuild   R   ] sys-devel/gcc-4.1.1-r3  USE="fortran gcj gtk nls (-altivec) -bootstrap -build -doc (-hardened) -ip28 -ip32r10k -mudflap (-multilib) -multislot (-n32) (-n64) -nocxx -objc -objc++ -objc-gc -test -vanilla"

Does anyone understand why those java libs would keep coming up?

Edit: Seems i didn't do a good enough search of the forms. Found my answer here https://forums.gentoo.org/viewtopic-t-539086-highlight-gcj.html


Last edited by roki942 on Tue Feb 13, 2007 7:32 am; edited 1 time in total
Back to top
View user's profile Send private message
yabbadabbadont
Advocate
Advocate


Joined: 14 Mar 2003
Posts: 4791
Location: 2 exits past crazy

PostPosted: Tue Feb 13, 2007 4:32 am    Post subject: Reply with quote

You have the gcj USE flag enabled. Was that intentional?

Code:
/home/bubba $ euse -i gcj
global use flags (searching: gcj)
************************************************************
[-    ] gcj - Enable building with gcj (The GNU Compiler for the Javatm Programming Language)

local use flags (searching: gcj)
************************************************************
no matching entries found
Back to top
View user's profile Send private message
roki942
Apprentice
Apprentice


Joined: 18 Apr 2005
Posts: 181
Location: Seattle

PostPosted: Tue Feb 13, 2007 4:38 am    Post subject: Reply with quote

yabbadabbadont wrote:
You have the gcj USE flag enabled. Was that intentional?

Yes it was, I forget which ebuild it is, but one does require being built with it.
Back to top
View user's profile Send private message
desultory
Administrator
Administrator


Joined: 04 Nov 2005
Posts: 8341

PostPosted: Sun Feb 18, 2007 11:07 am    Post subject: Reply with quote

In addition to the topic linked to by n00bsRus, this has been discussed in topic: "Persistent revdep-rebuild issues: gcc and libgcj.la".

Moved from Portage & Programming to Duplicate Threads.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Duplicate Threads All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum