Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[KDE] Problème montage auto (résolu)
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index French
View previous topic :: View next topic  
Author Message
Faust_
Apprentice
Apprentice


Joined: 13 Jan 2005
Posts: 175
Location: Marseille

PostPosted: Thu Feb 08, 2007 6:10 pm    Post subject: [KDE] Problème montage auto (résolu) Reply with quote

salut,
j'explique en gros, j'avais 10 mois de retard de mises à jour sur ma gentoo pour cause de panne de net et de manque de temps
après avoir tout remis à jour, tout fonctionnait nickel, je décide donc de passer mon système en UTF-8 et la le problème survient :)
ma femme à un commodore evic (baladeur ogg/mp3,etc à disque dur de 20 go en fat) et avant de passer mon système en UTF-8 je le branchais et il était reconnu et monté direct comme une simple clé usb
alors que maintenant il se monte mais je peux seulement lire, plus écrire :(
la seule différence que je vois est que dans mtab il y a utf8 dans la ligne de montage du périphérique
donc si quelqu'un pouvait m'expliquer comment faire pour qu'il se monte comme avant (le forcer) quand j'étais en ISO-8859-1 (ISO-8859-15)

pour info il se monte toujours nickel sous XP en lecture/écriture, sauf que je n'ai pas de windows à la maison :(
info supplémentaire; ma fille à un baladeur mp3, une simple clé usb à mémoire flash et elle fonctionne toujours


Last edited by Faust_ on Thu Feb 08, 2007 10:59 pm; edited 2 times in total
Back to top
View user's profile Send private message
Temet
Advocate
Advocate


Joined: 14 Mar 2006
Posts: 2586
Location: 92

PostPosted: Thu Feb 08, 2007 6:44 pm    Post subject: Reply with quote

Déjà merci!
Bah oui, depuis la mise à jour de hal, j'avais pas fait gaffe mais comme d'hab ce crétin veut monter mon baladeur en utf.
Comme j'ai l'hab, je te donne la solution.

vim /usr/share/hal/fdi/policy/10osvendor/20-storage-methods.fdi

Dans la section : "<!-- allow these mount options for vfat -->"

Remplace:

Code:
<append key="volume.mount.valid_options" type="strlist">utf8</append>
<append key="volume.mount.valid_options" type="strlist">shortname=</append>
<append key="volume.mount.valid_options" type="strlist">codepage=</append>
<append key="volume.mount.valid_options" type="strlist">iocharset=</append>


par

Code:
<!--<append key="volume.mount.valid_options" type="strlist">utf8</append>-->
<append key="volume.mount.valid_options" type="strlist">shortname=</append>
<append key="volume.mount.valid_options" type="strlist">codepage=850</append>
<append key="volume.mount.valid_options" type="strlist">iocharset=iso8859-15</append>


Et ensuite :
Code:
/etc/init.d/hald restart


Si t'as toujours pas les droits d'écritures, tente de jouer sur l'umask ou l'uid ;)
Back to top
View user's profile Send private message
geekounet
Bodhisattva
Bodhisattva


Joined: 11 Oct 2004
Posts: 3772
Location: Wellington, Aotearoa

PostPosted: Thu Feb 08, 2007 7:01 pm    Post subject: Reply with quote

C'est quoi le problème de la monter en UTF-8 ?
Back to top
View user's profile Send private message
Faust_
Apprentice
Apprentice


Joined: 13 Jan 2005
Posts: 175
Location: Marseille

PostPosted: Thu Feb 08, 2007 9:14 pm    Post subject: Reply with quote

bon apparemment le problème est résolu
aucune manip ne donnant rien, en dernier recours j'ai tenté fsck.vfat /dev/sda1 -a -w
et effectivement il y avait des petits problèmes niveau fs qui ont été réparé et tout refonctionne nickel
j'avais pourtant tenté le coup sous windows qui n'avait trouvé aucune erreur

enfin bon
en tout cas Temet merci pour l'aide :)
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index French All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum