Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Multiple Problems
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Desktop Environments
View previous topic :: View next topic  
Author Message
Houdini
Apprentice
Apprentice


Joined: 14 Jun 2002
Posts: 224
Location: New Mexico Tech, Socorro, NM

PostPosted: Tue Jun 18, 2002 12:09 am    Post subject: Multiple Problems Reply with quote

I've been slowly installing/configuring my gentoo box for the last few days. I've run into these problems, and wondered if anyone could help.

1) on every text terminal but vt1, shift+2 ("@") has somehow become the erase-line sequence. Only on login. Once I'm logged in, it's fine. This was more irritating when my password included a @, now it's just an oddity.

2) Not as much of a problem as a "wtf?" The NVidia driver isn't showing it's splash screen. I know it's working, because it leaves a lot of stuff in my xf86 log, and it's defaulting to 1600x1200, something which I don't think I could do in software.

3) Speaking of X, why is it defaulting to 1600x1200, and how do I stop it? Pressing ctrl+alt+"-" lowers the resolution, but my desktop (currently KDE) doesn't go with it. 1600x1200 is going to make me go blind.

4) If I switch between console and X, anything running (like mp3s) stops for a few seconds. Is there any way to get that not to happen?

I'm having some problems, but I'm liking gentoo :)
_________________
^]:wq
Back to top
View user's profile Send private message
delta407
Bodhisattva
Bodhisattva


Joined: 23 Apr 2002
Posts: 2876
Location: Chicago, IL

PostPosted: Tue Jun 18, 2002 12:13 am    Post subject: Reply with quote

1) That's weird :)

2) Are you running the "nvidia" driver? If so, is it just going so fast that your monitor doesn't change resolutions quickly enough?

3) You can change your /etc/X11/XF86Config like the following:
Code:
Section "Screen"
        Identifier "Screen0"
        Device     "Card0"
        Monitor    "Monitor0"
        DefaultDepth 24
        SubSection "Display"
                Depth     24
                Modes     "1152x864" "1024x768" "800x600" "640x480"
        EndSubSection
EndSection


4) What kernel and sound system are you running?
Back to top
View user's profile Send private message
Houdini
Apprentice
Apprentice


Joined: 14 Jun 2002
Posts: 224
Location: New Mexico Tech, Socorro, NM

PostPosted: Tue Jun 18, 2002 12:26 am    Post subject: Reply with quote

Thanks for the fast response!

1) Innit?

2) Yep, and that's possible.

3) Done, and thank you.

4) Running 2.4.19-crypto-r7, using ALSA on a SB Audigy.

also, I remembered one more thing. I followed the desktop guide to setting things up, and did all the alsa stuff. But, my volumes aren't being saved. Doing "amixer set" etc etc means I'll get deafened the first time, and alsamixer isn't doing it's job (saving settingS). Any ideas?

I'm not totally new to Linux, I've been running Slackware for a while on a server, but this is my first desktop Linux machine.
_________________
^]:wq
Back to top
View user's profile Send private message
delta407
Bodhisattva
Bodhisattva


Joined: 23 Apr 2002
Posts: 2876
Location: Chicago, IL

PostPosted: Tue Jun 18, 2002 12:35 am    Post subject: Reply with quote

2) To check if your nvidia drivers are actually working, run glxgears from a console while X is running (i.e. gnome-terminal, xterm, or konsole) and check your framerates. They should be obscene. :)

4) Do you have low-latency or preempt patches enabled? It sounds like your video card is blocking the rest of your system while it changes modes. (You also might double-check your audio buffering settings, but...)

5, sorta) Make sure /etc/init.d/alsa[sound] is set to start on boot, i.e. rc-update add alsa[sound] default. (I think the lastest is alsasound, but it may be just plain alsa. Try and see. :D)
Back to top
View user's profile Send private message
delta407
Bodhisattva
Bodhisattva


Joined: 23 Apr 2002
Posts: 2876
Location: Chicago, IL

PostPosted: Tue Jun 18, 2002 12:36 am    Post subject: Reply with quote

1) Hey, same on my box! (Except it erases on the first virtual terminal, too.) What gives?
Back to top
View user's profile Send private message
Houdini
Apprentice
Apprentice


Joined: 14 Jun 2002
Posts: 224
Location: New Mexico Tech, Socorro, NM

PostPosted: Tue Jun 18, 2002 5:27 am    Post subject: Reply with quote

1) irritating, isn't it? Think of how long it would take you to catch that if you had an @ in your root password... (note, I no longer do, leave my root password alone :P ) Good damned thing it doesn't on vt1, or I'd be getting out the recovery disks.

2) k, will do (I'm in windows right now)

3) umm, no #3

4) Both. They are part of the recent kernel packages from gentoo, right?

5-ish) I did that. I noticed something: when I'm booting, the alsa drivers entry has an error, "alsa drivers already loaded" (something like that). wtf? I followed the desktop directions to a T.

Thanks for all the help :)
_________________
^]:wq
Back to top
View user's profile Send private message
delta407
Bodhisattva
Bodhisattva


Joined: 23 Apr 2002
Posts: 2876
Location: Chicago, IL

PostPosted: Tue Jun 18, 2002 5:33 am    Post subject: Reply with quote

1) I think it's the work of agetty, or the devil, or both. :D

2) Also, try emerge evas and run evas-test; watch the framerate meter in Software mode, and then click to go to Hardware mode. It should be a lot faster than Software.

3) Was already answered, so I didn't answer it again, but I just did, so nevermind...

4) Yes, they're in Gentoo-sources, but you have to enable them under General Setup.

5) Hmmm...
Back to top
View user's profile Send private message
pjp
Administrator
Administrator


Joined: 16 Apr 2002
Posts: 18337

PostPosted: Tue Jun 18, 2002 5:43 am    Post subject: Reply with quote

Houdini wrote:
5-ish) I did that. I noticed something: when I'm booting, the alsa drivers entry has an error, "alsa drivers already loaded" (something like that). wtf? I followed the desktop directions to a T.


I asked about this a while back, noone seemed to know the answer. Sound works,
so I've just ignored it. I don't know enough yet to decipher why it does it.
_________________
Don't even pause and ask them why. Turn around and say goodbye.
Back to top
View user's profile Send private message
Houdini
Apprentice
Apprentice


Joined: 14 Jun 2002
Posts: 224
Location: New Mexico Tech, Socorro, NM

PostPosted: Tue Jun 18, 2002 7:37 am    Post subject: Reply with quote

1) No... my Slack box doesn't do that, and it's using agetty. Also, if it was agetty, why would one console not do it?

2) Umm... I installed it. It segfaults when I click "Hardware". Is this a bad thing?

3) ressurecting this one. X bitches and only lets me be at 8 bit color. What on earth have I done here? Windows can use 24 bit color, I know linux can :)

4) just looked, low latency is on, preempt is on.

5) Yeah, it kind of works, but I have to re-set all my sound levels every time I boot. Meh, I'll play with this one later.
_________________
^]:wq
Back to top
View user's profile Send private message
Houdini
Apprentice
Apprentice


Joined: 14 Jun 2002
Posts: 224
Location: New Mexico Tech, Socorro, NM

PostPosted: Tue Jun 18, 2002 7:07 pm    Post subject: Reply with quote

Something's jacked on my machine:

2)
sh-2.05a$ glxgears
Error: couldn't get an RGB, Double-buffered visual
sh-2.05a$

So, um, what did I break?
_________________
^]:wq
Back to top
View user's profile Send private message
sphexn
Guest





PostPosted: Tue Jun 18, 2002 7:36 pm    Post subject: alsa Reply with quote

Hi houdini!

I had the same problems with this muting after reboot... try to edit the /etc/modules.conf :

## ALSA portion
alias snd-card-0 snd-emu10k1
## alias snd-card-1 snd-ens1371
## OSS/Free portion
## alias sound-slot-0 snd-card-0
alias sound-slot-0 snd-card-0
## alias sound-slot-1 snd-card-1


after editing the file type "update-modules" in the console... this solved my problems and now it's working also after reboot... btw. my systems also tells me that the alsa sound driver is already running ;-)

greets, sphex
Back to top
Houdini
Apprentice
Apprentice


Joined: 14 Jun 2002
Posts: 224
Location: New Mexico Tech, Socorro, NM

PostPosted: Tue Jun 18, 2002 8:26 pm    Post subject: Reply with quote

Hi sphexn

I looked, and that was the entries I had in modules.conf. Update-modules works fine, but my sound is still muted on boot.

Thanks for the suggestion, though.
_________________
^]:wq
Back to top
View user's profile Send private message
Houdini
Apprentice
Apprentice


Joined: 14 Jun 2002
Posts: 224
Location: New Mexico Tech, Socorro, NM

PostPosted: Tue Jun 18, 2002 9:22 pm    Post subject: Reply with quote

Yay! I found a fix for the sound problem :!:

There's a few rather silly errors in the desktop guide that lead to this. Instructions for fixing it:

1) open up /etc/modules.autoload
comment out the alsa stuff (2 lines?)

2) rc-update del alsasound # should find it in "default"
rc-update add alsasound boot

3) reboot. the alsa driver should load correctly, but complain about your sound being muted

4) crack open alsamixer and set your sound levels.

5) reboot again

6) enjoy persistent-across-boots sound levels :)

Who can I contact to get this fixed in the Desktop Guide?

EDIT: I forgot to mention, the driver no longer complains about already being loaded on boot now. yay!
_________________
^]:wq
Back to top
View user's profile Send private message
Houdini
Apprentice
Apprentice


Joined: 14 Jun 2002
Posts: 224
Location: New Mexico Tech, Socorro, NM

PostPosted: Wed Jun 19, 2002 12:26 am    Post subject: Reply with quote

Well, thanks for all the help. I got the remaining problems figured out.

Once I mangled my XF86Config in the right way to get more than 8 bit color, everything related to X works. glxgears and evas_test work (yes, I'm using the hardware rendering).

Thanks to everyone who replied.
_________________
^]:wq
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Desktop Environments All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum