Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[Xorg] Echec installation au moment des drivers ATI (Résolu)
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index French
View previous topic :: View next topic  
Author Message
Unknownn
n00b
n00b


Joined: 30 Jan 2007
Posts: 13

PostPosted: Sun Feb 04, 2007 4:53 pm    Post subject: [Xorg] Echec installation au moment des drivers ATI (Résolu Reply with quote

Bonjour tout le monde,

Je viens d'installer fraichement Gentoo sur mon PC, tout s'est bien passé sauf à la fin de l'installation de Xorg.
J'utilise la version AMD64 de Gentoo que j'ai installé à partir du minimal CD.

Après une bonne heure d'installation, j'arrive à l'étape 103 ou 104, c'est là où il passe à l'installation du driver ATI (oui j'ai une carte ATI malheuresement). Jsuis tellement déçu que j'ai pris une photo de l'erreur.

=> http://img159.imageshack.us/img159/4549/img0052bzg5.jpg

J'ai suivi le tutorial et j'ai donc rajouté dans mon fichier /etc/make.conf

Code:
INPUT_DEVICES="keyboard mouse"
VIDEO_CARDS="fglrx"


Merci d'avance... :cry: :cry:
Unknownn


Last edited by Unknownn on Tue Feb 06, 2007 9:32 pm; edited 1 time in total
Back to top
View user's profile Send private message
nost4r
Apprentice
Apprentice


Joined: 08 Oct 2006
Posts: 164
Location: Bordeaux

PostPosted: Sun Feb 04, 2007 5:04 pm    Post subject: Reply with quote

Ben apres avoir rajouter ce que tu as mis dans ton make.conf , tu ré emerges les drivers
Back to top
View user's profile Send private message
man in the hill
Veteran
Veteran


Joined: 15 Dec 2005
Posts: 1552
Location: Madinina

PostPosted: Sun Feb 04, 2007 5:33 pm    Post subject: Reply with quote

As-tu emergé libdrm !
_________________
Get Up and Go !
Back to top
View user's profile Send private message
nykos
Guru
Guru


Joined: 08 Jun 2005
Posts: 488
Location: Strasbourg

PostPosted: Sun Feb 04, 2007 5:56 pm    Post subject: Reply with quote

j'ai aucune idée de ce qu'est libdrm mais j'ai pas souvenir d'avoir installé ça chez moi...

tu as quelle carte graphique ?
je crois que cette erreur est courante avec cette version des drivers ati, tu devrais essayer des drivers plus récents qui sont en ~amd64
_________________
-=Nykos=-
TARGA Traveller 826T - AMD Turion 64 MT 32 1,8GHz - ATI Radeon X700 Mobility (ati-drivers)
Back to top
View user's profile Send private message
Unknownn
n00b
n00b


Joined: 30 Jan 2007
Posts: 13

PostPosted: Sun Feb 04, 2007 6:27 pm    Post subject: Reply with quote

J'ai juste suivi le tuto à la lettre, je n'ai rien fait de plus. Les drivers ATI ont été téléchargé automatiquement lors de
Code:
emerge xorg-x11


Je suis juste à l'installation du serveur X, je n'ai rien installé pour ma carte. Ma carte graphique est une Sapphire X800XL

Merci de me guider :oops:
Back to top
View user's profile Send private message
Aefron
n00b
n00b


Joined: 27 Oct 2006
Posts: 41

PostPosted: Sun Feb 04, 2007 7:16 pm    Post subject: Reply with quote

+1 avec ce que dit Nykos... au vu de ton log d'erreur, portage essaie de compiler fglrx.ko (les .ko sont des modules noyau), mais comme ça merde (incompatibilité avec ta version de X.org ou de ton noyau), il s'arrête là...

Essaye donc de rajouter x11-drivers/ati-drivers ~amd64 dans ton /etc/portage/package.keywords (ou fais flagedit x11-drivers/ati-drivers ~amd64 -- +~amd64 , si tu as flagedit d'installé)...

Sinon, plutôt que d'activer VIDEO_CARDS="fglrx" , tu peux aussi essayer avec les drivers libres VIDEO_CARDS="radeon" ...

... heureux possesseur de deux X800XL dans mon PC (même si dri, ie l'accélération 3D, ne marche pour l'instant que quand une seule carte est activée, l'accélération 2D fonctionne parfaitement avec les deux...)... et je n'ai plus de couilles lorsqu'il y a un nouveau kernel (vu que le driver est alors compilé à partir des sources, pas de problème avec les changement d'API) ou un nouveau X.org (même raison)...

... certes, je ne joue ni n'utilise beryl&cie (ce qui veut juste dire que je ne sais pas si ça se comporte bien ou mal dans ces cas), je dois utiliser un adaptateur vga/svideo pour afficher sur une télé, mais la 3D marche tout à fait correctement en bi-écran, la 2D fonctionne très bien en tri-écran, et je n'ai pas ces sâles galères d'API/ABI avec les ignobles blob ati ou nvidia...

Franchement, même si je suis conscient d'être une espèce rare, je suis un linuxien tout à fait content d'avoir des cartes ati (je n'ai d'ailleurs plus que ça sur mes PC ou je fais tourner du clickodrome)... plutôt crever ou arrêter le PC que de partir sur du nvidia ou de l'ati > X850, avec les plaies que l'on se traîne avec... à la limite, je suis curieux de voir ce que donneront les cartes intel si elles sortent en PCI-E (voir si le support du dri multi-cartes est plus avancé que pour les radeons)...


Edit : sinon, libdrm, normalement, il est installé à partir du moment ou on installe un driver qui gère le dri, puisqu'ils sont sensés avoir besoin de mesa (il me semble, mais je dis peut-être une connerie), qui dépend de lui...
Back to top
View user's profile Send private message
davidou2a
Guru
Guru


Joined: 15 Dec 2006
Posts: 574
Location: Ajaccio

PostPosted: Sun Feb 04, 2007 8:14 pm    Post subject: Reply with quote

personnellement j'ai eu ce souçis, j'ai fait
Code:
emerge xorg-server && emerge x11-drm

puis j'ai DL les drivers ATI sur le site ATI, et j'ai fait un
Code:
aticonfig --initial

et ça marche du 1er coup, apres y a plus qu a affiner le xorg.conf...
_________________
L'enfer je connais, il s'appelle Windows...
Back to top
View user's profile Send private message
El_Goretto
Moderator
Moderator


Joined: 29 May 2004
Posts: 3110
Location: Paris

PostPosted: Sun Feb 04, 2007 10:18 pm    Post subject: Reply with quote

Bon, va vraiment falloir arrêter avec les astuces et popottes persos, hein... Si le tuto indiqué a été suivi pour fglrx, c'est nickel. S'il n'y a pas eu d'erreur de compilation de fglrx, alors il reste plus que la config xorg.conf à voir (et un éventuel framebuffer qui pue à enlever).

Parce qu'on est encore en train de confuser fglrx et le driver libre radeon (libdrm? x11-drm?).
Manquerait plus qu'on se rende compte qu'à la fin, c'est le framebuffer le tueur, et on en revient à ce qui se dit dans 80% des "threads ATI"... :)
_________________
-FreeNAS: µ-serv Gen8 G1610T, 16Go ECC & µ-serv N40L, 8Go ECC
-FreeBSD 11/Vimage/Jails: DS61, i3 2100T, 16Go
-Réseau: ERL-3 + ESL-24 + GS108Tv2
-NAS: RN312
Back to top
View user's profile Send private message
nykos
Guru
Guru


Joined: 08 Jun 2005
Posts: 488
Location: Strasbourg

PostPosted: Sun Feb 04, 2007 11:15 pm    Post subject: Reply with quote

pareil, j'ai l'impression qu'il faut bidouiller pour avoir une ati qui marche alors que chez moi ça a marché dès le début
le coup du libdrm ou je sais pas quel autre paquet, normalement c'est des dépendances alors ya pas besoin de s'en préoccuper, ça le fait tout seul 8)

pour ton erreur de compilation, je ne peux que réitérer mon conseil : essaye une version plus récente des ati-drivers
_________________
-=Nykos=-
TARGA Traveller 826T - AMD Turion 64 MT 32 1,8GHz - ATI Radeon X700 Mobility (ati-drivers)
Back to top
View user's profile Send private message
Aefron
n00b
n00b


Joined: 27 Oct 2006
Posts: 41

PostPosted: Sun Feb 04, 2007 11:56 pm    Post subject: Reply with quote

El_Goretto wrote:
S'il n'y a pas eu d'erreur de compilation de fglrx, alors il reste plus que la config xorg.conf à voir (et un éventuel framebuffer qui pue à enlever).


Sauf que là, vu la gueule de son log, c'est la compilation de fglrx qui plante ("install: cannot stat 'fglrx.ko': no such file or directory")... donc, il faut en essayer une autre version, le driver libre, voire un autre kernel ou un autre X.org (mais, bon, là, ça commence à devenir un tantinet casse-couille)...

... sinon, pour libdrm, apparemment, c'est une dépendance de xorg-server quand on active le flag dri (et aussi de mesa et de xf86-video-ati, chez moi, mais parce que j'utilise les drivers libres)... après, je ne sais pas si les blobs proprios ont besoin de dri où s'ils implémentent leur trifouille tout seuls...

... ceci dit, vu que, pour fglrx, il faut créer aussi une section d'autorisation sur dri pour les utilisateurs dans le Xorg.conf (cf le tuto Gentoo), il semble quand même qu'il soit nécessaire (de toute façon, il est emergé tout seul si on active le flag dri)...
Back to top
View user's profile Send private message
galeo
n00b
n00b


Joined: 27 Dec 2005
Posts: 57

PostPosted: Mon Feb 05, 2007 11:39 am    Post subject: Reply with quote

juste pour info sa ne viens pas du 64bit, j'ai la meme erreur sous un athlon-XP 32bit

Last edited by galeo on Mon Feb 05, 2007 9:02 pm; edited 1 time in total
Back to top
View user's profile Send private message
El_Goretto
Moderator
Moderator


Joined: 29 May 2004
Posts: 3110
Location: Paris

PostPosted: Mon Feb 05, 2007 6:24 pm    Post subject: Reply with quote

Non galeo, tu ne peux pas avoir la même erreur puisqu'on ne la voit pas sur la capture d'écran...

Suivez les indications de nykos en prenant la version la plus récente de fglrx, et en vérifiant si elle est bien censée fonctionner sur votre version de noyau. Si vous tenez à l'accélération 3D, bien sûr, autrement radeon ira très bien.

Sinon, vous allez avoir une fessée et vous irez au coin, galopins! (façon polie de signaler un demerden sie sich si vous ne suivez pas les indications élémentaires).
_________________
-FreeNAS: µ-serv Gen8 G1610T, 16Go ECC & µ-serv N40L, 8Go ECC
-FreeBSD 11/Vimage/Jails: DS61, i3 2100T, 16Go
-Réseau: ERL-3 + ESL-24 + GS108Tv2
-NAS: RN312
Back to top
View user's profile Send private message
Unknownn
n00b
n00b


Joined: 30 Jan 2007
Posts: 13

PostPosted: Mon Feb 05, 2007 8:55 pm    Post subject: Reply with quote

Bonjour ça bouge bien par ici :D

Je suis impressionné par la réactivité du forum, merci à tous 8)

Pour en revenir au problème, j'ai une chose que je ne comprends pas (ne me tappez pas dessus je débute). Comme je l'ai dit plus haut, je ne suis qu'à l'installation du serveur X. Donc installer les drivers d'une manière ou d'une autre ne change pas réellement le soucis puisque l'installation du serveur X ne s'est pas achevé. Si je reprends l'install (du début je ne sais pas comme faire), il va me réinstaller exactement la même chose donc il va rebloquer au même problème. (Il se peut que tout ce que je raconte soit faux mais ma logique me dit ça) Que faire alors ? Modifier /etc/make.conf mais de quelle manière ?

Sinon, je préfère utiliser les drivers proprio ATI que les drivers libres. Sur la FAQ ATI, il ne parle pas des R430 (ma carte, une X800XL est une R430), et il est noté que pour les drivers libres, les R300 n'étaient pas encore supportés. Je tiens à l'accélération 3D. La version des pilotes qu'il m'installe automatiquement est la 8.27.10 qui est version assez ancienne. Que puis-je faire pour qu'il m'installe la dernière ou du moins une plus récente automatiquement ?

Quote:
Essaye donc de rajouter x11-drivers/ati-drivers ~amd64 dans ton /etc/portage/package.keywords (ou fais flagedit x11-drivers/ati-drivers ~amd64 -- +~amd64 , si tu as flagedit d'installé)...

Perso, je ne sais pas ce que ce fichier fait (je chercherai demain ou vous me donnerez la réponse), mais à première vu, il semble que ce soit une solution, je ne l'exclus pour le moment.

Je vous remercie pour toutes vos réponses, je ne testerai cela que demain.
Back to top
View user's profile Send private message
galeo
n00b
n00b


Joined: 27 Dec 2005
Posts: 57

PostPosted: Mon Feb 05, 2007 9:02 pm    Post subject: Reply with quote

Quote:
Non galeo, tu ne peux pas avoir la même erreur


bon .... meme probleme si tu prefert :D
Code:

install: cannot stat `fglrx.ko': No such file or directory

!!! ERROR: x11-drivers/ati-drivers-8.27.10-r1 failed.
Call stack:
  ebuild.sh, line 1546:   Called dyn_install
  ebuild.sh, line 1020:   Called src_install
  ati-drivers-8.27.10-r1.ebuild, line 205:   Called linux-mod_src_install
  linux-mod.eclass, line 540:   Called die

!!! doins fglrx.ko failed
!!! If you need support, post the topmost build error, and the call stack if relevant.
Back to top
View user's profile Send private message
nykos
Guru
Guru


Joined: 08 Jun 2005
Posts: 488
Location: Strasbourg

PostPosted: Mon Feb 05, 2007 9:30 pm    Post subject: Reply with quote

Unknownn wrote:
Que puis-je faire pour qu'il m'installe la dernière ou du moins une plus récente automatiquement ?
Quote:
Essaye donc de rajouter x11-drivers/ati-drivers ~amd64 dans ton /etc/portage/package.keywords (ou fais flagedit x11-drivers/ati-drivers ~amd64 -- +~amd64 , si tu as flagedit d'installé)...

Perso, je ne sais pas ce que ce fichier fait (je chercherai demain ou vous me donnerez la réponse), mais à première vu, il semble que ce soit une solution, je ne l'exclus pour le moment.


Cette commande dit au système d'installer la version instable des drivers ati (qui est quand même relativement stable)
_________________
-=Nykos=-
TARGA Traveller 826T - AMD Turion 64 MT 32 1,8GHz - ATI Radeon X700 Mobility (ati-drivers)
Back to top
View user's profile Send private message
Unknownn
n00b
n00b


Joined: 30 Jan 2007
Posts: 13

PostPosted: Tue Feb 06, 2007 9:46 pm    Post subject: Reply with quote

Ok donc finalement, tout est bien qui fini bien :)

Pour vous expliquer, j'ai installé une version plus récente des pilotes ATI proprio en rajoutant x11-drivers/ati-drivers ~amd64 dans /etc/portage/package.keywords Il m'a alors installé la version 8.32.5 beaucoup plus récente que la 8.27.10 initialement installé. Et l'installation a reprise sans broncher :)

Ensuite j'ai eu quelques soucis avec la configuration du serveur X.
Quote:
Fatal server error:
Caught signal 11. Server aborting


Heuresement davidou2a m'a posté ses conseils. J'ai alors installé x11-drm, mais il ne m'a pas permis de régler les problèmes, je suis alors passé à Xorg-server qui m'a installé les pilotes pour ma souris et mon clavier (et oui !! Je n'en avais pas ! et c'était listé dans les erreurs) et qui a tout réglé finalement :) Sans son message, je n'aurais pas pensé au aticonfig --initial non plus, ils devraient le rajouter dans le tuto.

Donc je vous remercie, tout le monde, de m'avoir aidé et d'avoir tenté de m'aider. Je reste impressionné par le nombre de participant sur le forum, bonne continuation,

Unknownn :D

PS: Je continuerai mon aventure demain, il paraît que l'install de Gnome est longue :wink:
Back to top
View user's profile Send private message
davidou2a
Guru
Guru


Joined: 15 Dec 2006
Posts: 574
Location: Ajaccio

PostPosted: Tue Feb 06, 2007 10:08 pm    Post subject: Reply with quote

pour aticonfig --initial c'est ecrit sur le site de ATI ;) et je crois sur le tuto ATI du wiki gentoo...

Enfin voila bonne chance pour la suite ;)
_________________
L'enfer je connais, il s'appelle Windows...
Back to top
View user's profile Send private message
Unknownn
n00b
n00b


Joined: 30 Jan 2007
Posts: 13

PostPosted: Tue Feb 06, 2007 10:31 pm    Post subject: Reply with quote

davidou2a wrote:
pour aticonfig --initial c'est ecrit sur le site de ATI ;) et je crois sur le tuto ATI du wiki gentoo...

Enfin voila bonne chance pour la suite ;)

Oui sur le site, je connais la commande (au moins uen chose que je connais :lol: ) mais je n'y aurais pas pensé puisque dans le tuto et la FAQ ATI , il n'est écrit nul part alors qu'il nous fait bien installer les drivers proprio :roll:

Merci davidou2a 8)
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index French All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum