Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
problema twinview nvidia tvout gdm terminais virtuais
View unanswered posts
View posts from last 24 hours
View posts from last 7 days

 
Reply to topic    Gentoo Forums Forum Index Portuguese
View previous topic :: View next topic  
Author Message
Maleita
Apprentice
Apprentice


Joined: 16 Sep 2004
Posts: 246
Location: Brasil -> São Paulo->Campinas

PostPosted: Tue Jan 30, 2007 12:34 pm    Post subject: problema twinview nvidia tvout gdm terminais virtuais Reply with quote

Bom dia ,meu problema é o seguinte,estou usando o driver beta,e quando ativo o Twinview ,perco os VT's(terminais virtuais) as letras ficam enormes no terminal virtual não dá pra ver nada,e se der um "gdm-restart" trava ,só reiniciando!!!!!!!!!!!!!!!!
Sem a opção do twinview,fica tudo normal ,sem problema nenhum.
Code:

Section "Screen"
    Identifier     "Screen0"
    Device         "Device0"
    Monitor        "Monitor0"
    DefaultDepth    24
    Option     "AllowGLXWithComposite" "True"
    Option    "DPI" "72x72"
    Option     "RenderAccel"      "True"
    Option     "HWcursor"         "True"
    Option     "CursorShadow"     "True"
    Option     "CursorShadowAlpha" "32"
    Option     "CursorShadowXOffset" "3"
    Option     "CursorShadowYOffset" "3"
#    Option         "TwinView" "True"
#    Option         "TwinViewOrientation" "RightOf"
    Option         "UseEdidFreqs" "True"
#    Option         "MetaModes" "1600x1200, 1024x768"
    Option         "DamageEvents" "true"
    Option         "Coolbits" "1"
    Option         "backingstore"
    Option         "AddARGBGLXVisuals" "True"
#    Option         "DynamicTwinView" "1"
    Option         "AllowDDCCI" "true" 
 SubSection     "Display"
        Depth       24
        Modes      "1600x1200" "1280x1024" "1024x768" "800x600" "640x480"
    EndSubSection
EndSection


Code:

CHOST="x86_64-pc-linux-gnu"
CFLAGS="-march=nocona -O2 -pipe -fomit-frame-pointer -mmmx -msse -msse2"
CXXFLAGS="${CFLAGS}"
MAKEOPTS="-j3"
LINGUAS="pt_BR"
SYNC="rsync://rsync.namerica.gentoo.org/gentoo-portage"
EMERGE_DEFAULT_OPTS="--alphabetical"
INPUT_DEVICES="keyboard mouse"
VIDEO_CARDS="fbdev nv nvidia vesa v4l vga"
FEATURES="ccache parallel-fetch fixpackages buildpkg"
CCACHE_DIR="/var/tmp/ccache/"
CCACHE_SIZE="2G"
ACCEPT_KEYWORDS=""
PORTAGE_BINHOST="/usr/portage/packages"
LIRC_DEVICES="pixelview_pro"

ai estão meu make.conf e meu xorg.conf.
Back to top
View user's profile Send private message
dedalu
n00b
n00b


Joined: 11 Jan 2007
Posts: 8

PostPosted: Tue Jan 30, 2007 8:11 pm    Post subject: Reply with quote

Qual o número da versão do nvidia-driver, qual sua placa?

Os drivers x86 (o meu aqui é 1.0.8776) em uma GeForce4 Ti 4800 SE funcionam muito bem. Quem sabe alguma dessas outras Options (DamageEvents, Coolbits etc.) pode ser incompatível com o TwinView, não sei...

Seria uma opção tentar um ServerLayout com Option "xinerama" no lugar de "twinview" (seria uma outra configuração, na verdade).

Ainda: para que os programas se comportem de acordo, será importante USE="xinerama" no make.conf, mas isso não tem nada a ver.

Abraços.
Back to top
View user's profile Send private message
Maleita
Apprentice
Apprentice


Joined: 16 Sep 2004
Posts: 246
Location: Brasil -> São Paulo->Campinas

PostPosted: Tue Jan 30, 2007 10:43 pm    Post subject: Reply with quote

desmascarei o driver nvidia,estou usando a ultima versão,a placa é um FX 5200 XFX,e realmente perco a gdm,se der um gdm-restart trava mesmo até o num-lock trava,não consigo voltar no X .
Ai só reiniciando.isso só acontece com o twinview.com um monitor é normal.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Portuguese All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum