Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
pcmcia wifi карта вешает ноут при переводе в monitor-режим
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Russian
View previous topic :: View next topic  
Author Message
amazing
n00b
n00b


Joined: 28 Jan 2007
Posts: 9
Location: Russia, SPb

PostPosted: Sun Jan 28, 2007 12:59 am    Post subject: pcmcia wifi карта вешает ноут при пере Reply with quote

Есть в наличии pcmcia карточка на Atheros 5212 чипе (NetGear WG511T). Поблема в том, что не могу карту перевести в monitor-режим. Ноутбук виснет намертво. Есть подозрения, что дело в pcmcia.

Code:
# uname -r
2.6.19-gentoo-r4


Code:
# emerge -pv virtual/pcmcia sys-apps/pcmciautils sys-apps/pcmcia-cs sys-fs/udev
[ebuild   R   ] virtual/pcmcia-2.6.13  0 kB
[ebuild   R   ] sys-apps/pcmciautils-014-r1  USE="udev -debug -static -staticsocket" 0 kB
[ebuild   R   ] sys-apps/pcmcia-cs-3.2.8-r2  USE="X gtk -trusted -vanilla -xforms" 0 kB
[ebuild   R   ] sys-fs/udev-103  USE="(-selinux)" 0 kB

Code:
# dmesg| tail -n21
pccard: CardBus card inserted into slot 0
ath_hal: module license 'Proprietary' taints kernel.
ath_hal: 0.9.17.2 (AR5210, AR5211, AR5212, RF5111, RF5112, RF2413, RF5413)
wlan: 0.8.4.2 (0.9.2.1)
ath_rate_amrr: no version for "ether_sprintf" found: kernel tainted.
ath_rate_amrr: 0.1 (0.9.2.1)
ath_pci: 0.9.4.5 (0.9.2.1)
PCI: Enabling device 0000:0a:00.0 (0000 -> 0002)
ACPI: PCI Interrupt 0000:0a:00.0[A] -> GSI 20 (level, low) -> IRQ 20
wifi0: 11b rates: 1Mbps 2Mbps 5.5Mbps 11Mbps
wifi0: 11g rates: 1Mbps 2Mbps 5.5Mbps 11Mbps 6Mbps 9Mbps 12Mbps 18Mbps 24Mbps 36Mbps 48Mbps 54Mbps
wifi0: turboG rates: 6Mbps 12Mbps 18Mbps 24Mbps 36Mbps 48Mbps 54Mbps
wifi0: H/W encryption support: WEP AES AES_CCM TKIP
wifi0: mac 7.9 phy 4.5 radio 5.6
wifi0: Use hw queue 1 for WME_AC_BE traffic
wifi0: Use hw queue 0 for WME_AC_BK traffic
wifi0: Use hw queue 2 for WME_AC_VI traffic
wifi0: Use hw queue 3 for WME_AC_VO traffic
wifi0: Use hw queue 8 for CAB traffic
wifi0: Use hw queue 9 for beacons
wifi0: Atheros 5212: mem=0x52000000, irq=20

Kernel .config
Code:
CONFIG_PCMCIA=m
CONFIG_PCMCIA_LOAD_CIS=y
CONFIG_PCMCIA_IOCTL=y
CONFIG_PCMCIA_PROBE=y

Никто не сталкивался с этим?
Back to top
View user's profile Send private message
Zlo_ch
n00b
n00b


Joined: 20 Sep 2006
Posts: 18
Location: Ryazan

PostPosted: Sun Jan 28, 2007 9:28 am    Post subject: Reply with quote

Привет amazing!!!
Возникала таже проблема но с совершенно другой картой при использование ndiswrapper при явном указании канала .... стал использовать родные драйвера под линукс все нормально стало работать .....
Как у тебя были дела с прошлыми версиями ядра ? ... возникали ли проблемы
А если серьезно попробуй разные версии pcmcia
Back to top
View user's profile Send private message
amazing
n00b
n00b


Joined: 28 Jan 2007
Posts: 9
Location: Russia, SPb

PostPosted: Sun Jan 28, 2007 10:53 am    Post subject: Reply with quote

Zlo_ch, день добрый!
Я не могу использовать "родные" драйвера, их просто нет. Для Atheros чипов идут драйвера внешним модулем (madwifi.org), в ядре поддержка не реализована.
А подозрения на pcmcia у меня потому, что на 2.6.18 + не помню какая версия pcmcia утилит была - вешалось все ровно так же, с другой карточкой, тоже wifi. Но раньше я ее и вставить в слот не успевал, как все зависало. Так что драйвера к wifi тут не при чем... Да и в рассылке бы писали об этом.
На мой взгляд в этом могут быть виноваты две вещи: поддержка (драйвер) cardbus в ядре или софт для управления pcmcia. Боюсь, что первое вероятнее всего.
Ядро я точно не могу поменять, а с pcmcia софтом попробую поиграться, спасибо.
Back to top
View user's profile Send private message
Zlo_ch
n00b
n00b


Joined: 20 Sep 2006
Posts: 18
Location: Ryazan

PostPosted: Mon Jan 29, 2007 2:15 am    Post subject: Reply with quote

Ты знаешь очень у многих проблемы с 2.6.19 ядром, в частности с данным типом оборудования .... покажи подробнее логи и пишется ли в логи что-либо перед тем как система виснет и покажи как настраиваешь ....
Back to top
View user's profile Send private message
amazing
n00b
n00b


Joined: 28 Jan 2007
Posts: 9
Location: Russia, SPb

PostPosted: Mon Jan 29, 2007 6:20 pm    Post subject: Reply with quote

Если копать в сторону ядра, то на 2.6.18 было еще хуже, я об этом писал. Зарелизят 2.6.20 - попробую как на нем будет. downgrade делать ой как не хочется.
Логов нет, система намертво виснет, не успевает ничего сказать. Хотя можно попробовать включить опцию "Kernel debugging"...
Сдвиги будут - напишу.
Back to top
View user's profile Send private message
Zlo_ch
n00b
n00b


Joined: 20 Sep 2006
Posts: 18
Location: Ryazan

PostPosted: Thu Feb 01, 2007 8:45 pm    Post subject: Reply with quote

Слушай а посмотри в сторону hal и dbus моет они влияют :) проверь на флаги , Может они как-то влияют....
Back to top
View user's profile Send private message
_Sir_
Guru
Guru


Joined: 17 Jan 2005
Posts: 337
Location: Russia, Togliatti

PostPosted: Wed Feb 21, 2007 3:13 pm    Post subject: Reply with quote

Не берусь утверждать, так как автор поста преступно утаил имя ноутбука, но доподлинно проверено, что под XP практически невозможно заставить работать любую pcmcia-карту в ноутбуках Compaq Evo N600 и сходных :)))) Под линукс проверить не удалось из за негодности привода CD. Проблема решается бубуном и службой поддержки HP которая предлагает ряд фиксов, но мне не повезло :)

Ноутбук насмерть "замерзает" когда вставляешь карту, и так же беспроблемно оживает, когда ее извлекаешь. Это картинка такая

И еще. Ты уверен в необходимости флага ammr для пакета
madwifi-ng? Мне кажется, есть смысл его выключить.
_________________
(Sir) * Life is placeholder for Love *
Back to top
View user's profile Send private message
amazing
n00b
n00b


Joined: 28 Jan 2007
Posts: 9
Location: Russia, SPb

PostPosted: Fri Feb 23, 2007 4:48 pm    Post subject: Reply with quote

_Sir_

Имя ноутбука sony vgn-sz1xrp.

amrr флаг для madwifi-ng не влияет на работу сисистемы в целом, она не виснет с ним или без него. Проверено опытным путем.

Ядро обновил до 2.6.20.

В итоге мой atheros больше не виснет в режиме мониторинга :)
Проверено на kismet 2007.01.R1

Если что еще уточнить, спрашивайте.

Всем большое спасибо за проявленый интерес к данной теме. И с праздником вас, мужики!
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Russian All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum