Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[kernel] Je ne peux charger gspca module
View unanswered posts
View posts from last 24 hours

Goto page 1, 2  Next  
Reply to topic    Gentoo Forums Forum Index French
View previous topic :: View next topic  
Author Message
pacho2
Developer
Developer


Joined: 04 Mar 2005
Posts: 2599
Location: Oviedo, Spain

PostPosted: Sat Jan 27, 2007 3:52 pm    Post subject: [kernel] Je ne peux charger gspca module Reply with quote

J'ai installé gspcav1-20070110, mais, il ne charge pas, je reçu le suivant:
modprobe gspca
Code:

FATAL: Error inserting gspca
(/lib/modules/2.6.19-gentoo-r4/usb/video/gspca.ko): Unknown symbol in module,
or unknown parameter (see dmesg)


dmesg:
Code:
gspca: disagrees about version of symbol video_devdata
gspca: Unknown symbol video_devdata
gspca: disagrees about version of symbol video_unregister_device
gspca: Unknown symbol video_unregister_device
gspca: disagrees about version of symbol video_device_alloc
gspca: Unknown symbol video_device_alloc
gspca: disagrees about version of symbol video_register_device
gspca: Unknown symbol video_register_device
gspca: disagrees about version of symbol video_usercopy
gspca: Unknown symbol video_usercopy
gspca: disagrees about version of symbol video_device_release
gspca: Unknown symbol video_device_release


Mon kernel config est ici. C'est un kernel 2.6.19-r4 (J'utilise gentoo-sources-2.6.19-r4) sur amd64

Merci beaucoup


Last edited by pacho2 on Sun Jan 28, 2007 12:11 am; edited 1 time in total
Back to top
View user's profile Send private message
nost4r
Apprentice
Apprentice


Joined: 08 Oct 2006
Posts: 164
Location: Bordeaux

PostPosted: Sat Jan 27, 2007 4:35 pm    Post subject: Reply with quote

J'ai ce même message d'erreur avec le module ipw2200 .
Back to top
View user's profile Send private message
Scullder
Guru
Guru


Joined: 16 Mar 2006
Posts: 466
Location: France

PostPosted: Sat Jan 27, 2007 10:29 pm    Post subject: Reply with quote

Complètement par hasard (et avec très peu de chances que ce soit ça), t'as utilisé la même version de gcc pour compiler le noyau et tes modules ?
_________________
Linux gentoo 2.6.18-ck1-r2 #1 PREEMPT Fri Nov 17 01:37:56 CET 2006 x86_64 AMD Athlon(tm) 64 Processor 3000+ AuthenticAMD GNU/Linux
Back to top
View user's profile Send private message
kernelsensei
Bodhisattva
Bodhisattva


Joined: 22 Feb 2004
Posts: 5619
Location: Woustviller/Moselle/FRANCE (49.07°N;7.02°E)

PostPosted: Sat Jan 27, 2007 10:41 pm    Post subject: Reply with quote

Salut,

merci de changer le titre en [kernel] Je ne peux charger gspca module (par exemple) afin que celui-ci soit conforme !

Amicalement,
_________________
$ ruby -e'puts " .:@BFegiklnorst".unpack("x4ax7aaX6ax5aX15ax4aax6aaX7ax2aX5aX8 \
axaX3ax8aX4ax6aX3aX6ax3ax3aX9ax4ax2aX9axaX6ax3aX2ax4ax3aX4aXaX12ax10aaX7a").join'
Back to top
View user's profile Send private message
pacho2
Developer
Developer


Joined: 04 Mar 2005
Posts: 2599
Location: Oviedo, Spain

PostPosted: Sun Jan 28, 2007 12:12 am    Post subject: Reply with quote

Scullder wrote:
Compl�tement par hasard (et avec tr�s peu de chances que ce soit �a), t'as utilis� la m�me version de gcc pour compiler le noyau et tes modules ?


Oui, j'ai utilise la meme version de gcc :-|
Back to top
View user's profile Send private message
razer
l33t
l33t


Joined: 08 Oct 2004
Posts: 893
Location: Paris - France

PostPosted: Sun Jan 28, 2007 10:14 am    Post subject: Reply with quote

Salut,

Je pense que tu dois avoir une redondance entre des modules/fonctions compilées lors de la compil de ton noyau, et d'autres qui sont crées avec le module externe que tu tentes d'ajouter...
Comme il revient le thème "video", il s'agit peut-être de v4l (???)
Pour çà tu dois nous dire à quoi sert exactement ton module et le matériel qui lui est associé (carte d'acquisition ?)
je crois que le code de v4l intégré directement dans le noyau est assez obsolète, or tu as dans ton "config" :
Code:
# Multimedia devices
#
CONFIG_VIDEO_DEV=m
CONFIG_VIDEO_V4L1=y
CONFIG_VIDEO_V4L1_COMPAT=y
CONFIG_VIDEO_V4L2=y


Essaye de recompiler ton noyau sans le support de v4l, recompile ensuite ton module, et dis nous ce que çà donne
Back to top
View user's profile Send private message
pacho2
Developer
Developer


Joined: 04 Mar 2005
Posts: 2599
Location: Oviedo, Spain

PostPosted: Sun Jan 28, 2007 4:50 pm    Post subject: Reply with quote

razer wrote:
Salut,

Je pense que tu dois avoir une redondance entre des modules/fonctions compilées lors de la compil de ton noyau, et d'autres qui sont crées avec le module externe que tu tentes d'ajouter...
Comme il revient le thème "video", il s'agit peut-être de v4l (???)
Pour çà tu dois nous dire à quoi sert exactement ton module et le matériel qui lui est associé (carte d'acquisition ?)
je crois que le code de v4l intégré directement dans le noyau est assez obsolète, or tu as dans ton "config" :
Code:
# Multimedia devices
#
CONFIG_VIDEO_DEV=m
CONFIG_VIDEO_V4L1=y
CONFIG_VIDEO_V4L1_COMPAT=y
CONFIG_VIDEO_V4L2=y


Essaye de recompiler ton noyau sans le support de v4l, recompile ensuite ton module, et dis nous ce que çà donne


J'ai essaié sans le support de v4l mais gspca ne compile pas :-/ Je doit compile kernel avec CONFIG_VIDEO_V4L1_COMPAT support...

Merci
Back to top
View user's profile Send private message
shakya
n00b
n00b


Joined: 04 Dec 2006
Posts: 40
Location: Somewhere

PostPosted: Sun Jan 28, 2007 6:46 pm    Post subject: Reply with quote

Bonjour

il me semble que le gspcav1 n'utilise que le v4l1 donc essaie de supprimer le support v4l2 dans ton noyau...
Back to top
View user's profile Send private message
pacho2
Developer
Developer


Joined: 04 Mar 2005
Posts: 2599
Location: Oviedo, Spain

PostPosted: Sun Jan 28, 2007 8:05 pm    Post subject: Reply with quote

shakya wrote:
Bonjour

il me semble que le gspcav1 n'utilise que le v4l1 donc essaie de supprimer le support v4l2 dans ton noyau...


J'ai essaié aussi sans v4l2 support, mais, il ne charge pas :-(

Merci
Back to top
View user's profile Send private message
shakya
n00b
n00b


Joined: 04 Dec 2006
Posts: 40
Location: Somewhere

PostPosted: Sun Jan 28, 2007 9:33 pm    Post subject: Reply with quote

tu as essayé de refaire apres compil des modules un
Code:
depmod -ae
?

sinon que te donne un
Code:
insmod -v [i]chemin-de_ton_module/nom_de_ton_module[/i]
?
Back to top
View user's profile Send private message
pacho2
Developer
Developer


Joined: 04 Mar 2005
Posts: 2599
Location: Oviedo, Spain

PostPosted: Sun Jan 28, 2007 9:48 pm    Post subject: Reply with quote

shakya wrote:
tu as essayé de refaire apres compil des modules un
Code:
depmod -ae
?

sinon que te donne un
Code:
insmod -v [i]chemin-de_ton_module/nom_de_ton_module[/i]
?


Code:
(22:47:33) root@localhost /lib/modules/2.6.19-gentoo-r4 # insmod -v usb/video/gspca.ko
insmod: can't read '-v': No such file or directory


Code:
(22:48:25) root@localhost /lib/modules/2.6.19-gentoo-r4 # insmod usb/video/gspca.ko -v
insmod: error inserting 'usb/video/gspca.ko': -1 Unknown symbol in module


Merci
Back to top
View user's profile Send private message
shakya
n00b
n00b


Joined: 04 Dec 2006
Posts: 40
Location: Somewhere

PostPosted: Mon Jan 29, 2007 12:27 am    Post subject: Reply with quote

pourrais tu essayer de compiler directement via cette archive et me donner les resultats ?

http://mxhaard.free.fr/spca50x/Download/gspcav1-20070110.tar.gz

C'est celle que jai installé sur un poste alors que lebuild n etais pas encore dispo et qui fonctionne sans probleme sur unede mes babasses...
Back to top
View user's profile Send private message
pacho2
Developer
Developer


Joined: 04 Mar 2005
Posts: 2599
Location: Oviedo, Spain

PostPosted: Mon Jan 29, 2007 10:11 am    Post subject: Reply with quote

Les memes resultats :-(
Code:

 modprobe gspca

FATAL: Error inserting gspca (/lib/modules/2.6.19-gentoo-r4/kernel/drivers/usb/media/gspca.ko): Unknown symbol in module, or unknown parameter (see dmesg)

Code:

gspca: disagrees about version of symbol video_devdata
gspca: Unknown symbol video_devdata
gspca: disagrees about version of symbol video_unregister_device
gspca: Unknown symbol video_unregister_device
gspca: disagrees about version of symbol video_device_alloc
gspca: Unknown symbol video_device_alloc
gspca: disagrees about version of symbol video_register_device
gspca: Unknown symbol video_register_device
gspca: disagrees about version of symbol video_usercopy
gspca: Unknown symbol video_usercopy
gspca: disagrees about version of symbol video_device_release
gspca: Unknown symbol video_device_release

Code:

insmod /lib/modules/2.6.19-gentoo-r4/kernel/drivers/usb/media/gspca.ko -v

insmod: error inserting '/lib/modules/2.6.19-gentoo-r4/kernel/drivers/usb/media/gspca.ko': -1 Unknown symbol in module
Back to top
View user's profile Send private message
shakya
n00b
n00b


Joined: 04 Dec 2006
Posts: 40
Location: Somewhere

PostPosted: Mon Jan 29, 2007 1:11 pm    Post subject: Reply with quote

ben mince...

ca doit venir d'une option dans ton noyau...

Essaies eventuellement de desactiver le CONFIG_LOCALVERSION_AUTO=y dans le general setup

comme ceci :

#
# General setup
#
CONFIG_LOCALVERSION=""
#CONFIG_LOCALVERSION_AUTO not set

recompile, passe sur le nouveau noyau et installe de nouveau gspcav1
Back to top
View user's profile Send private message
pacho2
Developer
Developer


Joined: 04 Mar 2005
Posts: 2599
Location: Oviedo, Spain

PostPosted: Mon Jan 29, 2007 2:56 pm    Post subject: Reply with quote

shakya wrote:
ben mince...

ca doit venir d'une option dans ton noyau...

Essaies eventuellement de desactiver le CONFIG_LOCALVERSION_AUTO=y dans le general setup

comme ceci :

#
# General setup
#
CONFIG_LOCALVERSION=""
#CONFIG_LOCALVERSION_AUTO not set

recompile, passe sur le nouveau noyau et installe de nouveau gspcav1


Le meme resultat :-(

Merci baucoup
Back to top
View user's profile Send private message
shakya
n00b
n00b


Joined: 04 Dec 2006
Posts: 40
Location: Somewhere

PostPosted: Mon Jan 29, 2007 4:10 pm    Post subject: Reply with quote

bon alors essayons un truc supplementaire... :wink:



#CONFIG_VIDEO_HELPER_CHIPS_AUTO not set

dans la section Video Capture Adapters de ta config noyau
Back to top
View user's profile Send private message
pacho2
Developer
Developer


Joined: 04 Mar 2005
Posts: 2599
Location: Oviedo, Spain

PostPosted: Mon Jan 29, 2007 8:11 pm    Post subject: Reply with quote

shakya wrote:
bon alors essayons un truc supplementaire... :wink:



#CONFIG_VIDEO_HELPER_CHIPS_AUTO not set

dans la section Video Capture Adapters de ta config noyau


Mon config a cette option ("#CONFIG_VIDEO_HELPER_CHIPS_AUTO not set") et module ne charge pas :-(

Est-ce que je doit activer cette option?

merci
Back to top
View user's profile Send private message
shakya
n00b
n00b


Joined: 04 Dec 2006
Posts: 40
Location: Somewhere

PostPosted: Tue Jan 30, 2007 3:31 pm    Post subject: Reply with quote

Ce n'est pas nécéssaire pour gspcav1...

J'ai vérifié le module gspcav1 avec une philips SPC 210 NC . Ca tourne impéccable sur mon laptop avec un 2.6.19-suspend2-r1. Au niveau des options j'ai ceci :

#
# Multimedia devices
#
CONFIG_VIDEO_DEV=y
CONFIG_VIDEO_V4L1=y
CONFIG_VIDEO_V4L1_COMPAT=y
CONFIG_VIDEO_V4L2=y

#
# Video Capture Adapters
#

#
# Video Capture Adapters
#
# CONFIG_VIDEO_ADV_DEBUG is not set
# CONFIG_VIDEO_HELPER_CHIPS_AUTO is not set


Essaie eventuellement avec une version du noyau differente de la 2.6.19-gentoo-r4
Back to top
View user's profile Send private message
kwenspc
Advocate
Advocate


Joined: 21 Sep 2003
Posts: 4954

PostPosted: Tue Jan 30, 2007 3:46 pm    Post subject: Reply with quote

Petite question: les drivers gspca ils remplacent les spca5xx?

Je dis ça parce que chez moi depuis quelques semaines n'importe quel spca5xx fait freezer ma bécane.
_________________
membre officieux du SAV Ati GEntoo
Back to top
View user's profile Send private message
shakya
n00b
n00b


Joined: 04 Dec 2006
Posts: 40
Location: Somewhere

PostPosted: Tue Jan 30, 2007 3:54 pm    Post subject: Reply with quote

en fait c'est la future version gspcav2 qui est appelé à remplacer gspcav1 et spca5xx.

Mais dans l'immédiat :

Pour les noyaux supérieurs à 2.6.11, il faut utiliser gspca. Pour les autres spca5xx.

voila

D'ailleurs tiens à ce propos nous avons ledroit à 2 ebuilds sur gspca :

gspca qui propose la version 01.00.10 et gspcav1 20070110 qui correspond à la 01.00.12. Lequel est appelé à disparaitre ?
Back to top
View user's profile Send private message
pacho2
Developer
Developer


Joined: 04 Mar 2005
Posts: 2599
Location: Oviedo, Spain

PostPosted: Wed Jan 31, 2007 7:03 pm    Post subject: Reply with quote

shakya wrote:
Ce n'est pas nécéssaire pour gspcav1...

J'ai vérifié le module gspcav1 avec une philips SPC 210 NC . Ca tourne impéccable sur mon laptop avec un 2.6.19-suspend2-r1. Au niveau des options j'ai ceci :

#
# Multimedia devices
#
CONFIG_VIDEO_DEV=y
CONFIG_VIDEO_V4L1=y
CONFIG_VIDEO_V4L1_COMPAT=y
CONFIG_VIDEO_V4L2=y

#
# Video Capture Adapters
#

#
# Video Capture Adapters
#
# CONFIG_VIDEO_ADV_DEBUG is not set
# CONFIG_VIDEO_HELPER_CHIPS_AUTO is not set


Essaie eventuellement avec une version du noyau differente de la 2.6.19-gentoo-r4


J'ai aidde ces options:
Code:
CONFIG_VIDEO_DEV=y
CONFIG_VIDEO_V4L1=y
CONFIG_VIDEO_V4L1_COMPAT=y
CONFIG_VIDEO_V4L2=y


et le module CHARGE :-D (avec erreurs :( )

Quand je charge gspca, je vois ces messages:
Code:

WARNING: Error inserting v4l1_compat (/lib/modules/2.6.19-gentoo-r4/v4l-dvb/video/v4l1-compat.ko): Invalid module format
WARNING: Error inserting v4l2_common (/lib/modules/2.6.19-gentoo-r4/v4l-dvb/video/v4l2-common.ko): Invalid module format
WARNING: Error inserting videodev (/lib/modules/2.6.19-gentoo-r4/v4l-dvb/video/videodev.ko): Unknown symbol in module, or unknown parameter (see dmesg)


dmesg:
Code:

v4l1_compat: exports duplicate symbol v4l_compat_translate_ioctl (owned by kernel)
v4l2_common: exports duplicate symbol v4l2_video_std_construct (owned by kernel)
videodev: Unknown symbol v4l2_norm_to_name
videodev: disagrees about version of symbol v4l_compat_translate_ioctl
videodev: Unknown symbol v4l_compat_translate_ioctl
/var/tmp/portage/gspcav1-20070110/work/gspcav1-20070110/gspca_core.c: USB SPCA5XX camera found.(ZC3XX)
/var/tmp/portage/gspcav1-20070110/work/gspcav1-20070110/gspca_core.c: [spca5xx_probe:3983] Camera type JPEG
/var/tmp/portage/gspcav1-20070110/work/gspcav1-20070110/Vimicro/zc3xx.h: [zc3xx_config:515] Sensor ID:10
/var/tmp/portage/gspcav1-20070110/work/gspcav1-20070110/Vimicro/zc3xx.h: [zc3xx_config:587] Find Sensor PAS106
/var/tmp/portage/gspcav1-20070110/work/gspcav1-20070110/gspca_core.c: [spca5xx_getcapability:1189] maxw 352 maxh 288 minw 176 minh 144
usbcore: registered new interface driver gspca
/var/tmp/portage/gspcav1-20070110/work/gspcav1-20070110/gspca_core.c: gspca driver 01.00.12 registered


Merci beaucoup
Back to top
View user's profile Send private message
kwenspc
Advocate
Advocate


Joined: 21 Sep 2003
Posts: 4954

PostPosted: Wed Jan 31, 2007 7:35 pm    Post subject: Reply with quote

Merci pour les précisions Shakya :D

Je vais tester ça un de ces soirs (et faire taires les mauvaises langues de la famille qui disent "ah bah c'est Linux..." )
_________________
membre officieux du SAV Ati GEntoo
Back to top
View user's profile Send private message
shakya
n00b
n00b


Joined: 04 Dec 2006
Posts: 40
Location: Somewhere

PostPosted: Wed Jan 31, 2007 10:22 pm    Post subject: Reply with quote

pacho2 wrote:

J'ai aidde ces options:
Code:
CONFIG_VIDEO_DEV=y
CONFIG_VIDEO_V4L1=y
CONFIG_VIDEO_V4L1_COMPAT=y
CONFIG_VIDEO_V4L2=y


et le module CHARGE :-D (avec erreurs :( )

Quand je charge gspca, je vois ces messages:
Code:

WARNING: Error inserting v4l1_compat (/lib/modules/2.6.19-gentoo-r4/v4l-dvb/video/v4l1-compat.ko): Invalid module format
WARNING: Error inserting v4l2_common (/lib/modules/2.6.19-gentoo-r4/v4l-dvb/video/v4l2-common.ko): Invalid module format
WARNING: Error inserting videodev (/lib/modules/2.6.19-gentoo-r4/v4l-dvb/video/videodev.ko): Unknown symbol in module, or unknown parameter (see dmesg)


dmesg:
Code:

v4l1_compat: exports duplicate symbol v4l_compat_translate_ioctl (owned by kernel)
v4l2_common: exports duplicate symbol v4l2_video_std_construct (owned by kernel)
videodev: Unknown symbol v4l2_norm_to_name
videodev: disagrees about version of symbol v4l_compat_translate_ioctl
videodev: Unknown symbol v4l_compat_translate_ioctl
/var/tmp/portage/gspcav1-20070110/work/gspcav1-20070110/gspca_core.c: USB SPCA5XX camera found.(ZC3XX)
/var/tmp/portage/gspcav1-20070110/work/gspcav1-20070110/gspca_core.c: [spca5xx_probe:3983] Camera type JPEG
/var/tmp/portage/gspcav1-20070110/work/gspcav1-20070110/Vimicro/zc3xx.h: [zc3xx_config:515] Sensor ID:10
/var/tmp/portage/gspcav1-20070110/work/gspcav1-20070110/Vimicro/zc3xx.h: [zc3xx_config:587] Find Sensor PAS106
/var/tmp/portage/gspcav1-20070110/work/gspcav1-20070110/gspca_core.c: [spca5xx_getcapability:1189] maxw 352 maxh 288 minw 176 minh 144
usbcore: registered new interface driver gspca
/var/tmp/portage/gspcav1-20070110/work/gspcav1-20070110/gspca_core.c: gspca driver 01.00.12 registered


Merci beaucoup


je ne vois pas comment tu pourrais charger le module videodev alors qu'il est dans dur dans ton noyau...

Essaie en installant le 2.6.19-gentoo-r5 et emerge à nouveau gspcav1 après reboot sur le nouveau noyau. Je rappelle toutefois que gspcav1 est pour le moment Hard masqued.
Back to top
View user's profile Send private message
pacho2
Developer
Developer


Joined: 04 Mar 2005
Posts: 2599
Location: Oviedo, Spain

PostPosted: Fri Feb 02, 2007 9:57 am    Post subject: Reply with quote

shakya wrote:

je ne vois pas comment tu pourrais charger le module videodev alors qu'il est dans dur dans ton noyau...

Essaie en installant le 2.6.19-gentoo-r5 et emerge à nouveau gspcav1 après reboot sur le nouveau noyau. Je rappelle toutefois que gspcav1 est pour le moment Hard masqued.


Je te jure que l'appareil-photo digital marche avec les erreurs.

Il pareil un probleme avec v4l-dvb-hg modules
https://forums.gentoo.org/viewtopic-p-3879314.html#3879314

Merci beaucoup
Back to top
View user's profile Send private message
shakya
n00b
n00b


Joined: 04 Dec 2006
Posts: 40
Location: Somewhere

PostPosted: Fri Feb 02, 2007 10:20 am    Post subject: Reply with quote

La cohabitation d'une webcam et d'une carte TV est toujours une grande aventure...

Je sais que ta webcam fonctionne puisque le chargement de gspca s'effectue bien (détection du sensor, du PAS, et activation du module)

Ce que je ne comprennais pas ce sont tes WARNINGS qui portaient sur des modules maintenant inexistant puisqu'ils étaient intégrés en dur dans ton kernel
( CONFIG_VIDEO_DEV=y, CONFIG_VIDEO_V4L1=y, CONFIG_VIDEO_V4L1_COMPAT=y, CONFIG_VIDEO_V4L2=y)

peut etre devrais tu compiler avec des options personnalisés ton v4l-dvb (en telechargeant directement toi meme les sources et en modifiant les options) ou encore modifier les includes de gspca.h sur gspcav1 ou peut etre plus simplement en integrant directement v4l-dvb en module dans le noyau (CONFIG_DVB=m , CONFIG_DVB_CORE=m dans la section Digital Video Broadcasting Devices) après avoir patché avec la branche aka hg

mais bon le principal c'est que ta cam fonctionne ;)

A tout hasard quel type de carte tv utilises tu ?
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index French All times are GMT
Goto page 1, 2  Next
Page 1 of 2

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum