Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
** Major XEffects change **
View unanswered posts
View posts from last 24 hours

Goto page 1, 2, 3, 4  Next  
Reply to topic    Gentoo Forums Forum Index Unsupported Software
View previous topic :: View next topic  
Author Message
nesl247
Veteran
Veteran


Joined: 15 Jun 2004
Posts: 1614
Location: Florida

PostPosted: Thu Jan 25, 2007 12:20 am    Post subject: ** Major XEffects change ** Reply with quote

Hey folks. XEffects user's who use the live ebuilds will need to upgrade to portage-2.1.2-r4. Also, any -* in your package.keywords file for beryl related packages needs to be replaced with **.

Thank you,
nesl247 - Alex

P.S. Beryl 0.2.0 (0.1.99.2) is in xeffects for those of you who wanted it.
Back to top
View user's profile Send private message
immudium
Guru
Guru


Joined: 12 Oct 2004
Posts: 332
Location: Utah

PostPosted: Thu Jan 25, 2007 2:01 am    Post subject: Re: ** Major XEffects change ** Reply with quote

nesl247 wrote:

P.S. Beryl 0.2.0 (0.1.99.2) is in xeffects for those of you who wanted it.


Ooh yay! I do.

Also thanks for the heads up about portage. Since that is the only package on my entire system that I specifically force to run at the stable version, I can only imagine the confusion it would have caused had I tried to use the cvs ebuilds.

Excellent work as always 8)
Back to top
View user's profile Send private message
beatryder
Veteran
Veteran


Joined: 08 Apr 2005
Posts: 1138

PostPosted: Thu Jan 25, 2007 3:57 am    Post subject: Reply with quote

Problem:

Code:

These are the packages that would be merged, in order:

Calculating world dependencies |
emerge: there are no ebuilds to satisfy "~x11-themes/emerald-themes-0.1.99.2".
(dependency required by "x11-wm/emerald-0.1.99.2" [ebuild])



!!! Problem resolving dependencies for x11-wm/emerald
!!! Depgraph creation failed.


and the only fix is to install the CVS version, which I do not want to do :p
_________________
Dont make it idiot proof, make it work.
Neucode.org
<suppressed key>
Back to top
View user's profile Send private message
nesl247
Veteran
Veteran


Joined: 15 Jun 2004
Posts: 1614
Location: Florida

PostPosted: Thu Jan 25, 2007 4:07 am    Post subject: Reply with quote

Oops, missed bumping that package, done.
Back to top
View user's profile Send private message
beatryder
Veteran
Veteran


Joined: 08 Apr 2005
Posts: 1138

PostPosted: Thu Jan 25, 2007 4:16 am    Post subject: Reply with quote

nesl247 wrote:
Oops, missed bumping that package, done.


YAY!
I emerge nowz!
Futz:
Code:

Osiris ryan # emerge -Dauv world

These are the packages that would be merged, in order:

Calculating world dependencies \
!!! Multiple versions within a single package slot have been
!!! pulled into the dependency graph:

('ebuild', '/', 'x11-plugins/beryl-plugins-0.1.4', 'nomerge') pulled in by
  ('ebuild', '/', 'x11-plugins/beryl-dbus-0.1.4', 'nomerge')

('ebuild', '/', 'x11-plugins/beryl-plugins-0.1.99.2', 'merge') pulled in by
  ('ebuild', '/', 'x11-wm/beryl-core-0.1.99.2', 'merge')

It may be possible to solve this problem by using package.mask to
prevent one of those packages from being selected. However, it is also
possible that conflicting dependencies exist such that they are
impossible to satisfy simultaneously. If such a conflict exists in the
dependencies of two different packages, then those packages can not be
installed simultaneously.

For more information, see MASKED PACKAGES section in the emerge man page
or refer to the Gentoo Handbook.

!!! Depgraph creation failed.

Osiris ryan # cat /etc/portage/package.keywords/beryl
x11-apps/xlsclients
x11-apps/xvinfo
x11-wm/beryl
x11-wm/beryl-core
x11-wm/emerald
x11-plugins/beryl-plugins
x11-plugins/beryl-dbus
x11-misc/beryl-manager
x11-misc/beryl-settings
x11-themes/emerald-themes
>=x11-libs/libwnck-2.14.2
x11-themes/emerald-themes
x11-wm/aquamarine
x11-misc/beryl-settings-bindings



Halp?
_________________
Dont make it idiot proof, make it work.
Neucode.org
<suppressed key>
Back to top
View user's profile Send private message
desultory
Administrator
Administrator


Joined: 04 Nov 2005
Posts: 9392

PostPosted: Thu Jan 25, 2007 5:47 am    Post subject: Reply with quote

Made topic sticky, at the request of nesl247.
Back to top
View user's profile Send private message
nesl247
Veteran
Veteran


Joined: 15 Jun 2004
Posts: 1614
Location: Florida

PostPosted: Thu Jan 25, 2007 12:49 pm    Post subject: Reply with quote

beatryder wrote:
nesl247 wrote:
Oops, missed bumping that package, done.


YAY!
I emerge nowz!
Futz:
Code:

Osiris ryan # emerge -Dauv world

These are the packages that would be merged, in order:

Calculating world dependencies \
!!! Multiple versions within a single package slot have been
!!! pulled into the dependency graph:

('ebuild', '/', 'x11-plugins/beryl-plugins-0.1.4', 'nomerge') pulled in by
  ('ebuild', '/', 'x11-plugins/beryl-dbus-0.1.4', 'nomerge')

('ebuild', '/', 'x11-plugins/beryl-plugins-0.1.99.2', 'merge') pulled in by
  ('ebuild', '/', 'x11-wm/beryl-core-0.1.99.2', 'merge')

It may be possible to solve this problem by using package.mask to
prevent one of those packages from being selected. However, it is also
possible that conflicting dependencies exist such that they are
impossible to satisfy simultaneously. If such a conflict exists in the
dependencies of two different packages, then those packages can not be
installed simultaneously.

For more information, see MASKED PACKAGES section in the emerge man page
or refer to the Gentoo Handbook.

!!! Depgraph creation failed.

Osiris ryan # cat /etc/portage/package.keywords/beryl
x11-apps/xlsclients
x11-apps/xvinfo
x11-wm/beryl
x11-wm/beryl-core
x11-wm/emerald
x11-plugins/beryl-plugins
x11-plugins/beryl-dbus
x11-misc/beryl-manager
x11-misc/beryl-settings
x11-themes/emerald-themes
>=x11-libs/libwnck-2.14.2
x11-themes/emerald-themes
x11-wm/aquamarine
x11-misc/beryl-settings-bindings



Halp?


Remove beryl-dbus. It's no longer there, but in beryl-plugins with USE="dbus"
Back to top
View user's profile Send private message
beatryder
Veteran
Veteran


Joined: 08 Apr 2005
Posts: 1138

PostPosted: Thu Jan 25, 2007 7:03 pm    Post subject: Reply with quote

Ok, thats great, now emerald wont compile:
Code:
creating emerald-theme-manager
make[2]: Leaving directory `/var/tmp/portage/x11-wm/emerald-0.1.99.2/work/emerald-0.1.99.2/themer'
Making all in pixmaps
make[2]: Entering directory `/var/tmp/portage/x11-wm/emerald-0.1.99.2/work/emerald-0.1.99.2/pixmaps'
make[2]: Nothing to be done for `all'.
make[2]: Leaving directory `/var/tmp/portage/x11-wm/emerald-0.1.99.2/work/emerald-0.1.99.2/pixmaps'
Making all in misc
make[2]: Entering directory `/var/tmp/portage/x11-wm/emerald-0.1.99.2/work/emerald-0.1.99.2/misc'
make[2]: Nothing to be done for `all'.
make[2]: Leaving directory `/var/tmp/portage/x11-wm/emerald-0.1.99.2/work/emerald-0.1.99.2/misc'
Making all in defaults
make[2]: Entering directory `/var/tmp/portage/x11-wm/emerald-0.1.99.2/work/emerald-0.1.99.2/defaults'
Making all in theme
make[3]: Entering directory `/var/tmp/portage/x11-wm/emerald-0.1.99.2/work/emerald-0.1.99.2/defaults/theme'
make[3]: Nothing to be done for `all'.
make[3]: Leaving directory `/var/tmp/portage/x11-wm/emerald-0.1.99.2/work/emerald-0.1.99.2/defaults/theme'
make[3]: Entering directory `/var/tmp/portage/x11-wm/emerald-0.1.99.2/work/emerald-0.1.99.2/defaults'
make[3]: Nothing to be done for `all-am'.
make[3]: Leaving directory `/var/tmp/portage/x11-wm/emerald-0.1.99.2/work/emerald-0.1.99.2/defaults'
make[2]: Leaving directory `/var/tmp/portage/x11-wm/emerald-0.1.99.2/work/emerald-0.1.99.2/defaults'
Making all in doc
make[2]: Entering directory `/var/tmp/portage/x11-wm/emerald-0.1.99.2/work/emerald-0.1.99.2/doc'
make[2]: Nothing to be done for `all'.
make[2]: Leaving directory `/var/tmp/portage/x11-wm/emerald-0.1.99.2/work/emerald-0.1.99.2/doc'
Making all in po
make[2]: Entering directory `/var/tmp/portage/x11-wm/emerald-0.1.99.2/work/emerald-0.1.99.2/po'
make[2]: *** No rule to make target `en.gmo', needed by `all-yes'.  Stop.
make[2]: Leaving directory `/var/tmp/portage/x11-wm/emerald-0.1.99.2/work/emerald-0.1.99.2/po'
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/var/tmp/portage/x11-wm/emerald-0.1.99.2/work/emerald-0.1.99.2'
make: *** [all] Error 2

!!! ERROR: x11-wm/emerald-0.1.99.2 failed.
Call stack:
  ebuild.sh, line 1611:   Called dyn_compile
  ebuild.sh, line 968:   Called qa_call 'src_compile'
  environment, line 1751:   Called src_compile
  ebuild.sh, line 1301:   Called gnome2_src_compile
  gnome2.eclass, line 71:   Called die

!!! compile failure
!!! If you need support, post the topmost build error, and the call stack if relevant.
!!! A complete build log is located at '/var/log/portage/x11-wm:emerald-0.1.99.2:20070125-190308.log'.

!!! This ebuild is from an overlay: '/usr/portage/local/layman/xeffects'

_________________
Dont make it idiot proof, make it work.
Neucode.org
<suppressed key>
Back to top
View user's profile Send private message
nesl247
Veteran
Veteran


Joined: 15 Jun 2004
Posts: 1614
Location: Florida

PostPosted: Thu Jan 25, 2007 7:05 pm    Post subject: Reply with quote

"en" is not a valid LINGUAS. Don't set one, at least for emerald. I'll try and fix this when I get home.
Back to top
View user's profile Send private message
beatryder
Veteran
Veteran


Joined: 08 Apr 2005
Posts: 1138

PostPosted: Thu Jan 25, 2007 7:10 pm    Post subject: Reply with quote

nesl247 wrote:
"en" is not a valid LINGUAS. Don't set one, at least for emerald. I'll try and fix this when I get home.


Would en_US be appropriate?


/edit: yes, yes it is! Thanks, you sent me in the right direction.
_________________
Dont make it idiot proof, make it work.
Neucode.org
<suppressed key>
Back to top
View user's profile Send private message
slycordinator
Advocate
Advocate


Joined: 31 Jan 2004
Posts: 3065
Location: Korea

PostPosted: Thu Jan 25, 2007 9:24 pm    Post subject: Reply with quote

nesl247 wrote:
"en" is not a valid LINGUAS.


Correction: not valid FOR THAT PACKAGE.

Both mplayer and openoffice, for instance, use "en".

Furthermore, the gentoo localization guide specifically shows using the "en" LINGUAS.
http://www.gentoo.org/doc/en/guide-localization.xml
Back to top
View user's profile Send private message
nesl247
Veteran
Veteran


Joined: 15 Jun 2004
Posts: 1614
Location: Florida

PostPosted: Thu Jan 25, 2007 10:06 pm    Post subject: Reply with quote

Oops, I guess I missed typing that when I wrote it, you're 100% correct,
Back to top
View user's profile Send private message
josed
n00b
n00b


Joined: 30 Jun 2006
Posts: 24
Location: chile

PostPosted: Fri Jan 26, 2007 5:13 am    Post subject: Reply with quote

beatryder wrote:
nesl247 wrote:
Oops, missed bumping that package, done.


YAY!
I emerge nowz!
Futz:
Code:

Osiris ryan # emerge -Dauv world

These are the packages that would be merged, in order:

Calculating world dependencies \
!!! Multiple versions within a single package slot have been
!!! pulled into the dependency graph:

('ebuild', '/', 'x11-plugins/beryl-plugins-0.1.4', 'nomerge') pulled in by
  ('ebuild', '/', 'x11-plugins/beryl-dbus-0.1.4', 'nomerge')

('ebuild', '/', 'x11-plugins/beryl-plugins-0.1.99.2', 'merge') pulled in by
  ('ebuild', '/', 'x11-wm/beryl-core-0.1.99.2', 'merge')

It may be possible to solve this problem by using package.mask to
prevent one of those packages from being selected. However, it is also
possible that conflicting dependencies exist such that they are
impossible to satisfy simultaneously. If such a conflict exists in the
dependencies of two different packages, then those packages can not be
installed simultaneously.

For more information, see MASKED PACKAGES section in the emerge man page
or refer to the Gentoo Handbook.

!!! Depgraph creation failed.

Osiris ryan # cat /etc/portage/package.keywords/beryl
x11-apps/xlsclients
x11-apps/xvinfo
x11-wm/beryl
x11-wm/beryl-core
x11-wm/emerald
x11-plugins/beryl-plugins
x11-plugins/beryl-dbus
x11-misc/beryl-manager
x11-misc/beryl-settings
x11-themes/emerald-themes
>=x11-libs/libwnck-2.14.2
x11-themes/emerald-themes
x11-wm/aquamarine
x11-misc/beryl-settings-bindings



Halp?


same problem... what i have to do?

pleezz!!
_________________
Portage 2.1.3.9 (default-linux/amd64/2006.0, gcc-4.1.2, glibc-2.5-r4, 2.6.22-gentoo-r5 x86_64)
Gentoo Base System version 1.12.9
Back to top
View user's profile Send private message
desultory
Administrator
Administrator


Joined: 04 Nov 2005
Posts: 9392

PostPosted: Fri Jan 26, 2007 5:34 am    Post subject: Reply with quote

josed wrote:
same problem... what i have to do?

pleezz!!
Scroll up.
Back to top
View user's profile Send private message
wizard69
Apprentice
Apprentice


Joined: 22 Sep 2003
Posts: 178
Location: Berlin

PostPosted: Fri Jan 26, 2007 3:49 pm    Post subject: Reply with quote

i replaced my package.keywords as suggested by nesl247 with

Code:

x11-apps/xlsclients
x11-apps/xvinfo
x11-wm/beryl **
x11-wm/beryl-core **
x11-wm/emerald **
x11-wm/aquamarine **
x11-plugins/beryl-plugins **
x11-plugins/beryl-plugins-extra **
x11-plugins/beryl-plugins-vidcap **
x11-misc/beryl-manager **
x11-misc/beryl-settings **
x11-misc/beryl-settings-bindings **
x11-themes/emerald-themes **


I upgraded the beryl packages (emerge by path) and now if i run emerge -uD world portage tries to downgrade the packages

Code:

 emerge -uD world -av

These are the packages that would be merged, in order:

Calculating world dependencies... done!
[ebuild     U ] x11-wm/beryl-core-9999 [0.1.99.2] 0 kB [1]
[ebuild     U ] x11-misc/beryl-manager-9999 [0.1.99.2] 0 kB [1]
[ebuild     U ] x11-wm/emerald-9999 [0.1.99.2] USE="-debug" 0 kB [1]
[ebuild     U ] x11-plugins/beryl-plugins-9999 [0.1.99.2] USE="dbus -vidcap" 0 kB [1]
[ebuild     U ] x11-misc/beryl-settings-bindings-9999 [0.1.99.2] 0 kB [1]
[ebuild     U ] x11-themes/emerald-themes-9999 [0.1.99.2] 0 kB [1]
[ebuild     U ] x11-misc/beryl-settings-9999 [0.1.99.2] 0 kB [1]
[ebuild     U ] x11-wm/beryl-9999 [0.1.99.2] 0 kB [1]

Total: 8 packages (8 upgrades), Size of downloads: 0 kB
Portage overlays:
 [1] /usr/local/layman/xeffects

is there any way round this intill the 9999 ebuild disappear from the overlay?
Back to top
View user's profile Send private message
n0rbi666
l33t
l33t


Joined: 04 Mar 2005
Posts: 707
Location: \Poland\Krakow

PostPosted: Fri Jan 26, 2007 4:02 pm    Post subject: Reply with quote

-9999 is cvs/svn/git ebuilds
put in your package.keywords :
Code:
<x11-wm/beryl-9999 **

(only example, put it for al beryl packages :) )
Back to top
View user's profile Send private message
UncleOwen
Veteran
Veteran


Joined: 27 Feb 2003
Posts: 1493
Location: Germany, Hamburg

PostPosted: Fri Jan 26, 2007 4:12 pm    Post subject: Reply with quote

wizard69 wrote:
I upgraded the beryl packages (emerge by path) and now if i run emerge -uD world portage tries to downgrade the packages

I don't see any downgrades, just upgrades.

Quote:
is there any way round this intill the 9999 ebuild disappear from the overlay?

Put the version you don't want in package.mask.
Back to top
View user's profile Send private message
wizard69
Apprentice
Apprentice


Joined: 22 Sep 2003
Posts: 178
Location: Berlin

PostPosted: Fri Jan 26, 2007 4:41 pm    Post subject: Reply with quote

Quote:
don't see any downgrades, just upgrades.


beryl-plugins-0.1.99.2 are the new released ebuilds from the xeffects overlay the x11-plugins/beryl-plugins-9999 are the old ones. So in this case even though portage says elsewise it is a downgrade.


@n0rbi666 so you suggest using the version number in package.keywords i thought that wasn't needed this is from the howto on the xeffects-wiki

Quote:

If you want to use the live svn ebuilds instead (or if you want to use aquamarine, you need at least the aquamarine line): Please see the Overlay setup guide. Then add the following to /etc/portage/package.keywords instead of the above (This is regardless of ~arch or arch):

x11-apps/xlsclients
x11-apps/xvinfo
x11-wm/beryl **
x11-wm/beryl-core **
x11-wm/emerald **
x11-wm/aquamarine **
x11-wm/heliodor **
x11-plugins/beryl-plugins **
x11-plugins/beryl-plugins-extra **
x11-plugins/beryl-plugins-vidcap **
x11-misc/beryl-manager **
x11-misc/beryl-settings **
x11-misc/beryl-settings-bindings **
x11-themes/emerald-themes **


Up till today and the changes in the keywords -* to ** everything worked fine.
Back to top
View user's profile Send private message
n0rbi666
l33t
l33t


Joined: 04 Mar 2005
Posts: 707
Location: \Poland\Krakow

PostPosted: Fri Jan 26, 2007 5:04 pm    Post subject: Reply with quote

wizard69 but portage thinks, that 9999 is newer than 1.99.2 - so, if you want 1.99.2 - you must use version numer :)
Back to top
View user's profile Send private message
gnomen
n00b
n00b


Joined: 04 Sep 2005
Posts: 48

PostPosted: Fri Jan 26, 2007 5:11 pm    Post subject: Reply with quote

wizard69 wrote:
beryl-plugins-0.1.99.2 are the new released ebuilds from the xeffects overlay the x11-plugins/beryl-plugins-9999 are the old ones

That is wrong. A live cvs ebuild is newer than a beta release

Code:
x11-plugins/beryl-plugins **

in package.keywords will emerge the live cvs ebuild

Code:
=x11-plugins/beryl-plugins-0.1* **"

will keep the beta release
Back to top
View user's profile Send private message
wizard69
Apprentice
Apprentice


Joined: 22 Sep 2003
Posts: 178
Location: Berlin

PostPosted: Fri Jan 26, 2007 6:24 pm    Post subject: Reply with quote

@n0rbi666 THX for the tip was starting to get frustrating but it works know with


Code:

=x11-misc/beryl-manager-0.1.99.2 **
=x11-wm/emerald-0.1.99.2 **
=x11-plugins/beryl-plugins-0.1.99.2 **
=x11-misc/beryl-settings-bindings-0.1.99.2 **
=x11-themes/emerald-themes-0.1.99.2 **
=x11-misc/beryl-settings-0.1.99.2 **
=x11-wm/beryl-0.1.99.2 **
=x11-wm/beryl-core-0.1.99.2 **


@gnomen what do you mean that is wrong the 0.199.2 are the newest ebuild in the xeffects-overlay check the change log

[quote]
25 Jan 2007; Alex Heck <nesl247@gmail.com> +beryl-core-0.1.99.2.ebuild:
Version bump

06 Jan 2007; Alex Heck <nesl247@gmail.com> beryl-core-9999.ebuild:
Switch to beryl-mesa-0.1.4
Quote:


Of course you can recieve a more current version through checking out the svn tree but i prefer to use layman. Hence the fact that those are the newest ebuilds available to layman users.
Back to top
View user's profile Send private message
keenblade
Veteran
Veteran


Joined: 03 Oct 2004
Posts: 1087

PostPosted: Fri Jan 26, 2007 7:12 pm    Post subject: Reply with quote

gnomen wrote:
wizard69 wrote:
beryl-plugins-0.1.99.2 are the new released ebuilds from the xeffects overlay the x11-plugins/beryl-plugins-9999 are the old ones

That is wrong. A live cvs ebuild is newer than a beta release

beryl-plugins-9999 must be the newest, because it is from svn's trunk branch. Also it is not cvs but svn, if you use this:
http://svn.gentoo-xeffects.org/xeffects/trunk
Btw, I am getting this error, when building themes. Any idea?
Code:

make[1]: Entering directory `/var/tmp/portage/x11-themes/emerald-themes-9999/work/emerald-themes'
Making all in themes
make[2]: Entering directory `/var/tmp/portage/x11-themes/emerald-themes-9999/work/emerald-themes/themes'
make[2]: *** No rule to make target `Cross-Eyed-Fish.emerald', needed by `all-am'.  Stop.
make[2]: Leaving directory `/var/tmp/portage/x11-themes/emerald-themes-9999/work/emerald-themes/themes'
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/var/tmp/portage/x11-themes/emerald-themes-9999/work/emerald-themes'
make: *** [all] Error 2

!!! ERROR: x11-themes/emerald-themes-9999 failed.
Call stack:
  ebuild.sh, line 1611:   Called dyn_compile
  ebuild.sh, line 968:   Called qa_call 'src_compile'
  environment, line 3484:   Called src_compile
  emerald-themes-9999.ebuild, line 27:   Called die

!!! make failed

_________________
Anyway it's all the same at the end...
Need help to get it working: "x-fi surround 5.1"
Back to top
View user's profile Send private message
nesl247
Veteran
Veteran


Joined: 15 Jun 2004
Posts: 1614
Location: Florida

PostPosted: Fri Jan 26, 2007 7:14 pm    Post subject: Reply with quote

Aah guys for the upgrade issue, ** is for live ebuilds, ~arch is for the 0.1.99.2
Back to top
View user's profile Send private message
keenblade
Veteran
Veteran


Joined: 03 Oct 2004
Posts: 1087

PostPosted: Fri Jan 26, 2007 7:36 pm    Post subject: Reply with quote

nesl247 wrote:
Aah guys for the upgrade issue, ** is for live ebuilds, ~arch is for the 0.1.99.2

Then I used the wrong code. I am on ~amd64 and used **
So, do I need to use ~amd64 , unmerge all beryl stuff, delete svn sources and then reemerge?
I am confused, since I thought getting the bleeding edge svn version is already means
ACCEPT_KEYWORDS="~amd64"
in my make .conf.
_________________
Anyway it's all the same at the end...
Need help to get it working: "x-fi surround 5.1"
Back to top
View user's profile Send private message
keenblade
Veteran
Veteran


Joined: 03 Oct 2004
Posts: 1087

PostPosted: Fri Jan 26, 2007 8:29 pm    Post subject: Reply with quote

Doesn't

    beryl-0.1.99.2.ebuild
    beryl-plugins-0.1.99.2.ebuild
supposed to have
KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
instead of
KEYWORDS=""
?
_________________
Anyway it's all the same at the end...
Need help to get it working: "x-fi surround 5.1"
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Unsupported Software All times are GMT
Goto page 1, 2, 3, 4  Next
Page 1 of 4

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum