Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[Packages] Paquets cassés [Résolu]
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index French
View previous topic :: View next topic  
Author Message
jerep6
Apprentice
Apprentice


Joined: 02 Aug 2006
Posts: 215
Location: Landes

PostPosted: Sun Jan 21, 2007 8:26 pm    Post subject: [Packages] Paquets cassés [Résolu] Reply with quote

Salut !!
J'ai sèrieusement déconné en voulant désinstaller ces paquets :
Code:
emerge -avC "=dev-java/java-sdk-docs-1.5.0-r1" "=media-plugins/gst-plugins-esd-0.8.12" media-libs/musicbrainz "=gnome-base/orbit-0.5.17-r1" "=media-libs/gstreamer-0.8.12" app-mobilephone/gsmlib

Le revdep-rebuild n'était pas beau à voir alors je les ai réinstallé (sauf java-sdk-doc).

Le problème, c'est que revdep-rebuild me dis tjs ceci :
Code:
Checking dynamic linking consistency...
  broken /usr/bin/gnome-name-service (requires  libIIOP.so.0 libORBitCosNaming.so.0 libORBit.so.0 libORBitutil.so.0)
  broken /usr/bin/goad-browser (requires  libIIOP.so.0 libORBitCosNaming.so.0 libORBit.so.0 libORBitutil.so.0)
  broken /usr/bin/loadshlib (requires  libIIOP.so.0 libORBitCosNaming.so.0 libORBit.so.0 libORBitutil.so.0)
  broken /usr/lib/libgnorba.so.27.1.8 (requires  libIIOP.so.0 libORBitCosNaming.so.0 libORBit.so.0 libORBitutil.so.0)
  broken /usr/lib/libgnorba.la (requires /usr/lib/libORBitCosNaming.la)
  broken /usr/lib/libgnorba.la (requires /usr/lib/libORBit.la)
  broken /usr/lib/libgnorba.la (requires /usr/lib/libIIOP.la)
  broken /usr/lib/libgnorba.la (requires /usr/lib/libORBitutil.la)
 done.

All prepared. Starting rebuild...
emerge --oneshot  =gnome-base/gnome-libs-1.4.2
..........
Calculating dependencies \
emerge: there are no ebuilds to satisfy "=gnome-base/gnome-libs-1.4.2".


gnome-base/gnome-libs à disparu de portage? Comment faire pour résoudre ce problème?
Merci.

PS : Notez que j'ai désinstallé gnome-base/orbit-0.5.17-r1 mais que ce packages n'existe plus, j'ai donc sur mon système la version supèrieure c'est à dire la 2.14.2.


Last edited by jerep6 on Thu Jan 25, 2007 8:00 pm; edited 1 time in total
Back to top
View user's profile Send private message
Mythril
n00b
n00b


Joined: 07 Oct 2006
Posts: 52

PostPosted: Sun Jan 21, 2007 8:51 pm    Post subject: Reply with quote

Gnome 1 a été supprimé de Portage, recompile les packages qui dépendaient de gnome 1 pour qu'ils dépendent maintenant de gtk+2 et gnome2
Back to top
View user's profile Send private message
geekounet
Bodhisattva
Bodhisattva


Joined: 11 Oct 2004
Posts: 3772
Location: Wellington, Aotearoa

PostPosted: Sun Jan 21, 2007 9:00 pm    Post subject: Reply with quote

Si les *.la sont redondants sur plusieurs revdep-rebuild, supprime les, ils sont simplement restés à l'unmerge parce qu'ils ont été modifié par un fix_libtool_files.sh
Back to top
View user's profile Send private message
jerep6
Apprentice
Apprentice


Joined: 02 Aug 2006
Posts: 215
Location: Landes

PostPosted: Sun Jan 21, 2007 9:07 pm    Post subject: Reply with quote

Je vais supprimer les *.la.
Comment savoir quels packages dépendent de gnome1? et par extension quels packages dois je recompiler?
Back to top
View user's profile Send private message
jerep6
Apprentice
Apprentice


Joined: 02 Aug 2006
Posts: 215
Location: Landes

PostPosted: Thu Jan 25, 2007 7:59 pm    Post subject: Reply with quote

Apparemment j'ai résolu le problème :
--désinstallation de gnome-libs-1.4.2
--desinstallation de media-libs/gdk-pixbuf-0.22.0-r5

A quoi me servent ces deux packages puisque je ne les utilises jamais? (Aucune librairies de broken avec revdep-rebuild). En plus, je n'utilise pas gnome (USE="-gnome").

Voilà, merci de m'avoir aidé.
Back to top
View user's profile Send private message
Mythril
n00b
n00b


Joined: 07 Oct 2006
Posts: 52

PostPosted: Thu Feb 01, 2007 1:36 pm    Post subject: Reply with quote

jerep6 wrote:
A quoi me servent ces deux packages puisque je ne les utilises jamais? (Aucune librairies de broken avec revdep-rebuild). En plus, je n'utilise pas gnome (USE="-gnome").


Ce devaient être d'anciennes dépendances, pour des paquets qui ont été désinstallés entre temps... Pour supprimer les dépendances obsolètes, fais un "emerge --depclean".
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index French All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum