Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[VIDEO + AUDIO] Lecture de DVD qui foire [Resolu => Stage5]
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index French
View previous topic :: View next topic  
Author Message
davidou2a
Guru
Guru


Joined: 15 Dec 2006
Posts: 574
Location: Ajaccio

PostPosted: Sat Jan 20, 2007 9:16 pm    Post subject: [VIDEO + AUDIO] Lecture de DVD qui foire [Resolu => Stage Reply with quote

Bonsoir a tous, voila jusque la je lisait mes DVD tranquilement avec VLC... seulment et je ne sais trop pourquoi car je n'ai rien modifié de spécial ni fait d'emerge -u world,
Mis a part tenter de mettre "filezilla" en "~amd64" via l'ebuild dispo LA mais je pense pas que ça ait pu influencer la dessus

VLC ainsi que Totem refusent desormais de lire les DVD ils freezent inexplicablement au moment ou il devraient commencer la lecture... j'ai ouvert VLC via une console pour voir si des erreurs en voila le resultat :

Code:
davidou@Warthdog ~ $ mplayer dvd://
MPlayer 1.0pre8-4.1.1 (C) 2000-2006 MPlayer Team
MMX2 supported but disabled
3DNow supported but disabled
3DNowExt supported but disabled
CPUflags:  MMX: 1 MMX2: 0 3DNow: 0 3DNow2: 0 SSE: 1 SSE2: 1
Compilé pour CPU x86 avec les extensions: MMX SSE SSE2


Lecture de dvd://
Lecture de la structure du disque, veuillez patienter...
Il y a 18 titres sur ce DVD.
Il y a 28 chapitres sur ce titre DVD.
Il y a 1 angles sur ce titre DVD.
DVD ouvert avec succès.
Fichier de type MPEG-PS détecté.
VIDEO:  MPEG2  720x576  (aspect 3)  25.000 fps  9800.0 kbps (1225.0 kbyte/s)
==========================================================================
Opening audio decoder: [liba52] AC3 decoding with liba52
Using SSE optimized IMDCT transform
AC3: 5.1 (3f+2r+lfe)  48000 Hz  448.0 kbit/s
Using MMX optimized resampler
AUDIO: 48000 Hz, 2 ch, s16le, 448.0 kbit/29.17% (ratio: 56000->192000)
Selected audio codec: [a52] afm: liba52 (AC3-liba52)
==========================================================================
==========================================================================
Ouverture du décodeur vidéo: [mpegpes] MPEG 1/2 Video passthrough
VDec: requête de config de vo - 720 x 576 (espace colorimétrique préferé: Mpeg PES)
N'a pas pu trouver espace colorimétrique correspondant - nouvel essai avec -vf scale...
Ouverture du filtre vidéo: [scale]
Le périphérique de sortie vidéo sélectionné est incompatible avec ce codec.
Essayer d'ajouter le filtre d'échelle, e.g. -vf spp,scale plutôt que -vf spp.
Echec de l'initialisation de VDecoder :(
Ouverture du décodeur vidéo: [libmpeg2] MPEG 1/2 Video decoder libmpeg2-v0.4.0b
Codec vidéo choisi: [mpeg12] vfm: libmpeg2 (MPEG-1 or 2 (libmpeg2))
==========================================================================
alsa-init: using device default

et ça freeze la...

quelqu un aurait il une idée? ou des suggestions?
_________________
L'enfer je connais, il s'appelle Windows...


Last edited by davidou2a on Sun Jan 21, 2007 7:27 pm; edited 3 times in total
Back to top
View user's profile Send private message
Scullder
Guru
Guru


Joined: 16 Mar 2006
Posts: 466
Location: France

PostPosted: Sat Jan 20, 2007 9:27 pm    Post subject: Reply with quote

Bonsoir,
Pour filezilla, ça doit pas avoir de rapport.
Essaie peut-être de recompiler libdvdread et libdvdcss avec des flags safe. C'est probablement une librairie commune à cex deux programmes qui casse tout. Essaie aussi avec d'autres dvd si t'en as sous la main.
_________________
Linux gentoo 2.6.18-ck1-r2 #1 PREEMPT Fri Nov 17 01:37:56 CET 2006 x86_64 AMD Athlon(tm) 64 Processor 3000+ AuthenticAMD GNU/Linux
Back to top
View user's profile Send private message
davidou2a
Guru
Guru


Joined: 15 Dec 2006
Posts: 574
Location: Ajaccio

PostPosted: Sat Jan 20, 2007 9:34 pm    Post subject: Reply with quote

Plus aucun DVD passe en fait deja il me mets les menu en anglais et non plus en français, ensuite des que je clique sur play movie dans le men u de n'importe lequel de mes dvd ça freeze au niveau de VLC... je vais recompiler libDVDread et libDVDcss avec les flags safe comme tu as dit je poste le resultat juste apres...
_________________
L'enfer je connais, il s'appelle Windows...
Back to top
View user's profile Send private message
Temet
Advocate
Advocate


Joined: 14 Mar 2006
Posts: 2586
Location: 92

PostPosted: Sat Jan 20, 2007 11:20 pm    Post subject: Reply with quote

Gaffe au matos ... j'ai des DVDs (originaux hein) qui passent sur mon graveur DVD mais pas sur mon lecteur ... il a vieilli bien vite je trouve :cry:
Back to top
View user's profile Send private message
davidou2a
Guru
Guru


Joined: 15 Dec 2006
Posts: 574
Location: Ajaccio

PostPosted: Sat Jan 20, 2007 11:39 pm    Post subject: Reply with quote

C'est un graveur DVD +/- double couche...

de toute maniere j'avais une MAJ a faire alors j'ai fait le bourrin on verra bien ce que ça donne
j'ai lancé la guerre systeme du jour avec au menu et dans l'ordre:
Code:
# emerge --sync
# emerge --update --deep --newuse world
# emerge --depclean
# revdep-rebuild

A l'instant ou j'ecris les paquets sont en compilation... reste 120 paquets environ...
On verra ce que ça va donner au pire j'ai mon stage 5 d'avant ce probleme... ou une sauvegarde incrementale d'hier sur mon serveur de sauvegarde...

De toute maniere ce post n'a plus lieu d'etre... vu que je me suis pas trop foulé...
_________________
L'enfer je connais, il s'appelle Windows...
Back to top
View user's profile Send private message
davidou2a
Guru
Guru


Joined: 15 Dec 2006
Posts: 574
Location: Ajaccio

PostPosted: Sun Jan 21, 2007 12:42 am    Post subject: Reply with quote

alors en fait je viens de me rendre compte que au niveau audio ça bloque aussi, je peux plus lire ni ogg, ni mp3...
bref recompil des lib audio? de toute façon je mets a jour le systeme entier apres j'aviserai...
_________________
L'enfer je connais, il s'appelle Windows...
Back to top
View user's profile Send private message
d2_racing
Bodhisattva
Bodhisattva


Joined: 25 Apr 2005
Posts: 13047
Location: Ste-Foy,Canada

PostPosted: Sun Jan 21, 2007 12:54 am    Post subject: Reply with quote

Salut, tu feras attention avec ton emerge --depclean,car dernièrement, il y a eu du monde qui on perdu la commande emerge suite a un emerge --depclean.

On fait quoi quand emerge ne fonctionne plus....
Back to top
View user's profile Send private message
davidou2a
Guru
Guru


Joined: 15 Dec 2006
Posts: 574
Location: Ajaccio

PostPosted: Sun Jan 21, 2007 1:13 am    Post subject: Reply with quote

on ressors le stage 5 mdr dans ce cas :)
_________________
L'enfer je connais, il s'appelle Windows...
Back to top
View user's profile Send private message
Scullder
Guru
Guru


Joined: 16 Mar 2006
Posts: 466
Location: France

PostPosted: Sun Jan 21, 2007 1:47 am    Post subject: Reply with quote

d2_racing wrote:
Salut, tu feras attention avec ton emerge --depclean,car dernièrement, il y a eu du monde qui on perdu la commande emerge suite a un emerge --depclean.

On fait quoi quand emerge ne fonctionne plus....


J'ai perdu bien plus que ça à cause d'un world mal en point :lol:

Pour ton prob, aucune idée (une lib ou sortie son occupée) mais si tu trouves d'où ça vient, dit le nous.
_________________
Linux gentoo 2.6.18-ck1-r2 #1 PREEMPT Fri Nov 17 01:37:56 CET 2006 x86_64 AMD Athlon(tm) 64 Processor 3000+ AuthenticAMD GNU/Linux
Back to top
View user's profile Send private message
davidou2a
Guru
Guru


Joined: 15 Dec 2006
Posts: 574
Location: Ajaccio

PostPosted: Sun Jan 21, 2007 2:27 am    Post subject: Reply with quote

Bon eh bien en consultant mes processus j'ai vu ceçi :
Code:
32005 ?        00:00:00 esdplay <defunct>
  724 ?        00:00:00 esdplay <defunct>
 1096 ?        00:00:00 esdplay <defunct>
 1553 ?        00:00:00 esdplay <defunct>
 1635 ?        00:00:00 esdplay <defunct>
 1742 ?        00:00:00 esdplay <defunct>
 1959 ?        00:00:00 esdplay <defunct>
 1969 ?        00:00:00 esdplay <defunct>
 1970 ?        00:00:00 esdplay <defunct>
 2005 ?        00:00:00 esdplay <defunct>
 2020 ?        00:00:00 esdplay <defunct>
 2029 ?        00:00:00 esdplay <defunct>
 2046 ?        00:00:00 esdplay <defunct>
 2131 ?        00:00:00 esdplay <defunct>
 2327 ?        00:00:00 esdplay <defunct>
 2361 ?        00:00:00 esdplay <defunct>
 2399 ?        00:00:00 esdplay <defunct>
 2506 ?        00:00:00 esdplay <defunct>
20662 ?        00:00:00 esdplay <defunct>
22282 ?        00:00:00 esdplay <defunct>
24903 ?        00:00:00 esdplay <defunct>
29518 ?        00:00:00 esdplay <defunct>


j'ai donc fait un kill sur esd puis un killall esdplay...
VLC relis avec son et sans bug les mpg j'ai pas encore testé sur les DVD... a mon avis les processus esdplay venaient peut etre de tous les bugs de mes multiples essai de lecture dvd... mais le probleme de base est pas la c'est bien la lecture dvd qui plante carrement...
_________________
L'enfer je connais, il s'appelle Windows...


Last edited by davidou2a on Sun Jan 21, 2007 2:58 am; edited 1 time in total
Back to top
View user's profile Send private message
Enlight
Advocate
Advocate


Joined: 28 Oct 2004
Posts: 3519
Location: Alsace (France)

PostPosted: Sun Jan 21, 2007 2:47 am    Post subject: Reply with quote

Heu les gars, on a encore le droit de parler de ça?
Back to top
View user's profile Send private message
davidou2a
Guru
Guru


Joined: 15 Dec 2006
Posts: 574
Location: Ajaccio

PostPosted: Sun Jan 21, 2007 2:51 am    Post subject: Reply with quote

Enlight wrote:
Heu les gars, on a encore le droit de parler de ça?

Parler de quoi? :)
_________________
L'enfer je connais, il s'appelle Windows...
Back to top
View user's profile Send private message
kernelsensei
Bodhisattva
Bodhisattva


Joined: 22 Feb 2004
Posts: 5619
Location: Woustviller/Moselle/FRANCE (49.07°N;7.02°E)

PostPosted: Sun Jan 21, 2007 11:06 am    Post subject: Reply with quote

davidou2a wrote:
Enlight wrote:
Heu les gars, on a encore le droit de parler de ça?

Parler de quoi? :)


Lecture de DVD sous linux ?
_________________
$ ruby -e'puts " .:@BFegiklnorst".unpack("x4ax7aaX6ax5aX15ax4aax6aaX7ax2aX5aX8 \
axaX3ax8aX4ax6aX3aX6ax3ax3aX9ax4ax2aX9axaX6ax3aX2ax4ax3aX4aXaX12ax10aaX7a").join'
Back to top
View user's profile Send private message
lost_in_the_shell
n00b
n00b


Joined: 20 Jan 2007
Posts: 34

PostPosted: Sun Jan 21, 2007 11:13 am    Post subject: Reply with quote

En effet c'est bizarre , moi j'ai eu exactement le même problême hier chez moi , çà marchait il y a deux jours (le soir même de ma premier gentoo 8) ) et tout d'un coup çà s'est mit à me mettre des trucs du genre....

en ce qui me concerne çà s'est résolu aprés avoir re-emerger avec les USES libdvdcss et libdvdread (je n'ai d'ailleur pas compris comment çà se faisait que çà marchait avant sans , enfin bon)

désolé si mon commentaire n'apporte rien de neuf mais c'était juste pour te dire que tu n'es pas le seule (on était deux hier) :wink:
_________________
Vista : "Virus Introduced System Trojan and Adware" : haute sécurité(ptdr)
En résumé : Tous à vos Superstores informatiques , précipitez vous sur les coffrets restant , et surtout NE L'ACHETEZ PAS ! n.b : ne le téléchargez pas non plus
Back to top
View user's profile Send private message
davidou2a
Guru
Guru


Joined: 15 Dec 2006
Posts: 574
Location: Ajaccio

PostPosted: Sun Jan 21, 2007 1:14 pm    Post subject: Reply with quote

j'ai laissé tourner la MAJ durant la nuit et ça a bloqué lors de la MAJ de VLC (comme par hasard) donc je l'ai unmergé et j'ai repris la MAJ pour les paquets restants ~20 paquets... donc je vais voir apres si ça remarche deja avec totem...
_________________
L'enfer je connais, il s'appelle Windows...
Back to top
View user's profile Send private message
El_Goretto
Moderator
Moderator


Joined: 29 May 2004
Posts: 3110
Location: Paris

PostPosted: Sun Jan 21, 2007 3:16 pm    Post subject: Reply with quote

Euh, alors rien à voir avec le schmilblick, mais on parle de VLC (cf le texte) ou de mplayer (cf la citation de code)?
_________________
-FreeNAS: µ-serv Gen8 G1610T, 16Go ECC & µ-serv N40L, 8Go ECC
-FreeBSD 11/Vimage/Jails: DS61, i3 2100T, 16Go
-Réseau: ERL-3 + ESL-24 + GS108Tv2
-NAS: RN312
Back to top
View user's profile Send private message
davidou2a
Guru
Guru


Joined: 15 Dec 2006
Posts: 574
Location: Ajaccio

PostPosted: Sun Jan 21, 2007 6:42 pm    Post subject: Reply with quote

désolé de m'etre mal expliqué en fait tous les lecteurs merdaient... j'ai fait appel a mon stage 5 et le probleme est resolu c'est a ne rien y comprendre...
_________________
L'enfer je connais, il s'appelle Windows...
Back to top
View user's profile Send private message
d2_racing
Bodhisattva
Bodhisattva


Joined: 25 Apr 2005
Posts: 13047
Location: Ste-Foy,Canada

PostPosted: Sun Jan 21, 2007 7:47 pm    Post subject: Reply with quote

Tu as fait appel à ton stage 5...c'est à dire que tu as restaurer ton archive et tu as repris les MAJ depuis ton dernier backup ???
Back to top
View user's profile Send private message
davidou2a
Guru
Guru


Joined: 15 Dec 2006
Posts: 574
Location: Ajaccio

PostPosted: Sun Jan 21, 2007 8:01 pm    Post subject: Reply with quote

J'ai décompressé l'archive dans la partition formatée via le livecd tout simplement, j'ai juste fais une modif ou deux et j'ai relancé la becane...
_________________
L'enfer je connais, il s'appelle Windows...
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index French All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum