Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[XSL-PHP 5.1.4] - installer l'extention XSL ?(non-résolu)
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index French
View previous topic :: View next topic  
Author Message
arnoweb
n00b
n00b


Joined: 15 Jan 2007
Posts: 27

PostPosted: Tue Jan 16, 2007 2:35 pm    Post subject: [XSL-PHP 5.1.4] - installer l'extention XSL ?(non-résolu) Reply with quote

Je souhaite installer l'extention xsl sur la distro modifié par ovh de ma gentoo avec php 5.1.4

Ce que j'ai pu comprendre, c'est que j'ai un fichier ebuild (php5-ovh.ebuid) dans lequel de nombreuses commandes sont passées pour compiler ou recomplier php. Dans le guide, on nous indique donc de mettre à jour notre php via la commande "emerge" de ce fichier ebuild.
Code:

emerge -pv php5-ovh
USE="xsl" emerge php5-ovh


Cependant, à la lecture de ce fichier php-5.ebuild, il n'y a pas d'information concernant la possibilité de configurer php avec l'extention xsl.

Le point de départ est donc la commande emerge pour installer une extention mais cela ne fonctionne pas, donc je bloque à ce niveau là ?

J'ai comparé avec un tutoriel pour installer une autre extention mais le point de départ pour xsl me semble pas identique.

Je bloque donc dès le emerge ?

http://i.majibox.com/articles.php?lng=fr&pg=212 est le tutoriel pour installer une extention différente de xsl mais qui peut serveir de comparatif et d'aide à mon avis.


Last edited by arnoweb on Tue Jan 16, 2007 6:34 pm; edited 3 times in total
Back to top
View user's profile Send private message
Temet
Advocate
Advocate


Joined: 14 Mar 2006
Posts: 2586
Location: 92

PostPosted: Tue Jan 16, 2007 2:42 pm    Post subject: Reply with quote

Yo, t'es sur la zone française mon grand là o_O ;)
Back to top
View user's profile Send private message
GaMeS
Guru
Guru


Joined: 08 Nov 2005
Posts: 374
Location: Nantes

PostPosted: Tue Jan 16, 2007 6:25 pm    Post subject: Reply with quote

Bonjour arnoweb :)

Tout d'abord, la documention de chez OVH c'est pas tiptop, je t'invites à lire la documention handbook à propos des USE
(Voir le fichier /etc/portage/package.use)

Ensuite, pour ce qui est ton USE "XSL", il n'est pas présent dans Apache mais dans dev-lang/php
Edit: je croyais que tu cherchais la USE dans apache... enfin en tout cas c'est pour dire que moi je l'ai cette USE.


Quote:


geekb0x portage #emerge -pv dev-lang/php

Calculating dependencies... done!
[ebuild R ] dev-lang/php-5.1.6-r6 USE="apache2 berkdb cli crypt gdbm iconv mysql ncurses nls pcre readline reflection session spl ssl unicode zlib (-adabas) -apache -bcmath (-birdstep) -bzip2 -calendar -cdb -cgi -cjk -concurrentmodphp -ctype -curl -curlwrappers -db2 -dbase (-dbmaker) -debug -discard-path -doc (-empress) (-empress-bcs) (-esoob) -exif -fastbuild (-fdftk) (-filepro) -firebird -flatfile -force-cgi-redirect (-frontbase) -ftp -gd -gd-external -gmp -hardenedphp -hash -hyperwave-api -imap (-informix) -inifile -interbase -iodbc -ipv6 -java-external -kerberos -ldap -libedit -mcve -memlimit -mhash -ming -msql -mssql -mysqli -oci8 (-oci8-instant-client) -odbc -pcntl -pdo -pdo-external -pic -posix -postgres -qdbm -recode -sapdb -sasl -sharedext -sharedmem -simplexml -snmp -soap -sockets (-solid) -spell -sqlite (-sybase) (-sybase-ct) -sysvipc -threads -tidy -tokenizer -truetype -vm-goto -vm-switch -wddx -xml -xmlreader -xmlrpc -xmlwriter -xpm -xsl -yaz -zip" 0 kB

Total size of downloads: 0 kB


Et enfin, pour notre bien être nous préférons formater nos titres conformément à la charte ci-contre
_________________
$this->setLife(FALSE);
printf "I'm not a gamer !";
Back to top
View user's profile Send private message
arnoweb
n00b
n00b


Joined: 15 Jan 2007
Posts: 27

PostPosted: Tue Jan 16, 2007 6:47 pm    Post subject: Reply with quote

J'ai modifié le titre selon les règles du forum.

Oui, j'ai lu cette doc aussi et d'autres encore.

Pourquoi et comment sais-tu que USE "xsl" n'est pas dans Apache mais dans dev-lang/php ?
Ca me parait logique que ce soit effectivement dans dev-lang/php.

J'ai donc ce fichier ebuild et j'ai tout simplement envie de le modifier pour pouvoir faire :

Code:
emerge -pv php5-ovh

Puis
Code:
USE="xsl" emerge php5-ovh


De la manière qu'indiquer sur le guide ovh :
http://guides.ovh.com/Release2OptionsPhp

En regardant le fichier ebuild, je me rend compte qu'il fait un appel à un package ovh via ftp.
Dans ce package, l'extention ou plutôt le paquet (répertoire) xsl est bien présent, donc je suppose qu'il a été installé.

Mon fichier ebuild original:

Code:

inherit eutils
RESTRICT=""

DESCRIPTION=""
HOMEPAGE=""
SRC_URI="ftp://ftp.serversite.comgentoo/php-$PV.tar.bz2
imagemagick? (http://pecl.php.net/get/imagick-0.9.11.tgz)
"
MASQUAGE=""

SLOT=""
KEYWORDS=""
IUSE="curl imagemagick"

DEPEND="!dev-lang/php
   !dev-php/php
   >=media-libs/jpeg-6b
   media-libs/libpng
   sys-libs/zlib
   >=dev-libs/libxml2-2.6.8
   =sys-libs/db-4*
   =media-libs/freetype-2*
   >=media-libs/t1lib-5.0.0
   sys-devel/gettext
   virtual/imap-c-client
   virtual/krb5
   >=dev-libs/libmcrypt-2.4
   virtual/libiconv
   >=mysql-5.0.21
   curl? ( >=net-misc/curl-7.10.5 )
   imagemagick? ( >=media-gfx/imagemagick-6.2.6.0 )
"
RDEPEND="${DEPEND}"

src_unpack() {
   unpack "php-$PV.tar.bz2"
   cd ${WORKDIR}/"php-$PV"
   epatch ${FILESDIR}/php5-readmycnf-mysql.patch
   epatch ${FILESDIR}/php5-readmycnf-mysqli.patch
   epatch ${FILESDIR}/php5-readmycnf-pdo.patch
   if use imagemagick ; then
      cd ${WORKDIR}
      unpack imagick-0.9.11.tgz
      ln -s ${WORKDIR}/imagick-0.9.11 ${WORKDIR}/"php-$PV/ext/imagick"
      cd ${WORKDIR}/"php-$PV"
      rm ./configure
      ./buildconf --force
   fi
}

src_compile() {
   cd ${WORKDIR}/"php-$PV"
   local myconf
   useq curl && myconf="${myconf} --with-curl"
   useq imagemagick && myconf="${myconf} --with-imagick"
   ./configure ${myconf} \
   --prefix=/usr/local/php5 \
   --with-config-file-path=/usr/local/lib/php5 \
   --with-pear=/usr/share/php5 \
   --with-dbase \
   --with-filepro \
   --with-xml \
   --enable-exif \
   --enable-ftp \
   --with-db \
   --enable-bcmath \
   --enable-calendar \
   --with-gd \
   --enable-gd-native-ttf \
   --with-freetype-dir \
   --with-gettext \
   --with-zlib-dir \
   --enable-trans-sid \
   --with-imap \
   --with-kerberos \
   --with-imap-ssl \
   --with-openssl \
   --enable-sysvsem \
   --enable-sysvshm \
   --with-dom \
   --with-mcrypt \
   --with-iconv \
   --enable-mbstring=all \
   --enable-mbregex \
   --with-png-dir=/usr \
   --with-jpeg-dir=/usr \
   --with-mysql=/usr \
   --with-mime-magic=/usr/share/misc/file/magic.mime \
   --enable-cgi || die "Configure failed"
   emake || die "Compile failed"
}

src_install() {
   cd ${WORKDIR}/"php-$PV"
   make DESTDIR="/usr/local" install || die "Install failed"
   insinto /usr/local/lib/php5/
   newins ${WORKDIR}/"php-$PV/php.ini-dist" php.ini
   ln -sf /usr/local/php5/bin/php /usr/local/bin/php5
}

pkg_postinst() {
   if [ `cat /etc/portage/package.mask | grep $MASQUAGE | wc -l` = 1 ]; then
     einfo "Mask ok"
   else
     einfo "Add Mask"
     echo $MASQUAGE >> /etc/portage/package.mask
   fi
   if [ `cat /etc/portage/profile/package.provided | grep $MASQUAGE-$PV | wc -l` = 1 ]; then
     einfo "Provide ok"
   elif [ `cat /etc/portage/profile/package.provided | grep $MASQUAGE | wc -l` = 1 ]; then
     perl -pi -e "s|($MASQUAGE.*)|$MASQUAGE-$PV|" /etc/portage/profile/package.provided
     einfo "Provide updated"
   else
     echo $MASQUAGE-$PV >> /etc/portage/profile/package.provided
     einfo "Add Provide"
   fi
}


A la manière de l'activation de CURL dans cet ebuild, j'ai envie de le modifier ainsi :

Code:

inherit eutils
RESTRICT=""

DESCRIPTION=""
HOMEPAGE=""
SRC_URI="ftp://ftp.serversite.comgentoo/php-$PV.tar.bz2
imagemagick? (http://pecl.php.net/get/imagick-0.9.11.tgz)
"
MASQUAGE=""

SLOT=""
KEYWORDS=""
IUSE="curl imagemagick"

DEPEND="!dev-lang/php
   !dev-php/php
   >=media-libs/jpeg-6b
   media-libs/libpng
   sys-libs/zlib
   >=dev-libs/libxml2-2.6.8
   =sys-libs/db-4*
   =media-libs/freetype-2*
   >=media-libs/t1lib-5.0.0
   sys-devel/gettext
   virtual/imap-c-client
   virtual/krb5
   >=dev-libs/libmcrypt-2.4
   virtual/libiconv
   >=mysql-5.0.21
#J'APPELLE LE PAQUET XSL
# NET-MISC CORRESPOND A QUOI ? COMMENT CONNAITRE LA VERSION DE XSL
   xsl? ( >=net-misc/curl-7.10.5 )
   curl? ( >=net-misc/curl-7.10.5 )
   imagemagick? ( >=media-gfx/imagemagick-6.2.6.0 )
"
RDEPEND="${DEPEND}"

src_unpack() {
   unpack "php-$PV.tar.bz2"
   cd ${WORKDIR}/"php-$PV"
   epatch ${FILESDIR}/php5-readmycnf-mysql.patch
   epatch ${FILESDIR}/php5-readmycnf-mysqli.patch
   epatch ${FILESDIR}/php5-readmycnf-pdo.patch
   if use imagemagick ; then
      cd ${WORKDIR}
      unpack imagick-0.9.11.tgz
      ln -s ${WORKDIR}/imagick-0.9.11 ${WORKDIR}/"php-$PV/ext/imagick"
      cd ${WORKDIR}/"php-$PV"
      rm ./configure
      ./buildconf --force
   fi
}

src_compile() {
   cd ${WORKDIR}/"php-$PV"
   local myconf
   useq xsl && myconf="${myconf} --with-xsl"
   useq curl && myconf="${myconf} --with-curl"
   useq imagemagick && myconf="${myconf} --with-imagick"
   ./configure ${myconf} \
   --prefix=/usr/local/php5 \
   --with-config-file-path=/usr/local/lib/php5 \
   --with-pear=/usr/share/php5 \
   --with-dbase \
   --with-filepro \
   --with-xml \
   --enable-exif \
   --enable-ftp \
   --with-db \
   --enable-bcmath \
   --enable-calendar \
   --with-gd \
   --enable-gd-native-ttf \
   --with-freetype-dir \
   --with-gettext \
   --with-zlib-dir \
   --enable-trans-sid \
   --with-imap \
   --with-kerberos \
   --with-imap-ssl \
   --with-openssl \
   --enable-sysvsem \
   --enable-sysvshm \
   --with-dom \
   --with-mcrypt \
   --with-iconv \
   --enable-mbstring=all \
   --enable-mbregex \
   --with-png-dir=/usr \
   --with-jpeg-dir=/usr \
   --with-mysql=/usr \
   --with-mime-magic=/usr/share/misc/file/magic.mime \
   --enable-cgi || die "Configure failed"
   emake || die "Compile failed"
}

src_install() {
   cd ${WORKDIR}/"php-$PV"
   make DESTDIR="/usr/local" install || die "Install failed"
   insinto /usr/local/lib/php5/
   newins ${WORKDIR}/"php-$PV/php.ini-dist" php.ini
   ln -sf /usr/local/php5/bin/php /usr/local/bin/php5
}

pkg_postinst() {
   if [ `cat /etc/portage/package.mask | grep $MASQUAGE | wc -l` = 1 ]; then
     einfo "Mask ok"
   else
     einfo "Add Mask"
     echo $MASQUAGE >> /etc/portage/package.mask
   fi
   if [ `cat /etc/portage/profile/package.provided | grep $MASQUAGE-$PV | wc -l` = 1 ]; then
     einfo "Provide ok"
   elif [ `cat /etc/portage/profile/package.provided | grep $MASQUAGE | wc -l` = 1 ]; then
     perl -pi -e "s|($MASQUAGE.*)|$MASQUAGE-$PV|" /etc/portage/profile/package.provided
     einfo "Provide updated"
   else
     echo $MASQUAGE-$PV >> /etc/portage/profile/package.provided
     einfo "Add Provide"
   fi
}


Les 2 problemes :
A quoi corresond :
net-misc/curl-7.10.5
et faut-il donné un chemin du style :
--with-xsl=/usr
?
Back to top
View user's profile Send private message
arnoweb
n00b
n00b


Joined: 15 Jan 2007
Posts: 27

PostPosted: Tue Jan 16, 2007 6:54 pm    Post subject: Reply with quote

De plus, j'ai cette erreur sans rien avoir modifier :
Code:

emerge -pv php5-ovh


!!! Failed to complete python imports. There are internal modules for
!!! python and failure here indicates that you have a problem with python
!!! itself and thus portage is not able to continue processing.

!!! You might consider starting python with verbose flags to see what has
!!! gone wrong. Here is the information we got for this exception:
    bad marshal data

et ma version de python est :
Code:

Python 2.4.2 (#1, May 26 2006, 22:55:38)
[GCC 3.4.5 (Gentoo 3.4.5, ssp-3.4.5-1.0, pie-8.7.9)] on linux2
Type "help", "copyright", "credits" or "license" for more information.
Back to top
View user's profile Send private message
NiLuJe
Guru
Guru


Joined: 06 Nov 2004
Posts: 303
Location: Paris, France

PostPosted: Tue Jan 16, 2007 7:49 pm    Post subject: Reply with quote

Heu, j'suis le seul à trouver cet `ebuild` OVH horriblement laid?

Ça serait pas plus simple de passer via l'ebuild original (à savoir, dev-lang/php) avec les flags USE qui vont bien?

(Je sais strictement pas comment OVH organise leur machin, c'est un overlay supplémentaire? Y'a pas d'arbre portage officiel du tout?).

Par contre l'erreur python ça sent le pâté... Tu t'es déjà servi de Portage/emerge sur cette machine?
Back to top
View user's profile Send private message
GaMeS
Guru
Guru


Joined: 08 Nov 2005
Posts: 374
Location: Nantes

PostPosted: Tue Jan 16, 2007 8:17 pm    Post subject: Reply with quote

Je sais que j'avais aidé une personne du forum pour un problème similaire, il était passer sous le vrai Apache et le vrai Php du portage gentoo et ça avais fonctionné.

Si tu veux faire cela regarde dans le /etc/make.conf et supprime l'overlay, supprime également les /etc/portage/package.mask et enfin supprime apache-ovh et php-ovh :)
_________________
$this->setLife(FALSE);
printf "I'm not a gamer !";
Back to top
View user's profile Send private message
arnoweb
n00b
n00b


Joined: 15 Jan 2007
Posts: 27

PostPosted: Tue Jan 16, 2007 9:16 pm    Post subject: Reply with quote

L'ebuild original serait mieux et ne casserait pas tout le système mis en place ?
J'ai l'impression que sur Gentoo tout est plus complexe.
Pour l'overlay, effectivement, j'ai édité le fichier suivant :
/etc/make.conf

Et là, pas de surprise, GENTOO_MIRRORS et PORTDIR_OVERLAY dirige respectivement vers un serveur ftp lié au provider et vers un path portage spécifique.

Python fonctionne pourtant vua que la commande
Code:
python
m'indique la console python. Je n'ai jamais fait de emerge auparavant, non.

Ca me parait mal commencé et tout ça pour installer une petite extention mais j'en apprends des choses.
Back to top
View user's profile Send private message
GaMeS
Guru
Guru


Joined: 08 Nov 2005
Posts: 374
Location: Nantes

PostPosted: Tue Jan 16, 2007 9:26 pm    Post subject: Reply with quote

L'ebuild original ne va en rien casser le système (enfin ça ne l'avais pas casser quand j'avais fais ça)

De toute façon l'ebuild fais par OVH c'est de la m***e :-)

Regarde du côté du /etc/portage/package.mask aussi et commente les différents programmes, change de mirroir dans le /etc/make.conf, fais un emerge --sync et à toi la belle vie sous Gentoo !
_________________
$this->setLife(FALSE);
printf "I'm not a gamer !";
Back to top
View user's profile Send private message
arnoweb
n00b
n00b


Joined: 15 Jan 2007
Posts: 27

PostPosted: Tue Jan 16, 2007 10:21 pm    Post subject: Reply with quote

alors dans le fichier /etc/portage/package.mask , j'ai :

net-www/apache
dev-lang/php
net-mail/qmail-autoresponder
sys-process/daemontools
net-mail/ezmlm
net-mail/ezmlm-idx
net-mail/fastforward
mail-mta/qmail
net-mail/qmailadmin
net-mail/qmailanalog
sys-apps/ucspi-tcp
net-mail/vpopmail

Il faudrait que je les mette en commentaire du style :
#net-www/apache

Enfin de toute façon, juste pour installer une extention, ça me parait pas évident de tout reconfigurer sans avoir de prblème où je risque d'y passer des jours et des jours sans réelles connaissance de Gentoo.

Pour mon information, il n'existe pas un CD qui simulerait l'utilisation de Gentoo sous windows ?

J'essaye pour mon propre intérêt d'installer Gentoo-like sous cygwin, pour info, le lien :
http://gentoo-wiki.com/HOWTO_Gentoo_on_Cygwin
Back to top
View user's profile Send private message
GaMeS
Guru
Guru


Joined: 08 Nov 2005
Posts: 374
Location: Nantes

PostPosted: Tue Jan 16, 2007 10:27 pm    Post subject: Reply with quote

arnoweb wrote:
alors dans le fichier /etc/portage/package.mask , j'ai :
Il faudrait que je les mette en commentaire du style :
#net-www/apache


Oui, exactement.

arnoweb wrote:

Enfin de toute façon, juste pour installer une extention, ça me parait pas évident de tout reconfigurer sans avoir de prblème où je risque d'y passer des jours et des jours sans réelles connaissance de Gentoo.

Son apache à redémarrer en moin de 30 minutes le temps de compilation :-)
Juste à revoir quelques options dans le /etc/apache2/httpd.conf
(DocumentRoot truc comme ça)

arnoweb wrote:

Pour mon information, il n'existe pas un CD qui simulerait l'utilisation de Gentoo sous windows ?


Heu ben, au pire tu installes Gentoo sous un environement VMware en suivant bien le HOW-TO Install Gentoo on VMware et le Handbook Gentoo
_________________
$this->setLife(FALSE);
printf "I'm not a gamer !";
Back to top
View user's profile Send private message
arnoweb
n00b
n00b


Joined: 15 Jan 2007
Posts: 27

PostPosted: Tue Jan 16, 2007 10:45 pm    Post subject: Reply with quote

Merci pour le lien, ça me parait passionnant !

En ce qui concerne la réinstalle complète, je crois que je vais laisser tomber car il y a webmin, webanalyzer, phpmyadmin et je me vois mal tout reconfigurer. Pff, c'est domage !

Est-on obligé de passer par un ebuild pour ajouter un extention ?

Admettons :
1.j'installe la lib xslt dans usr/src/xslt (répertoire xslt que je crée via mkdir)
2. je fais un wget http://server.com/lalibxslt.tar
3. tar -xjvf lalibxslt.tar
4. cd xslt/
5. ./configure --with-php-config=/usr/local/php5/bin/php-config
make
make install
6. Fichier php.ini :
extension_dir="/usr/local/php5/lib/php/extensions/xslt/"
extension="xsl.so"
7. Redémarrage d'apache : /etc/init.d/apache -restart

Pourquoi est-on obliger de faire un emerge avec un python peut être mal configurer apparemment ?
Back to top
View user's profile Send private message
NiLuJe
Guru
Guru


Joined: 06 Nov 2004
Posts: 303
Location: Paris, France

PostPosted: Wed Jan 17, 2007 3:58 am    Post subject: Reply with quote

Tu te vois faire ça à chaque fois que tu veux mettre à jour / installer / ajouter une extension à un programme/lib?

C'est pour éviter ces étapes fastidieuses ça qu'on a un joli package manager, dans le cas de Gentoo, portage. Et étant une meta distribution source, ben faut recompiler ;)

Ceci dit, rien ne t'empêche d'installer quelque-chose à la main, c'est juste:

1/ long et pénible.
2/ sale.
3/ sale.
4/ sale.
5/ heu, sale.
6/ Ce n'est ni le but ni la philosophie de Gentoo, si tu aimes te faire du mal comme ça, LFS est ton ami ;)

Reste que le coup de python qui crie lors des appels à emerge, ça sent le roussi... (Et étant une tanche niveau python & cie, je laisse le soin à quelqu'un de plus éclairé que moi de t'aiguiller la dessus [désolé les gars ^^])

La migration depuis l'overlay OVH vers l'arbre officiel doit être faisable, mais je n'ai strictement aucune idée de quels packages OVH `fourni`, et leurs différences par rapport aux ebuilds officiels, donc je ne peux pas t'en dire plus. Niveau config, si les versions/extensions correspondent plus ou moins, ça ne devrait pas poser franchement de problèmes, mais bon, sait-on jamais ;)

Si quelqu'un connaît plus en détail le fourbi installé sur les Gentoo OVH, ça serait sympathique de nous éclairer un peu la dessus ;)
Back to top
View user's profile Send private message
GaMeS
Guru
Guru


Joined: 08 Nov 2005
Posts: 374
Location: Nantes

PostPosted: Wed Jan 17, 2007 8:05 am    Post subject: Reply with quote

arnoweb wrote:

Admettons :
1.j'installe la lib xslt dans usr/src/xslt (répertoire xslt que je crée via mkdir)
2. je fais un wget http://server.com/lalibxslt.tar
3. tar -xjvf lalibxslt.tar
4. cd xslt/
5. ./configure --with-php-config=/usr/local/php5/bin/php-config
make
make install
6. Fichier php.ini :
extension_dir="/usr/local/php5/lib/php/extensions/xslt/"
extension="xsl.so"
7. Redémarrage d'apache : /etc/init.d/apache -restart


Je plussoie NiLuJe, si tu commences à faire ça autant prendre une LFS :)
J'avais eu que des problèmes avec le Apache-OVH et impossible de mettre le paramètre PCRE.

Tu n'as pas besoin de réinstaller complètement la Gentoo d'OVH (quoi que plus raisonable pour plus de stabilité) mais install Apache et PHP du portage de Gentoo et tes soucis vont s'envoler (normalement)

De toute façon tu n'as rien à perdre vu que ton Apache-OVH ne fonctionne pas, donc supprime moi ça et install apache2 :)
_________________
$this->setLife(FALSE);
printf "I'm not a gamer !";
Back to top
View user's profile Send private message
arnoweb
n00b
n00b


Joined: 15 Jan 2007
Posts: 27

PostPosted: Wed Jan 17, 2007 10:20 am    Post subject: Reply with quote

Quote:
Tu te vois faire ça à chaque fois que tu veux mettre à jour / installer / ajouter une extension à un programme/lib?

C'est certe pas optimal, mais c'est comme cela que ça fonctionnait avec PHP4 + Sablotron. A chaque mise à jour sur la Redhat, nécessité de réinstaller sablotron. Ca peut être pas mal de tout comprendre en passant par chaque commande, enfin, j'ai pris cet exemple pour installer :
http://i.majibox.com/articles.php?lng=fr&pg=212
C'est sale peut être
Quote:
sale
mais cela paraît correct (même si un peu à l'ancienne) ?

Le seul problème, c'est que chez moi, la fonction emerge ne semble pas marcher et cela viendrait peut être de la version de Python incompatible avec cette fonction. Je ne trouve pas ça très correct de constater que cette fonction n'est pas utilisable.
Code:

gensync ovh

Cela permettrait-il d'avoir python à jour ?

Quote:
Si tu veux faire cela regarde dans le /etc/make.conf et supprime l'overlay, supprime également les /etc/portage/package.mask et enfin supprime apache-ovh et php-ovh


Installation Apache-php-mysql via la base proposé par Gentoo se ferait ainsi alors ? :

1. Install de php (uniquement ou d'apache, mysql) ? Je ne veux pas que ça change les paramètres des logiciels de mail (qmail et autres) ni webmin !
J'ai trouvé l'ebuild de gentoo ici : /usr/portage/dev-lang/php
Code:

emerge -pv php
USE="xsl" emerge php


Quote:
De toute façon tu n'as rien à perdre vu que ton Apache-OVH ne fonctionne pas, donc supprime moi ça et install apache2

Si tout fonctionne par contre.
Back to top
View user's profile Send private message
Scullder
Guru
Guru


Joined: 16 Mar 2006
Posts: 466
Location: France

PostPosted: Wed Jan 17, 2007 11:37 am    Post subject: Reply with quote

NiLuJe wrote:
Heu, j'suis le seul à trouver cet `ebuild` OVH horriblement laid?

Ça serait pas plus simple de passer via l'ebuild original (à savoir, dev-lang/php) avec les flags USE qui vont bien?

(Je sais strictement pas comment OVH organise leur machin, c'est un overlay supplémentaire? Y'a pas d'arbre portage officiel du tout?).

Par contre l'erreur python ça sent le pâté... Tu t'es déjà servi de Portage/emerge sur cette machine?


Nan mais sur les gentoo made in ovh, y'a pas que leurs ebuild de laids :) Leur make.conf est pas mal non plus, on a l'impression qu'ils ont pas lu la doc en entier (manque la moitié des variables, même le accept_keyword, et ils se sont planté dans les cflags, -march=k8 sur un xeon avec de la redondance sur des flags pour activer sse 1 et 2).
J'ai jeté un oeil sur une gentoo d'ovh, j'ai un peu l'impression que ça a été fait totalement à l'arrache pour proposer le plus de choix possible et faire bien sur le papier, je suis censé maintenir ce serveur pendant 4 mois là.
D'ailleurs, je me demande si les utilisateurs qui louent ces serveurs ont déjà fait un emerge --sync et emerge -uDav world, y'a pas assez de place, 3Go pour / par défaut.
J'ai fait le sync sur un serveur ovh la semaine dernière (jamais fait et 180 jours d'uptime), plus que 200Mo de libre, une centaine de maj à faire. :roll: J'ai envie de tout réinstaller (à mon avis la seule solution si on ne veut plus bidouiller) mais c'est sur un serveur en utilisation donc je peux pas.

On pourrait dire que c'est à l'utilisateur de s'en occuper aussi un peu, mais bon le serveur est livré prêt à fonctionner avec une très mauvaise config. Ils sont restés en kernel 2.4 pour d'obscures raisons...

arnoweb wrote:
C'est certe pas optimal, mais c'est comme cela que ça fonctionnait avec PHP4 + Sablotron. A chaque mise à jour sur la Redhat, nécessité de réinstaller sablotron. Ca peut être pas mal de tout comprendre en passant par chaque commande, enfin, j'ai pris cet exemple pour installer :
http://i.majibox.com/articles.php?lng=fr&pg=212
C'est sale peut être
Quote:
sale
mais cela paraît correct (même si un peu à l'ancienne) ?


Oui mais c'est vraiment de la merde (méthode officielle ou non), ça va si tu comptes pas faire les mises à jour par la suite et avoir un serveur complètement troué, mais si tu fais les mises à jour, ça finira par casser.
_________________
Linux gentoo 2.6.18-ck1-r2 #1 PREEMPT Fri Nov 17 01:37:56 CET 2006 x86_64 AMD Athlon(tm) 64 Processor 3000+ AuthenticAMD GNU/Linux
Back to top
View user's profile Send private message
arnoweb
n00b
n00b


Joined: 15 Jan 2007
Posts: 27

PostPosted: Wed Jan 17, 2007 12:58 pm    Post subject: Reply with quote

Dans le fichier make.conf, effectivement :
Code:
CFLAGS="-O2 -pipe -march=k8"
CHOST="x86_64-pc-linux-gnu"


Quote:
un serveur complètement troué
, qu'entends tu par là ?

Connaître la taille de son compte : la place déjà prise sur mon serveur :
Code:
du -sh
2.6 G


Est-ce que :
Code:
gensync ovh

équivaut à
Code:
emerge --sync

Cela met à jour les paquets, tous ou pas ? cela prend du temps ?
Back to top
View user's profile Send private message
Scullder
Guru
Guru


Joined: 16 Mar 2006
Posts: 466
Location: France

PostPosted: Wed Jan 17, 2007 1:31 pm    Post subject: Reply with quote

arnoweb wrote:
Quote:
un serveur complètement troué
, qu'entends tu par là ?


touplein de failles de sécurité

arnoweb wrote:

Connaître la taille de son compte : la place déjà prise sur mon serveur :
Code:
du -sh
2.6 G


la commande "df -h", c'est plus rapide et pratique ^^

arnoweb wrote:
[
Est-ce que :
Code:
gensync ovh

équivaut à
Code:
emerge --sync

Cela met à jour les paquets, tous ou pas ? cela prend du temps ?


gensync, c'est sûrement un alias ou un script pour mettre à jour l'overlay ovh. Pas encore essayé. C'est pas équivalent, et non ça met pas à jour les paquets. Mettre à jour les paquets, oui ça prend du temps et surtout c'est délicat sur un serveur mal administré et quand on a beaucoup de retard.
Lit la doc sur http://www.gentoo.org/doc/fr Tu y trouveras les réponses à tes questions :p
_________________
Linux gentoo 2.6.18-ck1-r2 #1 PREEMPT Fri Nov 17 01:37:56 CET 2006 x86_64 AMD Athlon(tm) 64 Processor 3000+ AuthenticAMD GNU/Linux
Back to top
View user's profile Send private message
GaMeS
Guru
Guru


Joined: 08 Nov 2005
Posts: 374
Location: Nantes

PostPosted: Wed Jan 17, 2007 1:55 pm    Post subject: Reply with quote

Scullder wrote:

Ils sont restés en kernel 2.4 pour d'obscures raisons...


Le kernel 2.4 a fais ses preuves tout simplement contrairement au 2.6 continuellement en développement.

Et puis bon avoir le support MachinChose qui serve pas en 2.6 ça sert pas à grand chose :)

Mais c'est sur qu'au niveau de la configuration du serveur, des fichiers de configurations, OVH à fais ça vite fais mal fais :)
_________________
$this->setLife(FALSE);
printf "I'm not a gamer !";
Back to top
View user's profile Send private message
arnoweb
n00b
n00b


Joined: 15 Jan 2007
Posts: 27

PostPosted: Wed Jan 17, 2007 2:07 pm    Post subject: Reply with quote

Code:
gensync ovh

Ca doit être effectivement pour mettre à jour l'overlay et plus exactement l'arbre
Quote:
Tout d'abord mettez à jour l'arbre de Gentoo selon ovh


Est-ce que cela est nécessaire, long voir dangereux ?
Back to top
View user's profile Send private message
Scullder
Guru
Guru


Joined: 16 Mar 2006
Posts: 466
Location: France

PostPosted: Wed Jan 17, 2007 2:27 pm    Post subject: Reply with quote

GaMeS wrote:
Scullder wrote:

Ils sont restés en kernel 2.4 pour d'obscures raisons...


Le kernel 2.4 a fais ses preuves tout simplement contrairement au 2.6 continuellement en développement.

Et puis bon avoir le support MachinChose qui serve pas en 2.6 ça sert pas à grand chose :)

Mais c'est sur qu'au niveau de la configuration du serveur, des fichiers de configurations, OVH à fais ça vite fais mal fais :)


Oui le kernel 2.4 a fait ses preives, mais le 2.4-ovh ? xD

C'est assez effrayant :
https://forums.gentoo.org/viewtopic-p-3847937.html#3847937
Il turisto wrote:

edit : j'avoue que pour le kernel je flippais un peu aussi et que c'est hardcore mais c'étais nécessaire au niveau sécurité et mise à jour. Car (si je me souvient bien) la dernière glib (entre autre) ne compilait pas avec le kernel ovh. Et puis ils ont la main sur ce kernel (grâce à lui ils peuvent monitorer je sais pas trop quoi, ...) et ça j'aime pas. ils ont tellement la main qu'a chaque compilation le mec recevait un message comme quoi il y avait un virus sur la machine car un programme (portage/gcc) écrivait un exécutable (forcément vu que je compile) dans un dossier non autorisé (le dossier de compilation par défaut de portage) et qu'évidemment ils avaient supprimé cet exe (j'avais pas vu tiens ... pq mon programme il marche pas ???).


arnoweb wrote:
Code:
gensync ovh

Ca doit être effectivement pour mettre à jour l'overlay et plus exactement l'arbre
Quote:
Tout d'abord mettez à jour l'arbre de Gentoo selon ovh


Est-ce que cela est nécessaire, long voir dangereux ?


Ca dépend si tu veux mettre à jour ou non.
N'empêche, je pensais Linux à l'abri des virus et toussa, mais finalement, j'en doute fortement =]
_________________
Linux gentoo 2.6.18-ck1-r2 #1 PREEMPT Fri Nov 17 01:37:56 CET 2006 x86_64 AMD Athlon(tm) 64 Processor 3000+ AuthenticAMD GNU/Linux
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index French All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum