Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
драйвер ieee 1394 перестал работать
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Russian
View previous topic :: View next topic  
Author Message
4le
Tux's lil' helper
Tux's lil' helper


Joined: 17 Feb 2005
Posts: 96
Location: СПб

PostPosted: Sun Jan 14, 2007 2:07 pm    Post subject: драйвер ieee 1394 перестал работать Reply with quote

Ситуация такая:
Нажимаю в Kino Capture, камера начинает воспроизводить, создаётся dv-файл ~14K и всё...
В превью первый кадр, при старте кино из консоли в выводе ошибок нет.
После завершения капчуринга dv-файл всё так же ~14K. В вертикальном списке сцен всего одна сцена с продолжительностью 1 фрейм (первый).

В сентябре всё работало, сейчас нет.
Регулярно обновляюсь, ACCEPT_KEYWORD="~x86" т.е. всё "свежее".
В инете ничего по теме не нашёл.
Как лечить?


Last edited by 4le on Wed Jan 17, 2007 3:21 pm; edited 1 time in total
Back to top
View user's profile Send private message
Laitr Keiows
Moderator
Moderator


Joined: 04 Jul 2005
Posts: 891
Location: Kobe, Japan

PostPosted: Mon Jan 15, 2007 6:55 am    Post subject: Reply with quote

1) USE="debug" emerge ....
2) Откатись до x86.
Back to top
View user's profile Send private message
4le
Tux's lil' helper
Tux's lil' helper


Joined: 17 Feb 2005
Posts: 96
Location: СПб

PostPosted: Mon Jan 15, 2007 12:06 pm    Post subject: USE="debug" emerge Reply with quote

Laitr Keiows wrote:
1) USE="debug" emerge ....

Что из "equery g kino" так собрать? Всё? Не смешно.
Laitr Keiows wrote:
2) Откатись до x86.

Всю систему? Или "только" около трёхсот пакетов от которых зависит кино?
Сто против одного, что проблема а-ля "Пререезд SATA в другую ветку" в ядре.
Хотелось бы действительно решить проблему, и не откатом на 2.4, сменой камеры и подобной лингамнёй.
Back to top
View user's profile Send private message
Laitr Keiows
Moderator
Moderator


Joined: 04 Jul 2005
Posts: 891
Location: Kobe, Japan

PostPosted: Mon Jan 15, 2007 12:15 pm    Post subject: Re: USE="debug" emerge Reply with quote

4le wrote:
Хотелось бы действительно решить проблему, и не откатом на 2.4, сменой камеры и подобной лингамнёй.

Тогда man strace и ищи на чем оно затыкается.
Back to top
View user's profile Send private message
4le
Tux's lil' helper
Tux's lil' helper


Joined: 17 Feb 2005
Posts: 96
Location: СПб

PostPosted: Wed Jan 17, 2007 12:09 am    Post subject: Ieee 1394 Reply with quote

Ситуация немного прояснилась
Code:

# cat /var/log/messages | grep 1394 | grep error
Oct 30 03:36:54 toohes ohci1394: fw-host0: Unrecoverable error!
...
Jan 17 02:01:28 toohes ohci1394: fw-host0: Unrecoverable error!

Здесь описана похожая проблема. Насколько я понял (увы, языками не владею), затыка в конфликте IRQ.
Как раз где-то в конце октября я успешно имплантировал своему старичку новый SATA-винт через PCI-контроллер.
Может кто-нибудь знает как такое лечить?
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Russian All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum