Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Out of the blue: Failed to calculate module dependencies
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Kernel & Hardware
View previous topic :: View next topic  
Author Message
butters
Guru
Guru


Joined: 13 May 2002
Posts: 427
Location: Poughkeepsie, NY

PostPosted: Tue Jun 18, 2002 1:23 am    Post subject: Out of the blue: Failed to calculate module dependencies Reply with quote

I've had Gentoo up and running (excellent) for two weeks now and I'm slowly plowing through getting one more service/application running at a time. I finally got sound working with ALSA on my Hercules Game Theater XP (after two recompiled kernels).

I'm trying out the Mozilla email client, I click on a web link (to a Gentoo forums thread I was watching), and my system hard restarts out of nowhere. It rebooted and came right back up. I boldly deciding to see if the fault was repeatable. I openned Mozilla, started the email client, and clicked on the same link. Hard restart again. System comes right back up. I open an xterm to see what gives. Restarts again.

This time the system didn't quite come right back up. It wouldn't start X and dropped back to a console login. I looked up the console and saw the problem. "Failed to calculate dependencies," it said, after "Calculating module dependencies." So it couldn't load the NVdriver modules for my GeForce2 MX and therefore couldn't find a try to modprobe the drivers manually, but it can't find the modules. I notice that my sound modules didn't load either, so I did "modprobe cs46xx," which failed the same way. So I rebooted. The same error on bootup, no X.

How come my system started randomly restarting? And, more importantly, what made the kernel module loader break? Finally, and most importantly, how do I fix this?

Thanks for all your help. These forums rock.
_________________
If tugboats were bigger, they'd be the ones getting tugged.
Back to top
View user's profile Send private message
delta407
Bodhisattva
Bodhisattva


Joined: 23 Apr 2002
Posts: 2876
Location: Chicago, IL

PostPosted: Tue Jun 18, 2002 1:56 am    Post subject: Reply with quote

Try running a vanilla kernel, and possibly disable power management.
Back to top
View user's profile Send private message
burzmali
Apprentice
Apprentice


Joined: 18 Apr 2002
Posts: 235
Location: ca

PostPosted: Tue Jun 18, 2002 2:56 am    Post subject: Reply with quote

try insmod NVdriver and insmod cs46xx and see if that works. i get failed to calculate module dependencies every boot, but all my modules still load. also check /lib/modules/<kernel verion> and see if your modules are still there.
_________________
burzmali
www.burzmali.net
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Kernel & Hardware All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum