Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[Emerge] Gajim dépend de Totem... ?? [Résolu]
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index French
View previous topic :: View next topic  
Author Message
Nah
Tux's lil' helper
Tux's lil' helper


Joined: 01 May 2006
Posts: 107
Location: Lille,France

PostPosted: Thu Jan 11, 2007 4:59 pm    Post subject: [Emerge] Gajim dépend de Totem... ?? [Résolu] Reply with quote

Bonjour,

en voulant installer Gajim (version en ~x86), je me retrouve avec des dépendances plutot suprenante (totem..).
Code:
emerge -pv gajim

These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild  N    ] x11-libs/gtksourceview-1.8.1  USE="-debug -doc" 752 kB
[ebuild  N    ] gnome-extra/gnome-media-2.16.1  USE="ipv6 mad ogg vorbis -debug" 2,904 kB
[ebuild  N    ] media-plugins/gst-plugins-dvdread-0.10.4  703 kB
[ebuild  N    ] media-plugins/gst-plugins-pango-0.10.4  1,072 kB
[ebuild  N    ] media-libs/a52dec-0.7.4-r5  USE="oss -djbfft" 235 kB
[ebuild  N    ] media-plugins/gst-plugins-a52dec-0.10.3  591 kB
[ebuild  N    ] media-libs/libmpeg2-0.4.0b  USE="X sdl" 462 kB
[ebuild  N    ] media-plugins/gst-plugins-mpeg2dec-0.10.3  0 kB
[ebuild  N    ] media-video/totem-2.16.4  USE="a52 dbus dvd firefox gnome hal mad mpeg ogg vorbis xv -debug -ffmpeg -flac -lirc -nsplugin -nvtv -theora -xine" 1,777 kB
[ebuild  N    ] dev-python/gnome-python-desktop-2.16.0  USE="X -debug" 419 kB
[ebuild  N    ] app-text/gtkspell-2.0.11-r1  USE="-doc" 339 kB
[ebuild  N    ] dev-python/pysqlite-2.3.1  77 kB
[ebuild  N    ] gnome-extra/libgda-1.2.3  USE="berkdb ldap -debug -doc -firebird -freetds -mdb -mysql -oci8 -odbc -postgres -sqlite -xbase" 1,050 kB
[ebuild  N    ] gnome-extra/gtkhtml-2.6.3  USE="-accessibility -debug" 382 kB
[ebuild  N    ] dev-python/gnome-python-extras-2.14.0-r1  USE="X firefox -debug -doc -seamonkey" 339 kB
[ebuild  N    ] net-im/gajim-0.11-r3  USE="X dbus gnome nls spell trayicon -avahi -idle -libnotify -srv -xhtml" 2,622 kB

Total size of downloads: 13,731 kB

Après recherche, je n'ai pas trouver grand chose, hormis des problèmes similaire conercant Gedit, résolu par un simple -python. Ici pas le moindre useflags python...
Donc comment éviter toutes ses dépendances ?

Merci d'avance ! :P


Last edited by Nah on Thu Jan 11, 2007 5:21 pm; edited 1 time in total
Back to top
View user's profile Send private message
Bapt
Veteran
Veteran


Joined: 14 Apr 2003
Posts: 1152
Location: Paris

PostPosted: Thu Jan 11, 2007 5:10 pm    Post subject: Reply with quote

ajoute un --tree :
Code:
emerge -pv --tree gajim

tu verras d'où viennent les dépendances, et de mémoire elles viennent de gnome-python-desktop qui dépend de totem :)
la solution c'est de virer le flag gnome pour gajim.
Back to top
View user's profile Send private message
Magic Banana
Veteran
Veteran


Joined: 13 Dec 2005
Posts: 1907
Location: Belo Horizonte, Minas Gerais, Brasil

PostPosted: Thu Jan 11, 2007 5:13 pm    Post subject: Reply with quote

Dépendances de gajim-0.11-r3:
gnome?
      ( dev-python/gnome-python-extras dev-python/gnome-python-desktop )


dbus?
      ( ||
            (
                  ( >=sys-apps/dbus-0.90 dev-python/dbus-python dev-libs/dbus-glib )
           
                  ( <sys-apps/dbus-0.90 )
             )
       )

libnotify?
      ( x11-libs/libnotify )

xhtml?
      ( dev-python/docutils )

srv?
      ( net-dns/bind-tools )

idle?
      ( x11-libs/libXScrnSaver )

spell?
      ( app-text/gtkspell )

avahi?
      ( net-dns/avahi )


Les mots clés précédents les points d'intérogation sont des USE flags que tu peux donc activer ou non dans /etc/portage/packages.use pour faire une (dés)activation par paquet (sinon /etc/make.conf).

Le "||" est un "ou". Donc une seule des des dépendances suivantes est nécessaire.

Comment est-ce que tu peux avoir ces informations ? Soit en regardant dans l'ebuild directement, soit en consultant gentoo-portage. Par exemple voilà la page d'où j'ai copié les dépendances.

EDIT : L'option -tree permet ensuite de se rendre compte des dépendances en cascade
Back to top
View user's profile Send private message
Bapt
Veteran
Veteran


Joined: 14 Apr 2003
Posts: 1152
Location: Paris

PostPosted: Thu Jan 11, 2007 5:17 pm    Post subject: Reply with quote

A noter que pour les utilisateurs de paludis l'option --show-medata permet de visualiser les dépendances sans avoir à éditer l'ebuild :
Code:
>paludis -q gajim --show-metadata                 <(18:15:58)>
* net-im/gajim
    gentoo:                0.10.1 0.11-r3* {:0}
    DESCRIPTION:           Jabber client written in PyGTK
    HOMEPAGE:              http://www.gajim.org/
    LICENSE:               GPL-2
    DEPEND:                || ( ( <dev-lang/python-2.5 dev-python/pysqlite ) >=dev-lang/python-2.5 ) dev-python/pygtk sys-devel/gettext dev-util/intltool dev-util/pkgconfig
    RDEPEND:               gnome? ( dev-python/gnome-python-extras dev-python/gnome-python-desktop ) dbus? ( || ( ( >=sys-apps/dbus-0.90 dev-python/dbus-python dev-libs/dbus-glib ) ( <sys-apps/dbus-0.90 ) ) ) libnotify? ( x11-libs/libnotify ) xhtml? ( dev-python/docutils ) srv? ( net-dns/bind-tools ) idle? ( x11-libs/libXScrnSaver ) spell? ( app-text/gtkspell ) avahi? ( net-dns/avahi )
    PDEPEND:
    IUSE:                  avahi dbus gnome idle libnotify nls spell srv trayicon X xhtml
    KEYWORDS:              ~amd64 ~sparc ~x86
    PROVIDE:
    RESTRICT:
    SRC_URI:               http://www.gajim.org/downloads/gajim-0.11.tar.bz2
Back to top
View user's profile Send private message
Nah
Tux's lil' helper
Tux's lil' helper


Joined: 01 May 2006
Posts: 107
Location: Lille,France

PostPosted: Thu Jan 11, 2007 5:20 pm    Post subject: Reply with quote

Merci pour les infos. ;)
C'est bien le flags "gnome" qui est fautif, je l'ai virer.

Merci.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index French All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum