Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Configurar o keyboard no gentoo 2006.1
View unanswered posts
View posts from last 24 hours
View posts from last 7 days

 
Reply to topic    Gentoo Forums Forum Index Portuguese
View previous topic :: View next topic  
Author Message
jagodes
n00b
n00b


Joined: 08 Jan 2007
Posts: 2

PostPosted: Mon Jan 08, 2007 1:23 pm    Post subject: Configurar o keyboard no gentoo 2006.1 Reply with quote

Boas pessoal

Alguem me pode dar uma ajuda, quando instalei o gentoo, installei com o kb em us, e agora não consigo alterar, ou melhor utilizo o x para alterar mas teclas com o "ç" não funcionam, alguem me pode ajudar.

Obrigado a todos
Back to top
View user's profile Send private message
_sebastian
n00b
n00b


Joined: 02 Aug 2006
Posts: 34
Location: Canoas / Rio Grande do Sul

PostPosted: Mon Jan 08, 2007 10:34 pm    Post subject: Reply with quote

usando o gnome tu podes alterar seguindo
Code:

Desktop > Preferences > Keyboard


na guia layout, tu altera o keyboard model pra
Quote:
Brazilian ABNT2


deve resolver

abraço
_________________
Sebastian SWC
AvaCorp - http://www.avacorp.com.br
Blog: http://sebastianswc.com
Back to top
View user's profile Send private message
BaYGoN
Tux's lil' helper
Tux's lil' helper


Joined: 21 Sep 2004
Posts: 109
Location: Brasília - DF (Brasil)

PostPosted: Tue Jan 09, 2007 1:46 pm    Post subject: Reply with quote

Se você quiser fazer isso a nível de sistema, vc deve editar o arquivo /etc/conf.d/keymaps. Localize a variável KEYMAP e altere seu valor para br-abnt2. A linha deve ficar assim:

Quote:
KEYMAP="br-abnt2"


Acho que vc vai precisar reiniciar sua máquina.

[]'s
BaYGoN
_________________
Linux User #433896
HP DV6-6190US / Linux 3.4.6-pf #1 SMP PREEMPT Fri Aug 10 13:19:26 BRT 2012 x86_64 Intel(R) Core(TM) i7-2630QM CPU @ 2.00GHz GenuineIntel GNU/Linux
"The destiny of every guru is to be a noob for eternity"
Back to top
View user's profile Send private message
jagodes
n00b
n00b


Joined: 08 Jan 2007
Posts: 2

PostPosted: Tue Jan 09, 2007 4:42 pm    Post subject: Reply with quote

Boas Obrigado pela ajuda, mas aindanão tenho o meu problema resolvido, no ficheiro KEYMAPS introduzi "pt-latin1" que é o meu teclado já fiz reboot mas continua a não funcionar, continuo a ter falta de caracteres nomeadamente "ç"

mais alguma ideia?

obg
Back to top
View user's profile Send private message
thiagonunes
Apprentice
Apprentice


Joined: 16 Nov 2005
Posts: 171
Location: Brasil -> RS -> Rio Grande

PostPosted: Wed Jan 24, 2007 7:09 am    Post subject: Reply with quote

No X a configuraçao é diferente, é feita na seção input device do teclado no xorg.conf.

Abaixo a minha funcionando ok para um teclado abnt2.

Section "InputDevice"
Identifier "Keyboard0"
Driver "kbd"
Option "AutoRepeat" "250 30"
Option "XkbRules" "xorg"
Option "XkbModel" "abnt2"
Option "XkbLayout" "br"
EndSection
Back to top
View user's profile Send private message
dedalu
n00b
n00b


Joined: 11 Jan 2007
Posts: 8

PostPosted: Fri Jan 26, 2007 2:51 am    Post subject: Reply with quote

Hoje tive o mesmo problema usando LANG=pt_BR.UTF-8, mas só no KDE. Por incrível que pareça, não conhecia o fórum em português! Por isso, postei uma resposta , que reproduzo aqui:

Isso acontece com teclados US, não com os ABNT, que já têm ç. Acho que é um bug no kde e em alguns aplicativos como o lyx. Ao invés de ler /usr/share/X11/locale/pt_BR.UTF-8/Compose, lêem en_US.UTF-8/Compose. Várias páginas na internet e o próprio post propõem modificar o en_US.UTF-8/Compose. Mas ele vai ser reescrito em algum emerge mais cedo ou mais tarde. Por isso, a melhor solução é usar o seguinte

~/.XCompose:
Code:
include "/usr/share/X11/locale/pt_BR.UTF-8/Compose"
<dead_acute> <c> : "ç" U00E7 # LATIN SMALL LETTER C WITH CEDILLA
<dead_acute> <C> : "Ç" U00C7 # LATIN CAPITAL LETTER C WITH CEDILLA


e o

xorg.conf
Code:
Option          "XkbRules" "xorg"
Option          "XkbModel" "microsoft"
Option          "XkbLayout" "us"
Option          "XkbVariant" "intl"
Option          "XkbOptions" "compose:rwin"


Notem que estou usando a tecla rwin como compose para outros caracteres como æ (compose a+e), ¥ (compose -+y) etc. Uma olhada no próprio pt_BR.UTF-8/Compose será muito útil.

Abraços.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Portuguese All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum