Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[resolvido] !!! ERROR: x11-drivers/nvidia-drivers-1.0.9...
View unanswered posts
View posts from last 24 hours
View posts from last 7 days

 
Reply to topic    Gentoo Forums Forum Index Portuguese
View previous topic :: View next topic  
Author Message
_sebastian
n00b
n00b


Joined: 02 Aug 2006
Posts: 34
Location: Canoas / Rio Grande do Sul

PostPosted: Sat Jan 06, 2007 11:58 am    Post subject: [resolvido] !!! ERROR: x11-drivers/nvidia-drivers-1.0.9... Reply with quote

pessoal, eu jah vi um post com o mesmo q problema q o mew. soh q, pelo o q eu entendi, o kra não usando o genkernel, como eu.

dando o comando:

Code:
#emerge nvidia-drivers
Calculating dependencies   #[32;01m*#[0m Determining the location of the kernel source code
 #[32;01m*#[0m Found kernel source directory:
 #[32;01m*#[0m     /usr/src/linux
 #[31;01m*#[0m Could not find a usable .config in the kernel source directory.
 #[31;01m*#[0m Please ensure that /usr/src/linux points to a configured set of Linux sources.
 #[31;01m*#[0m If you are using KBUILD_OUTPUT, please set the environment var so that
 #[31;01m*#[0m it points to the necessary object directory so that it might find .config.
 ##... done!

>>> Emerging (1 of 1) x11-drivers/nvidia-drivers-1.0.9746 to /
 * NVIDIA-Linux-x86-1.0-9746-pkg0.run MD5 ;-) ...                         [ ok ]
 * NVIDIA-Linux-x86-1.0-9746-pkg0.run RMD160 ;-) ...                      [ ok ]
 * NVIDIA-Linux-x86-1.0-9746-pkg0.run SHA1 ;-) ...                        [ ok ]
 * NVIDIA-Linux-x86-1.0-9746-pkg0.run SHA256 ;-) ...                      [ ok ]
 * NVIDIA-Linux-x86-1.0-9746-pkg0.run size ;-) ...                        [ ok ]
 * checking ebuild checksums ;-) ...                                      [ ok ]
 * checking auxfile checksums ;-) ...                                     [ ok ]
 * checking miscfile checksums ;-) ...                                    [ ok ]
 * checking NVIDIA-Linux-x86-1.0-9746-pkg0.run ;-) ...                    [ ok ]

!!! ERROR: x11-drivers/nvidia-drivers-1.0.9746 failed.
Call stack:
  ebuild.sh, line 1562:   Called dyn_setup
  ebuild.sh, line 665:   Called pkg_setup
  nvidia-drivers-1.0.9746.ebuild, line 119:   Called linux-mod_pkg_setup
  linux-mod.eclass, line 458:   Called linux-info_pkg_setup
  linux-info.eclass, line 554:   Called die

!!! Unable to calculate Linux Kernel version
!!! If you need support, post the topmost build error, and the call stack if relevant.


sinceramente, eu não sei o q fazer... alguém pode me dar uma ajuda???

eu segui o howto da gento wiki, fazendo todos os passos até o emerge do nvdia-drivers

link do howto:
http://gentoo-wiki.com/HOWTO_nVidia_Drivers


certo entaum???

aguardo a ajuda de vcs... abraços
_________________
Sebastian SWC
AvaCorp - http://www.avacorp.com.br
Blog: http://sebastianswc.com


Last edited by _sebastian on Thu Mar 01, 2007 11:52 pm; edited 2 times in total
Back to top
View user's profile Send private message
MetalGod
Bodhisattva
Bodhisattva


Joined: 10 Mar 2003
Posts: 816
Location: Portugal

PostPosted: Sat Jan 06, 2007 7:35 pm    Post subject: Reply with quote

faz ai um
Code:
ls -la /usr/src/linux

_________________
ex: Gentoo Linux Developer: amd64 media-optical sound gnome
ex: Portuguese Moderator
------------------------------------------------------------------------------
God Doesn't Play Dice
Back to top
View user's profile Send private message
_sebastian
n00b
n00b


Joined: 02 Aug 2006
Posts: 34
Location: Canoas / Rio Grande do Sul

PostPosted: Sun Jan 07, 2007 10:26 pm    Post subject: Reply with quote

ta na mão:

Code:
seba@Cidadela ~ $ ls -la /usr/src/linux
lrwxrwxrwx 1 root root 22 Jan  4  2007 /usr/src/linux -> linux-2.6.18-gentoo-r6

_________________
Sebastian SWC
AvaCorp - http://www.avacorp.com.br
Blog: http://sebastianswc.com
Back to top
View user's profile Send private message
BaYGoN
Tux's lil' helper
Tux's lil' helper


Joined: 21 Sep 2004
Posts: 109
Location: Brasília - DF (Brasil)

PostPosted: Mon Jan 08, 2007 8:01 pm    Post subject: Reply with quote

Quote:
[31;01m*#[0m Could not find a usable .config in the kernel source directory.


Como a própria mensagem já diz, o emerge não consegue encontrar o arquivo de configuração do seu kernel. Você teria algum backup dele no seu /boot?

Se nao tiver, vc terá que recompilar seu kernel novamente. Não sei se existe algum comando que monte o arquivo .config do kernel usando o kernel que está rodando atualmente, mas se alguém souber pode ser útil pra resolver o seu problema.

Outra coisa, qual a versão do kernel que vc está rodando neste momento? É a mesma versão que o symlink linux aponta (linux-2.6.18-gentoo-r6) ? Descubra com uname -a. Se não for, vc deve ter atualizado o seu world com uma nova versão do kernel e não recompilou as novas fontes.

Vc pode resolver isso de duas formas: ou vc recompila as novas fontes e atualiza teu kernel, ou vc recria o symlink linux apontando para as fontes do kernel que vc está rodando atualmente.

Lembre-se que, depois que vc atualiza teu kernel, todo programa que vc instalou que gera módulos precisa ser "emergido" novamente, para que os módulos sejam recompilados novamente contra as fontes do kernel novo. Exemplo: vmware-workstation, nvidia-drivers, ntfs-3g, ipw2200 entre muitos outros.

Att,
Roberto Tracanna
_________________
Linux User #433896
HP DV6-6190US / Linux 3.4.6-pf #1 SMP PREEMPT Fri Aug 10 13:19:26 BRT 2012 x86_64 Intel(R) Core(TM) i7-2630QM CPU @ 2.00GHz GenuineIntel GNU/Linux
"The destiny of every guru is to be a noob for eternity"
Back to top
View user's profile Send private message
_sebastian
n00b
n00b


Joined: 02 Aug 2006
Posts: 34
Location: Canoas / Rio Grande do Sul

PostPosted: Mon Jan 08, 2007 10:25 pm    Post subject: Reply with quote

rodando o comando uname:
Code:
Cidadela seba # uname -a
Linux Cidadela 2.6.17-gentoo-r7 #1 SMP Wed Sep 20 14:24:14 UTC 2006 i686 Intel(R) Pentium(R) 4 CPU 3.00GHz GenuineIntel GNU/Linux



dei o comando agora:
Code:
emerge --update --world


vou esperar acabar pra ver se resolve
_________________
Sebastian SWC
AvaCorp - http://www.avacorp.com.br
Blog: http://sebastianswc.com
Back to top
View user's profile Send private message
BaYGoN
Tux's lil' helper
Tux's lil' helper


Joined: 21 Sep 2004
Posts: 109
Location: Brasília - DF (Brasil)

PostPosted: Tue Jan 09, 2007 1:41 pm    Post subject: Reply with quote

Não vai resolver. O que aconteceu foi exatamente o que eu havia dito: vc baixou e atualizou o kernel (e o emerge atualizou o symlink) mas vc não recompilou o novo kernel. Como eu havia dito...

Quote:
Vc pode resolver isso de duas formas: ou vc recompila as novas fontes e atualiza teu kernel, ou vc recria o symlink linux apontando para as fontes do kernel que vc está rodando atualmente.


O modo rápido para resolver isso (como root):
Code:
cd /usr/src
rm linux
ln -s linux-2.6.17-gentoo-r7 linux


Pronto! Pode dar um emerge nvidia-drivers que agora vai...

[]'s
BaYGoN
_________________
Linux User #433896
HP DV6-6190US / Linux 3.4.6-pf #1 SMP PREEMPT Fri Aug 10 13:19:26 BRT 2012 x86_64 Intel(R) Core(TM) i7-2630QM CPU @ 2.00GHz GenuineIntel GNU/Linux
"The destiny of every guru is to be a noob for eternity"
Back to top
View user's profile Send private message
_sebastian
n00b
n00b


Joined: 02 Aug 2006
Posts: 34
Location: Canoas / Rio Grande do Sul

PostPosted: Tue Jan 09, 2007 4:40 pm    Post subject: Reply with quote

Puts... realmente não tinha entedido... :( q coisa...

agora jah ta feita... fucei um um monte de pacotes ontem e mais nada funcionou. peguei e deixei "formatando"

desculpa a falta de atenção e vlw pela força!


Editado por metalgod: Não são permitidas asneiras neste forum! Modere-se sff.
_________________
Sebastian SWC
AvaCorp - http://www.avacorp.com.br
Blog: http://sebastianswc.com
Back to top
View user's profile Send private message
_sebastian
n00b
n00b


Joined: 02 Aug 2006
Posts: 34
Location: Canoas / Rio Grande do Sul

PostPosted: Tue Jan 09, 2007 4:42 pm    Post subject: Reply with quote

quando eu chegar em casa explico melhor o que aconteceu...
_________________
Sebastian SWC
AvaCorp - http://www.avacorp.com.br
Blog: http://sebastianswc.com
Back to top
View user's profile Send private message
_sebastian
n00b
n00b


Joined: 02 Aug 2006
Posts: 34
Location: Canoas / Rio Grande do Sul

PostPosted: Wed Jan 10, 2007 12:38 am    Post subject: Reply with quote

rodei os comandos que me passaste pra alterar o atalho simbolico e naum deu certo.

o erro q aparec eh este:

Code:
Cidadela src # emerge nvidia-drivers
Calculating dependencies... done!
>>> Emerging (1 of 1) x11-drivers/nvidia-drivers-1.0.8776 to /
>>> checking ebuild checksums ;-)
>>> checking auxfile checksums ;-)
>>> checking miscfile checksums ;-)
>>> checking NVIDIA-Linux-x86-1.0-8776-pkg0.run ;-)
 * Determining the location of the kernel source code
 * Found kernel source directory:
 *     /usr/src/linux
 * Could not find a usable .config in the kernel source directory.
 * Please ensure that /usr/src/linux points to a configured set of Linux sources.
 * If you are using KBUILD_OUTPUT, please set the environment var so that
 * it points to the necessary object directory so that it might find .config.

!!! ERROR: x11-drivers/nvidia-drivers-1.0.8776 failed.
Call stack:
  ebuild.sh, line 1555:   Called dyn_setup
  ebuild.sh, line 668:   Called pkg_setup
  nvidia-drivers-1.0.8776.ebuild, line 112:   Called linux-mod_pkg_setup
  linux-mod.eclass, line 458:   Called linux-info_pkg_setup
  linux-info.eclass, line 554:   Called die

!!! Unable to calculate Linux Kernel version
!!! If you need support, post the topmost build error, and the call stack if relevant.

_________________
Sebastian SWC
AvaCorp - http://www.avacorp.com.br
Blog: http://sebastianswc.com
Back to top
View user's profile Send private message
thiagonunes
Apprentice
Apprentice


Joined: 16 Nov 2005
Posts: 171
Location: Brasil -> RS -> Rio Grande

PostPosted: Sat Jan 27, 2007 6:51 am    Post subject: Reply with quote

Dus meu,

Muita calma nessa hora. Aparentemente pensei que seu erro foi decorrido de um simples e banal engano seu, facilmente resolvivel olhando a saida do emerge.

No entanto pelo que observei você não tem domínio do que o baygon esta lhe pedindo, então precisamos que você nos responda algumas coisas para que possamos lhe ajudar melhor.

1) Você instalou o gentoo pelo handbook (como deveria ser) ou usou o instalador do livecd (não recomendado para iniciantes)?

2) Você compilou o seu kernel atual na mão (o recomendado) ou usou genkernel (não que não seja recomendado, mas espera-se que apenas pessoas que AINDA não dominam a configuração manual do kernel o usem)?

Bom, você usa o kernel 2.6.17-gentoo-r7, se eu não me engano é o kernel que vem no livecd 2006.1, o que praticamente me responde as duas perguntas, mas prefiro que você responda e me confirme.

[]'s
Back to top
View user's profile Send private message
_sebastian
n00b
n00b


Joined: 02 Aug 2006
Posts: 34
Location: Canoas / Rio Grande do Sul

PostPosted: Wed Feb 07, 2007 1:26 am    Post subject: Reply with quote

thiagonunes wrote:
Dus meu,

Muita calma nessa hora. Aparentemente pensei que seu erro foi decorrido de um simples e banal engano seu, facilmente resolvivel olhando a saida do emerge.

No entanto pelo que observei você não tem domínio do que o baygon esta lhe pedindo, então precisamos que você nos responda algumas coisas para que possamos lhe ajudar melhor.

1) Você instalou o gentoo pelo handbook (como deveria ser) ou usou o instalador do livecd (não recomendado para iniciantes)?

2) Você compilou o seu kernel atual na mão (o recomendado) ou usou genkernel (não que não seja recomendado, mas espera-se que apenas pessoas que AINDA não dominam a configuração manual do kernel o usem)?

Bom, você usa o kernel 2.6.17-gentoo-r7, se eu não me engano é o kernel que vem no livecd 2006.1, o que praticamente me responde as duas perguntas, mas prefiro que você responda e me confirme.

[]'s


eh velho, eu instalei do live em cd...

mas vou fomatar agora e fazer pelo jeito certo, ou seja, pelo randbook
_________________
Sebastian SWC
AvaCorp - http://www.avacorp.com.br
Blog: http://sebastianswc.com
Back to top
View user's profile Send private message
thiagonunes
Apprentice
Apprentice


Joined: 16 Nov 2005
Posts: 171
Location: Brasil -> RS -> Rio Grande

PostPosted: Wed Feb 07, 2007 10:39 am    Post subject: Reply with quote

Beleza, assim que se faz.

Se tiveres algum problema é só gritar que a gente ajuda.

Só um aviso: A maioria da documentação em português está desatualizada, portanto recomendo que uses o handbook em inglês. Aqui: http://www.gentoo.org/doc/en/handbook/index.xml

Para ver se alguma tradução está desatulizada é só olhar na barra azul da esquerda na parte superior, alí vai ter um aviso dizendo quando o original em inglês foi atualizado pela última vez.
Back to top
View user's profile Send private message
_sebastian
n00b
n00b


Joined: 02 Aug 2006
Posts: 34
Location: Canoas / Rio Grande do Sul

PostPosted: Sat Feb 10, 2007 8:31 pm    Post subject: Reply with quote

thiagonunes wrote:
Beleza, assim que se faz.

Se tiveres algum problema é só gritar que a gente ajuda.

Só um aviso: A maioria da documentação em português está desatualizada, portanto recomendo que uses o handbook em inglês. Aqui: http://www.gentoo.org/doc/en/handbook/index.xml

Para ver se alguma tradução está desatulizada é só olhar na barra azul da esquerda na parte superior, alí vai ter um aviso dizendo quando o original em inglês foi atualizado pela última vez.


pois é velho.. instalei... levo um puta tempo instala o gnome no "braço", mas eu ainda não peguei a mãnha de compilar o kernel na mão e instalei pelo genkernel o gentoo-sources.

dae tah... tudo bonitaum, to acessando o gnome na boa e não encontrei nenhum arquivo de configuração do X.org (que sempre tava em /etc/x11/xorg.conf), dae, pra pelo menos dizer que tentei, copiei as linhas que diziam (pra alterar no xorg.conf no howto da wiki (http://gentoo-wiki.com/HOWTO_nVidia_Drivers) e explodiram erros antes de iniciar o X.... eu não sei como jogar esse erro num arquivo pra postar aki... :(

até agora, vlw pela força

copiei aqueles trexp
_________________
Sebastian SWC
AvaCorp - http://www.avacorp.com.br
Blog: http://sebastianswc.com
Back to top
View user's profile Send private message
thiagonunes
Apprentice
Apprentice


Joined: 16 Nov 2005
Posts: 171
Location: Brasil -> RS -> Rio Grande

PostPosted: Sun Feb 11, 2007 4:10 am    Post subject: Reply with quote

Devagar, cada coisa a seu tempo. Eu sei que tu ta loco pra ver tua geforce rodando a milhões mas você tem outras coisas a fazer antes de pensar em aceleração 3d. Você nem tem X ainda (ou não deveria).

O X provê um driver para placas nvidia, que é o 'nv', porém esse driver não suporta aceleração 3d.

Então antes de se preocupar com o driver da nvidia você tem que instalar e configurar o X, e esse doc aqui vai lhe ensinar a fazer isso: http://www.gentoo.org/doc/en/xorg-config.xml . Depois que seu X estiver bombando tu pensa em interfaces gráficas e aceleração 3d.

Bom, e também recomendo que você leia a documentação do portage para aprender a trabalhar bem com ele. Aqui: http://www.gentoo.org/doc/en/handbook/handbook-x86.xml?part=2
Back to top
View user's profile Send private message
_sebastian
n00b
n00b


Joined: 02 Aug 2006
Posts: 34
Location: Canoas / Rio Grande do Sul

PostPosted: Sun Feb 11, 2007 10:35 pm    Post subject: Reply with quote

thiagonunes wrote:
Devagar, cada coisa a seu tempo. Eu sei que tu ta loco pra ver tua geforce rodando a milhões mas você tem outras coisas a fazer antes de pensar em aceleração 3d. Você nem tem X ainda (ou não deveria).

O X provê um driver para placas nvidia, que é o 'nv', porém esse driver não suporta aceleração 3d.

Então antes de se preocupar com o driver da nvidia você tem que instalar e configurar o X, e esse doc aqui vai lhe ensinar a fazer isso: http://www.gentoo.org/doc/en/xorg-config.xml . Depois que seu X estiver bombando tu pensa em interfaces gráficas e aceleração 3d.

Bom, e também recomendo que você leia a documentação do portage para aprender a trabalhar bem com ele. Aqui: http://www.gentoo.org/doc/en/handbook/handbook-x86.xml?part=2


cara tu é o meu herói!!!!

mas, aacho q fiz uma puta merda... eu peguei e depois de dar o emerge -u world eu rodei o comando:
Code:
emerge gnome-light

e depois rodei:
Code:
emerge gnome xscreemsaver


por isso q eu to rodando o gnome e tals... mas ta cheio de problema... tipo: não le img jpg por exemplo e não toca soum (nada a ver mas não funfa...) vou tentar configurar o xorg como diz o manual e, se não der certo, vou ter q reinstalar?

Valeu pela força
_________________
Sebastian SWC
AvaCorp - http://www.avacorp.com.br
Blog: http://sebastianswc.com
Back to top
View user's profile Send private message
_sebastian
n00b
n00b


Joined: 02 Aug 2006
Posts: 34
Location: Canoas / Rio Grande do Sul

PostPosted: Mon Feb 12, 2007 12:39 am    Post subject: Resolvido! Reply with quote

agora foi!!!
_________________
Sebastian SWC
AvaCorp - http://www.avacorp.com.br
Blog: http://sebastianswc.com
Back to top
View user's profile Send private message
thiagonunes
Apprentice
Apprentice


Joined: 16 Nov 2005
Posts: 171
Location: Brasil -> RS -> Rio Grande

PostPosted: Mon Feb 12, 2007 5:10 am    Post subject: Reply with quote

_sebastian wrote:

cara tu é o meu herói!!!!


Hehe, valeu, as vezes vale a pena ficar meia hora pensando pra responder um post. Não foi o caso do último, mas as vezes é.

Quote:

mas, aacho q fiz uma puta merda... eu peguei e depois de dar o emerge -u world eu rodei o comando:
Code:
emerge gnome-light

e depois rodei:
Code:
emerge gnome xscreemsaver



Nenhum problema. O pacote gnome-light é um meta-pacote para um gnome básico, ou seja, ele em si não instala nada, mas tem como dependência todos os pacotes necessários para se ter um gnome capado rodando.

E o gnome mesmo é um meta-pacote para todos os pacotes do gnome, então o pacote gnome-light já está englobado pelo pacote gnome.

Então... quando você deu emerge gnome simplesmente instalou tudo que faltava para ter um gnome completo.

Quote:

por isso q eu to rodando o gnome e tals... mas ta cheio de problema... tipo: não le img jpg por exemplo e não toca soum (nada a ver mas não funfa...) vou tentar configurar o xorg como diz o manual e, se não der certo, vou ter q reinstalar?


Claro que não, teoricamente um usuário de gentoo nunca teria motivo para reinstalar o sistema inteiro porque, como o gentoo é uma distribuição que tem por propósito ensinar ao usuário como as coisas funcionam, ele deve saber o que fazer para consertar o seu sistema. Claro que as vezes acontece de uma reinstalação ser menos trabalhosa q o conserto, mas consertar sempre é mais divertido. :P

Em relação ao som tem o alsa-guide pois, como eu te disse, cada coisa a seu tempo. Aqui ele: http://www.gentoo.org/doc/en/alsa-guide.xml

Em relação ao:
Quote:

agora foi!!!


O que foi!
Back to top
View user's profile Send private message
_sebastian
n00b
n00b


Joined: 02 Aug 2006
Posts: 34
Location: Canoas / Rio Grande do Sul

PostPosted: Mon Feb 12, 2007 10:18 pm    Post subject: Reply with quote

thiagonunes wrote:
_sebastian wrote:

cara tu é o meu herói!!!!


Hehe, valeu, as vezes vale a pena ficar meia hora pensando pra responder um post. Não foi o caso do último, mas as vezes é.

Quote:

mas, aacho q fiz uma puta merda... eu peguei e depois de dar o emerge -u world eu rodei o comando:
Code:
emerge gnome-light

e depois rodei:
Code:
emerge gnome xscreemsaver



Nenhum problema. O pacote gnome-light é um meta-pacote para um gnome básico, ou seja, ele em si não instala nada, mas tem como dependência todos os pacotes necessários para se ter um gnome capado rodando.

E o gnome mesmo é um meta-pacote para todos os pacotes do gnome, então o pacote gnome-light já está englobado pelo pacote gnome.

Então... quando você deu emerge gnome simplesmente instalou tudo que faltava para ter um gnome completo.

Quote:

por isso q eu to rodando o gnome e tals... mas ta cheio de problema... tipo: não le img jpg por exemplo e não toca soum (nada a ver mas não funfa...) vou tentar configurar o xorg como diz o manual e, se não der certo, vou ter q reinstalar?


Claro que não, teoricamente um usuário de gentoo nunca teria motivo para reinstalar o sistema inteiro porque, como o gentoo é uma distribuição que tem por propósito ensinar ao usuário como as coisas funcionam, ele deve saber o que fazer para consertar o seu sistema. Claro que as vezes acontece de uma reinstalação ser menos trabalhosa q o conserto, mas consertar sempre é mais divertido. :P

Em relação ao som tem o alsa-guide pois, como eu te disse, cada coisa a seu tempo. Aqui ele: http://www.gentoo.org/doc/en/alsa-guide.xml

Em relação ao:
Quote:

agora foi!!!


O que foi!



aheuAUEUHAehuAUAEEH desculpa o mau jeito... quis dizer que funcionou perfeitamente.

concordo, consertar é muito mais divertido!

kra, alguma idéia de como "conserto" o gnome pra ver imagens jpg e svg, por exemplo?
_________________
Sebastian SWC
AvaCorp - http://www.avacorp.com.br
Blog: http://sebastianswc.com
Back to top
View user's profile Send private message
thiagonunes
Apprentice
Apprentice


Joined: 16 Nov 2005
Posts: 171
Location: Brasil -> RS -> Rio Grande

PostPosted: Tue Feb 13, 2007 4:04 am    Post subject: Reply with quote

Como assim o gnome não estar mostrando jpeg e svg? Na real o gnome não é exatamente um software, e sim um pacote de softwares que fazem diversas funções.

Qual o seu problema de fato? O nautilus não está mostrando as miniaturas de figuras jpeg e svg, ou não tem um programa associado para abrir elas?

Acho que os dois formatos você pode ver até pelo firefox. Inclusive jpeg você pode ver até pelo cacaview (media-libs/libcaca) :P , mas eu prefiro o kview mesmo. Tem o eog que é do gnome mesmo, a mesma idéia que o kview, e você já deve até ter instalado o xview, que é bem simples mas faz o serviço.

Existem as USEs jpg e svg, talvez elas estejam desabilitadas e por isso os programas que as suportam não estão sendo compilados com suporte a isso. Roda um emerge --info e da uma olhada. Se ficar com alguma dúvida posta ele aí.

É bom sempre darmos uma olhada nas USEs do que vamos dar emerge. E sobre isso e outras coisas achei um doc interessante esses dias, olha: http://gentoo-wiki.com/HOWTO_Maintain_Gentoo_-_%22Best_Practices%22

A propósito, quanto ta fazendo o glxgears?
Back to top
View user's profile Send private message
_sebastian
n00b
n00b


Joined: 02 Aug 2006
Posts: 34
Location: Canoas / Rio Grande do Sul

PostPosted: Wed Feb 14, 2007 9:07 am    Post subject: Reply with quote

thiagonunes wrote:
Como assim o gnome não estar mostrando jpeg e svg? Na real o gnome não é exatamente um software, e sim um pacote de softwares que fazem diversas funções.

Qual o seu problema de fato? O nautilus não está mostrando as miniaturas de figuras jpeg e svg, ou não tem um programa associado para abrir elas?

Acho que os dois formatos você pode ver até pelo firefox. Inclusive jpeg você pode ver até pelo cacaview (media-libs/libcaca) :P , mas eu prefiro o kview mesmo. Tem o eog que é do gnome mesmo, a mesma idéia que o kview, e você já deve até ter instalado o xview, que é bem simples mas faz o serviço.

Existem as USEs jpg e svg, talvez elas estejam desabilitadas e por isso os programas que as suportam não estão sendo compilados com suporte a isso. Roda um emerge --info e da uma olhada. Se ficar com alguma dúvida posta ele aí.

É bom sempre darmos uma olhada nas USEs do que vamos dar emerge. E sobre isso e outras coisas achei um doc interessante esses dias, olha: http://gentoo-wiki.com/HOWTO_Maintain_Gentoo_-_%22Best_Practices%22

A propósito, quanto ta fazendo o glxgears?


simplesmente o gnome não mostra a miniatura e, pra ajudar, o gimp diz q essa imagem tem uma extensão inválida... :(

o q tu quer dizer por glxgear?

vou alterar as USe no make.conf e ae testar.

por falar em glx, é muito foda instalar?
_________________
Sebastian SWC
AvaCorp - http://www.avacorp.com.br
Blog: http://sebastianswc.com
Back to top
View user's profile Send private message
thiagonunes
Apprentice
Apprentice


Joined: 16 Nov 2005
Posts: 171
Location: Brasil -> RS -> Rio Grande

PostPosted: Thu Feb 15, 2007 4:16 am    Post subject: Reply with quote

AH! Hehehehe. Foi mal, não me liguei que o nvidia-guide não fala do glxgears.

Bom, olha só:

Primeiramente eu te digo que estamos discutindo o assunto errado, o nome do tópico é "!!! ERROR: x11-drivers/nvidia-drivers-1.0.9746 failed." e nós estamos falando sobre suporte a jpeg no gnome. Conforme https://forums.gentoo.org/viewtopic-t-122439.html?sid=49325ffe6d6745e3e95c2d3fe5ab1fa0 o ideal é você abrir outro tópico para falar desse outro problema específico, diga que tais e tais programas não estão fazendo isso e isso, poste junto o teu emerge info e mais qualquer informação que você achar relevante. É pura burocracia mas não esqueça que estamos num fórum e se outra pessoa estiver pocurando no fórum por alguém com um problema parecido vai ser muito mais facil pra ela se o nome do tópico corresponder ao assunto que está sendo tratado nele. Ta ligado?

Então. O glxgears é um programinha bem simples que vem no pacote do mesa que desenha umas engrenagens 3d girando na tela. Ele não tem nada de mais, porém por ser tão simples, não possuir qualquer configuração e abrir sempre do mesmo tamanho (ou seja, ele faz exatamente a mesma coisa em qualquer computador) o pessoal costuma se basear em quantos fps ele faz por segundo pra ter uma noção do 'poder' da sua placa de vídeo.

Como começastes a falar sobre outro assunto eu imaginei que tinhas conseguido instalar o driver da nvidia mas pelo que vi não tentaste ainda.

E então? Basicamente seguindo o nvidia-guide (http://www.gentoo.org/doc/en/nvidia-guide.xml) tu não deve ter mais problemas, depois é só correr pro abraço.
_________________
Coisas que todo usuário de gentoo tem que saber:
http://www.gentoo.org/doc/en/handbook/handbook-x86.xml?part=1
http://www.gentoo.org/doc/en/handbook/handbook-x86.xml?part=2
http://gentoo-wiki.com/HOWTO_Maintain_Gentoo_-_%22Best_Practices%22
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Portuguese All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum