Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Compiling GCC - ACCESS DENIED: open_wr:/etc/ld.so.cache~
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Portage & Programming
View previous topic :: View next topic  
Author Message
kalda341
n00b
n00b


Joined: 08 Nov 2013
Posts: 2

PostPosted: Fri Nov 08, 2013 9:40 pm    Post subject: Compiling GCC - ACCESS DENIED: open_wr:/etc/ld.so.cache~ Reply with quote

I'm moving from unstable to stable and was originally just going to let my system gradually fade into stable, but now I'm running into problems with dependencies with emerge so I've decided to try to change all packages (except glibc) to stable.
However, when I run "emerge -veD world", I run into the following error:

Code:

else /usr/bin/install -c -m 644 /var/tmp/portage/sys-libs/glibc-9999/work/build-default-i686-pc-linux-gnu-nptl/stubs.h /var/tmp/portage/sys-libs/glibc-9999/image//usr/include/gnu/stubs-32.h; fi
rm -f /var/tmp/portage/sys-libs/glibc-9999/work/build-default-i686-pc-linux-gnu-nptl/stubs.h
/var/tmp/portage/sys-libs/glibc-9999/work/build-default-i686-pc-linux-gnu-nptl/elf/sln /var/tmp/portage/sys-libs/glibc-9999/work/build-default-i686-pc-linux-gnu-nptl/elf/symlink.list
rm -f /var/tmp/portage/sys-libs/glibc-9999/work/build-default-i686-pc-linux-gnu-nptl/elf/symlink.list
test ! -x /var/tmp/portage/sys-libs/glibc-9999/work/build-default-i686-pc-linux-gnu-nptl/elf/ldconfig || LC_ALL=C LANGUAGE=C \
  /var/tmp/portage/sys-libs/glibc-9999/work/build-default-i686-pc-linux-gnu-nptl/elf/ldconfig -r /var/tmp/portage/sys-libs/glibc-9999/image/ \
                /lib /usr/lib
/var/tmp/portage/sys-libs/glibc-9999/work/build-default-i686-pc-linux-gnu-nptl/elf/ldconfig: Warning: ignoring configuration file that cannot be opened: /etc/ld.so.conf: No such file or directory
 * ACCESS DENIED:  open_wr:      /etc/ld.so.cache~
/var/tmp/portage/sys-libs/glibc-9999/work/build-default-i686-pc-linux-gnu-nptl/elf/ldconfig: Can't create temporary cache file /etc/ld.so.cache~: Operation not permitted
make[1]: [install] Error 1 (ignored)
make[1]: Leaving directory `/var/tmp/portage/sys-libs/glibc-9999/work/glibc-9999'
/usr/portage/sys-libs/glibc/files/eblits/src_install.eblit: line 142: cd: /var/tmp/portage/sys-libs/glibc-9999/work/extra/locale: No such file or directory
!!! dosbin: locale-gen does not exist
dosbin failed
 * ERROR: sys-libs/glibc-9999::gentoo failed (install phase):
 *   (no error message)
 *
 * Call stack:
 *           ebuild.sh, line   93:  Called src_install
 *         environment, line 4185:  Called eblit-run 'src_install'
 *         environment, line 1040:  Called eblit-glibc-src_install
 *   src_install.eblit, line  258:  Called toolchain-glibc_src_install
 *   src_install.eblit, line  143:  Called die
 * The specific snippet of code:
 *      dosbin locale-gen || die
 *
 * If you need support, post the output of `emerge --info '=sys-libs/glibc-9999::gentoo'`,
 * the complete build log and the output of `emerge -pqv '=sys-libs/glibc-9999::gentoo'`.
 * The complete build log is located at '/var/tmp/portage/sys-libs/glibc-9999/temp/build.log'.
 * The ebuild environment file is located at '/var/tmp/portage/sys-libs/glibc-9999/temp/environment'.
 * Working directory: '/var/tmp/portage/sys-libs/glibc-9999/work/build-default-i686-pc-linux-gnu-nptl'
 * S: '/var/tmp/portage/sys-libs/glibc-9999/work/glibc-9999'
 * --------------------------- ACCESS VIOLATION SUMMARY ---------------------------
 * LOG FILE: "/var/log/sandbox/sandbox-2184.log"
 *
VERSION 1.0
FORMAT: F - Function called
FORMAT: S - Access Status
FORMAT: P - Path as passed to function
FORMAT: A - Absolute Path (not canonical)
FORMAT: R - Canonical Path
FORMAT: C - Command Line

F: open_wr
S: deny
P: /etc/ld.so.cache~
A: /etc/ld.so.cache~
R: /etc/ld.so.cache~
C: /var/tmp/portage/sys-libs/glibc-9999/work/build-default-i686-pc-linux-gnu-nptl/elf/ldconfig -r /var/tmp/portage/sys-libs/glibc-9999/image  /lib /usr/lib
 * --------------------------------------------------------------------------------
 * QA Notice: file does not exist:
 *
 *    dosbin: locale-gen does not exist



Code:

=================================================================
                        System Settings
=================================================================
System uname: Linux-3.10.7-gentoo-r1-i686-AMD_Athlon-tm-_II_X2_245_Processor-with-gentoo-2.2
KiB Mem:     6223376 total,   1379976 free
KiB Swap:    2047996 total,   2047760 free
Timestamp of tree: Fri, 08 Nov 2013 02:45:01 +0000
ld GNU ld (GNU Binutils) 2.23.1
app-shells/bash:          4.2_p45
dev-lang/python:          2.7.5-r3, 3.2.5-r3
dev-util/cmake:           2.8.10.2-r2
dev-util/pkgconfig:       0.28
sys-apps/baselayout:      2.2
sys-apps/openrc:          0.11.8
sys-apps/sandbox:         2.6-r1
sys-devel/autoconf:       2.13, 2.69
sys-devel/automake:       1.10.3, 1.12.6, 1.13.4
sys-devel/binutils:       2.23.1
sys-devel/gcc:            4.7.3-r1
sys-devel/gcc-config:     1.7.3
sys-devel/libtool:        2.4.2
sys-devel/make:           3.82-r4
sys-kernel/linux-headers: 3.9 (virtual/os-headers)
sys-libs/glibc:           2.17
Repositories: gentoo sublime-text steam-overlay x-portage
Installed sets: @steam
ACCEPT_KEYWORDS="x86"
ACCEPT_LICENSE="* -@EULA"
CBUILD="i686-pc-linux-gnu"
CFLAGS="-O2 -march=native -pipe"
CHOST="i686-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/share/config /usr/share/gnupg/qualified.txt"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo"
CXXFLAGS="-O2 -march=native -pipe"
DISTDIR="/usr/portage/distfiles"
FCFLAGS="-O2 -march=i686 -pipe"
FEATURES="assume-digests binpkg-logs config-protect-if-modified distlocks ebuild-locks fixlafiles merge-sync news parallel-fetch preserve-libs protect-owned sandbox sfperms strict unknown-features-warn unmerge-logs unmerge-orphans userfetch userpriv usersandbox usersync"
FFLAGS="-O2 -march=i686 -pipe"
GENTOO_MIRRORS="http://ftp.swin.edu.au/gentoo ftp://ftp.swin.edu.au/gentoo"
LANG="en_US.UTF-8"
LC_ALL="en_US.UTF-8"
LDFLAGS="-Wl,-O1 -Wl,--as-needed"
MAKEOPTS="-j2"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --omit-dir-times --compress --force --whole-file --delete --stats --human-readable --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/var/lib/layman/sublime-text /var/lib/layman/steam /usr/local/portage"
SYNC="rsync://rsync1.au.gentoo.org/gentoo-portage"
USE="3dnow 3dnowext X a52 aac acl acpi alsa berkdb bluetooth branding bzip2 cairo cdda cdr cli cracklib crypt cups cxx dbus declarative dri dts dvd dvdr emboss encode exif fam firefox flac fortran gdbm gif gpm gtk iconv ipv6 jpeg kde kipi lcms ldap libnotify mad mmx mng modules mp3 mp4 mpeg mudflap ncurses nls nptl nptlonly ogg opengl openmp pam pango pcre pdf phonon plasma png policykit ppds pulseaudio qt3support qt4 readline samba sdl semantic-desktop session spell sse2 sse3 ssl startup-notification svg symlink systemd tcpd threads tiff truetype udev udisks unicode upcall upower usb vorbis wxwidgets x264 x86 xcb xcomposite xinerama xml xmp xscreensaver xv xvid xvmc zlib" ABI_X86="32" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1 emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" APACHE2_MODULES="authn_core authz_core socache_shmcb unixd actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgi cgid dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" CALLIGRA_FEATURES="kexi words flow plan sheets stage tables krita karbon braindump author" CAMERAS="ptp2" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf superstar2 timing tsip tripmate tnt ubx" INPUT_DEVICES="evdev" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LIBREOFFICE_EXTENSIONS="presenter-console presenter-minimizer" OFFICE_IMPLEMENTATION="libreoffice" PHP_TARGETS="php5-5" PYTHON_SINGLE_TARGET="python2_7" PYTHON_TARGETS="python2_7 python3_2" RUBY_TARGETS="ruby19 ruby18" USERLAND="GNU" VIDEO_CARDS="nvidia" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account"
Unset:  CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, INSTALL_MASK, PORTAGE_BUNZIP2_COMMAND, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS, USE_PYTHON


I've reluctantly tried "FEATURES=-sandbox emerge -veD world," without success. Does anyone know how to help?

Sorry if I've left anything out, it's my first post on the forum.
Thanks!
Back to top
View user's profile Send private message
eyoung100
Veteran
Veteran


Joined: 23 Jan 2004
Posts: 1406

PostPosted: Fri Nov 08, 2013 9:55 pm    Post subject: Reply with quote

See Moving from unstable (~amd64) to stable (amd64).

All the packages in the toolchain must stay Testing or Live, and downgrading GLIBC is unsupported.
_________________
The Birth and Growth of Science is the Death and Atrophy of Art -- Unknown
Registerd Linux User #363735
Adopt a Post | Strip Comments| Emerge Wrapper
Back to top
View user's profile Send private message
kalda341
n00b
n00b


Joined: 08 Nov 2013
Posts: 2

PostPosted: Sat Nov 09, 2013 7:45 pm    Post subject: Reply with quote

eyoung100 wrote:
See Moving from unstable (~amd64) to stable (amd64).

All the packages in the toolchain must stay Testing or Live, and downgrading GLIBC is unsupported.

I've read that and followed those steps without success, because even if I keep the toolchain Testing, it still wants to compile GCC and I get this error.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Portage & Programming All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum