Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Problemas com emerge do Gentoo (Tutoo)
View unanswered posts
View posts from last 24 hours
View posts from last 7 days

 
Reply to topic    Gentoo Forums Forum Index Portuguese
View previous topic :: View next topic  
Author Message
mfdzerohour
Tux's lil' helper
Tux's lil' helper


Joined: 31 Aug 2005
Posts: 143
Location: Paranaíba-MS

PostPosted: Sat Dec 30, 2006 1:13 am    Post subject: Problemas com emerge do Gentoo (Tutoo) Reply with quote

Boa Noite,

Não sei se posso postar aqui as minhas duvidas, mas acho que aqui seria o lugar onde teria as respostas mas rapidamente!

Tive que reinstalar o gentoo na minha maquina, pois o meu HD queimou, então comprei um novo de 80 GB, mas fiquei com preguissa de instalar o gentoo pelos pacotes do mesmo (demorei uma semana para intalar o mesmo), como eu tinha os cdś do tutoo baixados e sabia que o mesmo é um gentoo personalizado =, eu o instalei, ele é baseado na versão do gentoo 2005.0 ou 2005.1, ta rodando legal os aplicativos, o problema que encontrei foi com o emerge atualizei os pacotes pois nem sincronizando o mesmo estava arrumei e isto está ok agora, mas ele não atualiza o gentoo (emerge - uDav world), ele está apresentando erros alguém poderia me ajudar a solucionar o problema? Os erros encontrados são:

localhost marcelo # emerge -uDav world

These are the packages that would be merged, in order:

Calculating world dependencies |
emerge: there are no ebuilds to satisfy "=dev-python/PyQt-3.13".
(dependency required by "dev-python/pykde-3.11.3" [ebuild])

!!! Problem resolving dependencies for kde-misc/tutookcm
!!! Depgraph creation failed.


O Grande problema está que o pacote dev-python/PyQt-3.13 não existe, o que existe é a versão superior localhost marcelo #PyQt-3.14.1-r2 e PyQt-3.17, já instalei a versão 3.17 mas mesmo assim não deu ele pede o arquivo, instalei a dependencia do 3.17 que seria o pykde-3.16.0, mas mesmo assim ele faz referencia aos pacotes de versões antigas o que poderia fazer para solucionar o problema?

Desde já agradeço a ajuda e Boas Festas para Todos!!!

Marcelo Duarte
Back to top
View user's profile Send private message
thiagonunes
Apprentice
Apprentice


Joined: 16 Nov 2005
Posts: 171
Location: Brasil -> RS -> Rio Grande

PostPosted: Sat Jan 20, 2007 5:11 am    Post subject: Reply with quote

Quote:

Boa Noite,

Não sei se posso postar aqui as minhas duvidas, mas acho que aqui seria o lugar onde teria as respostas mas rapidamente!


É cara, acho que você se enganou. Já fazem mais de 20 dias que vocês postou essa dúvida e nada. Eu tenho observado ultimamente que o pessoal não é muito chegado no fórum. O que bomba mesmo é a lista, lá o que você enviar provavelmente você terá alguma resposta em menos de duas horas. Com você usa gentoo eu recomendo que se inscreva, é só mandar um email para gentoo-user-br+subscribe@lists.gentoo.org .

Quote:

Tive que reinstalar o gentoo na minha maquina, pois o meu HD queimou, então comprei um novo de 80 GB, mas fiquei com preguissa de instalar o gentoo pelos pacotes do mesmo (demorei uma semana para intalar o mesmo), como eu tinha os cdś do tutoo baixados e sabia que o mesmo é um gentoo personalizado =, eu o instalei, ele é baseado na versão do gentoo 2005.0 ou 2005.1, ta rodando legal os aplicativos, o problema que encontrei foi com o emerge atualizei os pacotes pois nem sincronizando o mesmo estava arrumei e isto está ok agora, mas ele não atualiza o gentoo (emerge - uDav world), ele está apresentando erros alguém poderia me ajudar a solucionar o problema? Os erros encontrados são:

localhost marcelo # emerge -uDav world

These are the packages that would be merged, in order:

Calculating world dependencies |
emerge: there are no ebuilds to satisfy "=dev-python/PyQt-3.13".
(dependency required by "dev-python/pykde-3.11.3" [ebuild])

!!! Problem resolving dependencies for kde-misc/tutookcm
!!! Depgraph creation failed.


O Grande problema está que o pacote dev-python/PyQt-3.13 não existe, o que existe é a versão superior localhost marcelo #PyQt-3.14.1-r2 e PyQt-3.17, já instalei a versão 3.17 mas mesmo assim não deu ele pede o arquivo, instalei a dependencia do 3.17 que seria o pykde-3.16.0, mas mesmo assim ele faz referencia aos pacotes de versões antigas o que poderia fazer para solucionar o problema?

Desde já agradeço a ajuda e Boas Festas para Todos!!!

Marcelo Duarte


Bom, de fato o problema parece ser da árvore do portage. De onde você sincroniza? Acho que o mirror da unicamp é bem confiável, o endereço pra ele é rsync://ww.las.ic.unicamp.br/getnoo-portage. O mirrorselect pode te ajudar nisso.

Veja também que quem está causando esse problema é um pacote do tutoo. Como você fez com que ele não atualizasse mais com o overlay dele os pacotes dele ficaram desatualizados e pedindo por dependências antigas da árvore do portage. Se você pretende continuar com essa instalação do tutoo eu recomendo "dar um jeito" dele atualizar os pacotes específicos dele também ou desinstalar esse pacote que está dando problemas.

Mas o que eu recomendo mesmo é que você recomece um gentoo do zero, dá trabalho, mas você sabe que vale a pena não? Faça isso em outra partição e vá usando o tutoo enquanto o seu gentoo não está ok.

Então ,topa?
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Portuguese All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum