Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[Software] Probleme Php
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index French
View previous topic :: View next topic  
Author Message
najem2005
n00b
n00b


Joined: 27 Dec 2006
Posts: 34

PostPosted: Wed Dec 27, 2006 5:43 pm    Post subject: [Software] Probleme Php Reply with quote

Bonjours quand je tape : emerge php
je recois
Code:


/usr/portage/eclass/apache-module.eclass: line 243: //usr/sbin/apxs2: Aucun fichier ou répertoire de ce type
 * The module you are trying to install (php)
 * will only work with one of the following MPMs:
 *    itk peruser prefork
 * You do not currently have any of these MPMs installed.
 * Please re-install apache with the correct mpm-* USE flag set.

!!! ERROR: dev-lang/php-5.1.6-r6 failed.
Call stack:
  ebuild.sh, line 1562:   Called dyn_setup
  ebuild.sh, line 665:   Called pkg_setup
  php-5.1.6-r6.ebuild, line 64:   Called apache-module_pkg_setup
  apache-module.eclass, line 374:   Called apache2_pkg_setup
  apache-module.eclass, line 255:   Called die

!!! No safe MPM installed.
!!! If you need support, post the topmost build error, and the call stack if relevant.

ns38302 portage-ovh # emerge php-5.1.6-r6
Calculating dependencies

!!! 'php-5.1.6-r6' is not a valid package atom.
!!! Please check ebuild(5) for full details.
!!! (Did you specify a version but forget to prefix with '='?)
Back to top
View user's profile Send private message
Tuxicomane
Apprentice
Apprentice


Joined: 14 Nov 2006
Posts: 290
Location: Val-de-Marne, FRANCE

PostPosted: Wed Dec 27, 2006 5:54 pm    Post subject: Reply with quote

Re-bonjour ! :)
Alors à priori, c'est une histoire de USE flag, il faut que tu recompile apache comme indiqué, c'est-à-dire avec un des USE flags commencant par mpm-

------
Sinon,
Quote:
ns38302 portage-ovh # emerge php-5.1.6-r6

Ce n'est pas le problème ici, mais à noter que pour installer une version précise, la syntaxe est
Code:
emerge =php-5.1.6-r6


Last edited by Tuxicomane on Wed Dec 27, 2006 5:56 pm; edited 1 time in total
Back to top
View user's profile Send private message
najem2005
n00b
n00b


Joined: 27 Dec 2006
Posts: 34

PostPosted: Wed Dec 27, 2006 5:55 pm    Post subject: Reply with quote

je pense pas ce que tu dit ma donner
Code:
 *
/usr/portage/eclass/apache-module.eclass: line 243: //usr/sbin/apxs2: Aucun fichier ou répertoire de ce type
 * The module you are trying to install (php)
 * will only work with one of the following MPMs:
 *    itk peruser prefork
 * You do not currently have any of these MPMs installed.
 * Please re-install apache with the correct mpm-* USE flag set.

!!! ERROR: dev-lang/php-5.1.6-r6 failed.
Call stack:
  ebuild.sh, line 1562:   Called dyn_setup
  ebuild.sh, line 665:   Called pkg_setup
  php-5.1.6-r6.ebuild, line 64:   Called apache-module_pkg_setup
  apache-module.eclass, line 374:   Called apache2_pkg_setup
  apache-module.eclass, line 255:   Called die

!!! No safe MPM installed.
!!! If you need support, post the topmost build error, and the call stack if relevant.



No safe MPM installed. :wink:
Back to top
View user's profile Send private message
Tuxicomane
Apprentice
Apprentice


Joined: 14 Nov 2006
Posts: 290
Location: Val-de-Marne, FRANCE

PostPosted: Wed Dec 27, 2006 6:00 pm    Post subject: Reply with quote

J'ai édité, c'était ptêt pas très clair.
Bon si tu fait un emerge -pvt apache, tu vas voir entre autre
Code:
[ebuild  N    ] net-www/apache-2.0.59-r2  USE="ssl threads -apache2 -debug -doc -ldap -mpm-itk -mpm-leader -mpm-peruser -mpm-prefork -mpm-threadpool -mpm-worker (-selinux) -static-modules" 4,690 kB


Comme tu vois, il y a des USE qui commencent par mpm-
Il faut que tu en choisissent une parmi mpm-itk, mpm-peruser et mpm-prefork

Maintenant je ne sais pas à quoi ça correspond, peut-être un euse -i mpm-itk t'éclairera
Back to top
View user's profile Send private message
najem2005
n00b
n00b


Joined: 27 Dec 2006
Posts: 34

PostPosted: Wed Dec 27, 2006 6:09 pm    Post subject: Reply with quote

j'ai recu :
Code:

ns38302 ~ # emerge -pvt apache

These are the packages that would be merged, in reverse order:

Calculating dependencies... done!
[ebuild  N    ] net-www/apache-2.0.58-r2  USE="apache2 ssl -debug -doc -ldap -mpm-itk -mpm-leader -mpm-peruser -mpm-prefork -mpm-threadpool -mpm-worker (-selinux) -static-modules -threads" 4,651 kB
[ebuild  N    ]  dev-libs/apr-util-0.9.12  USE="berkdb gdbm -ldap" 578 kB
[ebuild  N    ]   dev-libs/apr-0.9.12  USE="ipv6 -urandom" 1,024 kB

Total size of downloads: 6,254 k
Back to top
View user's profile Send private message
Tuxicomane
Apprentice
Apprentice


Joined: 14 Nov 2006
Posts: 290
Location: Val-de-Marne, FRANCE

PostPosted: Wed Dec 27, 2006 6:38 pm    Post subject: Reply with quote

Dis c'est compliqué ce que je dis ou quoi ? :?

Non parce que j'ai l'impression que tu ne lis pas :evil:

Si c'est la commande euse qui te dérange, il faut emerger gentoolkit pour l'avoir.
Back to top
View user's profile Send private message
truz
Apprentice
Apprentice


Joined: 26 Feb 2005
Posts: 293
Location: France - Paris

PostPosted: Wed Dec 27, 2006 6:44 pm    Post subject: Reply with quote

Je plussoie Tuxicomane, tu dois réemerger apache avec un des 3 USE Flags qu'il t'a indiqué. Le mieux étant d'ajouter une ligne du type "net-www/apache mpm-<celui que tu as choisi>" dans le fichier package.use
_________________
Je sais que mes droits s'arrêtent là où commencent ceux des autres. Mais est-ce ma faute si les droits des autres commencent si loin ? [Quino] -- Mafalda
Back to top
View user's profile Send private message
truz
Apprentice
Apprentice


Joined: 26 Feb 2005
Posts: 293
Location: France - Paris

PostPosted: Wed Dec 27, 2006 6:58 pm    Post subject: Reply with quote

Juste en passant, essaye de mettre des titres plus explicites pour tes posts: ça facilite les recherches, ça permet aux autres ayant le même problème que toi de trouver ce fil plus rapidement et comme ça on garde un forum bien rangé (et on évite les gentils rappels au règlement ;-). Ici je verrais plutôt un petit "[PHP] No safe MPM installed".
Bonne continuation sur gentoo ! :-)
_________________
Je sais que mes droits s'arrêtent là où commencent ceux des autres. Mais est-ce ma faute si les droits des autres commencent si loin ? [Quino] -- Mafalda
Back to top
View user's profile Send private message
najem2005
n00b
n00b


Joined: 27 Dec 2006
Posts: 34

PostPosted: Wed Dec 27, 2006 11:24 pm    Post subject: Reply with quote

c'est tu sais comment je peux regler mon problem aide moi
Back to top
View user's profile Send private message
Tuxicomane
Apprentice
Apprentice


Joined: 14 Nov 2006
Posts: 290
Location: Val-de-Marne, FRANCE

PostPosted: Wed Dec 27, 2006 11:46 pm    Post subject: Reply with quote

Comment ? Comme ça :
truz wrote:
Je plussoie Tuxicomane, tu dois réemerger apache avec un des 3 USE Flags qu'il t'a indiqué. Le mieux étant d'ajouter une ligne du type "net-www/apache mpm-<celui que tu as choisi>" dans le fichier package.use

Désolé mais je ne pense pas qu'on puisse faire plus clair.

Si tu ne sais pas quel mpm-bidule choisir cherche peut-être dans la doc.
Back to top
View user's profile Send private message
grosnours
Apprentice
Apprentice


Joined: 05 Jun 2006
Posts: 210
Location: Belgium

PostPosted: Thu Dec 28, 2006 3:11 pm    Post subject: Reply with quote

Le prefork ou l'itk sont les plus stables.
_________________
grosnours
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index French All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum