Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Weird curses problem
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Other Things Gentoo
View previous topic :: View next topic  
Author Message
Zuliani
n00b
n00b


Joined: 24 Nov 2006
Posts: 11

PostPosted: Sun Dec 24, 2006 12:38 pm    Post subject: Weird curses problem Reply with quote

Hello,
I've had this problem on Debian too so I hope someone can help me:
When I use any program on the CLI that uses ncurses, the layout gets fuckered, they're still useable, but it's quite annoying. I think the problem is the nvidiafb driver, becouse I don't have this problem on a regular 80*25 console.

Zuliani
Back to top
View user's profile Send private message
mjrosenb
Tux's lil' helper
Tux's lil' helper


Joined: 12 Jun 2006
Posts: 115
Location: CMU

PostPosted: Sun Dec 24, 2006 1:42 pm    Post subject: Reply with quote

When you say the layout gets fuckered, do you mean when the ncurses based program is running, or after it exists?
_________________
I'll be mjrosenb on #${COMPUTER_RELATED_SUBJECT}
1x i386 laptop w/ Gentoo
4x i386 desktop w/ Gentoo
2x dual proc i386 w/dragonfly bsd
1x x86-64 desktop w/ Gentoo
1x i386 desktop w/ FreeBSD
1x alpha workstation w/ Gentoo
looking for more
Back to top
View user's profile Send private message
i92guboj
Moderator
Moderator


Joined: 30 Nov 2004
Posts: 9752
Location: Córdoba (Spain)

PostPosted: Sun Dec 24, 2006 1:57 pm    Post subject: Re: Weird curses problem Reply with quote

Zuliani wrote:
Hello,
I've had this problem on Debian too so I hope someone can help me:
When I use any program on the CLI that uses ncurses, the layout gets fuckered, they're still useable, but it's quite annoying. I think the problem is the nvidiafb driver, becouse I don't have this problem on a regular 80*25 console.

Zuliani


Try to develop a bit more, for the sake of those of us that dont have their psychic powers on today.

When you say "layout fuckered" do you mean "strange symbols appear instead of the nice lines" or do you mean "all the output is dissordered and things appear randomly distributer across the term"?

What term are you using? Do you use unicode or a regular codepage? Which fonts are you using on that term?

I can say for sure that nvidia drivers are not the issue. We are talking about ncurses.
Back to top
View user's profile Send private message
Zuliani
n00b
n00b


Joined: 24 Nov 2006
Posts: 11

PostPosted: Sun Dec 24, 2006 2:10 pm    Post subject: Reply with quote

Sorry, It's just quite hard to describe, since it varies from program to program. I'm not sure what codepage I'm using :-s I don't know how to determine it either. I didn't change anything to the font of the terminal, so the default I guess.
I only have the problem while the program is running.
Back to top
View user's profile Send private message
i92guboj
Moderator
Moderator


Joined: 30 Nov 2004
Posts: 9752
Location: Córdoba (Spain)

PostPosted: Sun Dec 24, 2006 2:43 pm    Post subject: Reply with quote

Zuliani wrote:
Sorry, It's just quite hard to describe, since it varies from program to program. I'm not sure what codepage I'm using :-s I don't know how to determine it either. I didn't change anything to the font of the terminal, so the default I guess.
I only have the problem while the program is running.


Ok, for example, to start, try to post the output of "locale". Then, tell us what term are you using. If you are inside X, how do you open your term? Is it the one that opens by default when X is started if you have not configured X to use a particular desktop? Then it might be xterm. Post also the output of "echo $TERM" to confirm.

Next thing is to know what concrete programs are giving you the headache. For example, mc used to have some problems with ncurses, they are fixed usually by emerging it with USE="-ncurses slang". Slang works better with unicode usually.

Well, lets check your locale first.

EDIT, you could also post a screenie of the garbled term so we can make a more accurate idea on how it does look like.
Back to top
View user's profile Send private message
Kreso
n00b
n00b


Joined: 24 Sep 2006
Posts: 19

PostPosted: Sun Dec 31, 2006 1:41 am    Post subject: Reply with quote

I'm having this problem as well, mc and kernel's menuconfig look bad
it only occurs on virtual terminals. works fine under X terminals;
it's kinda hard to describu, I'll take a picture of tne monitor if I find my camera;

here's my locale output

Code:

LANG=
LC_CTYPE="POSIX"
LC_NUMERIC="POSIX"
LC_TIME="POSIX"
LC_COLLATE="POSIX"
LC_MONETARY="POSIX"
LC_MESSAGES="POSIX"
LC_PAPER="POSIX"
LC_NAME="POSIX"
LC_ADDRESS="POSIX"
LC_TELEPHONE="POSIX"
LC_MEASUREMENT="POSIX"
LC_IDENTIFICATION="POSIX"
LC_ALL=

Back to top
View user's profile Send private message
Kreso
n00b
n00b


Joined: 24 Sep 2006
Posts: 19

PostPosted: Sun Dec 31, 2006 1:45 am    Post subject: Reply with quote

and here's the solution:

https://forums.gentoo.org/viewtopic-t-508951-highlight-midnight+commander.html
Back to top
View user's profile Send private message
i92guboj
Moderator
Moderator


Joined: 30 Nov 2004
Posts: 9752
Location: Córdoba (Spain)

PostPosted: Sun Dec 31, 2006 1:58 am    Post subject: Reply with quote

Kreso wrote:
I'm having this problem as well, mc and kernel's menuconfig look bad
it only occurs on virtual terminals. works fine under X terminals;
it's kinda hard to describu, I'll take a picture of tne monitor if I find my camera;

here's my locale output

Code:

LANG=
LC_CTYPE="POSIX"
LC_NUMERIC="POSIX"
LC_TIME="POSIX"
LC_COLLATE="POSIX"
LC_MONETARY="POSIX"
LC_MESSAGES="POSIX"
LC_PAPER="POSIX"
LC_NAME="POSIX"
LC_ADDRESS="POSIX"
LC_TELEPHONE="POSIX"
LC_MEASUREMENT="POSIX"
LC_IDENTIFICATION="POSIX"
LC_ALL=



I dont know if you already found a solution, but anyway you should set a proper locale, instead of using posix unless you have a good reason to do so.

You can do so by putting two simple lines in your ~/.bashrc (or in /etc/bash/bashrc if you want to set it globally for all users).

Code:

export LANG=es_ES.utf8
export LC_ALL=es_ES.utf8


Of course, you need to change the locale to yours. that would be for spanish with unicode. The command "locale --all" will show a list of the available locales, you can also build more locales if needed. The list of locales that are built when emerging glibc is in /etc/locales.build, you just need to edit it, remove or add locales at your desire, and then emerge glibc for the new locales to be built. Mine looks like this:

Code:

$ cat /etc/locales.build
es_ES@euro/ISO-8859-15
es_ES.UTF-8/UTF-8
en_US@euro/ISO-8859-15
en_US.UTF-8/UTF-8


Of course, the C and POSIX locales are always built, no need to add them there. The posix character set is limited, and with it most pseudo graphical stuff in text mode will not be available. The reason why in a term you do not have that problem is cause X uses its own font engine, most terminals and the desktops environments do not care about that, since they use custom language settings and character sets.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Other Things Gentoo All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum