Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
install oracle 8
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Russian
View previous topic :: View next topic  
Author Message
yalex2000
n00b
n00b


Joined: 23 Sep 2004
Posts: 15
Location: Moscow

PostPosted: Wed Dec 20, 2006 8:08 am    Post subject: install oracle 8 Reply with quote

Help!!!
Кони будь ставил Oracle 8.1.7 на Gentoo???
Поделитесь опытом...

Я поставил Gentoo 2006.1 и пытаюсь запустить ./runInstaller

Вот что он выдает

Code:
 ./runInstaller
Initializing Java Virtual Machine from ../stage/Components/oracle.swd.jre/1.1.8/1/DataFiles/Expanded/linux/bin/jre. Please wait...
/media/cdrom/stage/Components/oracle.swd.jre/1.1.8/1/DataFiles/Expanded/linux/lib/linux/native_threads/libzip.so: symbol errno, version GLIBC_2.0 not defined in file libc.so.6 with link time reference (libzip.so)
Unable to initialize threads: cannot find class java/lang/Thread
Could not create Java VM


вот что установлено
Code:

Calculating dependencies... done!
[ebuild   R   ] dev-java/blackdown-jre-1.4.2.03-r13

Calculating dependencies... done!
[ebuild   R   ] sys-libs/glibc-2.4-r3


Помогите чайнику! Plz...
Back to top
View user's profile Send private message
046
Apprentice
Apprentice


Joined: 21 Jul 2004
Posts: 231
Location: Yaroslavl, Russia

PostPosted: Wed Dec 20, 2006 8:11 am    Post subject: Reply with quote

Ох, а посвежее оракл не годится почему-то?
Back to top
View user's profile Send private message
yalex2000
n00b
n00b


Joined: 23 Sep 2004
Posts: 15
Location: Moscow

PostPosted: Wed Dec 20, 2006 8:19 am    Post subject: Reply with quote

да пипес
у нас ток на нем софт работает :(
гавно еше то, но что поделаешь...
А шапку ставить нехочу - потому что отстой :)
Back to top
View user's profile Send private message
Laitr Keiows
Moderator
Moderator


Joined: 04 Jul 2005
Posts: 891
Location: Kobe, Japan

PostPosted: Wed Dec 20, 2006 9:15 am    Post subject: Re: install oracle 8 Reply with quote

yalex2000 wrote:
Code:
 /media/cdrom/stage/Components/oracle.swd.jre/1.1.8/1/DataFiles/Expanded/linux/lib/linux/native_threads/libzip.so: symbol errno, version GLIBC_2.0 not defined in file libc.so.6 with link time reference (libzip.so)

Попробуй поиском...
Back to top
View user's profile Send private message
046
Apprentice
Apprentice


Joined: 21 Jul 2004
Posts: 231
Location: Yaroslavl, Russia

PostPosted: Wed Dec 20, 2006 9:18 am    Post subject: Reply with quote

Ты можешь установить шапку, и использовать её в chroot, ну и оракл там установить ))
Back to top
View user's profile Send private message
yalex2000
n00b
n00b


Joined: 23 Sep 2004
Posts: 15
Location: Moscow

PostPosted: Wed Dec 20, 2006 10:53 am    Post subject: Re: install oracle 8 Reply with quote

Laitr Keiows wrote:

Попробуй поиском...


Что поиском? FAQ и доки все ро девятку минимум :(
А что ему не нравиться по поводу библиотек я так и не вьехал...

Я раньше ставил его на Gentoo только версия была старая (давно это было)
И тогда затык был в JAVA - но решилось создание линков в /usr/local
Back to top
View user's profile Send private message
yalex2000
n00b
n00b


Joined: 23 Sep 2004
Posts: 15
Location: Moscow

PostPosted: Wed Dec 20, 2006 2:02 pm    Post subject: Reply with quote

Ну пипес... Что никто таким извратом не занимался? :?

Я дал в путях прописал
Code:

~ $ echo $PATH
/usr/local/bin:.......:/opt/blackdown-jre-1.4.2.03/lib/i386


Code:
~ $ li
libart2-config        libjawt.so            libpng12-config
libawt.so             libjcov.so            libpng-config
libcmm.so             libJdbcOdbc.so        librmi.so
libdcpr.so            libjdwp.so            libtool
libdt_socket.so       libjpeg.so            libtoolize
libfontmanager.so     libjsig.so            libusb-config
libgcrypt-config      libjsoundalsa.so      libverify.so
libglade-convert      libjsound.so          libwmf-config
libhprof.so           libmlib_image.so      libwmf-fontmap
libIDL-config-2       libnative_chmod.so    libzip.so
libioser12.so         libnetcfg             linc-cleanup-sockets
libjaas_unix.so       libnet.so             line
libjavaplugin_jni.so  libnio.so             linguist
libjava.so            libol-config          link


один хрен пишет
Code:
$ ./runInstaller
Initializing Java Virtual Machine from ../stage/Components/oracle.swd.jre/1.1.8/1/DataFiles/Expanded/linux/bin/jre. Please wait...
/media/cdrom/stage/Components/oracle.swd.jre/1.1.8/1/DataFiles/Expanded/linux/lib/linux/native_threads/libzip.so: symbol errno, version GLIBC_2.0 not defined in file libc.so.6 with link time reference (libzip.so)
Unable to initialize threads: cannot find class java/lang/Thread
Could not create Java VM


Я так понял что он ругается на классы, а запрос на список классов вот что выдает:
Code:

$ java-config --list-available-packages
[Provided by the active vm] No Description (None)


в факе по яве а генте написано что надо установить значение CLASSPATH - а чот ставить то?

помогите нубу :cry:
Back to top
View user's profile Send private message
rusxakep
Guru
Guru


Joined: 09 Jul 2004
Posts: 458
Location: Moscow, Russia

PostPosted: Fri Dec 22, 2006 6:29 pm    Post subject: Reply with quote

тебе нужен glibc 2.0 (то есть старый). Возможно нужны libstdc++ и прочий старый -compat софт
Back to top
View user's profile Send private message
yalex2000
n00b
n00b


Joined: 23 Sep 2004
Posts: 15
Location: Moscow

PostPosted: Wed Dec 27, 2006 8:56 pm    Post subject: Reply with quote

Спасибо.
Попробую. ток теперь после нового года :)
Back to top
View user's profile Send private message
pacman
n00b
n00b


Joined: 29 Dec 2006
Posts: 1
Location: Russia, SPb

PostPosted: Fri Dec 29, 2006 2:14 pm    Post subject: Reply with quote

Начни с HOWTO.
хотя бы тут http://www.linux.com/howtos/Oracle8-on-RH7X-HOWTO-2.shtml
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Russian All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum