Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Can't install Beryl 0.1.2
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Duplicate Threads
View previous topic :: View next topic  
Author Message
DrAgOnTuX
Apprentice
Apprentice


Joined: 22 Aug 2006
Posts: 176
Location: Switzerland

PostPosted: Fri Dec 15, 2006 11:58 am    Post subject: Can't install Beryl 0.1.2 Reply with quote

Code:

ul08 ~ # emerge -av beryl

These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild  N    ] x11-wm/beryl-0.1.2  0 kB

Total size of downloads: 0 kB

Would you like to merge these packages? [Yes/No] Y

>>> Emerging (1 of 1) x11-wm/beryl-0.1.2 to /
 * checking ebuild checksums ;-) ...                                      [ ok ]
 * checking auxfile checksums ;-) ...                                     [ ok ]
 * checking miscfile checksums ;-) ...                                    [ ok ]
 * Please re-emerge >=x11-libs/cairo-1.2.2 with the X and pdf USE flag set

!!! ERROR: x11-wm/beryl-0.1.2 failed.
Call stack:
  ebuild.sh, line 1562:   Called dyn_setup
  ebuild.sh, line 665:   Called pkg_setup
  beryl-0.1.2.ebuild, line 24:   Called die

!!! Please emerge >=x11-libs/cairo-1.2.2 with the X and pdf flag set
!!! If you need support, post the topmost build error, and the call stack if relevant.

ul08 ~ # equery uses cairo
[ Searching for packages matching cairo... ]
[ Colour Code : set unset ]
[ Legend        : Left column  (U) - USE flags from make.conf                    ]
[                  : Right column (I) - USE flags packages was installed with ]
[ Found these USE variables for x11-libs/cairo-1.2.4 ]
 U I
 + + X        : Adds support for X11
 + + directfb : Adds support for DirectFB layer (library for FB devices)
 - - doc      : Adds extra documentation (API, Javadoc, etc)
 + + glitz    : Build with glitz support
 + + png      : Adds support for libpng (PNG images)
 + + svg      : Adds support for SVG (Scalable Vector Graphics http://www.w3.org/TR/SVG ).  This option is mainly intended for users that tend to browse multimedia sites frequently.
ul08 ~ # emerge -pv cairo

These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild   R   ] x11-libs/cairo-1.2.4  USE="X directfb glitz png svg -doc" 0 kB

Total size of downloads: 0 kB
ul08 ~ #

I don't use an portage overlay.
How can I emerge cairo with the required pdf flag?
Any ideas?
Back to top
View user's profile Send private message
vonr
Guru
Guru


Joined: 23 Mar 2006
Posts: 300
Location: Amsterdam, The Netherlands

PostPosted: Fri Dec 15, 2006 12:06 pm    Post subject: Reply with quote

The pdf USE flag to x11-libs/cairo was removed recently (see here), and should be enabled by default now. It could very well be that when you compiled cairo the first time, you didn't have pdf enabled.

Try recompiling x11-libs/cairo; it should do the trick.
_________________
Have you ever seen Geneva™, Monaco®, or New York®?
Geneva, Monaco, and New York are trademarks of Apple Computer, Inc., some registered in the U.S. and other countries.
Back to top
View user's profile Send private message
DrAgOnTuX
Apprentice
Apprentice


Joined: 22 Aug 2006
Posts: 176
Location: Switzerland

PostPosted: Fri Dec 15, 2006 12:29 pm    Post subject: Reply with quote

vonr wrote:
The pdf USE flag to x11-libs/cairo was removed recently (see here), and should be enabled by default now. It could very well be that when you compiled cairo the first time, you didn't have pdf enabled.

'emerge -av cairo' wrote:

... SNIP ...
* econf: updating cairo-1.2.4/config.sub with /usr/share/gnuconfig/config.sub
./configure --prefix=/usr --host=i686-pc-linux-gnu --mandir=/usr/share/man --infodir=/usr/share/info --datadir=/usr/share --sysconfdir=/etc --localstatedir=/var/lib --enable-xlib --disable-gtk-doc --enable-directfb --enable-svg --enable-pdf --enable-glitz --enable-png --enable-freetype --enable-ps --build=i686-pc-linux-gnu
checking for a BSD-compatible install... /bin/install -c
checking whether build environment is sane... yes
... SNIP ...

You're right.

vonr wrote:

Try recompiling x11-libs/cairo; it should do the trick.


I already recompiled cairo about 4 times :(
I recompiled everthing in my world file.
I did a 'emerge -avuD --newuse world'. (after a 'emerge --sync')
Back to top
View user's profile Send private message
vonr
Guru
Guru


Joined: 23 Mar 2006
Posts: 300
Location: Amsterdam, The Netherlands

PostPosted: Fri Dec 15, 2006 12:59 pm    Post subject: Reply with quote

Hmm, after a further look at /usr/portage/x11-wm/beryl/beryl-0.1.2.ebuild I found this:
Code:
if has_version ">=x11-libs/cairo-1.2.2" && ! built_with_use x11-libs/cairo X pdf; then
    einfo "Please re-emerge >=x11-libs/cairo-1.2.2 with the X and pdf USE flag set"
    die "Please emerge >=x11-libs/cairo-1.2.2 with the X and pdf flag set"
fi

Now, correct me if I'm wrong, but it seems like this would make x11-wm/beryl fail by definition under current circumstances, and as such should be considered a bug in the ebuild. If one compiles cairo in its current form, it will never be compiled with the pdf USE flag, so the built_with_use requirement will never be met.

You should file a bug report. Also, if you want to use beryl now, copy the ebuild to your overlay and remove the pdf bit from the ebuild, so that the line in question would look something like this:
Code:
if has_version ">=x11-libs/cairo-1.2.2" && ! built_with_use x11-libs/cairo X; then

[troll]Alternatively, you could just be wise and switch to compiz :D.[/troll]
_________________
Have you ever seen Geneva™, Monaco®, or New York®?
Geneva, Monaco, and New York are trademarks of Apple Computer, Inc., some registered in the U.S. and other countries.
Back to top
View user's profile Send private message
albright
Advocate
Advocate


Joined: 16 Nov 2003
Posts: 2061
Location: Near Toronto

PostPosted: Fri Dec 15, 2006 1:14 pm    Post subject: Reply with quote

why not just add "X" and "pdf" to the USE line in make.conf
and see what happens? Worked for me ...
Back to top
View user's profile Send private message
vonr
Guru
Guru


Joined: 23 Mar 2006
Posts: 300
Location: Amsterdam, The Netherlands

PostPosted: Fri Dec 15, 2006 1:38 pm    Post subject: Reply with quote

albright wrote:
why not just add "X" and "pdf" to the USE line in make.conf
and see what happens? Worked for me ...

Because that wouldn't satisfy built_with_use. Keep in mind that for most people their build of x11-libs/cairo is quite old; the USE flag was removed fairy recently, on December 7th, so it poses no issue for them.
_________________
Have you ever seen Geneva™, Monaco®, or New York®?
Geneva, Monaco, and New York are trademarks of Apple Computer, Inc., some registered in the U.S. and other countries.
Back to top
View user's profile Send private message
DrAgOnTuX
Apprentice
Apprentice


Joined: 22 Aug 2006
Posts: 176
Location: Switzerland

PostPosted: Fri Dec 15, 2006 2:49 pm    Post subject: Reply with quote

albright wrote:
why not just add "X" and "pdf" to the USE line in make.conf
and see what happens? Worked for me ...

I did, 2 months ago :lol: doesn't matter :(
Back to top
View user's profile Send private message
DrAgOnTuX
Apprentice
Apprentice


Joined: 22 Aug 2006
Posts: 176
Location: Switzerland

PostPosted: Fri Dec 15, 2006 3:54 pm    Post subject: Reply with quote

vonr wrote:
Hmm, after a further look at /usr/portage/x11-wm/beryl/beryl-0.1.2.ebuild I found this:
Code:
if has_version ">=x11-libs/cairo-1.2.2" && ! built_with_use x11-libs/cairo X pdf; then
    einfo "Please re-emerge >=x11-libs/cairo-1.2.2 with the X and pdf USE flag set"
    die "Please emerge >=x11-libs/cairo-1.2.2 with the X and pdf flag set"
fi

Now, correct me if I'm wrong, but it seems like this would make x11-wm/beryl fail by definition under current circumstances, and as such should be considered a bug in the ebuild. If one compiles cairo in its current form, it will never be compiled with the pdf USE flag, so the built_with_use requirement will never be met.

You should file a bug report. Also, if you want to use beryl now, copy the ebuild to your overlay and remove the pdf bit from the ebuild, so that the line in question would look something like this:
Code:
if has_version ">=x11-libs/cairo-1.2.2" && ! built_with_use x11-libs/cairo X; then



I'll give it a try 8)
Back to top
View user's profile Send private message
desultory
Administrator
Administrator


Joined: 04 Nov 2005
Posts: 7820

PostPosted: Mon May 21, 2007 7:35 am    Post subject: Reply with quote

Moved from Desktop Environments to Duplicate Threads, refer to topic "Please re-emerge [solved]".

As noted in the handbook USE flags specified via environment variables are not retained as persistent settings so, aside from when a given USE flag setting is itself transient in nature, use one of the persistent USE flag setting methods (/etc/make.conf, /etc/portage/package.use). Also, note that USE flags are case sensitive.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Duplicate Threads All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum