Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[PORTAGE] erreur tbz2
View unanswered posts
View posts from last 24 hours

Goto page 1, 2  Next  
Reply to topic    Gentoo Forums Forum Index French
View previous topic :: View next topic  
Author Message
Smain91
n00b
n00b


Joined: 18 Nov 2006
Posts: 31

PostPosted: Tue Dec 12, 2006 11:03 am    Post subject: [PORTAGE] erreur tbz2 Reply with quote

Bonjour à tous!

Voilà j'aimerai que vous m'aidiez à comprendre cette erreur.
Lorsque je fais:

emerge gnome xscreensaver
....
pyopengl-2.0.1.09.ebuild, line 32: Called built_with_use 'dev-lang/python' 'tk'
...
!!!dev-lang/python-2.4.3-r1 does not actually support the tk USE flag!


Voici mon make.conf si ça peut aider:
Code:
ACCEPT_KEYWORDS="~x86"
CFLAGS="-O2 -march=pentium4 -mtune=pentium4 -fomit-frame-pointer -mfpmath=sse -mmmx -msse -msse2 -pipe"
CHOST="i686-pc-linux-gnu"
CXXFLAGS="${CFLAGS} -fvisibility-inlines-hidden"
MAKEOPTS="-j2"
CCACHE_SIZE="2G"
FEATURES="ccache fixpackages"
VIDEO_CARDS="nvidia"
PORTAGE_NICENESS="19"
LIRC_OPTS="--with-driver=sir"
USE="X a52 aac aalib acpi alsa apache2 apm avahi audiofile bash-completion berkdb bluetooth bzip2 cairo cdinstall cdparanoia cdr cups curl curlwrappers dba dbus dga dio dri dvd dvdr dvdread evo ffmpeg firefox flash ftp gb gd gif gnome gnutls gstreamer gtk hal imap innodb ipv6 java joystick jpeg jpeg2k mad mng mozilla mp3 mpeg msn mysql mysqli ncurses nvidia odbc ogg pcmcia pdf perl php png session speex ssl theora unicode usb videos vorbis wifi win32codecs xine xml xpm xvid zlib -kde -qt3 -qt4 -arts" #oracle oci8 tk opengl
PKGDIR="/usr/portage/packages"
CLEAN_DELAY="0"
ALSA_CARDS="Emu10k1"
INPUT_DEVICES="mouse keyboard evdev joystick"

SYNC="rsync://rsync.europe.gentoo.org/gentoo-portage"

GENTOO_MIRRORS="http://adelie.polymtl.ca/ http://gentoo.mirrors.pair.com/ ftp://gentoo.mirrors.pair.com/ http://gentoo.cs.lewisu.edu/gentoo/ ftp://ftp.gentoo.mesh-solutions.com/gentoo/ "


Merci d'avance.


Last edited by Smain91 on Tue Dec 12, 2006 2:28 pm; edited 1 time in total
Back to top
View user's profile Send private message
bivittatus
l33t
l33t


Joined: 31 Jan 2006
Posts: 687
Location: Roissy-en-Brie (France)

PostPosted: Tue Dec 12, 2006 11:09 am    Post subject: Reply with quote

Si tu ne t'en sers pas pour autre chose, il faut que tu retires tk de ton USE
_________________
Linus TORVALDS: "Je ne suis pas là pour détruire Microsoft. Ce sera juste un effet secondaire tout à fait involontaire."
Back to top
View user's profile Send private message
Smain91
n00b
n00b


Joined: 18 Nov 2006
Posts: 31

PostPosted: Tue Dec 12, 2006 11:48 am    Post subject: Reply with quote

C'est déjà faite bivittatus, si tu regardes bien 'tk' est en commentaire.
Je sais c'est pas très lisible :wink: .
Merci quand même.
Back to top
View user's profile Send private message
kopp
Advocate
Advocate


Joined: 09 Apr 2004
Posts: 2885
Location: Grenoble, France

PostPosted: Tue Dec 12, 2006 11:52 am    Post subject: Reply with quote

que donne un emerge -pv gnome-python ?
Tu as recompilé python depuis que tu as enlevé tk de ton USE ?

EDIT: au passage, à quand remonte ton dernier --sync ?
dernier truc : si tu as -march, ça ne sert à rien de mettre -mtune dans les flags.
Back to top
View user's profile Send private message
blasserre
Veteran
Veteran


Joined: 10 Feb 2004
Posts: 1362
Location: Lille, Vlaanderen

PostPosted: Tue Dec 12, 2006 12:00 pm    Post subject: Reply with quote

à mon sens l'erreur est plus emerge gnome :x
qui va t'installer des milliard de trucs inutiles dont tu ne soupçonneras pas l'existence avant de chercher à faire un peu de place...
mais chacun voit midi à sa porte :wink:

edit : pour que vous compreniez bien que ce n'est pas un troll de/wm, je conseille un emerge gnome-light à la place
et oui, ok, je ne réponds pas à la question.... mais je pense à la pauvre machine qui va devoir compiler moi :(
_________________
benj

technicien professionnel, ascendant winner
Back to top
View user's profile Send private message
_droop_
l33t
l33t


Joined: 30 May 2004
Posts: 957

PostPosted: Tue Dec 12, 2006 12:03 pm    Post subject: Reply with quote

blasserre wrote:
à mon sens l'erreur est plus emerge gnome :x
qui va t'installer des milliard de trucs inutiles dont tu ne soupçonneras pas l'existence avant de chercher à faire un peu de place...
mais chacun voit midi à sa porte :wink:


Presenté comme ça, c'est pas très utile comme réflexion... Tu conseilles peut être gnome-light à la place de gnome ?
Back to top
View user's profile Send private message
blasserre
Veteran
Veteran


Joined: 10 Feb 2004
Posts: 1362
Location: Lille, Vlaanderen

PostPosted: Tue Dec 12, 2006 12:04 pm    Post subject: Reply with quote

_droop_ wrote:
blasserre wrote:
à mon sens l'erreur est plus emerge gnome :x
qui va t'installer des milliard de trucs inutiles dont tu ne soupçonneras pas l'existence avant de chercher à faire un peu de place...
mais chacun voit midi à sa porte :wink:


Presenté comme ça, c'est pas très utile comme réflexion... Tu conseilles peut être gnome-light à la place de gnome ?


tututututu... on a même plus le temps d'éditer/étayer ici :lol:
_________________
benj

technicien professionnel, ascendant winner
Back to top
View user's profile Send private message
_droop_
l33t
l33t


Joined: 30 May 2004
Posts: 957

PostPosted: Tue Dec 12, 2006 12:21 pm    Post subject: Reply with quote

blasserre wrote:
tututututu... on a même plus le temps d'éditer/étayer ici :lol:


:lol:
Back to top
View user's profile Send private message
kopp
Advocate
Advocate


Joined: 09 Apr 2004
Posts: 2885
Location: Grenoble, France

PostPosted: Tue Dec 12, 2006 12:26 pm    Post subject: Reply with quote

En même temps, il manque tellement de chose à gnome-light.... La dernière fois que j'ai installé gnome-light, j'ai passé plus de temps à rechercher ce qui me manquait que si j'avais compilé directement le tout.
Back to top
View user's profile Send private message
Smain91
n00b
n00b


Joined: 18 Nov 2006
Posts: 31

PostPosted: Tue Dec 12, 2006 1:23 pm    Post subject: Reply with quote

kopp wrote:
que donne un emerge -pv gnome-python ?
Tu as recompilé python depuis que tu as enlevé tk de ton USE ?

EDIT: au passage, à quand remonte ton dernier --sync ?
dernier truc : si tu as -march, ça ne sert à rien de mettre -mtune dans les flags.


Salux,

emerge-pv gnome-python donne
Code:

These are the packages that would be merged, in order:

Calculating dependencies  ...... done!
[ebuild  N    ] dev-python/pyopengl-2.0.1.09  0 kB
[ebuild  N    ] dev-python/numeric-24.2  727 kB
[ebuild  N    ] dev-python/pycairo-1.2.2  USE="-numeric" 472 kB
[ebuild  N    ] dev-python/pygtk-2.10.3  USE="opengl -doc" 1,932 kB
[ebuild  N    ] net-dns/avahi-0.6.15  USE="dbus gdbm gtk python -autoipd -bookmarks -doc -howl-compat -mdnsresponder-compat -mono -qt3 -qt4" 872 kB
[ebuild  N    ] dev-lang/tcl-8.4.13  USE="-debug -threads" 3,432 kB
[ebuild  N    ] dev-lang/tk-8.4.13  USE="-debug -threads" 3,177 kB
[ebuild  N    ] dev-db/unixODBC-2.2.11-r1  USE="-qt3" 2,351 kB
[ebuild  N    ] dev-db/mysql-5.0.30  USE="berkdb perl ssl -big-tables -cluster -debug -embedded -extraengine -latin1 -max-idx-128 -minimal (-selinux) -srvdir -static" 25,529 kB
[ebuild  N    ] virtual/mysql-5.0  0 kB
[ebuild  N    ] perl-core/Sys-Syslog-0.18  51 kB
[ebuild  N    ] virtual/perl-Storable-2.15  0 kB
[ebuild  N    ] dev-perl/Net-Daemon-0.39  31 kB
[ebuild  N    ] dev-perl/PlRPC-0.2018  18 kB
[ebuild  N    ] dev-perl/DBI-1.53  414 kB
[ebuild  N    ] dev-perl/DBD-mysql-3.0008  114 kB
[ebuild  N    ] app-misc/mime-types-7  7 kB
[ebuild  N    ] dev-libs/apr-0.9.12  USE="ipv6 -urandom" 1,025 kB
[ebuild  N    ] dev-libs/apr-util-0.9.12  USE="berkdb gdbm -ldap" 579 kB
[ebuild  N    ] net-www/apache-2.0.59-r2  USE="apache2 ssl -debug -doc -ldap -mpm-itk -mpm-leader -mpm-peruser -mpm-prefork -mpm-threadpool -mpm-worker (-selinux) -static-modules -threads" 4,690 kB
[ebuild  N    ] dev-libs/libmcrypt-2.5.7  512 kB
[ebuild  N    ] app-text/aspell-0.60.4-r1  USE="gpm nls" 1,638 kB
[ebuild  N    ] net-libs/c-client-2004g  USE="pam ssl" 2,195 kB
[ebuild  N    ] app-admin/php-toolkit-1.0-r2  0 kB
[ebuild  N    ] media-libs/t1lib-5.0.2  USE="X -doc" 1,658 kB
[ebuild  N    ] dev-libs/libgpg-error-1.5  USE="nls" 364 kB
[ebuild  N    ] dev-libs/libgcrypt-1.2.3  USE="nls" 966 kB
[ebuild  N    ] app-crypt/opencdk-0.5.7  USE="-doc" 469 kB
[ebuild  N    ] dev-lang/nasm-0.98.39-r3  USE="-build -doc" 532 kB
[ebuild  N    ] dev-libs/lzo-2.02-r1  USE="-examples" 586 kB
[ebuild  N    ] dev-libs/libtasn1-0.3.5  USE="-doc" 1,223 kB
[ebuild  N    ] net-libs/gnutls-1.6.0  USE="nls zlib -doc" 4,127 kB
[ebuild  N    ] net-misc/curl-7.15.5  USE="gnutls ipv6 ssl -ares -idn -kerberos -krb4 -ldap -test" 1,507 kB
[ebuild  N    ] dev-lang/php-5.1.6-r8  USE="apache2 berkdb bzip2 cli crypt curl curlwrappers ftp gd gdbm iconv imap ipv6 mysql mysqli ncurses nls odbc pcre readline reflection session spell spl ssl truetype unicode xml xpm zlib -adabas -apache -bcmath -birdstep -calendar -cdb -cgi -cjk -concurrentmodphp -ctype -db2 -dbase -dbmaker -debug -discard-path -doc -empress -empress-bcs -esoob -exif -fastbuild -fdftk -filepro -firebird -flatfile -force-cgi-redirect -frontbase -gd-external -gmp -hardenedphp -hash -hyperwave-api -informix -inifile -interbase -iodbc -java-external -kerberos -ldap -libedit -mcve -memlimit -mhash -ming -msql -mssql -oci8 -oci8-instant-client -pcntl -pdo -pdo-external -pic -posix -postgres -qdbm -recode -sapdb -sasl -sharedext -sharedmem -simplexml -snmp -soap -sockets -solid -sqlite -sybase -sybase-ct -sysvipc -threads -tidy -tokenizer -vm-goto -vm-switch -wddx -xmlreader -xmlrpc -xmlwriter -xsl -yaz -zip" 6,329 kB
[ebuild  N    ] app-portage/portage-utils-0.1.21  USE="python" 68 kB
[ebuild  N    ] dev-java/java-config-wrapper-0.12-r1  8 kB
[ebuild  N    ] dev-java/java-config-2.0.30  17 kB
[ebuild  N    ] dev-java/java-config-1.3.7  15 kB
[ebuild  N    ] media-sound/alsa-headers-1.0.14_pre20061130  7,092 kB
[ebuild  N    ] media-libs/alsa-lib-1.0.13  USE="-debug -doc" 694 kB
[ebuild  N    ] dev-java/sun-jdk-1.5.0.10  USE="X alsa -doc -examples -jce -nsplugin" 48,393 kB
[ebuild  N    ] virtual/jdk-1.5.0  0 kB
[ebuild  N    ] dev-lang/swig-1.3.29-r1  USE="java perl php python tk -doc -guile -lua -mono -ocaml -pike -ruby -tcl" 3,924 kB
[ebuild  N    ] sys-libs/libcap-1.10-r9  USE="python" 39 kB
[ebuild  N    ] dev-libs/libusb-0.1.12  USE="-debug -doc" 381 kB
[ebuild  N    ] sys-apps/eject-2.1.5-r1  USE="nls" 121 kB
[ebuild  N    ] sys-apps/pciutils-2.2.3-r2  1,096 kB
[ebuild  N    ] sys-fs/device-mapper-1.02.12  USE="(-selinux)" 159 kB
[ebuild  N    ] sys-fs/cryptsetup-luks-1.0.4  USE="nls -build -dynamic (-selinux)" 300 kB
[ebuild  N    ] sys-apps/hal-0.5.7.1-r2  USE="acpi crypt pcmcia -debug -dmi -doc (-selinux)" 1,468 kB
[ebuild  N    ] gnome-base/gconf-2.14.0  USE="-debug -doc" 1,852 kB
[ebuild  N    ] app-admin/gamin-0.1.8  USE="-debug -doc" 552 kB
[ebuild  N    ] gnome-base/gnome-vfs-2.16.3  USE="avahi gnutls hal ipv6 ssl -debug -doc -samba" 1,856 kB
[ebuild  N    ] gnome-base/libgnome-2.16.0  USE="-debug -doc -esd -static" 988 kB
[ebuild  N    ] gnome-base/libbonoboui-2.16.0  USE="X -debug -doc" 916 kB
[ebuild  N    ] gnome-base/gnome-keyring-0.6.0  USE="-debug" 466 kB
[ebuild  N    ] gnome-base/libgnomeui-2.16.1  USE="jpeg -debug -doc" 1,448 kB
[ebuild  N    ] gnome-base/gnome-mount-0.4-r5  USE="-debug" 357 kB
[ebuild  N    ] x11-themes/hicolor-icon-theme-0.9-r1  USE="-debug" 32 kB
[ebuild  N    ] dev-perl/XML-NamespaceSupport-1.09  8 kB
[ebuild  N    ] dev-perl/XML-SAX-0.14-r1  58 kB
[ebuild     U ] virtual/perl-Test-Simple-0.63 [0.62] 0 kB
[ebuild  N    ] dev-perl/XML-LibXML-Common-0.13  13 kB
[ebuild  N    ] dev-perl/XML-LibXML-1.62.001-r1  226 kB
[ebuild  N    ] dev-perl/XML-Simple-2.16  68 kB
[ebuild  N    ] x11-misc/icon-naming-utils-0.8.1  62 kB
[ebuild  N    ] x11-themes/gnome-icon-theme-2.16.1  USE="-debug" 2,433 kB
[ebuild  N    ] dev-python/pyorbit-2.14.1  USE="-debug" 276 kB
[ebuild  N    ] dev-python/gnome-python-2.16.2  USE="-debug -doc" 393 kB

Total: 69 packages (1 upgrade, 68 new), Size of downloads: 143,274 kB



je n'ai jamais compilé python avec ce flag, je viens d'installer gentoo et ce make.conf vient d'une précédente installation.

mon dernier --sync remonte à 12h environ, je vais le refaire sais t on jamais.

Merci pour le mtune je jette ça de suite.
Back to top
View user's profile Send private message
kopp
Advocate
Advocate


Joined: 09 Apr 2004
Posts: 2885
Location: Grenoble, France

PostPosted: Tue Dec 12, 2006 1:30 pm    Post subject: Reply with quote

Oups pardon, je voulais un emerge -pv python pyopengl
tant pi... commence par faire un emerge -auvDN world pour voir, si tu as changé des flags...
Je te demandais pour le sync parce que ton python ne semblait pas à jour.
La première chose à faire, si tu as le net, c'est de mettre à jour ce qui est déjà installé avant de commencer à installer.
Back to top
View user's profile Send private message
Smain91
n00b
n00b


Joined: 18 Nov 2006
Posts: 31

PostPosted: Tue Dec 12, 2006 1:59 pm    Post subject: Reply with quote

Nouvelle erreur en faisant

emerge -auvDN world

Il me demande si je veux updater, je réponds oui et au premier package voici l'erreur

i686-pc-linux-gnu-gcc: No such file or directory
....
!!!Failed to build tbz2tool
...

EDIT: le package concerné est portage-2.1.2_rc3

EDIT: même message d'erreur quand je fais 'emerge portage'


Last edited by Smain91 on Tue Dec 12, 2006 2:11 pm; edited 1 time in total
Back to top
View user's profile Send private message
kopp
Advocate
Advocate


Joined: 09 Apr 2004
Posts: 2885
Location: Grenoble, France

PostPosted: Tue Dec 12, 2006 2:10 pm    Post subject: Reply with quote

moche ça.... tu as bien fait ton détarrage comme il faut ?
la dernière fois que j'ai eu ça, c'était quand mon système était en l'air.
Back to top
View user's profile Send private message
Smain91
n00b
n00b


Joined: 18 Nov 2006
Posts: 31

PostPosted: Tue Dec 12, 2006 2:14 pm    Post subject: Reply with quote

snif je presque sur d'avoir tout fait comme il se doit.
c'est quoi un détarrage?
Back to top
View user's profile Send private message
Smain91
n00b
n00b


Joined: 18 Nov 2006
Posts: 31

PostPosted: Tue Dec 12, 2006 2:27 pm    Post subject: Reply with quote

Je n'arrive plus à emerge quoi que ce soit.
C'est un problème lié à portage je pense. J'édit le titre.

Help me please, lol.
Back to top
View user's profile Send private message
kopp
Advocate
Advocate


Joined: 09 Apr 2004
Posts: 2885
Location: Grenoble, France

PostPosted: Tue Dec 12, 2006 2:31 pm    Post subject: Reply with quote

Tu viens d'installer ton système non ? tu as décompressé une archive stage3 non ?
tu as récupéré quoi d'une ancienne installation en plus de ton make.conf ?
Back to top
View user's profile Send private message
Smain91
n00b
n00b


Joined: 18 Nov 2006
Posts: 31

PostPosted: Tue Dec 12, 2006 2:34 pm    Post subject: Reply with quote

Oui je viens d'installer et je n'ai récupéré que ce make.conf.
Back to top
View user's profile Send private message
kopp
Advocate
Advocate


Joined: 09 Apr 2004
Posts: 2885
Location: Grenoble, France

PostPosted: Tue Dec 12, 2006 2:59 pm    Post subject: Reply with quote

Tu as vérifié la somme md5 du stage3 ? Tu as utilisé le bon ?
Au passage, tu as utilisé quelle méthode d'installation ?
Back to top
View user's profile Send private message
Smain91
n00b
n00b


Joined: 18 Nov 2006
Posts: 31

PostPosted: Tue Dec 12, 2006 3:04 pm    Post subject: Reply with quote

J'ai installé à partir du stage 3, je pense avoir utilisé le bon, j'ai pas fait la somme MD5 :oops: .
La méthode d'installation est la classique : CD mini, dowload stage3 + portage, tar ....
Je sais pas pourquoi mais je sens la réinstall inévitable....snif

EDIT : Peut il y avoir un rapport avec le mirror utilisé, certains mirrors sont-ils plus "à jour" que d'autres?
Back to top
View user's profile Send private message
Magic Banana
Veteran
Veteran


Joined: 13 Dec 2005
Posts: 1907
Location: Belo Horizonte, Minas Gerais, Brasil

PostPosted: Tue Dec 12, 2006 3:16 pm    Post subject: Reply with quote

Aucun rapport. En fait, tu aurais pu installer ta Gentoo avec un CD minimal 2005.0 que ça n'y changerait rien ou presque (le profil contenant des valeurs par défaut de la variable USE et autres détails...). Ce qui compte c'est ce qui se trouve dans l'arbre Portage.
Back to top
View user's profile Send private message
kopp
Advocate
Advocate


Joined: 09 Apr 2004
Posts: 2885
Location: Grenoble, France

PostPosted: Tue Dec 12, 2006 3:18 pm    Post subject: Reply with quote

Question conne: tu as utilisais un stage3-x86 ou stage3-i686 ?
Back to top
View user's profile Send private message
Smain91
n00b
n00b


Joined: 18 Nov 2006
Posts: 31

PostPosted: Tue Dec 12, 2006 3:31 pm    Post subject: Reply with quote

J'ai utilisé un stage x86 :oops:
je ne veux pas mourrir con :
c koi la différence entre x86, i586 et i686?
Back to top
View user's profile Send private message
kopp
Advocate
Advocate


Joined: 09 Apr 2004
Posts: 2885
Location: Grenoble, France

PostPosted: Tue Dec 12, 2006 3:45 pm    Post subject: Reply with quote

Bon là voilà ton erreur alors ! D'où le
Code:
i686-pc-linux-gnu-gcc: No such file or directory

En gros, x86, ce sont toutes les machines intel (et compatible) depuis le 386, le i586 depuis le pentium et le i686 depuis le pentium Pro ou pentium II, je ne sais plus.
Donc vu que tu as un pentium 4, il vaut mieux utiliser le stage3 aproprié.
L'autre solution serait d'utiliser un CHOST approrié dans ton /etc/make.conf, mais autant recommencé vu que tu n'en es qu'au début !
Back to top
View user's profile Send private message
Smain91
n00b
n00b


Joined: 18 Nov 2006
Posts: 31

PostPosted: Tue Dec 12, 2006 3:48 pm    Post subject: Reply with quote

Ok je réinstall avec un stage i686, merci pour ton aide kopp, j'éditerai ce post en résolu quand j'aurai fini mon install. Let's go!
Back to top
View user's profile Send private message
nemo13
Veteran
Veteran


Joined: 08 Oct 2004
Posts: 1016
Location: France/Istres

PostPosted: Tue Dec 12, 2006 7:48 pm    Post subject: Re: [PORTAGE] erreur tbz2 Reply with quote

Smain91 wrote:

Voici mon make.conf si ça peut aider:
Code:

USE="... blabla ... -kde -qt3 -qt4 -arts" #oracle oci8 tk opengl

Merci d'avance.

Que vient faire le # après " et avant tk 8O 8O 8O ????
Pourtant mon boeuf-carottes nétait pas trop lourd
voili-voila
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index French All times are GMT
Goto page 1, 2  Next
Page 1 of 2

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum