Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[gnome dbus] problème revdep-rebuild (résolu)
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index French
View previous topic :: View next topic  
Author Message
Untux
Apprentice
Apprentice


Joined: 10 Apr 2006
Posts: 285

PostPosted: Sat Dec 09, 2006 8:42 pm    Post subject: [gnome dbus] problème revdep-rebuild (résolu) Reply with quote

Salut à tous,

Un revdep-rebuild me signale des liens cassés (requires libdbus-1.so.2) sur plusieurs composants gnome et il me donne la liste des paquets à reconstruire (gnome-base/{libbonoboui,libgnomeui} etc.). Lorsque j'essaie d'emerger ces paquets, la compilation échoue avec le message
Code:

...
/usr/lib/gcc/i686-pc-linux-gnu/4.1.1/../../../../i686-pc-linux-gnu/bin/ld: warning: libdbus-1.so.2, needed by /usr/lib/libgnomevfs-2.so, not found (try using -rpath or -rpath-link)
creating libbonoboui-scan
gtk-doc: Running scanner libbonoboui-scan
/var/tmp/portage/gnome-base/libbonoboui-2.16.0/work/libbonoboui-2.16.0/doc/api/.libs/lt-libbonoboui-scan: error while loading shared libraries: libdbus-1.so.2: cannot open shared object file: No such file or directory
Scan failed:
make[4]: *** [scan-build.stamp] Erreur 127
...

Le fichier libdbus-1.so.2 n'existe effectivement pas sur mon système, étant donné qu'une récente mise à jour du paquet sys-apps/dbus a remplacé ce fichier par libdbus-1.so.3.2.0. Est-ce que je dois créer un bug pour ça ? J'ai un petit doute parce que tout ça est encore un peu obscur pour moi, et en plus, je n'ai pas trouvé de posts similaires sur les forums Gentoo. Je me demande donc si j'ai pas oublié quelque chose ?!

Pour info :
ligbnomeui-2.16.1
libbonoboui-2.16.0
dbus-1.0.1-r2
et Gentoo à jour en ~x86

Merci d'avance pour votre aide.


Last edited by Untux on Sun Dec 10, 2006 12:35 am; edited 1 time in total
Back to top
View user's profile Send private message
Untux
Apprentice
Apprentice


Joined: 10 Apr 2006
Posts: 285

PostPosted: Sun Dec 10, 2006 12:35 am    Post subject: Reply with quote

Problème résolu. Dans la liste des paquets à reconstruire il y avait gnome-base/gnome-vfs. Il suffisait de le re-emerger en premier pour que la compilation des suivants fonctionne.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index French All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum