Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Xbox kernel help
View unanswered posts
View posts from last 24 hours

Reply to topic    Gentoo Forums Forum Index Gentoo on Alternative Architectures
View previous topic :: View next topic  
Author Message

Joined: 09 Dec 2006
Posts: 3

PostPosted: Sat Dec 09, 2006 4:54 am    Post subject: Xbox kernel help Reply with quote

I have been trying to make a fresh install of gentoo on the xbox with the latest 2.6 kernel, but lately it hasn't been happening. I have been following the skeptical "Xbox How To," guide over at the wiki but it only provides at little help for the latest kernel. What the problem I keep running into is at boot the root partition gets failed to be opened? At boot the last lines it displays are:

*Checking root filesystem ...
Failed to open the device '/dev/hda3' : No such file or directory

*Filesystem couldn't be fixed

The linuxboot.cfg for cronwell goes as follows:
kernel boot/bzImage
append root=/dev/hda3 splash=silent kbd-reset video=xbox:640x480,nohwcursor gentoo=nodevfs acpi=hw

Now my fstab setup look fine to me:
/dev/hda1               /boot           ext2            noauto,noatime  1 2
/dev/hda3               /               reiserfs        notail            0 1
/dev/hda2               none            swap            sw              0 0

/dev/cdroms/cdrom0      /mnt/cdrom      auto            noauto,ro       0 0
#/dev/fd0               /mnt/floppy     auto            noauto          0 0

# NOTE: The next line is critical for boot!
proc                    /proc           proc            defaults        0 0

shm                     /dev/shm        tmpfs           nodev,nosuid,noexec    0 0

And to prove the above with fdisk -l /dev/hda:
 Device Boot      Start         End      Blocks   Id  System
/dev/hda1   *           1          61      489951   83  Linux
/dev/hda2              62         183      979965   82  Linux swap / Solaris
/dev/hda3             184        9180    72268402+  83  Linux

I have fiddled around the the opt settings for the root partition by changing to defaults. The wiki guide says to "Include VM fs, /proc fs, /dev fs, /dev fs auto mount at boot", but the last 2 have been removed from the 2.6 kernel since .13 and aren't used with it any more, then I had installed the 2.6 version of devfs, udev and fiddled with it and nothing came to help the problem. So I have tried the good ole' method of search, read, and try, but that hasn't been turning up so good and have decided to go for the extra step in hope that somebody has run into this before or has a workaround that can be mentioned.

EDIT: A bump in progress I have tried switching to a diffrent fs type (ext3), but hasn't helped at all. Has anybody been able to setup this kernel verison?
Back to top
View user's profile Send private message
Tux's lil' helper
Tux's lil' helper

Joined: 12 Mar 2006
Posts: 107
Location: Newcastle, NSW, Australia

PostPosted: Mon Feb 19, 2007 1:05 am    Post subject: Reply with quote

I got a 2.6.16 kernel working. It is not a version, which should be the latest XBOX kernel in portage. Secondly, it was not patched by portage. I manually patched it using the xbox-2.6.16 patch file, copied over the kernel.config file to .config and ran make menuconfig.

I made the most minimal changes I could. I added all the USB stuff I would need to use a keyboard with the kernel, and added JFS support, since this is my filesystem of choice. I also needed device mapper support. I did get a successful boot from the hdd. I used an initramfs file, since I am using device mapping and LVM2 stuff.

I would assume that your kernel has the particular filesystems compiled in, not as modules. I also assume that cromwell says that the drive is NO FATX - MBR. If it says NO MBR, then you have problems with the partition table layout. Of course, if Gentoo can access it just fine, then I don't see this being an issue.

You are safe to follow the Gentoo Handbook for x86 to install Gentoo onto the XBOX. The only real difference comes in selecting the right profile and installing an xbox kernel.

Please let us know where the boot process stops working. Is it a kernel panic, or is it when the root filesystem is mounted during the init process.
Need assistance with any of the following? Just PM me and I will see what I can do

LDAP, Kerberos , SSH, Samba, PPP, DHCP, NTP, autofs, CUPS
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Gentoo on Alternative Architectures All times are GMT
Page 1 of 1

Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum