Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[beryl / emerald] pas de décoration ! [résolu (pour moi...)]
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index French
View previous topic :: View next topic  
Author Message
dkmatt
n00b
n00b


Joined: 13 Aug 2004
Posts: 49

PostPosted: Tue Dec 05, 2006 4:27 pm    Post subject: [beryl / emerald] pas de décoration ! [résolu (pour moi... Reply with quote

bonjour,
je suis actuellement sous xfce4 et je souhaitais tester beryl (avec ma carte nvidia et les drivers 1.0.9629). J'ai donc suivi correctement le tuto du wiki fr de gentoo sur beryl. Désormais j'ai donc beryl qui ce lance au démarrage de mes sessions xfce4 (je vois l'icone dans le systray) mais impossible d'avoir les décorations des fenêtres.
Je pourtant chercher un bon moment sur google mais impossible de savoir le pourquoi du comment !

Code:
# eselect opengl list
Available OpenGL implementations:
  [1]   nvidia *
  [2]   xorg-x11


mon xorg.conf
Code:
...
Section "Device"
        Identifier "GeForce4"
        Driver     "nvidia"
        VendorName "nVidia Corporation"
        BoardName  "NV28 [GeForce4 Ti 4200 AGP 8x]"
        BusID      "PCI:1:0:0"
        Option     "NoLogo" "true"
        Option     "NvAGP" "3"
        Option     "RenderAccel" "true"
        Option     "SWCursor" "0"
        Option     "HWCursor" "1"
        Option     "CursorShadow" "true"
        Option     "CursorShadowAlpha" "64"
        Option     "CursorShadowXOffset" "4"
        Option     "CursorShadowYOffset" "2"
        Option     "Overlay" "true"
        Option     "AllowGLXWithComposite" "true"
EndSection

Section "Screen"
        Identifier "Screen0"
        Device     "GeForce4"
        Monitor    "Belinea"
        Option      "AddARGBGLXVisuals" "true"
        DefaultDepth  24
        SubSection "Display"
                Viewport     0 1
                Depth     24
                Modes     "1024x768"
        EndSubSection
EndSection

Section "Extensions"
    Option "Composite" "Enable"
    Option "RENDER" "Enable"
EndSection

...


berylrc (fichier lancé au démarrage d'xfce4)
Code:
dbus-launch --auto-syntax --exit-with-session beryl-manager &
emerald --replace &
numlockx &
Je précise que dbus est bien dans mes USE.

lorsque je lance beryl-manager dans un terminal sous xfce4 :
Code:
** (beryl-manager:10500): WARNING **: Impossible de trouver un Selection Owner, peut-être n'y-a-t'il aucun gestionnaire de fenêtres ?
Sinon, 'tuez' manuellement le gestionnaire de fenêtres, et signalez le problème aux développeurs,le gestionnaire ne se conforme pas aux standards.
Recherche du gestionnaire de fenêtre défini dans xlsclients.
XGL Absent, checking for NVIDIA
Nvidia Present
Relaunching beryl with __GL_YIELD="NOTHING"
XGL Absent, checking for NVIDIA
Nvidia Present

** (beryl-manager:10500): WARNING **: Beryl a reçu un signal de terminaison 11


si je lance
Code:
emerald --replace
à la main, il ne m'affiche rien sur le terminal. De même si je fais un
Code:
set|grep XLIB_SKIP_ARGB_VISUALS


voila... si vous voulez d'autres info n'hésitez pas et merci d'avance !!
_________________
Powered by Gentoo 2.6.xx


Last edited by dkmatt on Wed Dec 06, 2006 3:36 pm; edited 1 time in total
Back to top
View user's profile Send private message
DuF
Advocate
Advocate


Joined: 09 Dec 2002
Posts: 2686
Location: Paris

PostPosted: Tue Dec 05, 2006 5:50 pm    Post subject: Reply with quote

Moi, pour le lancer sous XFCE pour le moment, une fois sous XFCE je lance un xterm et dedans je fais :
Code:
beryl &
emerald &

Car avec beryl-manager en ce moment ça fonctionne mal.... alors que de cette manière c'est niquel et super stable (beaucoup plus que mon firefox d'ailleurs :-D ).
Back to top
View user's profile Send private message
dkmatt
n00b
n00b


Joined: 13 Aug 2004
Posts: 49

PostPosted: Tue Dec 05, 2006 6:20 pm    Post subject: Reply with quote

j'ai testé mais sans succès !
quand je fais
Code:
$ emerald
emerald: Screen 0 on display ":0.0" already has a decoration manager; try using the --replace option to replace the current decoration manager.

je fais donc un
Code:
emerald --replace
mais ça n'a aucun effets.
_________________
Powered by Gentoo 2.6.xx
Back to top
View user's profile Send private message
letchideslandes
Apprentice
Apprentice


Joined: 21 Nov 2004
Posts: 197
Location: Landes France

PostPosted: Wed Dec 06, 2006 7:09 am    Post subject: Reply with quote

T'utilises quelle version du pilote ? Car il y a un problème avec les chipset NV2x ( ton cas ).
Une solution : http://letchideslandes.dyndns.org
Back to top
View user's profile Send private message
Il turisto
l33t
l33t


Joined: 12 May 2004
Posts: 968
Location: Battincourt - Belgique

PostPosted: Wed Dec 06, 2006 8:45 am    Post subject: Reply with quote

J'ai le même problème avec une ati radeon mobility et sur un autre pc avec une geforce2-mx.

Supprimer les répertoires .emerald et .beryl* n'y change rien et même si je désinstalle beryl et émerald je ne récupère pas mes décorations de fenêtres.
Back to top
View user's profile Send private message
Ascodas
Apprentice
Apprentice


Joined: 18 Nov 2004
Posts: 259

PostPosted: Wed Dec 06, 2006 12:24 pm    Post subject: Reply with quote

Même chose ici aussi et depuis peu avec une NV40 [GeForce 6800 Ultra/GeForce 6800 GT].

J'ai bien essayer de réinstaller béryl et ses dépendances mais sans succès ...
Back to top
View user's profile Send private message
dkmatt
n00b
n00b


Joined: 13 Aug 2004
Posts: 49

PostPosted: Wed Dec 06, 2006 3:38 pm    Post subject: Reply with quote

letchideslandes wrote:
T'utilises quelle version du pilote ? Car il y a un problème avec les chipset NV2x ( ton cas ).
Une solution : http://letchideslandes.dyndns.org

Merci, je suis passé a la versions 1.0.9631 et maintenant ça fonctionne au poil !
:D
_________________
Powered by Gentoo 2.6.xx
Back to top
View user's profile Send private message
Il turisto
l33t
l33t


Joined: 12 May 2004
Posts: 968
Location: Battincourt - Belgique

PostPosted: Tue Dec 12, 2006 12:57 pm    Post subject: Reply with quote

Je pensais que la version 0.1.3 de beryl aurait pu résoudre le problème mais il n'en est rien.

Ca deviens vraiment lourd comme problème car me voici sous gnome 2.16 avec le nouveau beryl et tjs pas de décorations de fenêtres.
Back to top
View user's profile Send private message
Ascodas
Apprentice
Apprentice


Joined: 18 Nov 2004
Posts: 259

PostPosted: Tue Dec 12, 2006 2:16 pm    Post subject: Reply with quote

Il turisto wrote:
Je pensais que la version 0.1.3 de beryl aurait pu résoudre le problème mais il n'en est rien.

Ca deviens vraiment lourd comme problème car me voici sous gnome 2.16 avec le nouveau beryl et tjs pas de décorations de fenêtres.



En ce qui me concerne la suppression des .beryl/* et .emerald/* de mon /home a été salvatrice, as tu essayé ?

Par contre le gestionnaire de beryl ne se lance pas, alors que celui d'emerald oui ...
Back to top
View user's profile Send private message
Il turisto
l33t
l33t


Joined: 12 May 2004
Posts: 968
Location: Battincourt - Belgique

PostPosted: Tue Dec 12, 2006 2:27 pm    Post subject: Reply with quote

Merci de ta réponse mais si tu regardes un peu plus haut je dis que je l'ai déjà fais.

Mais peut être veux tu dire que cela n'avais rien changé pour toi en version 0.1.2 et qu'en 0.1.3 cela à chnagé quelquechose?

Je vais essayer de le refaire ce soir et voir ce que cela donne.
Back to top
View user's profile Send private message
Ascodas
Apprentice
Apprentice


Joined: 18 Nov 2004
Posts: 259

PostPosted: Tue Dec 12, 2006 3:32 pm    Post subject: Reply with quote

Il turisto wrote:
Merci de ta réponse mais si tu regardes un peu plus haut je dis que je l'ai déjà fais.

Mais peut être veux tu dire que cela n'avais rien changé pour toi en version 0.1.2 et qu'en 0.1.3 cela à chnagé quelquechose?

Je vais essayer de le refaire ce soir et voir ce que cela donne.


ah désolé pour la confusion, je n'ai pas tout lu en effet, j'ai fait cette manip sous la 0.1.3 donc je ne peux pas te dire si elle aurait eu le même effet sous 0.1.2 .

Si tu lances sous kde par :

Code:
beryl &
emerald &


ou bien simplement :

Code:
beryl-manager &


ou encore via le 99kde-env et env-update puis kdm/starx ?

cela change t'il quelquechose pour toi ?
Back to top
View user's profile Send private message
Il turisto
l33t
l33t


Joined: 12 May 2004
Posts: 968
Location: Battincourt - Belgique

PostPosted: Tue Dec 12, 2006 4:19 pm    Post subject: Reply with quote

Oui cela change beaucoup car je suis sous gnome :-).


Sinon sans plaisanterie cele ne change rien. Ce ne fonctionne tout de même pas.
Tout à l'heure j'essaye le rm mais ca m'ennuie de devoir tout reconfigurer (j'espere que l'export de la config fonctionne).


Edit : le save de profil fonctionne mais le rm ne change rien. J'ai fais :

Code:

killall emerald
killall beryl
rm ~/.beryl* ~/.emerald
beryl &
emerald &


le tout sans relancer mon gnome mais ca ne marche pas :-(.
Back to top
View user's profile Send private message
Ascodas
Apprentice
Apprentice


Joined: 18 Nov 2004
Posts: 259

PostPosted: Tue Dec 12, 2006 7:42 pm    Post subject: Reply with quote

Il turisto wrote:
Oui cela change beaucoup car je suis sous gnome :-).


Sinon sans plaisanterie cele ne change rien. Ce ne fonctionne tout de même pas.
Tout à l'heure j'essaye le rm mais ca m'ennuie de devoir tout reconfigurer (j'espere que l'export de la config fonctionne).


Edit : le save de profil fonctionne mais le rm ne change rien. J'ai fais :

Code:

killall emerald
killall beryl
rm ~/.beryl* ~/.emerald
beryl &
emerald &


le tout sans relancer mon gnome mais ca ne marche pas :-(.



Décidément ... je suis à côté, tu as au moins le splash Beryl ? tu passes par une sur-couche opengl ?
Back to top
View user's profile Send private message
Il turisto
l33t
l33t


Joined: 12 May 2004
Posts: 968
Location: Battincourt - Belgique

PostPosted: Wed Dec 13, 2006 7:59 am    Post subject: Reply with quote

Oui oui beryl fonctionne parfaitement. Le cube tourne, la transparence fonctionne.

J'utilise le driver ati free (celui de xorg). Le propriétaire ne fonctionne pas avec ma carte.

Opengl fonctionne correctement.


Enfin bref tout va bien sauf les décorations.
Back to top
View user's profile Send private message
Ascodas
Apprentice
Apprentice


Joined: 18 Nov 2004
Posts: 259

PostPosted: Wed Dec 13, 2006 12:39 pm    Post subject: Reply with quote

As tu essayé heliodor ? mais je crois que c'est du svn
Back to top
View user's profile Send private message
Il turisto
l33t
l33t


Joined: 12 May 2004
Posts: 968
Location: Battincourt - Belgique

PostPosted: Wed Dec 13, 2006 2:52 pm    Post subject: Reply with quote

Euh non. Quelle différence entre heliodor et emerald?
Back to top
View user's profile Send private message
Temet
Advocate
Advocate


Joined: 14 Mar 2006
Posts: 2586
Location: 92

PostPosted: Wed Dec 13, 2006 2:57 pm    Post subject: Reply with quote

Heliodor > décos GNOME
Emerald > décos que tu connais
Aquamarine > décos KDE
Back to top
View user's profile Send private message
Il turisto
l33t
l33t


Joined: 12 May 2004
Posts: 968
Location: Battincourt - Belgique

PostPosted: Wed Dec 13, 2006 3:13 pm    Post subject: Reply with quote

Merci de ta réponse Temet.

je viens d'installer heliodor mais je ne sais pas trop comment m'en servir. Il ne me semble pas avoir de nouvelle entrée de config dans le menu ni rien et la commnde heliodor ne prend pas vraiment bcp d'arguments.
Back to top
View user's profile Send private message
Temet
Advocate
Advocate


Joined: 14 Mar 2006
Posts: 2586
Location: 92

PostPosted: Wed Dec 13, 2006 3:18 pm    Post subject: Reply with quote

Au pif : heliodor --replace
Back to top
View user's profile Send private message
Il turisto
l33t
l33t


Joined: 12 May 2004
Posts: 968
Location: Battincourt - Belgique

PostPosted: Wed Dec 13, 2006 3:23 pm    Post subject: Reply with quote

certe j'ai fais cela et heliodor tourne mais :

- tjs pas de décorations
- ou puis je configurer quelle décoration utiliser?
Back to top
View user's profile Send private message
titoucha
Advocate
Advocate


Joined: 21 Jul 2005
Posts: 2374
Location: Genève

PostPosted: Wed Dec 13, 2006 3:25 pm    Post subject: Reply with quote

Regarde sur le wiki http://gentoo-wiki.com/Beryl#Heliodor
_________________
Assurez-vous que le titre de votre message soit conforme aux conventions de ce forum (paragraphe 3/3 : Comment poster sur le forum ??)
Back to top
View user's profile Send private message
Il turisto
l33t
l33t


Joined: 12 May 2004
Posts: 968
Location: Battincourt - Belgique

PostPosted: Wed Dec 13, 2006 3:33 pm    Post subject: Reply with quote

Oui j'ai vu cet article mais ca ne change rien.

Je n'ai toujours pas de décorations et lorsque je change mon theme gnome cela ne ramène pas les bordures :-(.
Back to top
View user's profile Send private message
Ascodas
Apprentice
Apprentice


Joined: 18 Nov 2004
Posts: 259

PostPosted: Wed Dec 13, 2006 3:36 pm    Post subject: Reply with quote

Tu n'as aucun autres WM pour tester si le pb vient réellement de béryl ou alors de gnome ?
xfce c'est pas trop lourd ...
Back to top
View user's profile Send private message
Il turisto
l33t
l33t


Joined: 12 May 2004
Posts: 968
Location: Battincourt - Belgique

PostPosted: Wed Dec 13, 2006 3:59 pm    Post subject: Reply with quote

Non je n'en ai pas d'autres.

En effet je pourrais installer un xfce mais je n'utilise pas de gdm non plus.

J'hésite à installer xfce. Mon portable n'est pas très puissant et 28 megas de sources ca me parait long à compiler.
Si c'étais possible je préfèrerais une autre solution.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index French All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum