Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[SUBVERSION] Échec de l'exécution avec Apache
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index French
View previous topic :: View next topic  
Author Message
ade05fr
Apprentice
Apprentice


Joined: 18 Sep 2006
Posts: 281

PostPosted: Tue Dec 05, 2006 10:26 am    Post subject: [SUBVERSION] Échec de l'exécution avec Apache Reply with quote

hello

moi quand je configure subversion avec apache je n'arrive pas à faire fonctionner le tout.
je tente d'accéder à ma page contenant le repository en faisant http://localhost/repository

j'ai regardé dans mon error-log d'apache et j'ai des lignes du genre

...driver for [DBDriver unset] not available..
-- et surtout à la fin de la log j'ai un segmentation fault
[notice] child pid 8923 exit signal segmentation fault (11)
...

voici ce que j'ai dans httpd.conf :
...
LoadModule dav_module modules/mod_dav.so
LoadModule dav_svn_module modules/mod_dav_svn.so
LoadModule authz_svn_module modules/mod_authz_svn.so
...
<Directory "var/svn/repository">
Allow from all
</Directory>

voici ce que j'ai dans le ficheir /etc/conf.d/apache2:
...
APACHE2_OPTS="-D DEFAULT_VHOST -D INFO -D LANGUAGE -D SSL -D SSL_DEFAULT_VHOST -D SVN -D SVN_AUTHZ -D DAV -D DAV_FS"

voici ce que j'ai dans /etc/apache2/conf/modules.d/47_mod_dav_svn.conf
<IfDefine SVN>
<IfModule !mod_dav_svn.c>
LoadModule dav_svn_module modules/mod_dav_svn.so
</IfModule>
<Location /repository>
DAV svn
SVNPath /var/svn/repository
AuthType Basic
AuthName "Subversion repository"
AuthUserFile /var/svn/repository/conf/passhttp
Require valid-user
</Location>
<IfDefine SVN_AUTHZ>
<IfModule !mod_dav_svn.c>
LoadModule authz_svn_module modules/mod_authz_svn.so
</IfModule>
</IfDefine>
</IfDefine>

j'ai aussi fais un "chown -R apache:apache /var/svn/repository"

est ce que quelqu'un peut m'aider ? je ne comprends rien !!

merci d'avance


Last edited by ade05fr on Tue Dec 05, 2006 10:38 am; edited 1 time in total
Back to top
View user's profile Send private message
Magic Banana
Veteran
Veteran


Joined: 13 Dec 2005
Posts: 1907
Location: Belo Horizonte, Minas Gerais, Brasil

PostPosted: Tue Dec 05, 2006 10:33 am    Post subject: Reply with quote

Pourrais-tu s'il te plaït éditer ton premier post afin de mettre ton titre en conformité avec nos conventions. Par exemple tu pourrais le remplacer par : "[SUBVERSION] Échec de l'exécution avec Apache"
Back to top
View user's profile Send private message
_Seth_
Guru
Guru


Joined: 15 Sep 2004
Posts: 539
Location: encore paumé dans un labo ;)

PostPosted: Tue Dec 05, 2006 12:18 pm    Post subject: Reply with quote

Je fais un peu de svn mais je n'ai pas encore utilisé les fonctionnalités d'accès au dépot par le web. Du coup, je peux pas trop te dire pour la config d'apache.

Y'a juste quelque chose qui m'interpelle : dans l'error-log d'apache, tu as un
apache error log wrote:
[notice] child pid 8923 exit signal segmentation fault (11)

C'est peut être une hypothèse débile, mais est ce que tu n'aurais un problème d'execution d'un des modules svn (voir de svn) ? Par exemple si tu as compilé svn avec des cflags aggressifs ou que tu as changé de compilo/libs/que-sais-je récemment. J'espère que cela pourra t'aider.
_________________
no tears to cry, no feelings left
the species has amused itself to death
amused itself to death
Back to top
View user's profile Send private message
FLYLM
n00b
n00b


Joined: 25 Mar 2004
Posts: 62
Location: France

PostPosted: Tue Dec 05, 2006 1:27 pm    Post subject: Reply with quote

Au passage, et c'est sans rapport avec ton erreur, mais comme tu utilises Apache2, regarde si "dev-libs/apr" est bien compilée avec l'option "urandom". J'ai galéré plusieurs heures pour comprendre pourquoi mon install marchait, marchait pas, marchait, marchait pas....
Back to top
View user's profile Send private message
ade05fr
Apprentice
Apprentice


Joined: 18 Sep 2006
Posts: 281

PostPosted: Wed Dec 06, 2006 10:12 am    Post subject: Reply with quote

Hello

pour cela a qui cela peut intéresser j'ai solutionné mon problème de manière radicale.

j'ai fais

- emerge -C apr apr-util apache subversion
- USE="apache2" emerge -av subversion
- j'ai modifié mon fichier httpd.conf :
LoadModule dav_svn_module modules/mod_dav_svn.so (en dessous de la ligne avec mod_dav_fs.so)

j'ai modifié mon serverName :
ServerName jehamou:80
J'ai ajouté le directory contenant le repository afin qu'apache puisse le "voir"
<Directory "/var/svn/repository">
Allow from All
</Directory>

- j'ai modifié le fichier
/etc/apache2/modules.d/47_mod_dav_svn.conf
<Location /svn>
DAV svn
SVNParentPath /var/svn
SVNListParentPath on
</Location>

- enfin j'ai modifié le fichier /etc/conf.d/apache2
(simplement ajouté dans la ligne APACHE2_OPTS="-D DAV -D SVN............."

voili voilou

maintenant je vais essayer en mode sécurisé avec des users mais bon au moins je sais que cette config fonctionne.

bonne journée à tous
Back to top
View user's profile Send private message
Magic Banana
Veteran
Veteran


Joined: 13 Dec 2005
Posts: 1907
Location: Belo Horizonte, Minas Gerais, Brasil

PostPosted: Wed Dec 06, 2006 10:17 am    Post subject: Reply with quote

Pourrais-tu s'il te plaît ajouter " (résolu)" à la fin de ton titre. Ceci aide à faire une première recherche sur un problème.
Back to top
View user's profile Send private message
_Seth_
Guru
Guru


Joined: 15 Sep 2004
Posts: 539
Location: encore paumé dans un labo ;)

PostPosted: Wed Dec 06, 2006 11:49 am    Post subject: Reply with quote

Merci beaucoup d'avoir posté ta solution, c'est vraiment sympa. C'est très pénible de trouver un thread sans conclusion, ou avec juste un petit message qui dit que c'est résolu mais sans explications. Encore une fois merci beaucoup !
_________________
no tears to cry, no feelings left
the species has amused itself to death
amused itself to death
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index French All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum