Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
gmplayer crashes when fullscreen
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Multimedia
View previous topic :: View next topic  
Author Message
bori
n00b
n00b


Joined: 14 Apr 2006
Posts: 10

PostPosted: Mon Nov 27, 2006 6:34 pm    Post subject: gmplayer crashes when fullscreen Reply with quote

Greetings!

I have a little problem. My gmplayer (mplayer 1.0_rc1) crashes when I fullscreen the video. It is doing only in xv video output mode. And, what is the strangest thing, it does ONLY gmplayer, not mplayer! I don't know, when it had started, but I am updating my world nearly every day, so I think one of the updates does it.

Code:
MPlayer 1.0rc1-3.4.6 (C) 2000-2006 MPlayer Team
CPU: Intel(R) Pentium(R) D  CPU 2.66GHz (Family: 15, Model: 4, Stepping: 7)
MMX2 supported but disabled
CPUflags:  MMX: 1 MMX2: 0 3DNow: 0 3DNow2: 0 SSE: 1 SSE2: 1
PÅeloženo pro CPU x86 s rozšíÅeními: MMX SSE SSE2
Xlib:  extension "XFree86-VidModeExtension" missing on display ":0.0".
Xlib:  extension "XFree86-VidModeExtension" missing on display ":0.0".

PÅehrávám /home/bori/audio/Rammstein/Rammstein - Du Hast.mpg
.stran obrazu filmu je 1.34:1 - Å¡káluji na správný pomÄ
VO: [x11] 352x240 => 352x262 Planar YV12 70 fps  1150.0 kbps (143.8 kbyte/s)
SwScaler: using unscaled yuv420p -> rgb32 special converter===============
[mpeg1video @ 0xb2b150]ac-tex damaged at 17 9 15 ??% ??% ??,?% 0 0
[mpeg1video @ 0xb2b150]Warning MVs not availableavcodec codec family
[mpeg1video @ 0xb2b150]concealing 164 DC, 164 AC, 164 MV errors
A:  10.6 V:  10.6 A-V:  0.025 ct:  0.122 293/293  3% 15%  0.7% 0 0
===== POZASTAVENO ========================================================
Otevírám audio dekodér: [mp3lib] MPEG layer-2, layer-3
PÅehrávám /home/bori/audio/Rammstein/Rammstein - Du Hast.mpg>176400)
.stran obrazu filmu je 1.34:1 - Å¡káluji na správný pomÄ, layer-3)
VO: [xv] 352x240 => 352x262 Planar YV12  [fs]ps  1150.0 kbps (143.8 kbyte/s)
[ws] Error in display.  0.716 ct:  0.126   1/  1 ??% ??% ??,?% 0 0
[ws]  Error code: 2 ( BadValue (integer parameter out of range for operation) )
[ws]  Request code: 137©r: [ffmpeg] FFmpeg's libavcodec codec family
[ws]  Minor code: 19 [ffmpeg1] vfm: ffmpeg (FFmpeg MPEG-1)
[ws]  Modules: flip_page


I am sorry, but my mplayer is in czech...
Back to top
View user's profile Send private message
Gentoo Bob
Tux's lil' helper
Tux's lil' helper


Joined: 12 Feb 2006
Posts: 129
Location: Sitting behind a PC in Indiana

PostPosted: Tue Nov 28, 2006 5:00 pm    Post subject: Reply with quote

Try switching to "vo=x11". Also, try checking your USE flags. Make sure you have "X and gtk (if your using gnome, or qt3/qt4 if your using KDE). I would uninstall it and reinstall it after you set your new use flags. Hope that helps a bit.
_________________
AMD 64 X2 4400+ on ECS nForce4
2GB DDR, 250GB SATA, GeForce 5500FX 256MB DDR2 PCI-E
---and----
Dell Inspiron E1505 Laptop
Intel Centrino Duo, 2GB RAM, 80GB SATA HDD, Intel3490 ABG Wireless,CDRW
Back to top
View user's profile Send private message
bori
n00b
n00b


Joined: 14 Apr 2006
Posts: 10

PostPosted: Tue Nov 28, 2006 5:38 pm    Post subject: use flags an x11 Reply with quote

Well, x11 is working, but it's not good choice since video cannot be "really" fullscreened...
I'm using KDE, USE flag X is allowed and neither qt3 nor qt4 flags aren't there. But globally they are allowed.
Code:

[D] media-video/mplayer
     Available versions:  1.0_pre8 (~)1.0_pre8-r1 [M](~)1.0_rc1
     Installed versions:  1.0_rc1(07:22:59 11/22/06)(-3dfx -3dnow -3dnowext X -aac aalib alsa -altivec -amr arts -bidi -bindist -bl -cdparanoia -cpudetection -custom-cflags -debug -dga -directfb -doc -dts -dv -dvb dvd -dvdread -enca encode -esd -fbcon -ggi gif gtk iconv ipv6 -jack -joystick jpeg -libcaca -linguas_bg linguas_cs -linguas_da -linguas_de -linguas_el -linguas_en -linguas_es -linguas_fr -linguas_hu -linguas_ja -linguas_ko -linguas_mk -linguas_nl -linguas_no -linguas_pl -linguas_pt_BR -linguas_ro -linguas_ru -linguas_sk -linguas_tr -linguas_uk -linguas_zh_CN -linguas_zh_TW -lirc -live -livecd -lzo -mad -matrox mmx -mmxext -musepack -nas -openal opengl -oss png -real -rtc -samba sdl -speex sse sse2 -svga -tga -theora truetype unicode -v4l -v4l2 vorbis -win32codecs -x264 -xanim -xinerama xv -xvid -xvmc)
Back to top
View user's profile Send private message
yngwin
Retired Dev
Retired Dev


Joined: 19 Dec 2002
Posts: 4572
Location: Suzhou, China

PostPosted: Tue Nov 28, 2006 9:08 pm    Post subject: Reply with quote

Try with something else then, like -vo=gl2, see mplayer -vo help.
_________________
"Those who deny freedom to others deserve it not for themselves." - Abraham Lincoln
Free Culture | Defective by Design | EFF
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Multimedia All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum