Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
emerge error
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Duplicate Threads
View previous topic :: View next topic  
Author Message
swp6499
Tux's lil' helper
Tux's lil' helper


Joined: 01 Oct 2006
Posts: 93

PostPosted: Sat Nov 25, 2006 12:12 am    Post subject: emerge error Reply with quote

i was trying to emerge gnome 2.16 and i got this

!!! ERROR: x11-libs/gtk+-2.10.6 failed.
Call stack:
ebuild.sh, line 1562: Called dyn_setup
ebuild.sh, line 665: Called pkg_setup
gtk+-2.10.6.ebuild, line 53: Called die

!!! cairo needs the X and pdf flag set
!!! If you need support, post the topmost build error, and the call stack if relevant.

can someone tell me how to correct this please? thanks
Back to top
View user's profile Send private message
Arfrever
Bodhisattva
Bodhisattva


Joined: 29 Apr 2006
Posts: 2462
Location: Polska / Lenkija

PostPosted: Sat Nov 25, 2006 12:19 am    Post subject: Re: emerge error Reply with quote

Give the output of:
Code:
emerge -ptv cairo
emerge --info


Sveikinu
Arfrever
Back to top
View user's profile Send private message
swp6499
Tux's lil' helper
Tux's lil' helper


Joined: 01 Oct 2006
Posts: 93

PostPosted: Sat Nov 25, 2006 12:21 am    Post subject: Reply with quote

localhost stephen # emerge -ptv cairo

These are the packages that would be merged, in reverse order:

Calculating dependencies... done!
[ebuild R ] x11-libs/cairo-1.2.4 USE="X png -directfb -doc -glitz -pdf -svg" 0 kB

Total size of downloads: 0 kB
localhost stephen # emerge --info
Portage 2.1.1-r2 (default-linux/x86/2006.1/desktop, gcc-4.1.1, glibc-2.4-r3, 2.6.17-gentoo-r5 i686)
=================================================================
System uname: 2.6.17-gentoo-r5 i686 Intel(R) Pentium(R) M processor 1400MHz
Gentoo Base System version 1.12.1
Last Sync: Fri, 24 Nov 2006 22:30:01 +0000
app-admin/eselect-compiler: [Not Present]
dev-java/java-config: [Not Present]
dev-lang/python: 2.4.3-r1
dev-python/pycrypto: 2.0.1-r5
dev-util/ccache: [Not Present]
dev-util/confcache: [Not Present]
sys-apps/sandbox: 1.2.17
sys-devel/autoconf: 2.13, 2.59-r7
sys-devel/automake: 1.4_p6, 1.5, 1.6.3, 1.7.9-r1, 1.8.5-r3, 1.9.6-r2
sys-devel/binutils: 2.16.1-r3
sys-devel/gcc-config: 1.3.13-r3
sys-devel/libtool: 1.5.22
virtual/os-headers: 2.6.11-r2
ACCEPT_KEYWORDS="x86 ~x86"
AUTOCLEAN="yes"
CBUILD="i686-pc-linux-gnu"
CFLAGS="-O2 -march=pentium-m -pipe"
CHOST="i686-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/kde/3.5/env /usr/kde/3.5/share/config /usr/kde/3.5/shutdown /usr/share/X11/xkb /usr/share/config"
CONFIG_PROTECT_MASK="/etc/env.d /etc/gconf /etc/terminfo"
CXXFLAGS="-O2 -march=pentium-m -pipe"
DISTDIR="/usr/portage/distfiles"
FEATURES="autoconfig distlocks metadata-transfer sandbox sfperms strict"
GENTOO_MIRRORS="http://distfiles.gentoo.org http://distro.ibiblio.org/pub/linux/distributions/gentoo"
PKGDIR="/usr/portage/packages"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --delete-after --stats --timeout=180 --exclude='/distfiles' --exclude='/local' --exclude='/packages'"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
SYNC="rsync://rsync.gentoo.org/gentoo-portage"
USE="x86 X alsa arts berkdb bitmap-fonts cairo cdr cli cracklib crypt cups dbus dlloader dri dvd dvdr eds elibc_glibc emboss encode esd fam firefox fortran gdbm gif gnome gpm gstreamer gtk hal iconv input_devices_evdev input_devices_keyboard input_devices_mouse ipv6 isdnlog jpeg kde kernel_linux ldap libg++ mad mikmod mp3 mpeg ncurses nls nptl nptlonly ogg opengl oss pam pcre perl png ppds pppd python qt3 qt4 quicktime readline reflection sdl session spell spl ssl tcpd truetype truetype-fonts type1-fonts udev unicode userland_GNU video_cards_apm video_cards_ark video_cards_ati video_cards_chips video_cards_cirrus video_cards_cyrix video_cards_dummy video_cards_fbdev video_cards_glint video_cards_i128 video_cards_i740 video_cards_i810 video_cards_imstt video_cards_mga video_cards_neomagic video_cards_nsc video_cards_nv video_cards_rendition video_cards_s3 video_cards_s3virge video_cards_savage video_cards_siliconmotion video_cards_sis video_cards_sisusb video_cards_tdfx video_cards_tga video_cards_trident video_cards_tseng video_cards_v4l video_cards_vesa video_cards_vga video_cards_via video_cards_vmware video_cards_voodoo vorbis win32codecs xml xorg xv zlib"
Unset: CTARGET, EMERGE_DEFAULT_OPTS, INSTALL_MASK, LANG, LC_ALL, LDFLAGS, LINGUAS, MAKEOPTS, PORTAGE_RSYNC_EXTRA_OPTS, PORTDIR_OVERLAY
Back to top
View user's profile Send private message
swp6499
Tux's lil' helper
Tux's lil' helper


Joined: 01 Oct 2006
Posts: 93

PostPosted: Sat Nov 25, 2006 12:40 am    Post subject: Reply with quote

pdf was missing from my default USE flags i set it to be default is that ok?? it seems to be working ok now..or is there a better way?
Back to top
View user's profile Send private message
swp6499
Tux's lil' helper
Tux's lil' helper


Joined: 01 Oct 2006
Posts: 93

PostPosted: Sat Nov 25, 2006 12:43 am    Post subject: Reply with quote

ok i was wrong it still doesnt work i jumped too soon...sorry...i would still appreciate your help
Back to top
View user's profile Send private message
sg313
n00b
n00b


Joined: 25 Dec 2005
Posts: 34

PostPosted: Sat Nov 25, 2006 12:54 am    Post subject: Stupid Question ;) Reply with quote

Did you recompile cairo after setting the usefag?
If so, what is the error gtk+ bails out with now?
Back to top
View user's profile Send private message
swp6499
Tux's lil' helper
Tux's lil' helper


Joined: 01 Oct 2006
Posts: 93

PostPosted: Sat Nov 25, 2006 1:19 am    Post subject: Reply with quote

i did re-emerge cairo with USE="X pdf" emerge cairo and everything seems ok now..thanks
Back to top
View user's profile Send private message
Arfrever
Bodhisattva
Bodhisattva


Joined: 29 Apr 2006
Posts: 2462
Location: Polska / Lenkija

PostPosted: Sat Nov 25, 2006 1:28 am    Post subject: Reply with quote

swp6499 wrote:
everything seems ok now

Check `emerge -uDNptv world`, if you think so. (It's a good idea to have consistent system.)

Sveikinu
Arfrever
Back to top
View user's profile Send private message
swp6499
Tux's lil' helper
Tux's lil' helper


Joined: 01 Oct 2006
Posts: 93

PostPosted: Sat Nov 25, 2006 12:21 pm    Post subject: Reply with quote

i was going to try that but now i seem to have another problem..maybe u can check it out..heres a link to another post i made...any help is greatly appreciated... https://forums.gentoo.org/viewtopic-t-519141.html thanks
Back to top
View user's profile Send private message
noup
l33t
l33t


Joined: 21 Mar 2003
Posts: 917

PostPosted: Sat Nov 25, 2006 12:41 pm    Post subject: Reply with quote

swp6499 wrote:
i did re-emerge cairo with USE="X pdf" emerge cairo and everything seems ok now..thanks

One thing, you shouldn't change your use flags that way. You should use /etc/portage/package.use, otherwise your useflags will be lost on the next emerge of cairo.
_________________
noup.
Back to top
View user's profile Send private message
swp6499
Tux's lil' helper
Tux's lil' helper


Joined: 01 Oct 2006
Posts: 93

PostPosted: Sat Nov 25, 2006 12:48 pm    Post subject: Reply with quote

is there a way to fix it now that ive done it that way??
Back to top
View user's profile Send private message
sg313
n00b
n00b


Joined: 25 Dec 2005
Posts: 34

PostPosted: Sat Nov 25, 2006 1:30 pm    Post subject: Reply with quote

Sure. Just add the line
Code:
x11-libs/cairo X png pdf

to /etc/portage/package.use
(if you haven't already got a x11-libs/cairo line there)
you can always check what useflags are currently set/will be set upon recompile for a package by
Code:
 equery u <package-name>

Note that the I column lists the state of the flags for the currently installed package,
while the U column shows what flags would be set if you'd reemerge the package.
Node also that you need to call equery with -a to obtain information on
packages that are not currently installed.
Code:
 equery u -a <package-name>
Back to top
View user's profile Send private message
swp6499
Tux's lil' helper
Tux's lil' helper


Joined: 01 Oct 2006
Posts: 93

PostPosted: Sat Nov 25, 2006 1:56 pm    Post subject: Reply with quote

thanks for all your help i appreciate it alot...is there a possibility you could take a look at the link i gave above to another post where i have a problem and see what you think about that...im having trouble with that one big time and i cant figure out how to fix it...thanks a bunch
Back to top
View user's profile Send private message
desultory
Administrator
Administrator


Joined: 04 Nov 2005
Posts: 7820

PostPosted: Mon May 21, 2007 7:22 am    Post subject: Reply with quote

Moved from Portage & Programming to Duplicate Threads, refer to topic "Please re-emerge [solved]".

As noted in the handbook USE flags specified via environment variables are not retained as persistent settings so, aside from when a given USE flag setting is itself transient in nature, use one of the persistent USE flag setting methods (/etc/make.conf, /etc/portage/package.use). Also, note that USE flags are case sensitive.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Duplicate Threads All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum