Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
sparc64 on ultra10, want to use a 2.6 kernel
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Gentoo on Sparc
View previous topic :: View next topic  
Author Message
sheriff-jms
Tux's lil' helper
Tux's lil' helper


Joined: 28 May 2004
Posts: 79
Location: Pittsburgh, PA, USA

PostPosted: Mon Nov 20, 2006 9:34 pm    Post subject: sparc64 on ultra10, want to use a 2.6 kernel Reply with quote

Ok, I know I'm missing something easy here :)

The livecd boots up using a 2.6 kernel, but when I emerge sparc-sources on the machine during the build process, the only thing available are 2.4 kernel source trees.
Do I need to emerge a different package to get the 2.6 source tree?

Thanks
jms
Back to top
View user's profile Send private message
NeddySeagoon
Administrator
Administrator


Joined: 05 Jul 2003
Posts: 31342
Location: 56N 3W

PostPosted: Mon Nov 20, 2006 9:42 pm    Post subject: Reply with quote

sheriff-jms,

Code:
emerge sys-kernel/gentoo-sources
works on my Ultra 10
_________________
Regards,

NeddySeagoon

Computer users fall into two groups:-
those that do backups
those that have never had a hard drive fail.
Back to top
View user's profile Send private message
sheriff-jms
Tux's lil' helper
Tux's lil' helper


Joined: 28 May 2004
Posts: 79
Location: Pittsburgh, PA, USA

PostPosted: Mon Nov 20, 2006 9:44 pm    Post subject: Reply with quote

When I look on www.gentoo-portage.com and in my local portage tree, the newest kernel version listed is 2.4.33. There's nothing in 2.6 at all.
Back to top
View user's profile Send private message
NeddySeagoon
Administrator
Administrator


Joined: 05 Jul 2003
Posts: 31342
Location: 56N 3W

PostPosted: Mon Nov 20, 2006 9:50 pm    Post subject: Reply with quote

sheriff-jms,

What does your /etc/make.profile symlink point to ?
Some profiles force a 2.4 kernel

I get
Code:
/etc/make.profile -> ../usr/portage/profiles/default-linux/sparc/sparc64/2006.1/

changing your profile changes lots of use flags. you will need to chck your USE settings and
Code:
 emerge world -uDNav

_________________
Regards,

NeddySeagoon

Computer users fall into two groups:-
those that do backups
those that have never had a hard drive fail.
Back to top
View user's profile Send private message
sheriff-jms
Tux's lil' helper
Tux's lil' helper


Joined: 28 May 2004
Posts: 79
Location: Pittsburgh, PA, USA

PostPosted: Mon Nov 20, 2006 9:58 pm    Post subject: Reply with quote

That's where my profile is symlinked to as well...

When I search for sparc-sources in www.gentoo-portage.com, there is no mention of a 2.6 source tree, only 2.4.31 and 2.4.33.
Back to top
View user's profile Send private message
NeddySeagoon
Administrator
Administrator


Joined: 05 Jul 2003
Posts: 31342
Location: 56N 3W

PostPosted: Mon Nov 20, 2006 10:40 pm    Post subject: Reply with quote

sheriff-jms,

Can you post your
Code:
emerge --info
output please.
Code:
emerge gentoo-sources
should get you 2.6.18-r2, if you have --synced recently.
_________________
Regards,

NeddySeagoon

Computer users fall into two groups:-
those that do backups
those that have never had a hard drive fail.
Back to top
View user's profile Send private message
Plugin_baby
n00b
n00b


Joined: 18 Aug 2005
Posts: 26
Location: The Netherlands

PostPosted: Mon Nov 20, 2006 11:56 pm    Post subject: Reply with quote

I know it's a bit confusing, but sparc-sources is 2.4, gentoo-sources is 2.6 :)
Back to top
View user's profile Send private message
sheriff-jms
Tux's lil' helper
Tux's lil' helper


Joined: 28 May 2004
Posts: 79
Location: Pittsburgh, PA, USA

PostPosted: Tue Nov 21, 2006 4:57 pm    Post subject: Reply with quote

Ok, I understand now. This section of the install guide should probably be clarified a bit.
It's mentioned in the kernel guide, but probably should be mentioned on the page below.

http://www.gentoo.org/doc/en/handbook/handbook-sparc.xml?part=1&chap=7

If you want a 2.4 kernel, emerge sparc-sources.
If you want a 2.6 kernel, emerge gentoo-sources.

Thanks
jms
Back to top
View user's profile Send private message
marky9074
Apprentice
Apprentice


Joined: 24 Sep 2004
Posts: 196
Location: UK

PostPosted: Wed Nov 22, 2006 9:52 pm    Post subject: Reply with quote

2.6.17-r8 is the latest stable unless you are going to unmask 2.6.18-r2

I cant get the former to boot after compiling, missing something out, though followed the handbook...

Mark


Last edited by marky9074 on Thu Nov 23, 2006 7:49 am; edited 3 times in total
Back to top
View user's profile Send private message
NeddySeagoon
Administrator
Administrator


Joined: 05 Jul 2003
Posts: 31342
Location: 56N 3W

PostPosted: Wed Nov 22, 2006 11:10 pm    Post subject: Reply with quote

marky9074,

What error message do you get ?
_________________
Regards,

NeddySeagoon

Computer users fall into two groups:-
those that do backups
those that have never had a hard drive fail.
Back to top
View user's profile Send private message
marky9074
Apprentice
Apprentice


Joined: 24 Sep 2004
Posts: 196
Location: UK

PostPosted: Thu Nov 23, 2006 7:48 am    Post subject: Reply with quote

marky9074 wrote:
OK, this is what I get.....and I have followed to the 'T' the installation handbook....

Quote:
VFS: Cannot open root device "sda1" or unknown-block(0,0)
Please append a correct "root=" boot option
Kernel panic - not syncing: VFS: Unable to mount root fs on unknown-block(0,0)


It compiles OK...but I cannot boot it....

I have posted on the chroot thread about it..

Mark
Back to top
View user's profile Send private message
NeddySeagoon
Administrator
Administrator


Joined: 05 Jul 2003
Posts: 31342
Location: 56N 3W

PostPosted: Thu Nov 23, 2006 7:37 pm    Post subject: Reply with quote

marky9074,

Code:
unknown-block(0,0)
is the key part of the error. It tells that the kernel code for driving your SCSI controller is missing from the kernel. It comes in two parts, The high level part, which you get with SCSI Disk Support and the love level part, which is hardware specific.
Both or either can be missing. Modules won't work - the code must be built in.

Please post the SCSI line(s) from your lspci output if you want me to identify the kernel module you need.
_________________
Regards,

NeddySeagoon

Computer users fall into two groups:-
those that do backups
those that have never had a hard drive fail.
Back to top
View user's profile Send private message
marky9074
Apprentice
Apprentice


Joined: 24 Sep 2004
Posts: 196
Location: UK

PostPosted: Thu Nov 23, 2006 9:53 pm    Post subject: Reply with quote

marky ~ # lspci
80:00.0 Host bridge: Sun Microsystems Computer Corp. Psycho PCI Bus Module
0001:00:00.0 Host bridge: Sun Microsystems Computer Corp. Psycho PCI Bus Module
0001:00:01.0 Bridge: Sun Microsystems Computer Corp. EBUS (rev 01)
0001:00:01.1 Ethernet controller: Sun Microsystems Computer Corp. Happy Meal (rev 01)
0001:00:03.0 SCSI storage controller: LSI Logic / Symbios Logic 53c875 (rev 14)
0001:00:03.1 SCSI storage controller: LSI Logic / Symbios Logic 53c875 (rev 14)
marky ~ #
Back to top
View user's profile Send private message
marky9074
Apprentice
Apprentice


Joined: 24 Sep 2004
Posts: 196
Location: UK

PostPosted: Thu Nov 23, 2006 9:56 pm    Post subject: Reply with quote

In the low level SCSI there are LSI Logic that are not enable....though these are RAID?
Back to top
View user's profile Send private message
marky9074
Apprentice
Apprentice


Joined: 24 Sep 2004
Posts: 196
Location: UK

PostPosted: Thu Nov 23, 2006 10:00 pm    Post subject: Reply with quote

Ahhhh, got it I think....

<M> SYM53C8XX Version 2 SCSI support

Should be:

<*> SYM53C8XX Version 2 SCSI support (Only for Ultra 60 on-board SCSI adapter)

Damn, not sure how I missed this!

Thanks!

Mark
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Gentoo on Sparc All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum