Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Error for emerge -DuN gnome. ( cairo & librsvg ) packages
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Duplicate Threads
View previous topic :: View next topic  
Author Message
Jseven
n00b
n00b


Joined: 14 Nov 2006
Posts: 2

PostPosted: Sat Nov 18, 2006 7:23 pm    Post subject: Error for emerge -DuN gnome. ( cairo & librsvg ) package Reply with quote

Hello

When I emerge gnome with this command # emerge -DuN gnome , everything works well. But I face this error

when the emerging at "cairo" package it's complete without any error. after that directly emerging the "gnome-base/libsrvg-2.14.4" package

It's tell me that : Please re-emerge x11-libs/cairo with the png USE flag set.

I did it and add the "png" to USE in make.conf and re-emerged it.

Then its gave another error I can't describe it it's from compiler with libsrvg tell me it can't complete the installation

from make [1] and ebuild errors and stopping every thing.

that what I set to USE on make.conf

Code:
USE="-gtk -gnome png gt3 gt4 kde dvd alsa cdr unicode bidi"


There any errors ? or things incorrect ?

this error from two days stopped me :oops: , newbie to gentoo

jseven
_________________
Live Free 0r Die


Last edited by Jseven on Sun Nov 19, 2006 12:36 am; edited 1 time in total
Back to top
View user's profile Send private message
nixnut
Administrator
Administrator


Joined: 09 Apr 2004
Posts: 10973
Location: the dutch mountains

PostPosted: Sat Nov 18, 2006 8:46 pm    Post subject: Reply with quote

try reemerging librsvg first.
And post the last 20 lines of output if things break again.
_________________
Please add [solved] to the initial post's subject line if you feel your problem is resolved. Help answer the unanswered

talk is cheap. supply exceeds demand
Back to top
View user's profile Send private message
Jseven
n00b
n00b


Joined: 14 Nov 2006
Posts: 2

PostPosted: Sat Nov 18, 2006 11:12 pm    Post subject: Reply with quote

I removed cairo then emerged librsvg

it's go to download cairo first !

after that it's gave me this error

Code:

i686-pc-linux-gnu-gcc -march-athlon -pipe -02 -o .libs/test-preformance test-preformance.o /usr/lib/libpopt.so ./.libs/librsvg-2.so
/usr/lib/libgsf-1.so /usr/lib/libcroco-0.6.so /usr/lib/lib/gdk_pixbuf-2.0.so /usr/lib/libxml2.so /usr/lib/libpangoft2-1.0.so /usr/lib/libpango-1.0.so
/usr/lib/libgobject-2.0.so /usr/lib/libgmodule-2.0.so -ldl /usr/lib/libglib-2.0.so /usr/lib/libcairo.so /usr/lib/libpng12.so /usr/lib/libfontconfig.so
/usr/lib/libexpat.so /usr/lib/libfreetype.so -lz -lm
creating test-preformance
make[2]: Leaving directory '/var/tmp/portage/librsvg-2.14.4/work/librsvg-2.14.4'
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory '/var/tmp/portage/librsvg-2.14.4/work/librsvg-2.14.4'
make: *** [all] Error 2

!!!ERROR: gnome-base/librsvg-2.14.4 failed.
Call stack:
ebuild.sh, line 1546: Called dyn_compile
ebuild.sh, line 937: Called src_compile
ebuild.sh, line 1255: Called gnome2_src_compile
gnome2.eclass, line 64: Called die

!!! compile failure
!!! If you need support, post the topmost build error, and the call stack if lelevant.


That's last 20 lines , And that's what I can see in the screen.

thank you for your response
_________________
Live Free 0r Die
Back to top
View user's profile Send private message
stknightmare
n00b
n00b


Joined: 03 Sep 2006
Posts: 2

PostPosted: Fri Dec 22, 2006 9:19 pm    Post subject: Reply with quote

I have the exact same problem trying to emerge gnome.

Ps:Someone suggests that emerging gtk-doc solves the problem,compiling still though.
Back to top
View user's profile Send private message
morda
Tux's lil' helper
Tux's lil' helper


Joined: 30 Nov 2005
Posts: 92
Location: UK

PostPosted: Fri Dec 22, 2006 9:39 pm    Post subject: Reply with quote

Hi,

I have cairo compiled with svg flag as well. If you don't, give it a try.

Also, it's not directly related but you are trying to emerge Gnome with disabled gnome and gtk USE flags (-gnome -gtk). Maybe you should enable them, but I'm not an expert...


Regards - morda.
Back to top
View user's profile Send private message
stknightmare
n00b
n00b


Joined: 03 Sep 2006
Posts: 2

PostPosted: Fri Dec 22, 2006 10:10 pm    Post subject: Reply with quote

I fixed the problem.

Switch your USE on make.conf to
USE="gtk gnome png -qt3 -qt4 gnome -arts dvd alsa cdr unicode bidi -kde"

Dont know if it has any meaning either

Try an
1)USE="png X" emerge cairo
2)emerge gnome

if it doesnt work out try an
1)emerge gtk-doc
2)USE="png X" emerge cairo
3)emerge gnome

Ps:Solved it not sure how though.dont know if it was the gtk-doc and after that the cairo or only the emerging cairo with using x and png.
Back to top
View user's profile Send private message
kb_ganesh
n00b
n00b


Joined: 06 Feb 2006
Posts: 12

PostPosted: Mon Jan 01, 2007 7:02 am    Post subject: Reply with quote

As stated in many places (and as I have learnt from experience), its more advisable to use /etc/portage/package.use to specify package specific USE flags instead of the way suggested above..

eg., USE="png X" emerge cairo

can equivalently be achieved by adding the line

x11-libs/cairo png X

to /etc/portage/package.use and then emerge -av cairo
This has the advantage that even if you recompile/update the program later, the old setting are remembered unlike using UISE="" emerge where you are most likely not to remember the special USE flags you set when compiling earlier..
Back to top
View user's profile Send private message
desultory
Administrator
Administrator


Joined: 04 Nov 2005
Posts: 7816

PostPosted: Mon May 21, 2007 8:04 am    Post subject: Reply with quote

Moved from Desktop Environments to Duplicate Threads, refer to topic "problem emerging libsvg-cairo" specifically post 3829795 by madisonicus.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Duplicate Threads All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum