Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Installing Gentoo on Netra T1 200 [SOLVED]
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Gentoo on Sparc
View previous topic :: View next topic  
Author Message
psychocandy
Apprentice
Apprentice


Joined: 09 Nov 2006
Posts: 192

PostPosted: Fri Nov 17, 2006 2:32 pm    Post subject: Installing Gentoo on Netra T1 200 [SOLVED] Reply with quote

OK. Been struggling with this for about a week...

Current status is I've got everything untared and gentoo-source and sparc-sources emerged.

Have been fiddling with the config file and been compiling the kernel using :-

make clean vmlinux image modules modules_install


Have had the following problems (with sparc-sources) :-

1. Kernel too old error

and (with gentoo-sources) :-

1. Cant find root (think this was because I didnt have scsi drivers loaded)

2. Kernel fails to compile (unreferenced variables or something). Sorted this by removing drivers errors referred to (dont know why they should error though!).

3. Current message following last successful compile is

Instruction DUMP: da5ac000 ce02e00c 86028001 <c488c3a0> c20b400
0 8408a0ff 8600e001 80a04002 1240001c
[ 17.117500] Kernel panic - not syncing: Attempted to kill init!

4. Currently running another kernel compile with just the LSI sparc low-level drivers (this is what lspci reports).

Apart from that I'm stumped !!!!!



Heres the silo.conf:-

# Example of how can be silo.conf set up
partition = 1
root = /dev/sda1
timeout = 120
#password = __put_your_password_in_cleartext_here__
#restricted
image = /boot/gentoo64-default
label = gentoo64-default

When I've tried this next kernel I'll post config file, lspci, and /etc/fstab as well....


Last edited by psychocandy on Sat Nov 18, 2006 9:42 am; edited 1 time in total
Back to top
View user's profile Send private message
psychocandy
Apprentice
Apprentice


Joined: 09 Nov 2006
Posts: 192

PostPosted: Fri Nov 17, 2006 3:08 pm    Post subject: Heres lspci Reply with quote

00:01.0 PCI bridge: Sun Microsystems Computer Corp. Simba Advanced PCI Bridge
00:01.1 PCI bridge: Sun Microsystems Computer Corp. Simba Advanced PCI Bridge (rev 13)
01:03.0 Non-VGA unclassified device: ALi Corporation M7101 Power Management Controller [PMU]
01:05.1 Ethernet controller: Sun Microsystems Computer Corp. RIO GEM (rev 01)
01:05.3 USB Controller: Sun Microsystems Computer Corp. RIO USB (rev 01)
01:07.0 ISA bridge: ALi Corporation M1533/M1535 PCI to ISA Bridge [Aladdin IV/V/V+]
01:0c.0 Bridge: Sun Microsystems Computer Corp. RIO EBUS (rev 01)
01:0c.1 Ethernet controller: Sun Microsystems Computer Corp. RIO GEM (rev 01)
01:0c.3 USB Controller: Sun Microsystems Computer Corp. RIO USB (rev 01)
01:0d.0 IDE interface: ALi Corporation M5229 IDE (rev c3)
02:05.0 PCI bridge: Digital Equipment Corporation DECchip 21153 (rev 04)
02:08.0 SCSI storage controller: LSI Logic / Symbios Logic 53C896/897 (rev 07)
02:08.1 SCSI storage controller: LSI Logic / Symbios Logic 53C896/897 (rev 07)
03:00.0 Bridge: Sun Microsystems Computer Corp. EBUS (rev 01)
03:00.1 Ethernet controller: Sun Microsystems Computer Corp. Happy Meal (rev 01)
03:01.0 Bridge: Sun Microsystems Computer Corp. EBUS (rev 01)
03:01.1 Ethernet controller: Sun Microsystems Computer Corp. Happy Meal (rev 01)
03:02.0 Bridge: Sun Microsystems Computer Corp. EBUS (rev 01)
03:02.1 Ethernet controller: Sun Microsystems Computer Corp. Happy Meal (rev 01)
03:03.0 Bridge: Sun Microsystems Computer Corp. EBUS (rev 01)
03:03.1 Ethernet controller: Sun Microsystems Computer Corp. Happy Meal (rev 01
Back to top
View user's profile Send private message
psychocandy
Apprentice
Apprentice


Joined: 09 Nov 2006
Posts: 192

PostPosted: Fri Nov 17, 2006 3:25 pm    Post subject: .config file (SCSI section) Reply with quote

#
# SCSI device support
#
CONFIG_RAID_ATTRS=m
CONFIG_SCSI=y
CONFIG_SCSI_PROC_FS=y

#
# SCSI support type (disk, tape, CD-ROM)
#
CONFIG_BLK_DEV_SD=y
# CONFIG_CHR_DEV_ST is not set
# CONFIG_CHR_DEV_OSST is not set
CONFIG_BLK_DEV_SR=y
CONFIG_BLK_DEV_SR_VENDOR=y
CONFIG_CHR_DEV_SG=y
# CONFIG_CHR_DEV_SCH is not set

#
# Some SCSI devices (e.g. CD jukebox) support multiple LUNs
#
CONFIG_SCSI_MULTI_LUN=y
CONFIG_SCSI_CONSTANTS=y
# CONFIG_SCSI_LOGGING is not set

#
# SCSI Transport Attributes
#
CONFIG_SCSI_SPI_ATTRS=y
CONFIG_SCSI_FC_ATTRS=y
CONFIG_SCSI_ISCSI_ATTRS=m
# CONFIG_SCSI_SAS_ATTRS is not set

#
# SCSI low-level drivers
#
# CONFIG_ISCSI_TCP is not set
# CONFIG_BLK_DEV_3W_XXXX_RAID is not set
# CONFIG_SCSI_3W_9XXX is not set
# CONFIG_SCSI_ACARD is not set
# CONFIG_SCSI_AACRAID is not set
# CONFIG_SCSI_AIC7XXX is not set
# CONFIG_SCSI_AIC7XXX_OLD is not set
# CONFIG_SCSI_AIC79XX is not set
CONFIG_MEGARAID_NEWGEN=y
CONFIG_MEGARAID_MM=y
CONFIG_MEGARAID_MAILBOX=y
CONFIG_MEGARAID_LEGACY=y
CONFIG_MEGARAID_SAS=y
# CONFIG_SCSI_SATA is not set
# CONFIG_SCSI_DMX3191D is not set
# CONFIG_SCSI_FUTURE_DOMAIN is not set
# CONFIG_SCSI_IPS is not set
# CONFIG_SCSI_INITIO is not set
# CONFIG_SCSI_INIA100 is not set
# CONFIG_SCSI_SYM53C8XX_2 is not set
# CONFIG_SCSI_IPR is not set
# CONFIG_SCSI_QLOGIC_1280 is not set
# CONFIG_SCSI_QLOGICPTI is not set
# CONFIG_SCSI_QLA_FC is not set
# CONFIG_SCSI_LPFC is not set
# CONFIG_SCSI_DC395x is not set
# CONFIG_SCSI_DC390T is not set
# CONFIG_SCSI_DEBUG is not set
# CONFIG_SCSI_SUNESP is not set
Back to top
View user's profile Send private message
psychocandy
Apprentice
Apprentice


Joined: 09 Nov 2006
Posts: 192

PostPosted: Fri Nov 17, 2006 3:27 pm    Post subject: /etc/fstab Reply with quote

/dev/cdroms/cdrom0 /mnt/cdrom iso9660 auto,ro 0 0

/dev/sda1 / ext2 defaults, noatime 1 2
/dev/sda2 swap sw 0 0
/dev/sda4 /usr ext3 noatime 0 0
/dev/sda5 /var ext3 noatime 0 0
/dev/sda6 /home ext3 noatime 0 0

# NOTE: The next line is critical for boot!
proc /proc proc defaults 0 0

# glibc 2.2 and above expects tmpfs to be mounted at /dev/shm for
# POSIX shared memory (shm_open, shm_unlink).
# (tmpfs is a dynamically expandable/shrinkable ramdisk, and will
# use almost no memory if not populated with files)
shm /dev/shm tmpfs nodev,nosuid,noexec
0 0

openprom /proc/openprom openpromfs defaults 0 0
Back to top
View user's profile Send private message
psychocandy
Apprentice
Apprentice


Joined: 09 Nov 2006
Posts: 192

PostPosted: Fri Nov 17, 2006 4:39 pm    Post subject: Reply with quote

Got the kernel to boot now....

Found the correct SCSI driver and enabled this ONLY....
Back to top
View user's profile Send private message
NeddySeagoon
Administrator
Administrator


Joined: 05 Jul 2003
Posts: 31342
Location: 56N 3W

PostPosted: Fri Nov 17, 2006 4:44 pm    Post subject: Reply with quote

psychocandy,

You need
Code:
SYM53C8XX Version 2 SCSI support
not megaraid.
Code:
# CONFIG_SCSI_SYM53C8XX_2 is not set
is the problem. Look at the SCSI line in your PCI output.
Code:
02:08.1 SCSI storage controller: LSI Logic / Symbios Logic 53C896/897 (rev 07)

_________________
Regards,

NeddySeagoon

Computer users fall into two groups:-
those that do backups
those that have never had a hard drive fail.
Back to top
View user's profile Send private message
psychocandy
Apprentice
Apprentice


Joined: 09 Nov 2006
Posts: 192

PostPosted: Fri Nov 17, 2006 11:38 pm    Post subject: Reply with quote

NeddySeagoon wrote:
psychocandy,

You need
Code:
SYM53C8XX Version 2 SCSI support
not megaraid.
Code:
# CONFIG_SCSI_SYM53C8XX_2 is not set
is the problem. Look at the SCSI line in your PCI output.
Code:
02:08.1 SCSI storage controller: LSI Logic / Symbios Logic 53C896/897 (rev 07)


Yep. Should have looked carefully at the PCI output first.

Did this and kernel now compiles and boots OK.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Gentoo on Sparc All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum