Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[emerge] Digest Failed sur gtk+
View unanswered posts
View posts from last 24 hours

Goto page Previous  1, 2, 3, 4, 5  Next  
Reply to topic    Gentoo Forums Forum Index French
View previous topic :: View next topic  
Author Message
nemo13
Veteran
Veteran


Joined: 08 Oct 2004
Posts: 1016
Location: France/Istres

PostPosted: Mon Nov 20, 2006 9:26 pm    Post subject: Reply with quote

pathfinder wrote:
:
enotice, je le cherche..

c'est un script que tu peux trouver
on en parle ici
ou re-ici
dans ce post il y a en outre portlog-info de TGL qui est aussi cool
( au fait que devient TGL :?: )
A+
Back to top
View user's profile Send private message
pathfinder
l33t
l33t


Joined: 19 Jan 2006
Posts: 731
Location: Barcelona, Spain

PostPosted: Mon Nov 20, 2006 9:35 pm    Post subject: Reply with quote

ok
mais je fais quoi?
/var/db/pkg/sys-apps/ et je copie le fichier la avec une extension .ebuild?

non+
ca ne marche pas

sudo mkdir /usr/portage/sys-apps/enotice
et un sudo cp .ebuild dedans non plus car "masked"
je suis un peu largue...
Back to top
View user's profile Send private message
nemo13
Veteran
Veteran


Joined: 08 Oct 2004
Posts: 1016
Location: France/Istres

PostPosted: Mon Nov 20, 2006 10:09 pm    Post subject: Reply with quote

pathfinder wrote:
ok
mais je fais quoi?
/var/db/pkg/sys-apps/ et je copie le fichier la avec une extension .ebuild?

non+
ca ne marche pas

sudo mkdir /usr/portage/sys-apps/enotice
et un sudo cp .ebuild dedans non plus car "masked"
je suis un peu largue...


oups, désolé

pour l'ebuild il te faudrait créér ton overlay mais bon ce n'est pas trôp le moment.
il y a un an en décompressant le . tar.gz , le script suivant était fournit :
Code:
#!/bin/bash
#
# install-enotice.sh
#
# Thomas Bullinger, B-LUC Consulting <consult@btoy1.net>

source /etc/make.globals
source /etc/make.conf
if [ "T$PORT_ENOTICE_DIR" = 'T' ]
then
        # Add the correct variable to the make.conf file
        echo "PORT_ENOTICE_DIR=/var/enotice" >> /etc/make.conf
        PORT_ENOTICE_DIR=/var/enotice
fi
mkdir -p $PORT_ENOTICE_DIR

if [ ! -f /etc/portage/profile/profile.bashrc ]
then
        # Create the profile script
        mkdir -p /etc/portage/profile
        cd /etc/portage/profile
        wget -q http://dev.gentoo.org/~eldad/enotice/profile.bashrc
fi

if [ ! -f /usr/local/sbin/enotice ]
then
        # Create the enotice script
        mkdir -p /usr/local/sbin
        cd /usr/local/sbin
        wget -q http://dev.gentoo.org/~eldad/enotice/enotice
fi
chmod 500 /usr/local/sbin/enotice

donc à priori une fois ce script dans le répertoire de root ( enotice est pour root ou un membre de wheel )et rendu executable ben il doit rouler
voili-voila
Back to top
View user's profile Send private message
pathfinder
l33t
l33t


Joined: 19 Jan 2006
Posts: 731
Location: Barcelona, Spain

PostPosted: Tue Nov 21, 2006 10:39 am    Post subject: Reply with quote

ok, ok pour l oeverlay.j aime la methode, je ne la domine pas trop, mais c est une bonne idee.
je tenterai plus tard.
ce topic est en "suspend" car je dois d abord resoudre ceci:https://forums.gentoo.org/viewtopic-p-3731343.html#3731343
et j espere que ca ira...
Back to top
View user's profile Send private message
pathfinder
l33t
l33t


Joined: 19 Jan 2006
Posts: 731
Location: Barcelona, Spain

PostPosted: Tue Nov 21, 2006 11:50 am    Post subject: Reply with quote

voila,
le topic cite est clos: il faut les versions CVS et GIT de XORG modulaire pour pouvoir avoir le DRI.
JE ne risque pas, j attendrai, d autant que aiglx et beryl marchent sans ca.

Donc, aiglx est en cours, il m a renvoye a beryl.
et j ai unmaske le keywords PRESQUE comme mentionne (j ai rajoute l architecture)
voila:
Quote:
##########################################
############# BERYL STUFF #############
#Beryl Core
=x11-wm/beryl-0.1* ~x86
=x11-wm/beryl-core-0.1* ~x86
=x11-plugins/beryl-plugins-0.1* ~x86
=x11-plugins/beryl-dbus-0.1* ~x86
=x11-misc/beryl-manager-0.1* ~x86
=x11-misc/beryl-settings-0.1* ~x86
=x11-apps/xlsclients-1.0* ~x86
=x11-apps/xvinfo-1.0* ~x86
=x11-libs/libwnck-2.16* ~x86

#Experimental Plugins
x11-plugins/beryl-group-plugin [color=violet]-* je sais pas ce que c est svn et je sais pas si c est risque...

x11-plugins/beryl-threed-plugin -*
x11-plugins/beryl-vidcap -*[/color] CEUX CI NE SONT PAS DANS LE TREE DE PORTAGE NI DANS EIX... JE SAIS PAS POURQUOI

#Window Decorators
=x11-wm/emerald-0.1* ~x86
=x11-misc/emerald-themes-0.1* ~x86
#x11-wm/aquamarine -* je n ai pas KDE donc OUT CEUX CI N APPPARAISSENT NULLE PART
x11-wm/heliodor -* je sais pas si le mettre... JE COMPRENDS PAS NON PLUS...

EDIT4:
je pense que heliodor et aquamarine sont dans l overlay de xeffects, et qu il en est de meme pour tout ce qui est suivi de -* c est ca?
#
##########################################


Une question avant de poursuivre:
Je ne comprends pas le -*
vous me le conseillez? je suis en stable, et je voudrais y rester le max...
Je ne comprends pas trop non plus les * qui completent le numero de la version. pourquoi ne pas preciser une version?
ca risque d etre toujours instable et ne jamais etre rattrape? je precise plutot la version entiere?
ou mieux vaut laisser les patches d une version donnee?


Last edited by pathfinder on Tue Nov 21, 2006 12:25 pm; edited 1 time in total
Back to top
View user's profile Send private message
pathfinder
l33t
l33t


Joined: 19 Jan 2006
Posts: 731
Location: Barcelona, Spain

PostPosted: Tue Nov 21, 2006 11:59 am    Post subject: Reply with quote

autre chose:
uine fois tout installe, ils renvoient, dans le tuto de beryl, au tuo de aiglx.
cependant, dans le howto de aiglx, ils ne parlent apres que de compiz.
il y a autre chose a faire? ou je zappe completement?

vous connaissez un site pour un how to beryl et fluxbox?
http://wiki.gentoo-xeffects.org/FAQ
Quote:
Can I use compiz or beryl with fluxbox/openbox?

The answer is unfortunately no. Fluxbox and Openbox are both window managers. It is impossible to run multiple window managers. Thus when you start any window manager, it detects if one is currently running. Most by default will exit with an error about it, however some like beryl will replace the currently running window manager


pardon si je suis trop pressé...
Back to top
View user's profile Send private message
pathfinder
l33t
l33t


Joined: 19 Jan 2006
Posts: 731
Location: Barcelona, Spain

PostPosted: Tue Nov 21, 2006 12:07 pm    Post subject: Reply with quote

autre chose:
puisque fluxbox ne marche pas avec beryl, je fais comment?
je passe par gnome?


bon, a part ca:
tuto de beryl:
Quote:
# emerge -va mesa-progs #Only if configure fails for beryl!!!
# emerge -va libwnck beryl


mesa-progs est deja present sur mon poste...
MAIS il est pas dans mon world file :D :D :D :D
Ne devrais-je donc pas, et du coup, une correction dans le tuto s impose, faire plutot, simplement:
Code:
# emerge --oneshot -va libwnck
puis
emerge -va beryl
??
Back to top
View user's profile Send private message
pathfinder
l33t
l33t


Joined: 19 Jan 2006
Posts: 731
Location: Barcelona, Spain

PostPosted: Tue Nov 21, 2006 1:43 pm    Post subject: Reply with quote

aaaaaargh

j ai fait ce que j ai dit... ca plante completement!!
beryl crashe
X crashe
que ce soit depuis gnome, ou avant gnome, ou que ce soit en ligne de commande sans xdm...

Il y a le logo qui apparait, c est GRAVEMENT LENT ET SACCADE, ca rame a mort... et apres, CLACK on revient en xdm ou en mode console.

j avais lu un truc pour prevenir le blank screen, mais je vois pas du tout maintenant!!!
Back to top
View user's profile Send private message
pathfinder
l33t
l33t


Joined: 19 Jan 2006
Posts: 731
Location: Barcelona, Spain

PostPosted: Tue Nov 21, 2006 1:53 pm    Post subject: Reply with quote

en clair:

depuis gnome, ca plante tout X
depuis fluxbox, ca plante
en ligne de commande, avec beryl dans le .xinitrc, ca montre un logo de beryl TRES lentement, puis un ecran blanc et RIEN d autre. Rien de rien.

j avoue que je suis un peu pommé...
Back to top
View user's profile Send private message
Magic Banana
Veteran
Veteran


Joined: 13 Dec 2005
Posts: 1907
Location: Belo Horizonte, Minas Gerais, Brasil

PostPosted: Tue Nov 21, 2006 2:01 pm    Post subject: Reply with quote

Le -* veut dire que tu démasques le paquet pour toutes les architectures. Il est plus sage de préciser ton architecture. Le truc est qu'il est un peu difficile de suivre un howto si l'on s'attarde sur tous les détails. Du coup les auteurs font dans le bourrin.

Tu peux pour l'instant laisser de côté heliodor qui n'est pas encore dans Portage (il faut passer par un overlay). De toute façon emerald est déjà bien joli et très configurable.

Les étoiles pour complèter les numéros de version permettent comme tu l'a compris de se mettre à jour dans la branche stable tout en restant à Beryl 0.1.x. Du coup, si demain, Beryl 0.1.3 sort, tu auras l'update, si c'est Beryl 0.2, tu ne l'auras pas. Pour éviter toute update, remplace l'étoile par le numéro de version que tu souhaites.

Lorsque AIGLX est fonctionnel (ce qui est ton cas), tu peux lâcher le howto correspondant et te concentrer sur celui de Beryl (en laissant de côté heliodor et aquamarine). Comme tu l'as compris par toi même, Beryl ne fonctionne qu'associer à un environnement de Bureau (Gnome, Xfce ou KDE).

Enfin si libwnck est déjà sur ton système, tu n'as pas besoin de l'installer de nouveau. L'indication de l'howto concerne uniquement les personnes qui n'ont pas encore cette bibliothèque installée. Ce qui signifie donc qu'ils n'ont aucun logiciel sur leur système qui a pour dépendance libwnck. Ce qui signifie donc qu'ils soivent l'installer sans l'option "--oneshot" (autrement elle serait supprimée au prochain "emerge --depclean"). Tu vas me dire que c'est mal foutu puisque cette bibliothèque n'est pas utilisée directement par l'utilisateur final. C'est vrai. En fait ce serait pas mal de définir un USE flag dans Beryl qui conditionne l'installation de libwnck... Tu me suis ?
Back to top
View user's profile Send private message
pathfinder
l33t
l33t


Joined: 19 Jan 2006
Posts: 731
Location: Barcelona, Spain

PostPosted: Tue Nov 21, 2006 2:08 pm    Post subject: Reply with quote

Quote:
vi /etc/portage/package.use
x11-wm/beryl gnome liwnck


je t ai suivi? (oneshot pour libwnck)

mais j ai tout de meme cette lenteur extreme horrible... (et j avais meme pas blur d active dans BSM)

un ecran blanc et je peux rien faire...
autre chose: POURQUOI est ce que les raccourcis avec la Super Key utilisent la touche Windows!?! si on a un clavier Sun? on fait quoi?
si on cherche les claviers sans cette touche?
Back to top
View user's profile Send private message
Magic Banana
Veteran
Veteran


Joined: 13 Dec 2005
Posts: 1907
Location: Belo Horizonte, Minas Gerais, Brasil

PostPosted: Tue Nov 21, 2006 2:16 pm    Post subject: Reply with quote

Tous les raccourcis clavier peuvent être modifiés (beryl-settings si je me souviens bien qui se trouve dans le menu Préférence de Gnome). Pour la lenteur, à toi aussi d'adapter les paramètres (il y a de quoi y passer sa journée !).

Pour l'écran blanc, essaie encore une fois (c'est la technique du moment), de tout désactiver dans beryl-settings puis d'ajouter petit à petit des effets.
Back to top
View user's profile Send private message
pathfinder
l33t
l33t


Joined: 19 Jan 2006
Posts: 731
Location: Barcelona, Spain

PostPosted: Tue Nov 21, 2006 3:35 pm    Post subject: Reply with quote

rien a faire
j ai tout enleve a part le splash et le cube
plante pareil

j ai remis les options de xorg ui ont l air necessaires au niveau de plusieurs forums, toujours pareil, ca crashe.

j ai emerge x11-drm pour mon noyau 2.6.15 et rien a faire non plus.
quoique je sais pas s il charge le module qu il a emerge...
Back to top
View user's profile Send private message
Magic Banana
Veteran
Veteran


Joined: 13 Dec 2005
Posts: 1907
Location: Belo Horizonte, Minas Gerais, Brasil

PostPosted: Tue Nov 21, 2006 3:57 pm    Post subject: Reply with quote

Pourrais-tu nous copier le message d'erreur (à moins que tout X soit planté). Que donne la commande lsmod ? (c'est cette commande qui te permet de connaître les modules du noyau qui sont chagés en mémoire :wink: )

Je te rappelle que tu dois indiquer dans /etc/modules.autload/2.6 (je te le donne de tête, à vérifier donc) les modules à charger au démarrage du noyau.

Tu as aussi essayé d'enlever le splash ou/et le cube ?
Back to top
View user's profile Send private message
pathfinder
l33t
l33t


Joined: 19 Jan 2006
Posts: 731
Location: Barcelona, Spain

PostPosted: Tue Nov 21, 2006 4:08 pm    Post subject: Reply with quote

X plante
pas de message possible
pas enleve le splash ni le cube

mais je viens de retrouver ce truc avec l ecran blanc que j avais lu:
http://wiki.gentoo-xeffects.org/FAQ#How_do_I_get_rid_of_the_white_screen.3F
Quote:
How do I get rid of the white screen?

This is caused by a change in glproto 1.4.7 to 1.4.8. Thus we need to do the following:

# emerge -1 mesa xorg-server <your graphics driver>

* XGL Users do this also:

# emerge -1 xgl

* Beryl Users do this also:

# emerge -1 beryl-core

* Compiz Users do this also:

# emerge -1 compiz

Unfortunately this will take a while, but at least it should get rid of the white screen bug.

A much more descriptive difference list to come...


cependant, en cherchant encore un peu plus, ja i vu ceci:
https://forums.gentoo.org/viewtopic-t-517616.html
Quote:
Hello guys,

This is the appeal to all users who want to get rid of the white cube phenomenon. Here we share our experiences.

After spending dozens of hours on reading countless forum threads and HOWTOs about the white cube problem, I would like to merge and summarize all useful information about that annoying problem in a central place. This should help better in finding a solution than lots of threads with one or two replies that only contain a link to another useless HOWTO.

The current situation

Users of various distributions, all kinds of graphics drivers and different Xorg rendering methods (XGL/AIGLX) get a white cube when they run beryl.
Sometimes the cube is totally white from the beginning, sometimes it needs movements of elements to make it fully white but in the end it all looks the same. Usually the cube can be rotated and zoomed as normal.
This has happened from compiz pre-beryl-times through latest beryl 0.1.3-cvs.

Some users reported they had solved the problem by

- up-/downgrading/recompiling Nvidia drivers
- downgrading glproto from 1.4.8 to 1.4.7 and recompiling xorg-server
- following this HOWTO: http://wiki.gentoo-xeffects.org/FAQ#How_do_I_get_rid_of_the_white_screen.3F
- recompiling all kinds of other packages

But these are no sufficient solutions. There are users (like me) who have not got rid of the white screen using any of these or other suggested methods.

I think we should find out together whether the white cube problem is caused by a bug in beryl, xorg-server, glproto or in something else. Noone currently knows. When we know what causes the problem we can report it the particular developers and there is a good chance to have it fixed.

This is the beryl bug where I have just added my experiences: http://bugs.beryl-project.org/trac/ticket/469

Let's use the strengths of open source to regain our shiny eye candy! :D

ceci est un post
je vous conseillle donc de le lire car je n ai mis qu un extrait.

je le fais de ce pas.
on va se le faire.

Ma premiere Attaque:
Code:
# emerge -1 -ptv mesa xorg-server xf86-video-ati
comme suggéré ici.
je poursuis la lecture pendant la compilation.
Back to top
View user's profile Send private message
pathfinder
l33t
l33t


Joined: 19 Jan 2006
Posts: 731
Location: Barcelona, Spain

PostPosted: Tue Nov 21, 2006 4:29 pm    Post subject: Reply with quote

la ligne definitive est sans le -ptv et avec beryl-core
encore en cours

parcontre, sunstudioexpress merde... il faudra que je voie... il se plaint d un pdf (a moi sur un autre sujet) qui n a rien a voir avec mes fichiers fortran...

xorg-server met du temps...

autre chose: c est de toutes facons tres lent... c est le dRI qui aide pas?
je passe a un nouveau kernel? ca vaut la peine?

au fait:
Code:
lsmod
Module                  Size  Used by
radeon                108576  0
drm                    65428  1 radeon
intel_agp              21148  1
agpgart                29264  2 drm,intel_agp

Code:
drm
intel-agp
agpgart
radeon


c etait bien mis.
mais a l install de x11-drm, pour mon kernel 2.6.15, il a mis un truc dans /etc/modules.d/ mais je sais pas si c est bien ce module qu il considere maintenant.
toujours est il que ca marche toujours pas le dri...
Back to top
View user's profile Send private message
Magic Banana
Veteran
Veteran


Joined: 13 Dec 2005
Posts: 1907
Location: Belo Horizonte, Minas Gerais, Brasil

PostPosted: Tue Nov 21, 2006 4:36 pm    Post subject: Reply with quote

Bah c'est toujours amusant de se faire un nouveau noyau, non ? :lol:

Petite remarque si tu te décides pour un nouveau noyau : la dernière version dans la branche stable de Portage est la 2.6.18.
Si tu veux continuer à utiliser les drivers proprio d'ATI (ce que tu ne veux plus apriori mais bon), alors tu dois démasquer une version plus récente que la dernière marquée stable dans Portage. En effet, le support pour Linux 2.6.18 commence avec ati-drivers-8.28.8.

Alternativement (si tu veux pouvoir alterner sans reboot entre radeon/Beryl et ati-drivers/DRI), tu peux te contenter d'un Linux 2.6.17.

EDIT : Oui l'absence de DRI n'aide pas mais d'une manière général les drivers radeon sont moins performants que les drivers propriétaires. Cependant ils sont libres et les seuls à faire fonctionner les cartes ATI avec AIGLX.
Back to top
View user's profile Send private message
pathfinder
l33t
l33t


Joined: 19 Jan 2006
Posts: 731
Location: Barcelona, Spain

PostPosted: Tue Nov 21, 2006 4:49 pm    Post subject: Reply with quote

boin boin boin boiiiiiiiiin

marsh po.

emerge le tout, ne marche pas.
enleve le cube et le splash, ne reste que "general" que je ne peux enlever... et depuis gnome, ca crashe.
la session beryl, elle, crashe aussi.
quant a ligne de commande sans xdm pour gerer le tout et un "beryl" dans .xinitrc, bel ecran blanc et c est tout.

je sais pas si je suis fan :D

donc a moins que vous n ayiez d autres idees, je vais me jeter du pont. :D :D :D

serieusement, il reste la possibilite de downgrader glproto,mais c est ps bon ca, pour le futur, non? je me sens pas encore a l aise avec les yoyo problems... j ai peur d engendrer des boulettes.
Quote:
equery depends glproto

*** You are not in the portage group. You may experience cache problems
*** due to permissions preventing the creation of the on-disk cache.
*** Please add this user to the portage group if you wish to use portage.

*** WARNING *** For security reasons, only system administrators should be
*** WARNING *** allowed in the portage group. Untrusted users or processes
*** WARNING *** can potentially exploit the portage group for attacks such as
*** WARNING *** local privilege escalation.

[ Searching for packages depending on glproto... ]
x11-drivers/xf86-video-ati-6.6.3
x11-base/xorg-server-1.1.1-r1
x11-apps/xdriinfo-1.0.1
media-libs/mesa-6.5.1-r1


je passe a mesa 6.5.1.r2? (ca marchera pas de toutes facons)
j attends xorg 7.2 ?
nouveau noyau?


au fait, ati-drivers, je les avais laissés unmasked, car ils marchaient (desole)
je crois que je vais d ailleurs y revenir.
parce que seul le splash, le pauvre spalsh de beryl, c etait degueulasse, super saccade, genre arret sur image d un vieux magneto... (vous avez tous connu le VHS tout de meme!?)
et en plus GDM /XDM / mode graphique ca met environ 12-15 secondes avant de se charger, quant avec les drivers proprios, c est immediat
Back to top
View user's profile Send private message
pathfinder
l33t
l33t


Joined: 19 Jan 2006
Posts: 731
Location: Barcelona, Spain

PostPosted: Tue Nov 21, 2006 4:56 pm    Post subject: Reply with quote

au fait,
package.use, la ligne avecv libwnck en flag dans
x11-wm/beryl gnome liwnck
c est bon?

pour le reste, j emerge --sync, j update eix, je relance un emerge -auvDN world, juste pour voir...
Back to top
View user's profile Send private message
Magic Banana
Veteran
Veteran


Joined: 13 Dec 2005
Posts: 1907
Location: Belo Horizonte, Minas Gerais, Brasil

PostPosted: Tue Nov 21, 2006 5:08 pm    Post subject: Reply with quote

pathfinder wrote:
je passe a mesa 6.5.1.r2? (ca marchera pas de toutes facons)

Cela ne changera rien.

pathfinder wrote:
j attends xorg 7.2 ?

Et oui comme tout le monde ! La version 7.2 n'apportera rien du point de vue fonctionalité. Ce sera seulement une "bug-fix release" les développeurs ayant décidé de se concentrer sur les problèmes avant de se jeter dans un xorg-x11-7.3 nettement plus audacieux.

pathfinder wrote:
nouveau noyau?

Pourquoi pas. Prends en compte ma remarque précédente vis à vis de fglrx.

pathfinder wrote:
package.use, la ligne avecv libwnck en flag dans
x11-wm/beryl gnome liwnck
c est bon?


D'un point de vue syntaxique, aucun problème. En revanche, cela ne va pas avoir beaucoup d'effet étant donné que l'ebuild de Beryl n'utilise aucun USE flag ! Tu peux vérifier leur abcence avec un simple :
Code:
% emerge -pv beryl


Je ne sais pas où tu t'es trompé mais tu as dû te fourvoyer quelque part. Un espoir renaît pour faire fonctionner Beryl ! Descend du pont !
Back to top
View user's profile Send private message
pathfinder
l33t
l33t


Joined: 19 Jan 2006
Posts: 731
Location: Barcelona, Spain

PostPosted: Tue Nov 21, 2006 5:10 pm    Post subject: Reply with quote

Quote:
# emerge -ptuvDN world

These are the packages that would be merged, in reverse order:

Calculating world dependencies... done!
[nomerge ] app-misc/beagle-0.2.7 USE="gtk python -chm -debug -evo -ole -pdf"
[nomerge ] dev-dotnet/gnome-sharp-2.8.0
[nomerge ] dev-dotnet/gnomevfs-sharp-2.8.0
[nomerge ] dev-dotnet/gtk-sharp-2.8.0 USE="-doc"
[ebuild U ] dev-perl/XML-LibXML-1.60 [1.58-r1] 226 kB
[nomerge ] gnome-base/gnome-2.14.2 USE="cdr dvdr hal -accessibility"
[nomerge ] app-editors/gedit-2.14.3 USE="python spell -debug"
[nomerge ] dev-python/gnome-python-desktop-2.14.0 USE="X -debug"
[ebuild U ] x11-libs/libwnck-2.16.2 [2.16.1] USE="-debug -doc" 456 kB
[nomerge ] dev-util/anjuta-1.2.4-r1 USE="-debug"
[nomerge ] x11-libs/vte-0.12.2 USE="opengl python -debug -doc"
[nomerge ] dev-python/pygtk-2.8.6 USE="opengl -doc"
[ebuild U ] dev-python/pycairo-1.2.2 [1.0.2] USE="-numeric (-gtk%*) (-svg%)" 471 kB
[ebuild R ] app-text/acroread-7.0.8 USE="cups ldap nls nsplugin" LINGUAS="es fr -da -de -fi -it -ja -ko -nb% -nl -pt -sv -zh_CN -zh_TW (-no%)" 0 kB
[nomerge ] x11-misc/xscreensaver-4.24 USE="jpeg new-login nls opengl pam xinerama -gnome -insecure-savers -kerberos -krb4 -offensive"
[nomerge ] gnome-base/gdm-2.14.9-r1 USE="ipv6 pam tcpd xinerama -accessibility -debug (-selinux)"
[nomerge ] gnome-base/librsvg-2.14.4 USE="gnome zlib -debug -doc"
[nomerge ] gnome-extra/libgsf-1.14.0 USE="bzip2 gnome -debug -doc -static"
[ebuild U ] media-gfx/imagemagick-6.3.0.5 [6.2.9.5] USE="X bzip2 gs jpeg mpeg perl png tiff truetype xml zlib -doc -fpx -graphviz -jbig -jpeg2k -lcms -nocxx -wmf" 5,258 kB
[nomerge ] net-print/hplip-1.6.10 USE="X foomaticdb ppds qt3 -scanner -snmp"
[nomerge ] media-libs/netpbm-10.34 USE="jpeg png tiff xml zlib -svga"
[nomerge ] media-libs/urt-3.1b-r1 USE="X gif gs tiff"
[nomerge ] virtual/ghostscript-0
[nomerge ] app-text/ghostscript-gpl-8.54 USE="X cups emacs gtk -cjk -jpeg2k"
[ebuild U ] net-print/cups-1.2.6 [1.1.23-r8] USE="X%* dbus%* jpeg%* nls pam png%* ppds%* samba ssl tiff%* -php% -slp (-gnutls%)" 3,483 kB
[ebuild U ] sys-apps/dbus-0.62-r1 [0.61-r1] USE="X gtk python qt3 qt4%* -debug -doc -mono (-selinux)" 1,696 kB
[ebuild N ] app-text/libpaper-1.1.20 321 kB
[ebuild N ] x11-misc/xdg-utils-1.0 280 kB
[ebuild N ] x11-apps/xprop-1.0.1 USE="-debug" 90 kB
[nomerge ] media-gfx/gqview-2.0.1
[nomerge ] x11-libs/gtk+-2.8.19 USE="X jpeg tiff xinerama -debug -doc"
[nomerge ] x11-libs/pango-1.12.3 USE="-debug -doc"
[ebuild U ] x11-libs/cairo-1.2.4 [1.0.4] USE="X glitz pdf%* png -directfb% -doc -svg%" 2,815 kB
[ebuild U ] media-libs/glitz-0.5.6 [0.4.4] 448 kB

Total size of downloads: 15,547 kB

et merde!
je revois cairo en effet yoyo!!!
pourquoi il veut maintenant l upgrader!?!
glitz!? il est nulle part (keywords, use, world)!
c est pango qui vient emmerder?
ou le fait d avoir utilise beryl? je pige plus la. je suis fatigue.
je rentre.
Back to top
View user's profile Send private message
Magic Banana
Veteran
Veteran


Joined: 13 Dec 2005
Posts: 1907
Location: Belo Horizonte, Minas Gerais, Brasil

PostPosted: Tue Nov 21, 2006 5:17 pm    Post subject: Reply with quote

C'est effectivement dû aux paquets listés dans ton /etc/portage/package.keywords. Je te laisse (re)lire ce thread.
Back to top
View user's profile Send private message
pathfinder
l33t
l33t


Joined: 19 Jan 2006
Posts: 731
Location: Barcelona, Spain

PostPosted: Fri Nov 24, 2006 3:39 pm    Post subject: Reply with quote

voila mon keywords:
Quote:
=media-gfx/picasa-2.2.2820.5 ~x86
=net-im/amsn-0.96_rc1 ~x86
=x11-themes/amsn-skins-20040223 ~x86
=x11-misc/grsync-0.5-r1 ~x86
=x11-drivers/ati-drivers-8.30.3-r1 ~x86
=net-print/hplip-1.6.10 ~x86

##########################################
############# BERYL STUFF #############
#Beryl Core
=x11-wm/beryl-0.1* ~x86
=x11-wm/beryl-core-0.1* ~x86
=x11-plugins/beryl-plugins-0.1* ~x86
=x11-plugins/beryl-dbus-0.1* ~x86
=x11-misc/beryl-manager-0.1* ~x86
=x11-misc/beryl-settings-0.1* ~x86
=x11-apps/xlsclients-1.0* ~x86
=x11-apps/xvinfo-1.0* ~x86
=x11-libs/libwnck-2.16* ~x86

#Experimental Plugins
x11-plugins/beryl-group-plugin -*
x11-plugins/beryl-threed-plugin -*
x11-plugins/beryl-vidcap -*

#Window Decorators
=x11-wm/emerald-0.1* ~x86
=x11-misc/emerald-themes-0.1* ~x86


ok je relis de suite.
mais je pige pas trop, car ni pango, ni glitz, ni cairo ne sont presents dans keywords...
Back to top
View user's profile Send private message
pathfinder
l33t
l33t


Joined: 19 Jan 2006
Posts: 731
Location: Barcelona, Spain

PostPosted: Fri Nov 24, 2006 5:26 pm    Post subject: Reply with quote

j ai emerge thunderbird.
vlila maintenant:
Quote:
# emerge -ptuvDN world

These are the packages that would be merged, in reverse order:

Calculating world dependencies... done!
[nomerge ] app-misc/beagle-0.2.7 USE="gtk python -chm -debug -evo -ole -pdf"
[nomerge ] dev-dotnet/gnome-sharp-2.8.0
[nomerge ] dev-dotnet/gnomevfs-sharp-2.8.0
[nomerge ] dev-dotnet/gtk-sharp-2.8.0 USE="-doc"
[ebuild U ] dev-perl/XML-LibXML-1.60 [1.58-r1] 226 kB
[nomerge ] gnome-base/gnome-2.14.2 USE="cdr dvdr hal -accessibility"
[nomerge ] app-editors/gedit-2.14.3 USE="python spell -debug"
[nomerge ] dev-python/gnome-python-desktop-2.14.0 USE="X -debug"
[ebuild U ] x11-libs/libwnck-2.16.2 [2.16.1] USE="-debug -doc" 456 kB
[nomerge ] dev-util/anjuta-1.2.4-r1 USE="-debug"
[nomerge ] x11-libs/vte-0.12.2 USE="opengl python -debug -doc"
[nomerge ] dev-python/pygtk-2.8.6 USE="opengl -doc"
[ebuild U ] dev-python/pycairo-1.2.2 [1.0.2] USE="-numeric (-gtk%*) (-svg%)" 471 kB
[ebuild R ] app-text/acroread-7.0.8 USE="cups ldap nls nsplugin" LINGUAS="es fr -da -de -fi -it -ja -ko -nb% -nl -pt -sv -zh_CN -zh_TW (-no%)" 0 kB
[nomerge ] x11-misc/xscreensaver-4.24 USE="jpeg new-login nls opengl pam xinerama -gnome -insecure-savers -kerberos -krb4 -offensive"
[nomerge ] gnome-base/gdm-2.14.9-r1 USE="ipv6 pam tcpd xinerama -accessibility -debug (-selinux)"
[nomerge ] gnome-base/librsvg-2.14.4 USE="gnome zlib -debug -doc"
[nomerge ] gnome-extra/libgsf-1.14.0 USE="bzip2 gnome -debug -doc -static"
[ebuild U ] media-gfx/imagemagick-6.3.0.5 [6.2.9.5] USE="X bzip2 gs jpeg mpeg perl png tiff truetype xml zlib -doc -fpx -graphviz -jbig -jpeg2k -lcms -nocxx -wmf" 5,258 kB
[nomerge ] net-fs/samba-3.0.22-r3 USE="cups ldap pam python readline xml -acl -async -automount -doc -examples -kerberos -ldapsam -libclamav -mysql -oav -postgres -quotas (-selinux) -swat -syslog -winbind"
[ebuild U ] net-nds/openldap-2.3.27-r3 [2.3.27-r2] USE="berkdb crypt gdbm ipv6 perl readline ssl tcpd -debug -kerberos -minimal -odbc -overlays -samba -sasl (-selinux) -slp -smbkrb5passwd" 0 kB
[ebuild N ] net-print/foomatic-db-20060720 12,055 kB
[nomerge ] net-print/hplip-1.6.10 USE="X foomaticdb ppds qt3 -scanner -snmp"
[ebuild U ] net-print/foomatic-db-engine-3.0.20060720 [3.0.2] 306 kB
[ebuild U ] net-print/foomatic-filters-3.0.20060720 [3.0.2-r1] USE="cups (-samba%)" 161 kB
[nomerge ] media-libs/netpbm-10.34 USE="jpeg png tiff xml zlib -svga"
[nomerge ] media-libs/urt-3.1b-r1 USE="X gif gs tiff"
[nomerge ] virtual/ghostscript-0
[nomerge ] app-text/ghostscript-gpl-8.54 USE="X cups emacs gtk -cjk -jpeg2k"
[ebuild U ] net-print/cups-1.2.6 [1.1.23-r8] USE="X%* dbus%* jpeg%* nls pam png%* ppds%* samba ssl tiff%* -php% -slp (-gnutls%)" 3,483 kB
[ebuild U ] sys-apps/dbus-0.62-r1 [0.61-r1] USE="X gtk python qt3 qt4%* -debug -doc -mono (-selinux)" 1,696 kB
[ebuild N ] app-text/libpaper-1.1.20 321 kB
[ebuild N ] x11-misc/xdg-utils-1.0 280 kB
[ebuild N ] x11-apps/xprop-1.0.1 USE="-debug" 90 kB
[nomerge ] media-gfx/gqview-2.0.1
[nomerge ] x11-libs/gtk+-2.8.19 USE="X jpeg tiff xinerama -debug -doc"
[nomerge ] x11-libs/pango-1.12.3 USE="-debug -doc"
[ebuild U ] x11-libs/cairo-1.2.4 [1.0.4] USE="X glitz pdf%* png -directfb% -doc -svg%" 2,815 kB
[ebuild U ] media-libs/glitz-0.5.6 [0.4.4] 448 kB

[nomerge ] perl-core/Test-Harness-2.56
[nomerge ] dev-libs/openssl-0.9.8d USE="emacs sse2 zlib -bindist -test"
[nomerge ] dev-lang/perl-5.8.8-r2 USE="berkdb gdbm -build -debug -doc -ithreads -perlsuid"
[nomerge ] sys-devel/libperl-5.8.8-r1 USE="berkdb gdbm -debug -ithreads"
[nomerge ] sys-libs/db-4.2.52_p4-r2 USE="java -bootstrap -doc -nocxx -tcl -test"
[nomerge ] virtual/jre-1.5.0
[nomerge ] virtual/jdk-1.5.0
[nomerge ] dev-java/sun-jdk-1.5.0.08 USE="X alsa nsplugin -doc -examples -jce"
[nomerge ] media-libs/alsa-lib-1.0.13 USE="-debug -doc"
[ebuild NS ] sys-kernel/gentoo-sources-2.6.18-r3 USE="-build -symlink (-ultra1)" 228 kB

Total size of downloads: 28,300 kB


apparemment il ne va pas les downgrader, ... sauf peut etre a la prochaine version (le yoyo monte, puis descend)

ca peut etre du a aquoi?
je veux bien passer les keywords pour que les paquets X soient en ~, mais ej sais pas lesquels sont en cause...
Back to top
View user's profile Send private message
pathfinder
l33t
l33t


Joined: 19 Jan 2006
Posts: 731
Location: Barcelona, Spain

PostPosted: Mon Nov 27, 2006 5:39 pm    Post subject: Reply with quote

je suis idiot:
cairo et glitz et pango sont passes en stable pour les versions qu il me propose d upgrader, voila tout.
c est amsn qui me downgrade et que j ai en =version ~x86 dans mon keyword (pas bien grave).

je reinstalle le tout, et poursuis beryl...
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index French All times are GMT
Goto page Previous  1, 2, 3, 4, 5  Next
Page 4 of 5

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum