Joined: 12 May 2004
|Posted: Mon Nov 13, 2006 11:26 pm Post subject: [ GLSA 200611-06 ] OpenSSH: Multiple Denial of Service vulne
|Gentoo Linux Security Advisory
Title: OpenSSH: Multiple Denial of Service vulnerabilities (GLSA 200611-06)
Date: November 13, 2006
Several Denial of Service vulnerabilities have been identified in OpenSSH.
OpenSSH is a complete SSH protocol version 1.3, 1.5 and 2.0 implementation and includes sftp client and server support.
Vulnerable: < 4.4_p1-r5
Unaffected: >= 4.4_p1-r5
Architectures: All supported architectures
Tavis Ormandy of the Google Security Team has discovered a pre-authentication vulnerability, causing sshd to spin until the login grace time has been expired. Mark Dowd found an unsafe signal handler that was vulnerable to a race condition. It has also been discovered that when GSSAPI authentication is enabled, GSSAPI will in certain cases incorrectly abort.
The pre-authentication and signal handler vulnerabilities can cause a Denial of Service in OpenSSH. The vulnerability in the GSSAPI authentication abort could be used to determine the validity of usernames on some platforms.
There is no known workaround at this time.
All OpenSSH users should upgrade to the latest version:
|# emerge --sync
# emerge --ask --oneshot --verbose ">=net-misc/openssh-4.4_p1-r5"
OpenSSH Security Advisory