Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
OpenOffice 2.0.4 and ugly fonts in UI
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Documentation, Tips & Tricks
View previous topic :: View next topic  
Author Message
prymitive
Apprentice
Apprentice


Joined: 13 Jun 2004
Posts: 260

PostPosted: Tue Nov 07, 2006 9:53 pm    Post subject: OpenOffice 2.0.4 and ugly fonts in UI Reply with quote

I compiled openoffice but I got ugly fonts in UI, I dig into it a little and it appears that oo works best with freetype 2.2.1 but this version is masked in portage, if You want to have better looking oo unamsk freetype 2.2.1 and upgrade or compile manualy freetype 2.2.1 and put it in /usr/local/lib, than run oo with LD_PRELOAD=/usr/local/lib/libfreetype.so oo{writer2,draw2,whatever2}.
Back to top
View user's profile Send private message
Konsti
l33t
l33t


Joined: 10 Dec 2002
Posts: 691

PostPosted: Wed Nov 08, 2006 10:05 am    Post subject: Reply with quote

You could try OOO_FORCE_DESKTOP=gnome also. This changes the UI on my debian a bit, but the UI font is still ugly. Don't know why OOO has to have these ugly UI.
_________________
konsti@jabber.org
Back to top
View user's profile Send private message
prymitive
Apprentice
Apprentice


Joined: 13 Jun 2004
Posts: 260

PostPosted: Wed Nov 08, 2006 10:35 am    Post subject: Reply with quote

Konsti wrote:
You could try OOO_FORCE_DESKTOP=gnome also. This changes the UI on my debian a bit, but the UI font is still ugly. Don't know why OOO has to have these ugly UI.


I guess that this forces oo to use gtk widgets, I'm using kde so I will stick with qt, I tried gtk widgets but that didn't change anything with fonts, switching to freetype 2.2.1 did the trick.
Back to top
View user's profile Send private message
DerMojo
Guru
Guru


Joined: 14 Aug 2003
Posts: 395
Location: Germany

PostPosted: Wed Nov 08, 2006 12:54 pm    Post subject: Reply with quote

OOO_FORCE_DESKTOP=kde also works ...
_________________
To err is human, to forgive, beyond the scope of the Operating System.
Back to top
View user's profile Send private message
prymitive
Apprentice
Apprentice


Joined: 13 Jun 2004
Posts: 260

PostPosted: Wed Nov 08, 2006 12:56 pm    Post subject: Reply with quote

DerMojo wrote:
OOO_FORCE_DESKTOP=kde also works ...


and what more that a widgets for a given de will You get by that? I'm all about fonts in UI, not buttons and other controls.
Back to top
View user's profile Send private message
Konsti
l33t
l33t


Joined: 10 Dec 2002
Posts: 691

PostPosted: Wed Nov 08, 2006 1:22 pm    Post subject: Reply with quote

The environment variable changed the UI (which I did not attempt) and also the fint, so it looks a bit better.
_________________
konsti@jabber.org
Back to top
View user's profile Send private message
Insanity5902
Veteran
Veteran


Joined: 23 Jan 2004
Posts: 1228
Location: Fort Worth, Texas

PostPosted: Wed Nov 08, 2006 1:45 pm    Post subject: Reply with quote

prymitive wrote:
DerMojo wrote:
OOO_FORCE_DESKTOP=kde also works ...


and what more that a widgets for a given de will You get by that? I'm all about fonts in UI, not buttons and other controls.


It just doesn't change the widgets but grabs all the settings from that particular UI, otherwise it just uses java settings. Switching it to gnome or kde will use gtk or qt widgets and their current fonts settings, which might fix your font issues without having to emerge a ~ package
_________________
GibbonsR.net | OpenLaptops.org

Join the adopt an unanswered post initiative today
Back to top
View user's profile Send private message
prymitive
Apprentice
Apprentice


Joined: 13 Jun 2004
Posts: 260

PostPosted: Wed Nov 08, 2006 1:49 pm    Post subject: Reply with quote

Insanity5902 wrote:
prymitive wrote:
DerMojo wrote:
OOO_FORCE_DESKTOP=kde also works ...


and what more that a widgets for a given de will You get by that? I'm all about fonts in UI, not buttons and other controls.


It just doesn't change the widgets but grabs all the settings from that particular UI, otherwise it just uses java settings. Switching it to gnome or kde will use gtk or qt widgets and their current fonts settings, which might fix your font issues without having to emerge a ~ package


I'm running kde so openoffice uses kde settings, isn't it? My fonts have no antialiasing unless I load openoffice with freetype 2.2, it's not about settings for any DE.
Back to top
View user's profile Send private message
Insanity5902
Veteran
Veteran


Joined: 23 Jan 2004
Posts: 1228
Location: Fort Worth, Texas

PostPosted: Wed Nov 08, 2006 5:30 pm    Post subject: Reply with quote

If it matches your KDE desktop them yes, it is using KDE. Some WM don't report things correctly and this causes problems. FVWM is one none culprit, not sure it is their Fault or OpenOffice's or neither. But setting the OOO_FORCE_DESKTOP fixes a lot of visibility issues in OO.org

I didn't realize you were trying to get the antialias to work. That is a nice fix for it though.
_________________
GibbonsR.net | OpenLaptops.org

Join the adopt an unanswered post initiative today
Back to top
View user's profile Send private message
kaktyc
Tux's lil' helper
Tux's lil' helper


Joined: 14 Aug 2004
Posts: 100
Location: Russia, Vologda

PostPosted: Tue Nov 14, 2006 9:35 pm    Post subject: Reply with quote

prymitive wrote:
I compiled openoffice but I got ugly fonts in UI, I dig into it a little and it appears that oo works best with freetype 2.2.1 but this version is masked in portage, if You want to have better looking oo unamsk freetype 2.2.1 and upgrade or compile manualy freetype 2.2.1 and put it in /usr/local/lib, than run oo with LD_PRELOAD=/usr/local/lib/libfreetype.so oo{writer2,draw2,whatever2}.

Hi! I tried new freetype but UI fonts still are ugly. Could you post screenshots before applying LD_PRELOAD hack and after?
Back to top
View user's profile Send private message
prymitive
Apprentice
Apprentice


Joined: 13 Jun 2004
Posts: 260

PostPosted: Tue Nov 14, 2006 9:50 pm    Post subject: Reply with quote

Check if You have antialiasing enabled (Options->View)

before: http://img115.imageshack.us/img115/5700/d7kp2.png

after: http://img402.imageshack.us/img402/9417/d6xx9.png
Back to top
View user's profile Send private message
kaktyc
Tux's lil' helper
Tux's lil' helper


Joined: 14 Aug 2004
Posts: 100
Location: Russia, Vologda

PostPosted: Tue Nov 14, 2006 10:45 pm    Post subject: Reply with quote

Yes, I have antialiasing enabled. I noticed that only Tahoma font has this problem. All other fonts look fine.

http://img484.imageshack.us/img484/4605/tahomacu4.png
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Documentation, Tips & Tricks All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum