Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[ GLSA 200611-02 ] Qt: Integer overflow
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index News & Announcements
View previous topic :: View next topic  
Author Message
GLSA
Veteran
Veteran


Joined: 12 May 2004
Posts: 1471

PostPosted: Mon Nov 06, 2006 3:26 pm    Post subject: [ GLSA 200611-02 ] Qt: Integer overflow Reply with quote

Gentoo Linux Security Advisory

Title: Qt: Integer overflow (GLSA 200611-02)
Severity: normal
Exploitable: remote
Date: November 06, 2006
Updated: January 09, 2009
Bug(s): #151838
ID: 200611-02

Synopsis

An integer overflow flaw in the Qt pixmap handling could possibly lead to a Denial of Service or the remote execution of arbitrary code.

Background

Qt is a cross-platform GUI toolkit, which is used e.g. by KDE.

Affected Packages

Package: x11-libs/qt
Vulnerable: < 4.1.4-r2
Unaffected: >= 4.1.4-r2
Unaffected: >= 3.3.6-r4 < 3.3.7
Unaffected: >= 3.3.8 < 3.3.9
Unaffected: >= 3.3.8b < 3.3.9
Architectures: All supported architectures


Description

An integer overflow flaw has been found in the pixmap handling of Qt.

Impact

By enticing a user to open a specially crafted pixmap image in an application using Qt, e.g. Konqueror, a remote attacker could be able to cause an application crash or the execution of arbitrary code with the rights of the user running the application.

Workaround

There is no known workaround at this time.

Resolution

All Qt 3.x users should upgrade to the latest version:
Code:
# emerge --sync
# emerge --ask --oneshot --verbose ">=x11-libs/qt-3.3.6-r4"
All Qt 4.x users should upgrade to the latest version:
Code:
# emerge --sync
# emerge --ask --oneshot --verbose ">=x11-libs/qt-4.1.4-r2"


References

CVE-2006-4811


Last edited by GLSA on Sat Jan 10, 2009 4:18 am; edited 2 times in total
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index News & Announcements All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum