Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
chroot with install -- illegal instruction
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Duplicate Threads
View previous topic :: View next topic  
Author Message
harolds
n00b
n00b


Joined: 11 Jun 2004
Posts: 23
Location: Unionville, CT

PostPosted: Sat Nov 04, 2006 11:37 pm    Post subject: chroot with install -- illegal instruction Reply with quote

I am trying to install on a k3 system with 132M memory. I follow all the the directions for net install up to the chroot.

I get "illegal instruction".

I done a previous install a year or so ago and all when well, though slow.

Any ideas as to what I missed? I doubled checked everything in the handbook.

Harold :(
_________________
Harold in CT
Back to top
View user's profile Send private message
kevman
n00b
n00b


Joined: 22 Sep 2006
Posts: 44
Location: Pittsburgh, PA.

PostPosted: Sun Nov 05, 2006 12:03 am    Post subject: Reply with quote

I've never heard of the k3 CPU, but it looks like its not i686. Download and install the 2006.0 x86 stage and update world on it, or install from 2006.1 stage 1. I recommend the former, having never done a stage 1, and you will end up with the SAME thing either way.
_________________
[INSERT 800x600 SIGPIC HERE]
Back to top
View user's profile Send private message
harolds
n00b
n00b


Joined: 11 Jun 2004
Posts: 23
Location: Unionville, CT

PostPosted: Sun Nov 05, 2006 1:02 am    Post subject: Reply with quote

Sorry. It is a K6-2
_________________
Harold in CT
Back to top
View user's profile Send private message
Ejunkie
n00b
n00b


Joined: 07 Jan 2005
Posts: 58
Location: 127.0.0.1

PostPosted: Sun Nov 05, 2006 2:43 am    Post subject: Reply with quote

i think there's something wrong with your make.conf
Back to top
View user's profile Send private message
mark_alec
Bodhisattva
Bodhisattva


Joined: 11 Sep 2004
Posts: 6066
Location: Melbourne, Australia

PostPosted: Sun Nov 05, 2006 3:13 am    Post subject: Reply with quote

I suspect that you used a i686 stage tarball, which will _not_ work on a k6-2. You need to either use the 2006.0 i586 tarball, or a x86 stage1 tarball from 2006.1.
_________________
www.gentoo.org.au || #gentoo-au
Back to top
View user's profile Send private message
nixnut
Administrator
Administrator


Joined: 09 Apr 2004
Posts: 10973
Location: the dutch mountains

PostPosted: Sun Nov 05, 2006 11:29 am    Post subject: Reply with quote

Moved from Installing Gentoo to Duplicate Threads.
See https://forums.gentoo.org/viewtopic-t-97894-highlight-chroot+illegal+instruction.html
_________________
Please add [solved] to the initial post's subject line if you feel your problem is resolved. Help answer the unanswered

talk is cheap. supply exceeds demand
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Duplicate Threads All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum