Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
python-2.4.3-r1 does not actually support the tk USE flag
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Duplicate Threads
View previous topic :: View next topic  
Author Message
Kasumi_Ninja
Veteran
Veteran


Joined: 18 Feb 2006
Posts: 1825
Location: The Netherlands

PostPosted: Tue Oct 31, 2006 3:35 pm    Post subject: python-2.4.3-r1 does not actually support the tk USE flag Reply with quote

I got this error while emerging python:
Code:

>>> Emerging (1 of 7) dev-python/pyopengl-2.0.0.44 to /
 * PyOpenGL-2.0.0.44.tar.gz MD5 ;-) ...                                                                                                              [ ok ]
 * PyOpenGL-2.0.0.44.tar.gz RMD160 ;-) ...                                                                                                           [ ok ]
 * PyOpenGL-2.0.0.44.tar.gz SHA1 ;-) ...                                                                                                             [ ok ]
 * PyOpenGL-2.0.0.44.tar.gz SHA256 ;-) ...                                                                                                           [ ok ]
 * PyOpenGL-2.0.0.44.tar.gz size ;-) ...                                                                                                             [ ok ]
 * checking ebuild checksums ;-) ...                                                                                                                 [ ok ]
 * checking auxfile checksums ;-) ...                                                                                                                [ ok ]
 * checking miscfile checksums ;-) ...                                                                                                               [ ok ]
 * checking PyOpenGL-2.0.0.44.tar.gz ;-) ...                                                                                                         [ ok ]
>>> Unpacking source...
>>> Unpacking PyOpenGL-2.0.0.44.tar.gz to /var/tmp/portage/pyopengl-2.0.0.44/work
 * Applying config.diff ...                                                                                                                          [ ok ]
 * Applying pyopengl-2.0.0.44-fix_togl.patch ...                                                                                                     [ ok ]

!!! ERROR: dev-python/pyopengl-2.0.0.44 failed.
Call stack:
  ebuild.sh, line 1546:   Called dyn_unpack
  ebuild.sh, line 708:   Called src_unpack
  pyopengl-2.0.0.44.ebuild, line 34:   Called built_with_use 'dev-lang/python' 'tk'
  eutils.eclass, line 1619:   Called die

!!! dev-lang/python-2.4.3-r1 does not actually support the tk USE flag!
!!! If you need support, post the topmost build error, and the call stack if relevant.


I tried adjusting my package.use but this didn't help. Here's my package use:
Code:
dev-python/pyopengl -tk
dev-lang/python -tk


Any ideas what I can do?
_________________
Please add [solved] to the initial post's subject line if you feel your problem is resolved. Help answer the unanswered
Back to top
View user's profile Send private message
limn
l33t
l33t


Joined: 13 May 2005
Posts: 923

PostPosted: Tue Oct 31, 2006 5:41 pm    Post subject: Reply with quote

See this bug.
Back to top
View user's profile Send private message
Kasumi_Ninja
Veteran
Veteran


Joined: 18 Feb 2006
Posts: 1825
Location: The Netherlands

PostPosted: Tue Oct 31, 2006 6:23 pm    Post subject: Reply with quote

Darn I forgot to check bugs.gentoo! :oops: Thanks for the link, I'l try re-emerging python.
_________________
Please add [solved] to the initial post's subject line if you feel your problem is resolved. Help answer the unanswered
Back to top
View user's profile Send private message
nixnut
Bodhisattva
Bodhisattva


Joined: 09 Apr 2004
Posts: 10974
Location: the dutch mountains

PostPosted: Mon Nov 06, 2006 7:07 pm    Post subject: Reply with quote

Moved from Portage & Programming to Duplicate Threads.
Moved in favour of https://forums.gentoo.org/viewtopic-t-512983-highlight-pyopengl.html
_________________
Please add [solved] to the initial post's subject line if you feel your problem is resolved. Help answer the unanswered

talk is cheap. supply exceeds demand
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Duplicate Threads All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum