Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[X] revetement par défaut
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index French
View previous topic :: View next topic  
Author Message
Marsu
Guru
Guru


Joined: 18 Jun 2003
Posts: 329
Location: Lyon

PostPosted: Tue Oct 31, 2006 2:14 pm    Post subject: [X] revetement par défaut Reply with quote

Bonjour,

j'aimerais savoir comment modifier le revetement par défaut des applications X (genre Xfig ou emacs en mode graphique) par défaut c'est un horrible truc blanc et noir inutilisable. Alors que j'ai vu recemment sur je ne sais plus quelle capture d'écran que l'on pouvait remplacer cette horreur par un truc correct.

quelqu'un sait-il comment faire ?

merci de votre aide
_________________
qui ne tente rien n'a rien
Back to top
View user's profile Send private message
Magic Banana
Veteran
Veteran


Joined: 13 Dec 2005
Posts: 1907
Location: Belo Horizonte, Minas Gerais, Brasil

PostPosted: Tue Oct 31, 2006 3:02 pm    Post subject: Reply with quote

Ce sont des programmes à part qui s'occupent de ces décorations. Avec emacs 21.x (que tu as probablement), il est possible d'avoir une interface motif (un peu mieux que X pur et dur mais à peine) en mettant le flag correspondant dans ta variable USE. Mieux tu peux installer emacs-cvs depuis la branche de test qui, lui, a une belle interface gtk (ne pas oublier, encore une fois le flag correspondant).

Pour xfig, je ne sais pas. Comme il n'y a pas de flag particulier, peut-être que ce que tu as vu est un frontend à xfig...
Back to top
View user's profile Send private message
SanKuKai
Apprentice
Apprentice


Joined: 17 Feb 2006
Posts: 228
Location: Toulouse, France

PostPosted: Tue Oct 31, 2006 3:07 pm    Post subject: Reply with quote

Salut.

Les propriétés graphiques des applis X sont gérées par le fichier ~/.Xdefaults.
Par exemple pour modifier les couleurs de ton Xfig (ex : fond gris clair, police noire), il suffirait de rajouter ceci à ton .Xdefaults :
Code:

xfig*foreground:  black
xfig*background: light grey
Back to top
View user's profile Send private message
Marsu
Guru
Guru


Joined: 18 Jun 2003
Posts: 329
Location: Lyon

PostPosted: Tue Oct 31, 2006 4:15 pm    Post subject: Reply with quote

mettre les deux lignes dans .Xdefaults ne change rien, peut être est-ce du au fait j'utilise GDM ?
_________________
qui ne tente rien n'a rien
Back to top
View user's profile Send private message
SanKuKai
Apprentice
Apprentice


Joined: 17 Feb 2006
Posts: 228
Location: Toulouse, France

PostPosted: Tue Oct 31, 2006 4:56 pm    Post subject: Reply with quote

Je ne pense pas que ça vienne de là vu qu'avant j'utilisais mon .Xdefaults pour customiser xosview bien qu'utilisant gdm.
La section X RESOURCES and DEFAULTS de cette page de manuel, laisse à penser que je t'ai donné de mauvaises options et que ce serait plutôt -- toujours dans mon exemple du background gris clair et du foreground noir -- ceci :

Code:

xfig*canvasforeground:  black
xfig*canvasbackground:  light grey


En espérant que ça fonctionne ce coup-ci. ^^
Back to top
View user's profile Send private message
geekounet
Bodhisattva
Bodhisattva


Joined: 11 Oct 2004
Posts: 3772
Location: Wellington, Aotearoa

PostPosted: Tue Oct 31, 2006 5:08 pm    Post subject: Reply with quote

Il faut le charger le fichier après : xrdb -load ~/.Xdefaults

EDIT: j'aimerai bien pouvoir mettre des fontes antialiasées dans ses applications, mais je ne pense pas que ça soit possible.
Back to top
View user's profile Send private message
Marsu
Guru
Guru


Joined: 18 Jun 2003
Posts: 329
Location: Lyon

PostPosted: Tue Oct 31, 2006 7:51 pm    Post subject: Reply with quote

c'est marrant qu'un restart du serveur X ou un reboot ne permettent pas de recharger ces paramètres
_________________
qui ne tente rien n'a rien
Back to top
View user's profile Send private message
Marsu
Guru
Guru


Joined: 18 Jun 2003
Posts: 329
Location: Lyon

PostPosted: Tue Oct 31, 2006 7:55 pm    Post subject: Reply with quote

par contre, merci pour le xrdb, je connaissais pas la commande, et maintenant que je l'ai executée, emacs aussi a un menu correct ... sans que j'aie mis de ligne concernant emacs
_________________
qui ne tente rien n'a rien
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index French All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum