Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[résolut][python] bug emerge tk
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index French
View previous topic :: View next topic  
Author Message
alpha_one_x86
Guru
Guru


Joined: 29 Oct 2006
Posts: 544

PostPosted: Sun Oct 29, 2006 5:40 pm    Post subject: [résolut][python] bug emerge tk Reply with quote

quand je fais: emerge gnome ou emerge cedega ca me fait:
Code:
emerge cedega
Calculating dependencies... done!

>>> Emerging (1 of 11) dev-python/pyopengl-2.0.0.44 to /
 * PyOpenGL-2.0.0.44.tar.gz MD5 ;-) ...                                                                                                 [ ok ]
 * PyOpenGL-2.0.0.44.tar.gz RMD160 ;-) ...                                                                                              [ ok ]
 * PyOpenGL-2.0.0.44.tar.gz SHA1 ;-) ...                                                                                                [ ok ]
 * PyOpenGL-2.0.0.44.tar.gz SHA256 ;-) ...                                                                                              [ ok ]
 * PyOpenGL-2.0.0.44.tar.gz size ;-) ...                                                                                                [ ok ]
 * checking ebuild checksums ;-) ...                                                                                                    [ ok ]
 * checking auxfile checksums ;-) ...                                                                                                   [ ok ]
 * checking miscfile checksums ;-) ...                                                                                                  [ ok ]
 * checking PyOpenGL-2.0.0.44.tar.gz ;-) ...                                                                                            [ ok ]
>>> Unpacking source...
>>> Unpacking PyOpenGL-2.0.0.44.tar.gz to /var/tmp/portage/pyopengl-2.0.0.44/work
 * Applying config.diff ...                                                                                                             [ ok ]
 * Applying pyopengl-2.0.0.44-fix_togl.patch ...                                                                                        [ ok ]

!!! ERROR: dev-python/pyopengl-2.0.0.44 failed.
Call stack:
  ebuild.sh, line 1546:   Called dyn_unpack
  ebuild.sh, line 708:   Called src_unpack
  pyopengl-2.0.0.44.ebuild, line 34:   Called built_with_use 'dev-lang/python' 'tk'
  eutils.eclass, line 1619:   Called die

!!! dev-lang/python-2.4.3-r1 does not actually support the tk USE flag!
!!! If you need support, post the topmost build error, and the call stack if relevant.


Last edited by alpha_one_x86 on Mon Oct 30, 2006 4:34 am; edited 2 times in total
Back to top
View user's profile Send private message
kopp
Advocate
Advocate


Joined: 09 Apr 2004
Posts: 2885
Location: Grenoble, France

PostPosted: Sun Oct 29, 2006 6:05 pm    Post subject: Reply with quote

salut
Essaye ça
Code:
echo "dev-python/pyopengl -tk" >> /etc/portage/package.use

Si le répertoire n'existe pas, mkdir /etc/portage
Pour plus d'info sur ce répertoire et ce fichier, man portage
Sinon, ce qu'on t'a dit précédemment quant au sujet du message, c'est toujours valable.
Back to top
View user's profile Send private message
alpha_one_x86
Guru
Guru


Joined: 29 Oct 2006
Posts: 544

PostPosted: Sun Oct 29, 2006 6:28 pm    Post subject: Reply with quote

sur du qwerty c est dur...

voila jai fait la commande:
Code:
>>> Emerging (1 of 11) dev-python/pyopengl-2.0.0.44 to /
 * PyOpenGL-2.0.0.44.tar.gz MD5 ;-) ...                                   [ ok ]
 * PyOpenGL-2.0.0.44.tar.gz RMD160 ;-) ...                                [ ok ]
 * PyOpenGL-2.0.0.44.tar.gz SHA1 ;-) ...                                  [ ok ]
 * PyOpenGL-2.0.0.44.tar.gz SHA256 ;-) ...                                [ ok ]
 * PyOpenGL-2.0.0.44.tar.gz size ;-) ...                                  [ ok ]
 * checking ebuild checksums ;-) ...                                      [ ok ]
 * checking auxfile checksums ;-) ...                                     [ ok ]
 * checking miscfile checksums ;-) ...                                    [ ok ]
 * checking PyOpenGL-2.0.0.44.tar.gz ;-) ...                              [ ok ]
>>> Unpacking source...
>>> Unpacking PyOpenGL-2.0.0.44.tar.gz to /var/tmp/portage/pyopengl-2.0.0.44/work
 * Applying config.diff ...                                               [ ok ]
 * Applying pyopengl-2.0.0.44-fix_togl.patch ...                          [ ok ]

!!! ERROR: dev-python/pyopengl-2.0.0.44 failed.
Call stack:
  ebuild.sh, line 1546:   Called dyn_unpack
  ebuild.sh, line 708:   Called src_unpack
  pyopengl-2.0.0.44.ebuild, line 34:   Called built_with_use 'dev-lang/python' 'tk'
  eutils.eclass, line 1619:   Called die

!!! dev-lang/python-2.4.3-r1 does not actually support the tk USE flag!
!!! If you need support, post the topmost build error, and the call stack if relevant.


emerge info
Quote:
Portage 2.1.1-r1 (default-linux/amd64/2006.1, gcc-4.1.1, glibc-2.4-r3, 2.6.15-23-amd64-generic x86_64)
=================================================================
System uname: 2.6.15-23-amd64-generic x86_64 AMD Athlon(tm) 64 X2 Dual Core Processor 3800+
Gentoo Base System version 1.12.1
Last Sync: Sun, 29 Oct 2006 13:30:01 +0000
app-admin/eselect-compiler: [Not Present]
dev-java/java-config: [Not Present]
dev-lang/python: 2.4.3-r1
dev-python/pycrypto: 2.0.1-r5
dev-util/ccache: [Not Present]
dev-util/confcache: [Not Present]
sys-apps/sandbox: 1.2.17
sys-devel/autoconf: 2.13, 2.59-r7
sys-devel/automake: 1.4_p6, 1.5, 1.6.3, 1.7.9-r1, 1.8.5-r3, 1.9.6-r2
sys-devel/binutils: 2.16.1-r3
sys-devel/gcc-config: 1.3.13-r3
sys-devel/libtool: 1.5.22
virtual/os-headers: 2.6.11-r2
ACCEPT_KEYWORDS="amd64"
AUTOCLEAN="yes"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-O3 -pipe -march=k8 -msse3 -mfpmath=sse -mcpu=athlon-64 -mtune=k8"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/kde/3.5/env /usr/kde/3.5/share/config /usr/kde/3.5/shutdown /usr/share/X11/xkb /usr/share/config"
CONFIG_PROTECT_MASK="/etc/env.d /etc/gconf /etc/terminfo"
CXXFLAGS="-O3 -pipe -march=k8 -msse3 -mfpmath=sse -mcpu=athlon-64 -mtune=k8"
DISTDIR="/usr/portage/distfiles"
FEATURES="autoconfig distlocks metadata-transfer sandbox sfperms strict"
GENTOO_MIRRORS="http://distfiles.gentoo.org http://distro.ibiblio.org/pub/linux/distributions/gentoo"
LANG="fr_FR.UTF-8"
PKGDIR="/usr/portage/packages"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --delete-after --stats --timeout=180 --exclude='/distfiles' --exclude='/local' --exclude='/packages'"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
SYNC="rsync://rsync.gentoo.org/gentoo-portage"
USE="X alsa amd64 arts avi berkdb bitmap-fonts cairo cdr cli cracklib crypt cups dbus dlloader dri dvd dvdr eds elibc_glibc emboss encode esd fam firefox fortran gdbm gif gnome gpm gstreamer gtk gtk2 hal iconv input_devices_evdev input_devices_keyboard input_devices_mouse ipv6 isdnlog jpeg kde kernel_linux ldap libg++ mad mikmod mp3 mpeg ncurses nls nptl nptlonly ogg opengl oss pam pcre pdflib perl png ppds pppd python qt3 qt4 quicktime readline reflection sdl session spell spl ssl tcpd tk truetype truetype-fonts type1-fonts udev unicode userland_GNU video_cards_apm video_cards_ark video_cards_ati video_cards_chips video_cards_cirrus video_cards_cyrix video_cards_dummy video_cards_fbdev video_cards_glint video_cards_i128 video_cards_i810 video_cards_mga video_cards_neomagic video_cards_nv video_cards_rendition video_cards_s3 video_cards_s3virge video_cards_savage video_cards_siliconmotion video_cards_sis video_cards_sisusb video_cards_tdfx video_cards_tga video_cards_trident video_cards_tseng video_cards_v4l video_cards_vesa video_cards_vga video_cards_via video_cards_vmware video_cards_voodoo vorbis xml xorg xv zlib"
Unset: CTARGET, EMERGE_DEFAULT_OPTS, INSTALL_MASK, LC_ALL, LDFLAGS, LINGUAS, MAKEOPTS, PORTAGE_RSYNC_EXTRA_OPTS, PORTDIR_OVERLAY
Back to top
View user's profile Send private message
netfab
Veteran
Veteran


Joined: 03 Mar 2005
Posts: 1727
Location: 127.0.0.1

PostPosted: Sun Oct 29, 2006 6:39 pm    Post subject: Reply with quote

Salut,

Met ton système à jour, et je pense que çà se réglera tout seul.

Edit : voilà l'explication, je pense.
L'ebuild de pyopengl fait une vérification du flag tk sur python :
Code:

if built_with_use dev-lang/python tk
....

Si python a été compilé à l'époque du flag tcltk, çà donne une erreur.
Back to top
View user's profile Send private message
alpha_one_x86
Guru
Guru


Joined: 29 Oct 2006
Posts: 544

PostPosted: Sun Oct 29, 2006 7:02 pm    Post subject: Reply with quote

comment je le reemerge?
Back to top
View user's profile Send private message
kopp
Advocate
Advocate


Joined: 09 Apr 2004
Posts: 2885
Location: Grenoble, France

PostPosted: Sun Oct 29, 2006 7:12 pm    Post subject: Reply with quote

Si tu as pas besoin de tk, tu ajoutes -tk dans la variable USE dans /etc/make.conf
sinon,
Code:
echo "dev-lang/python -tk" >> /etc/portage/package.use

et puis dans les deux cas,
Code:
emerge -1av python

Au passage, je sais pas si c'est volontaire, mais tu utilises un profil très basique, tu devrais utiliser le 2006.1/Desktop.
Back to top
View user's profile Send private message
alpha_one_x86
Guru
Guru


Joined: 29 Oct 2006
Posts: 544

PostPosted: Sun Oct 29, 2006 7:24 pm    Post subject: Reply with quote

oui je connait pas ce que je doit mettre dans ma variable, il me faut apache, cedega, kde, firefox, gkrellm, xmms, sshd, k2B, j'ai un AMD X2, sur cette carte mere: http://www.rue-montgallet.com/prix/75012/acheter/41377/Gigabyte-GA-M55plus-S3G/, que doit je mettre dans use dans le noyau: genkernel --menuconfig all, comment je fait que eth0 marche en auto avec dhcp?
Back to top
View user's profile Send private message
kopp
Advocate
Advocate


Joined: 09 Apr 2004
Posts: 2885
Location: Grenoble, France

PostPosted: Sun Oct 29, 2006 7:52 pm    Post subject: Reply with quote

Ouhla, je t'arrête tout de suite. XMMS, faut l'oublier. Il va être retiré de l'arbre sous peu. On en a parlé ici
https://forums.gentoo.org/viewtopic-t-509930.html
Sinon, pour USE, il faut mettre ce que tu veux dans la variable USE du fichier /etc/make.conf
AU pire tu peux toujours les changer plus tard si ça te convient pas. J'ai écris une petite doc sur USE, si ça t'intéresse: https://forums.gentoo.org/viewtopic-t-428121.html
Jusqu'à preuve du contraire, je ne crois pas que genkernel se préoccupe de USE.
Pour ta config réseau, cela est expliqué dans la documentation http://www.gentoo.org/doc/fr/handbook/handbook-x86.xml?part=1&chap=8#doc_chap2
Back to top
View user's profile Send private message
alpha_one_x86
Guru
Guru


Joined: 29 Oct 2006
Posts: 544

PostPosted: Sun Oct 29, 2006 7:58 pm    Post subject: Reply with quote

pour mon reseau:

config_eth0=( "dhcp" )
dhcpcd_eth0="-t 10" # On attend une r�onse en 10 secondes maxi.
dhcp_eth0="release nodns nontp nonis"

et ca marche pas, mais tout marche si je lance "dhcpcd"
Back to top
View user's profile Send private message
man in the hill
Veteran
Veteran


Joined: 15 Dec 2005
Posts: 1552
Location: Madinina

PostPosted: Sun Oct 29, 2006 8:17 pm    Post subject: Reply with quote

alpha_one_x86 wrote:
pour mon reseau:

config_eth0=( "dhcp" )
dhcpcd_eth0="-t 10" # On attend une r�onse en 10 secondes maxi.
dhcp_eth0="release nodns nontp nonis"

et ca marche pas, mais tout marche si je lance "dhcpcd"

Tu l'as mis au runlevel:
Code:
rc-update add net.eth0 default

_________________
Get Up and Go !
Back to top
View user's profile Send private message
ryo-san
l33t
l33t


Joined: 17 Feb 2005
Posts: 729

PostPosted: Sun Oct 29, 2006 8:57 pm    Post subject: Reply with quote

lut

Je ne sais pas si c'est encore d'actualité le net.eth0, perso je n'ai plus que net et net.example
Code:

ryo@Gentoo ~ $ cat /etc/conf.d/net
# This blank configuration will automatically use DHCP for any net.*
# scripts in /etc/init.d.  To create a more complete configuration,
# please review /etc/conf.d/net.example and save your configuration


Code:

* sys-apps/baselayout
 Installed:           1.12.5-r2


donc : pas de conf => dhcp auto , a condition d'avoir emergé dhcpcd.
Back to top
View user's profile Send private message
kopp
Advocate
Advocate


Joined: 09 Apr 2004
Posts: 2885
Location: Grenoble, France

PostPosted: Sun Oct 29, 2006 9:06 pm    Post subject: Reply with quote

le net.eth0 c'est dans /etc/init.d/
Il y a toujours eu un seul fichier de configuration pour toutes les interfaces qui est /etc/conf.d/net
Mais il y a un lien symbolique pour chaque interface dans /etc/init.d/
Back to top
View user's profile Send private message
man in the hill
Veteran
Veteran


Joined: 15 Dec 2005
Posts: 1552
Location: Madinina

PostPosted: Sun Oct 29, 2006 10:40 pm    Post subject: Reply with quote

ryo-san wrote:
donc : pas de conf => dhcp auto , a condition d'avoir emergé dhcpcd.


ça c'est OK, c'est comme cela que cela fonctionne par défault mais si tu ne veux pas qu'il te réécrive ton fichier /etc/resolv.conf à chaque fois si tu as ton propre serveur dns comme moi, il vaut mieux faire la conf dans /etc/conf.d/net et rajouter ce genre d'option dhcp_eth0="release nodns nontp nonis"
_________________
Get Up and Go !
Back to top
View user's profile Send private message
ryo-san
l33t
l33t


Joined: 17 Feb 2005
Posts: 729

PostPosted: Mon Oct 30, 2006 12:32 am    Post subject: Reply with quote

arf ...
:roll:

Au temps pour moi , petit embrouillage :)
Back to top
View user's profile Send private message
alpha_one_x86
Guru
Guru


Joined: 29 Oct 2006
Posts: 544

PostPosted: Mon Oct 30, 2006 4:34 am    Post subject: Reply with quote

pour python c'est ok, le reseau je verai appres...
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index French All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum