Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
mc distorted graphics in console mode
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Desktop Environments
View previous topic :: View next topic  
Author Message
Mgiese
Veteran
Veteran


Joined: 23 Mar 2005
Posts: 1279
Location: indiana

PostPosted: Thu Oct 19, 2006 9:15 pm    Post subject: mc distorted graphics in console mode Reply with quote

hi there,

i am using midnight commander but when i use it without X-server i have dissorted letters .. in X its working fine.. any suggestions ?

my useflags are :
Code:
 app-misc/mc-4.6.1  USE="X gpm ncurses nls pam unicode -7zip -samba -slang"


thx a lot in advance
_________________
I do not have a Superman complex, for I am God not Superman :D


Last edited by Mgiese on Fri Oct 27, 2006 2:22 pm; edited 1 time in total
Back to top
View user's profile Send private message
psycepa
Veteran
Veteran


Joined: 27 Dec 2004
Posts: 1637
Location: Poland

PostPosted: Thu Oct 19, 2006 10:30 pm    Post subject: Reply with quote

I have seen somewhere that in such case reemerging ncurses fixes this problem, although I'm not 100% sure, just give it a try, and if you won't succeed, try to search the forum for mc problems, i'm sure I have seen a solution somewhere around here :)
_________________
RLUNo. 376073
bo czytac, to trzeba ze zrozumieniem (c) by psycepa
"nigdy nie kloc sie z glupcem, najpierw sprowadzi cie do swojego poziomu a potem pokona doswiadczeniem"
"Life is complex. It has its real and imaginary part."
Back to top
View user's profile Send private message
widremann
Veteran
Veteran


Joined: 14 Mar 2005
Posts: 1314

PostPosted: Fri Oct 20, 2006 12:20 am    Post subject: Reply with quote

Same problem. Something with unicode I think. Nobody gives a good answer though.
Back to top
View user's profile Send private message
swimmer
Veteran
Veteran


Joined: 15 Jul 2002
Posts: 1287
Location: Netherlands

PostPosted: Fri Oct 20, 2006 10:06 am    Post subject: Reply with quote

Re-emerging mc with the 'slang' use-flag should fix your problem ...

HTH
swimmer
Back to top
View user's profile Send private message
Mgiese
Veteran
Veteran


Joined: 23 Mar 2005
Posts: 1279
Location: indiana

PostPosted: Sat Oct 21, 2006 8:38 pm    Post subject: Reply with quote

Code:
emerge ncurses
and
Code:
USE="slang" emerge mc
wasnt fixing my problem.. the error i can see when i run mc is :
Code:
*** err [lib/liblow.c:(329)]:
this just happens into the console not when using the console in x ..
_________________
I do not have a Superman complex, for I am God not Superman :D
Back to top
View user's profile Send private message
fantalin
n00b
n00b


Joined: 30 Jul 2006
Posts: 8

PostPosted: Thu Oct 26, 2006 8:03 pm    Post subject: Reply with quote

liblow.c is caused due to a missing device
Start gpm service:
/etc/init.d/gpm start

Disable the gpm - useflag might help also.
Back to top
View user's profile Send private message
widremann
Veteran
Veteran


Joined: 14 Mar 2005
Posts: 1314

PostPosted: Fri Oct 27, 2006 12:04 am    Post subject: Reply with quote

swimmer wrote:
Re-emerging mc with the 'slang' use-flag should fix your problem ...

HTH
swimmer

Nope. Other ncurses-type apps like MOC are also not working. I followed the Unicode guide and now I get |, - and + for box drawing instead of the old PC box drawing chars that I'm used to (and that actually look nice). What's going on?
Back to top
View user's profile Send private message
Mgiese
Veteran
Veteran


Joined: 23 Mar 2005
Posts: 1279
Location: indiana

PostPosted: Fri Oct 27, 2006 2:22 pm    Post subject: Reply with quote

fantalin wrote:

/etc/init.d/gpm start
i tried that, the libc error is gone, but the graphic in mc is still distorted .. :(
_________________
I do not have a Superman complex, for I am God not Superman :D
Back to top
View user's profile Send private message
psycepa
Veteran
Veteran


Joined: 27 Dec 2004
Posts: 1637
Location: Poland

PostPosted: Fri Oct 27, 2006 8:08 pm    Post subject: Reply with quote

if the problem looks like here: http://img343.imageshack.us/img343/4259/mc5gq.png
the solution is to set proper encoding
in our (polish) forum the solution was given as follows:
/etc/rc.conf
Code:

UNICODE="no"



/etc/conf.d/consolefont
Code:

CONSOLEFONT="lat2-16"
CONSOLETRANSLATION="8859-2_to_uni"

Hope this helps

--edit--
some say that it will work even with UNICODE="yes" :wink:
_________________
RLUNo. 376073
bo czytac, to trzeba ze zrozumieniem (c) by psycepa
"nigdy nie kloc sie z glupcem, najpierw sprowadzi cie do swojego poziomu a potem pokona doswiadczeniem"
"Life is complex. It has its real and imaginary part."
Back to top
View user's profile Send private message
Mgiese
Veteran
Veteran


Joined: 23 Mar 2005
Posts: 1279
Location: indiana

PostPosted: Wed Nov 15, 2006 5:58 pm    Post subject: Reply with quote

hey THX a LOT , that was finaly helping me ... its was exact the error that the picture described...
_________________
I do not have a Superman complex, for I am God not Superman :D
Back to top
View user's profile Send private message
psycepa
Veteran
Veteran


Joined: 27 Dec 2004
Posts: 1637
Location: Poland

PostPosted: Thu Nov 16, 2006 11:00 pm    Post subject: Reply with quote

happy to help
greetz
_________________
RLUNo. 376073
bo czytac, to trzeba ze zrozumieniem (c) by psycepa
"nigdy nie kloc sie z glupcem, najpierw sprowadzi cie do swojego poziomu a potem pokona doswiadczeniem"
"Life is complex. It has its real and imaginary part."
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Desktop Environments All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum