Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[Solved] Emerge --sync, emerge won't work anymore
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Duplicate Threads
View previous topic :: View next topic  
Author Message
Lowrider
n00b
n00b


Joined: 20 May 2004
Posts: 27
Location: Italy

PostPosted: Mon Oct 16, 2006 4:58 pm    Post subject: [Solved] Emerge --sync, emerge won't work anymore Reply with quote

i just launched emerge --sync (as i do usually) and everything went fine until i recived this :

Code:
Performing Global Updates: /usr/portage/profiles/updates/3Q-2006
(Could take a couple of minutes if you have a lot of binary packages.)
  .='update pass'  *='binary update'  @='/var/db move'
  s='/var/db SLOT move' S='binary SLOT move' p='update /etc/portage/package.*'
..............
pTraceback (most recent call last):
  File "/usr/bin/emerge", line 4049, in ?
    emerge_main()
  File "/usr/bin/emerge", line 3770, in emerge_main
    portage.global_updates(settings, trees, mtimedb["updates"])
  File "/usr/lib/portage/pym/portage.py", line 6656, in global_updates
    myupd)
  File "/usr/lib/portage/pym/portage_update.py", line 198, in update_config_files
    write_atomic(updating_file, "".join(file_contents[x]))
  File "/usr/lib/portage/pym/portage_util.py", line 728, in write_atomic
    f.close()
  File "/usr/lib/portage/pym/portage_util.py", line 696, in close
    os.rename(self.name, self._real_name)
OSError: [Errno 16] Device or resource busy


almost at the end of the sync. from now on i can't use emerge , because i always get the same message.
i don't know what to do ! anybody has some clue ?

( pardom my n00bness if this is a n00b question )
_________________
I am the bullet in the gun
I am the truth from witch you run
I am the silencing machine
I am the end of all your dreams


Last edited by Lowrider on Sat Oct 21, 2006 10:58 am; edited 2 times in total
Back to top
View user's profile Send private message
nixnut
Administrator
Administrator


Joined: 09 Apr 2004
Posts: 10973
Location: the dutch mountains

PostPosted: Mon Oct 16, 2006 5:16 pm    Post subject: Reply with quote

Code:
OSError: [Errno 16] Device or resource busy

Looks like a problem accessing the... filesystem probably. Does this always happen? Even after reboots?
_________________
Please add [solved] to the initial post's subject line if you feel your problem is resolved. Help answer the unanswered

talk is cheap. supply exceeds demand
Back to top
View user's profile Send private message
masterdriverz
Retired Dev
Retired Dev


Joined: 28 Mar 2006
Posts: 391
Location: Far out in the uncharted backwaters of the unfashionable end of the Western Spiral arm of the galaxy

PostPosted: Mon Oct 16, 2006 5:22 pm    Post subject: Reply with quote

Try and upgrade portage - this only happens in one version of portage IIRC
_________________
Solutions to misc kde problems
Back to top
View user's profile Send private message
Lowrider
n00b
n00b


Joined: 20 May 2004
Posts: 27
Location: Italy

PostPosted: Mon Oct 16, 2006 5:45 pm    Post subject: Reply with quote

no it never happened before !

but how do i upgrade portage if i can't use emerge command ?
_________________
I am the bullet in the gun
I am the truth from witch you run
I am the silencing machine
I am the end of all your dreams
Back to top
View user's profile Send private message
masterdriverz
Retired Dev
Retired Dev


Joined: 28 Mar 2006
Posts: 391
Location: Far out in the uncharted backwaters of the unfashionable end of the Western Spiral arm of the galaxy

PostPosted: Thu Oct 19, 2006 8:07 pm    Post subject: Reply with quote

See here.
_________________
Solutions to misc kde problems
Back to top
View user's profile Send private message
lots
Tux's lil' helper
Tux's lil' helper


Joined: 11 Mar 2003
Posts: 95

PostPosted: Thu Oct 19, 2006 8:35 pm    Post subject: Reply with quote

I emerge --sync'd today as well, I have exactly the same problem, and the above link did not work. I followed the manual fix howto and used the portage-2.1.1.tar.bz2 file from http://distfiles.gentoo.org/distfiles. That did not help. I still get exactly the same error as the OP
Back to top
View user's profile Send private message
masterdriverz
Retired Dev
Retired Dev


Joined: 28 Mar 2006
Posts: 391
Location: Far out in the uncharted backwaters of the unfashionable end of the Western Spiral arm of the galaxy

PostPosted: Fri Oct 20, 2006 5:39 am    Post subject: Reply with quote

Did you have a look here?
_________________
Solutions to misc kde problems
Back to top
View user's profile Send private message
alk
n00b
n00b


Joined: 13 Jul 2004
Posts: 52

PostPosted: Fri Oct 20, 2006 6:03 am    Post subject: Reply with quote

there's a problem with latest portage snapshot on some (or maybe all) mirrors - portage-latest filesize is about 6 Mb
you should download former portage snapshot and unpack it to your /usr and run emerge --metadata then

yep http://distfiles.gentoo.org/snapshots/ is broken too
portage-latest.tar.bz2 19-Oct-2006 21:57 6.2M
portage-20061019.tar.bz2 19-Oct-2006 21:57 6.2M
portage-20061018.tar.bz2 18-Oct-2006 21:57 32M

use portage-20061018.tar.bz2 to repair your system


Last edited by alk on Fri Oct 20, 2006 6:23 am; edited 1 time in total
Back to top
View user's profile Send private message
lots
Tux's lil' helper
Tux's lil' helper


Joined: 11 Mar 2003
Posts: 95

PostPosted: Fri Oct 20, 2006 6:05 am    Post subject: Reply with quote

Anything having to do with the emerge command is broken. It spits out the same stuff as posted above if you do the following:

emerge --sync
emerge -h
emerge portage

... etc etc.. basically anything that begins with emerge :P

You get the idea. This happened after doing an emerge --sync, which seems to have failed. It ends with the quote above in the OP's first post.
Back to top
View user's profile Send private message
lots
Tux's lil' helper
Tux's lil' helper


Joined: 11 Mar 2003
Posts: 95

PostPosted: Fri Oct 20, 2006 1:05 pm    Post subject: Reply with quote

I tried out puting the portage tree from the 18th in, the 32M one. I ran emerge --metadata, and it spit out the same old error from the first post :) Also, I have done the manually fixing portage, by downloading and replacing the binaries as per the manual-fix instructions... I'm at a loss...

Who knew emerge --sync was dangerous :P


Last edited by lots on Fri Oct 20, 2006 1:21 pm; edited 1 time in total
Back to top
View user's profile Send private message
alk
n00b
n00b


Joined: 13 Jul 2004
Posts: 52

PostPosted: Fri Oct 20, 2006 1:20 pm    Post subject: Reply with quote

http://distfiles.gentoo.org/snapshots/
seems to be fixed for now

so just download latest snapshot from http://distfiles.gentoo.org/snapshots/
unpack it to /usr overwriting existing /usr/portage
and run emerge --metadata
Back to top
View user's profile Send private message
lots
Tux's lil' helper
Tux's lil' helper


Joined: 11 Mar 2003
Posts: 95

PostPosted: Fri Oct 20, 2006 1:23 pm    Post subject: Reply with quote

I'll try with the latest.

Nope no luck.
Back to top
View user's profile Send private message
alk
n00b
n00b


Joined: 13 Jul 2004
Posts: 52

PostPosted: Fri Oct 20, 2006 1:35 pm    Post subject: Reply with quote

you did it pretty fast
3 minutes ... did you made it proper?

p.s check your profile links also
Back to top
View user's profile Send private message
lots
Tux's lil' helper
Tux's lil' helper


Joined: 11 Mar 2003
Posts: 95

PostPosted: Fri Oct 20, 2006 1:56 pm    Post subject: Reply with quote

Heh, well my edit didnt appear to leave a time stamp :) Plus I was already doing it before you had posted your message.

I did unpack the portage-latest.tar.bz2 file and dropped it into /usr/portage
I then ran emerge --metadata, which resulted in the same error i've been getting this whole time

I did an equery check portage, just for kicks :P It appears my mtime is not right...

Code:

 # equery check portage
[ Checking sys-apps/portage-2.1.1 ]
!!! /usr/lib/portage/bin/doman has wrong mtime (is 1161289772, should be 1158349699)
!!! /usr/lib/portage/pym/cache/metadata.py has wrong mtime (is 1161289772, should be 1158349699)
!!! /usr/lib/portage/bin/clean_locks has wrong mtime (is 1161289772, should be 1158349699)
!!! /usr/lib/portage/bin/misc-functions.sh has wrong mtime (is 1161289772, should be 1158349699)
!!! /usr/lib/portage/bin/newman has wrong mtime (is 1161289772, should be 1158349699)
!!! /usr/lib/portage/pym/portage_dep.py has wrong mtime (is 1161289772, should be 1158349699)
!!! /usr/lib/portage/pym/emergehelp.py has wrong mtime (is 1161289772, should be 1158349699)
!!! /usr/lib/portage/pym/portage.py has wrong mtime (is 1161289772, should be 1158349699)
!!! /usr/lib/portage/pym/cache/metadata_overlay.py has wrong mtime (is 1161289772, should be 1158349699)
!!! /usr/lib/portage/pym/portage_checksum.py has wrong mtime (is 1161289772, should be 1158349699)
!!! /usr/lib/portage/bin/fixpackages has wrong mtime (is 1161289772, should be 1158349699)
!!! /usr/lib/portage/bin/newsbin has wrong mtime (is 1161289772, should be 1158349699)
!!! /usr/lib/portage/bin/dodoc has wrong mtime (is 1161289772, should be 1158349699)
!!! /usr/lib/portage/bin/newinitd has wrong mtime (is 1161289772, should be 1158349699)
!!! /usr/lib/portage/bin/prepalldocs has wrong mtime (is 1161289772, should be 1158349699)
!!! /usr/lib/portage/pym/elog_modules/mod_save.py has wrong mtime (is 1161289772, should be 1158349699)
!!! /usr/lib/portage/pym/cache/fs_template.py has wrong mtime (is 1161289772, should be 1158349699)
!!! /usr/lib/portage/bin/newdoc has wrong mtime (is 1161289772, should be 1158349699)
!!! /usr/lib/portage/bin/find-requires has wrong mtime (is 1161289772, should be 1158349699)
!!! /usr/lib/portage/pym/portage_exec.py has wrong mtime (is 1161289772, should be 1158349699)
!!! /usr/lib/portage/bin/doins has wrong mtime (is 1161289772, should be 1158349699)
!!! /usr/lib/portage/bin/newconfd has wrong mtime (is 1161289772, should be 1158349699)
!!! /usr/lib/portage/bin/newins has wrong mtime (is 1161289772, should be 1158349699)
!!! /usr/lib/portage/pym/output.py has wrong mtime (is 1161289772, should be 1158349699)
!!! /usr/lib/portage/bin/domo has wrong mtime (is 1161289772, should be 1158349699)
!!! /usr/lib/portage/bin/prepman has wrong mtime (is 1161289772, should be 1158349699)
!!! /usr/lib/portage/bin/fixdbentries has wrong mtime (is 1161289772, should be 1158349699)
!!! /usr/lib/portage/pym/cache/mappings.py has wrong mtime (is 1161289772, should be 1158349699)
!!! /usr/lib/portage/pym/cache/__init__.py has wrong mtime (is 1161289772, should be 1158349699)
!!! /usr/lib/portage/bin/fowners has wrong mtime (is 1161289772, should be 1158349699)
!!! /usr/lib/portage/pym/elog_modules/mod_custom.py has wrong mtime (is 1161289772, should be 1158349699)
!!! /usr/lib/portage/bin/dohard has wrong mtime (is 1161289772, should be 1158349699)
!!! /usr/lib/portage/bin/prepinfo has wrong mtime (is 1161289772, should be 1158349699)
!!! /usr/lib/portage/pym/cache/flat_hash.py has wrong mtime (is 1161289772, should be 1158349699)
!!! /usr/lib/portage/bin/pkgname has wrong mtime (is 1161289772, should be 1158349699)
!!! /usr/lib/portage/pym/portage_selinux.py has wrong mtime (is 1161289772, should be 1158349699)
!!! /usr/lib/portage/pym/portage_localization.py has wrong mtime (is 1161289772, should be 1158349699)
!!! /usr/lib/portage/bin/doconfd has wrong mtime (is 1161289772, should be 1158349699)
!!! /usr/lib/portage/bin/emaint has wrong mtime (is 1161289772, should be 1158349699)
!!! /usr/lib/portage/pym/cvstree.py has wrong mtime (is 1161289772, should be 1158349699)
!!! /usr/lib/portage/bin/dosbin has wrong mtime (is 1161289772, should be 1158349699)
!!! /usr/lib/portage/pym/cache/util.py has wrong mtime (is 1161289772, should be 1158349699)
!!! /usr/lib/portage/bin/doexe has wrong mtime (is 1161289772, should be 1158349699)
!!! /usr/lib/portage/bin/dolib.so has wrong mtime (is 1161289772, should be 1158349699)
!!! /usr/lib/portage/bin/pkgmerge has wrong mtime (is 1161289772, should be 1158349699)
!!! /usr/lib/portage/bin/env-update has wrong mtime (is 1161289772, should be 1158349699)
!!! /usr/lib/portage/bin/doinitd has wrong mtime (is 1161289772, should be 1158349699)
!!! /usr/lib/portage/bin/ebuild has wrong mtime (is 1161289772, should be 1158349699)
!!! /usr/lib/portage/bin/md5check.py has wrong mtime (is 1161289772, should be 1158349699)
!!! /usr/lib/portage/pym/cache/anydbm.py has wrong mtime (is 1161289772, should be 1158349699)
!!! /usr/lib/portage/bin/regenworld has wrong mtime (is 1161289772, should be 1158349699)
!!! /usr/lib/portage/pym/dispatch_conf.py has wrong mtime (is 1161289772, should be 1158349699)
!!! /usr/lib/portage/pym/eclass_cache.py has wrong mtime (is 1161289772, should be 1158349699)
!!! /usr/lib/portage/pym/cache/sqlite.py has wrong mtime (is 1161289772, should be 1158349699)
!!! /usr/lib/portage/pym/portage_versions.py has wrong mtime (is 1161289772, should be 1158349699)
!!! /usr/lib/portage/bin/dispatch-conf has wrong mtime (is 1161289772, should be 1158349699)
!!! /usr/lib/portage/bin/prepallinfo has wrong mtime (is 1161289772, should be 1158349699)
!!! /usr/lib/portage/bin/dolib.a has wrong mtime (is 1161289772, should be 1158349699)
!!! /usr/lib/portage/bin/pkgmerge.new has wrong mtime (is 1161289772, should be 1158349699)
!!! /usr/lib/portage/bin/isolated-functions.sh has wrong mtime (is 1161289772, should be 1158349699)
!!! /usr/lib/portage/bin/emerge-webrsync has wrong mtime (is 1161289772, should be 1158349699)
!!! /usr/lib/portage/pym/portage_update.py has wrong mtime (is 1161289772, should be 1158349699)
!!! /usr/lib/portage/pym/elog_modules/mod_mail.py has wrong mtime (is 1161289772, should be 1158349699)
!!! /usr/lib/portage/pym/portage_manifest.py has wrong mtime (is 1161289772, should be 1158349699)
!!! /usr/lib/portage/pym/xpak.py has wrong mtime (is 1161289772, should be 1158349699)
!!! /usr/lib/portage/bin/dobin has wrong mtime (is 1161289772, should be 1158349699)
!!! /usr/lib/portage/bin/prepallman has wrong mtime (is 1161289772, should be 1158349699)
!!! /usr/lib/portage/bin/fix-db.py has wrong mtime (is 1161289772, should be 1158349699)
!!! /usr/lib/portage/pym/portage_exception.py has wrong mtime (is 1161289772, should be 1158349699)
!!! /usr/lib/portage/bin/dosym has wrong mtime (is 1161289772, should be 1158349699)
!!! /usr/lib/portage/bin/doenvd has wrong mtime (is 1161289772, should be 1158349699)
!!! /usr/lib/portage/bin/emake has wrong mtime (is 1161289772, should be 1158349699)
!!! /usr/lib/portage/pym/elog_modules/mod_syslog.py has wrong mtime (is 1161289772, should be 1158349699)
!!! /usr/lib/portage/pym/cache/template.py has wrong mtime (is 1161289772, should be 1158349699)
!!! /usr/lib/portage/bin/portageq has wrong mtime (is 1161289772, should be 1158349699)
!!! /usr/lib/portage/bin/newlib.so has wrong mtime (is 1161289772, should be 1158349699)
!!! /usr/lib/portage/pym/portage_data.py has wrong mtime (is 1161289772, should be 1158349699)
!!! /usr/lib/portage/bin/prepallstrip has wrong mtime (is 1161289772, should be 1158349699)
!!! /usr/lib/portage/bin/newlib.a has wrong mtime (is 1161289772, should be 1158349699)
!!! /usr/lib/portage/bin/dohtml has wrong mtime (is 1161289772, should be 1158349699)
!!! /usr/lib/portage/bin/xpak has wrong mtime (is 1161289772, should be 1158349699)
!!! /usr/lib/portage/bin/dosed has wrong mtime (is 1161289772, should be 1158349699)
!!! /usr/lib/portage/bin/env-update.sh has wrong mtime (is 1161289772, should be 1158349699)
!!! /usr/lib/portage/bin/fperms has wrong mtime (is 1161289772, should be 1158349699)
!!! /usr/lib/portage/bin/newexe has wrong mtime (is 1161289772, should be 1158349699)
!!! /usr/lib/portage/pym/portage_util.py has wrong mtime (is 1161289772, should be 1158349699)
!!! /usr/lib/portage/bin/dolib has wrong mtime (is 1161289772, should be 1158349699)
!!! /usr/lib/portage/bin/md5check.sh has wrong mtime (is 1161289772, should be 1158349699)
!!! /usr/lib/portage/bin/archive-conf has wrong mtime (is 1161289772, should be 1158349699)
!!! /usr/lib/portage/pym/portage_debug.py has wrong mtime (is 1161289772, should be 1158349699)
!!! /usr/lib/portage/pym/portage_gpg.py has wrong mtime (is 1161289772, should be 1158349699)
!!! /usr/lib/portage/bin/dodir has wrong mtime (is 1161289772, should be 1158349699)
!!! /usr/lib/portage/bin/etc-update has wrong mtime (is 1161289772, should be 1158349699)
!!! /usr/lib/portage/bin/ebuild.sh has wrong mtime (is 1161289772, should be 1158349699)
!!! /usr/lib/portage/pym/portage_const.py has wrong mtime (is 1161289772, should be 1158349699)
!!! /usr/lib/portage/pym/elog_modules/__init__.py has wrong mtime (is 1161289772, should be 1158349699)
!!! /usr/lib/portage/pym/portage_mail.py has wrong mtime (is 1161289772, should be 1158349699)
!!! /usr/lib/portage/pym/portage_locks.py has wrong mtime (is 1161289772, should be 1158349699)
!!! /usr/lib/portage/bin/newbin has wrong mtime (is 1161289772, should be 1158349699)
!!! /usr/lib/portage/bin/emerge has wrong mtime (is 1161289772, should be 1158349699)
!!! /usr/lib/portage/bin/prepall has wrong mtime (is 1161289772, should be 1158349699)
!!! /usr/lib/portage/pym/cache/flat_list.py has wrong mtime (is 1161289772, should be 1158349699)
!!! /usr/lib/portage/bin/newenvd has wrong mtime (is 1161289772, should be 1158349699)
!!! /usr/lib/portage/pym/cache/cache_errors.py has wrong mtime (is 1161289772, should be 1158349699)
!!! /usr/lib/portage/bin/doinfo has wrong mtime (is 1161289772, should be 1158349699)
!!! /usr/lib/portage/bin/quickpkg has wrong mtime (is 1161289772, should be 1158349699)
!!! /usr/lib/portage/bin/portage_gpg_update.sh has wrong mtime (is 1161289772, should be 1158349699)
!!! /usr/lib/portage/bin/preplib has wrong mtime (is 1161289772, should be 1158349699)
!!! /usr/lib/portage/pym/cache/sql_template.py has wrong mtime (is 1161289772, should be 1158349699)
!!! /usr/lib/portage/pym/getbinpkg.py has wrong mtime (is 1161289772, should be 1158349699)
!!! /usr/lib/portage/bin/chkcontents has wrong mtime (is 1161289772, should be 1158349699)
!!! /usr/lib/portage/bin/repoman has wrong mtime (is 1161289772, should be 1158349699)
!!! /usr/lib/portage/bin/prepstrip has wrong mtime (is 1161289772, should be 1158349699)
 * 55 out of 168 files good
Back to top
View user's profile Send private message
alk
n00b
n00b


Joined: 13 Jul 2004
Posts: 52

PostPosted: Fri Oct 20, 2006 2:26 pm    Post subject: Reply with quote

that's ok, as you've changed this files manualy

please check twice that you don't have /usr/portage/portage/ ;)
Back to top
View user's profile Send private message
lots
Tux's lil' helper
Tux's lil' helper


Joined: 11 Mar 2003
Posts: 95

PostPosted: Fri Oct 20, 2006 2:29 pm    Post subject: Reply with quote

Yeah, that would be silly :)

I dont, I have the usual /usr/portage directory listing. Everything there looks ok. And there is no /usr/portage/portage ;)[/code]

Since this happened during an emerge --sync, I suspect that the update somehow broke something, and its kinda stuck in some "update mode" Because it tries to always finish the emerge --sync whenever I use emerge.
Back to top
View user's profile Send private message
Lowrider
n00b
n00b


Joined: 20 May 2004
Posts: 27
Location: Italy

PostPosted: Fri Oct 20, 2006 4:50 pm    Post subject: Reply with quote

i am currently downloading the latest portage ... let's see what happens

finally i'm remerge portage and everyhting seems to work

what i did :

- download latest snapshot and untar in /usr
- emerge --metadata with no luck: same error message
so i followed the guide here
with the exception of using the latest portage http://distfiles.gentoo.org/distfiles/portage-2.1.2_pre3.tar.bz2

hope it never happen again (and emerge works for now)
i fear to run emerge --sync again
_________________
I am the bullet in the gun
I am the truth from witch you run
I am the silencing machine
I am the end of all your dreams
Back to top
View user's profile Send private message
lots
Tux's lil' helper
Tux's lil' helper


Joined: 11 Mar 2003
Posts: 95

PostPosted: Fri Oct 20, 2006 7:11 pm    Post subject: Reply with quote

That seems to have done the trick for me as well. I wonder how wide spread that error is..

Anyway, its scary to run emerge --sync :) But I did it anyway, and everything seems to be up and running. There probably was the same error in the distfiles package I had tried out with the manual-fix howto the first time, is my only guess.
Back to top
View user's profile Send private message
Lowrider
n00b
n00b


Joined: 20 May 2004
Posts: 27
Location: Italy

PostPosted: Sat Oct 21, 2006 11:08 am    Post subject: Reply with quote

i synced today too, and everything went the way it should. this silly problem is finally solved :D

hope it never happen to anyone in the future
_________________
I am the bullet in the gun
I am the truth from witch you run
I am the silencing machine
I am the end of all your dreams
Back to top
View user's profile Send private message
tomk
Administrator
Administrator


Joined: 23 Sep 2003
Posts: 7219
Location: Sat in front of my computer

PostPosted: Sat Oct 28, 2006 9:44 am    Post subject: Reply with quote

Moved from Portage & Programming to Duplicate Threads, please see this topic: portage fails - errno 16 Device or resource busy.
_________________
Search | Read | Answer | Report | Strip
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Duplicate Threads All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum