Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[SOLVED] Проблема с загрузкой: Bad magic number...
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Russian
View previous topic :: View next topic  
Author Message
Satarsa
n00b
n00b


Joined: 21 Sep 2005
Posts: 70
Location: Russia, St.-Petersburg

PostPosted: Sun Oct 15, 2006 7:26 am    Post subject: [SOLVED] Проблема с загрузкой: Bad magic n Reply with quote

Совершенно непонятным образом возникла проблема с загрузкой Gentoo. Есть ноутбук asus a6tc, на него был установлен gentoo i686, целую неделю прилично работал, но потом, совершенно неожиданно, перестал грузиться. При загрузке начал говорить что-то типа
Code:

e2fsck: Bad magic number in super-block while trying to open /dev/hdc3

The superblock could not be read or does not describe a correct ext2
filesystem.  If the device is valid and it really contains an ext2
filesystem (and not swap or ufs or something else), then the superblock
is corrupt, and you might try running e2fsck with an alternate superblock:
    e2fsck -b 8193 <device>


Я загрузился с livecd, сделал
Code:
mkfs.ext3 -n /dev/hdc3


Оно мне
Code:

mkfs.ext3 -n /dev/hdc3
mke2fs 1.38 (30-Jun-2005)
Filesystem label=
OS type: Linux
Block size=4096 (log=2)
Fragment size=4096 (log=2)
36634624 inodes, 73259038 blocks
3662951 blocks (5.00%) reserved for the super user
First data block=0
2236 block groups
32768 blocks per group, 32768 fragments per group
16384 inodes per group
Superblock backups stored on blocks:
   32768, 98304, 163840, 229376, 294912, 819200, 884736, 1605632, 2654208,
   4096000, 7962624, 11239424, 20480000, 23887872, 71663616


Я ему
Code:
fsck.ext3 -b 32768 /dev/hdc3

Оно поисправляло что, но при следующей загрузке всё тоже самое.
Пробовал пересоздать разделы с нуля - таже фигня, не помогло :-(

И что теперь с этим делать? Как мне загрузить линукс? И почему целую неделю работал без проблем?

Кстати, lilo ещё выдавало warning: LBA32 addressing assumed. Что бы это значило?


Last edited by Satarsa on Tue Oct 17, 2006 7:14 am; edited 1 time in total
Back to top
View user's profile Send private message
Roger Enrasson
n00b
n00b


Joined: 08 Oct 2006
Posts: 9
Location: Minsk, Bielarus

PostPosted: Sun Oct 15, 2006 11:55 am    Post subject: Reply with quote

BIOS ковырял? LBA там не трогал? Диски там, может, настраивал?
_________________
...Far Above The Clouds...
Back to top
View user's profile Send private message
Satarsa
n00b
n00b


Joined: 21 Sep 2005
Posts: 70
Location: Russia, St.-Petersburg

PostPosted: Sun Oct 15, 2006 4:11 pm    Post subject: Reply with quote

Roger Enrasson wrote:
BIOS ковырял? LBA там не трогал? Диски там, может, настраивал?


Не, нашел ошибку. Оказалось, что в /dev/ ничего не было. Дальше уже дело техики.
Back to top
View user's profile Send private message
Laitr Keiows
Moderator
Moderator


Joined: 04 Jul 2005
Posts: 891
Location: Kobe, Japan

PostPosted: Tue Oct 17, 2006 5:34 am    Post subject: Reply with quote

напиши [SOLVED] в теме
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Russian All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum