Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[ ATI ] probleme de display [ on ]
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index French
View previous topic :: View next topic  
Author Message
amara
n00b
n00b


Joined: 19 Sep 2005
Posts: 74

PostPosted: Mon Oct 09, 2006 9:21 pm    Post subject: [ ATI ] probleme de display [ on ] Reply with quote

Voilà je possède une carte ati radeon 9600xt, et depuis que j'ai changer mon grub.conf en mettant "vga=791" depuis ma derniere compilation de noyau.
et du coup je ne peux plus lancer mon startx.

Code:

xauth:  creating new authority file /home/alkilo/.serverauth.9474


X Window System Version 7.0.0
Release Date: 21 December 2005
X Protocol Version 11, Revision 0, Release 7.0
Build Operating System:Linux 2.6.16-gentoo-r13 i686
Current Operating System: Linux amara 2.6.16-gentoo-r13 #1 SMP Mon Jul 31 12:29:50 CEST 2006 i686
Build Date: 21 July 2006
        Before reporting problems, check http://wiki.x.org
        to make sure that you have the latest version.
Module Loader present
Markers: (--) probed, (**) from config file, (==) default setting,
        (++) from command line, (!!) notice, (II) informational,
        (WW) warning, (EE) error, (NI) not implemented, (??) unknown.
(==) Log file: "/var/log/Xorg.0.log", Time: Mon Oct  9 23:14:07 2006
(EE) Unable to locate/open config file
xf86AutoConfig: Primary PCI is 1:0:0
Running "getconfig -X 70000000 -I /etc/X11,/usr/etc/X11,/usr/lib/xorg/modules,/usr/lib/X11/getconfig -v 0x1002 -d 0x4152 -r 0x00 -s 0x1681 -b 0x0002 -c 0x0300"
getconfig.pl: Version 1.0.
getconfig.pl: Xorg Version: 7.0.0.0.
getconfig.pl: 23 built-in rules.
getconfig.pl: rules file '/usr/lib/X11/getconfig/xorg.cfg' has version 1.0.
getconfig.pl: 1 rule added from file '/usr/lib/X11/getconfig/xorg.cfg'.
getconfig.pl: Evaluated 24 rules with 0 errors.
getconfig.pl: Weight of result is 500.
New driver is "ati"
(==) Using default built-in configuration (53 lines)
(WW) RADEON: No matching Device section for instance (BusID PCI:1:0:1) found

Fatal server error:
Cannot run in framebuffer mode. Please specify busIDs        for all framebuffer devices

XIO:  fatal IO error 104 (Connection reset by peer) on X server ":0.0"
      after 0 requests (0 known processed) with 0 events remaining.
Couldnt get a file descriptor referring to the console



Merci.


P4 2.6Ghz
gentoo 2.6
Back to top
View user's profile Send private message
grosnours
Apprentice
Apprentice


Joined: 05 Jun 2006
Posts: 210
Location: Belgium

PostPosted: Mon Oct 09, 2006 9:44 pm    Post subject: Reply with quote

Retire le vga=791 et remets vga=normal.
_________________
grosnours
Back to top
View user's profile Send private message
amara
n00b
n00b


Joined: 19 Sep 2005
Posts: 74

PostPosted: Mon Oct 09, 2006 10:07 pm    Post subject: Reply with quote

oui j'ai déjà essayé sa marche nickel, mais enfaite j'ai rajouté le vga=791 parce que je voulais que lors de mon demarrage et que je suis en mode console sa soit pas écrit en gros énorme.
sa me donne l'impression d'etre miope.
Back to top
View user's profile Send private message
nykos
Guru
Guru


Joined: 08 Jun 2005
Posts: 488
Location: Strasbourg

PostPosted: Tue Oct 10, 2006 8:29 am    Post subject: Reply with quote

fait voir ton grub.conf
t'as activé le framebuffer dans le noyau ?
_________________
-=Nykos=-
TARGA Traveller 826T - AMD Turion 64 MT 32 1,8GHz - ATI Radeon X700 Mobility (ati-drivers)
Back to top
View user's profile Send private message
amara
n00b
n00b


Joined: 19 Sep 2005
Posts: 74

PostPosted: Wed Oct 11, 2006 11:01 pm    Post subject: Reply with quote

voilà mon grub.conf

Code:

default 0
timeout 30
splashimage=(hd0,1)/grub/splash.xpm.gz


# Support VGA

title=Gentoo Linux IN PROGRESS
root (hd0,1)
kernel /boot/kernel-genkernel-x86-2.6.16-gentoo-r13 root=/dev/ram0 init=/linuxrc ramdisk=8192 real_root=/dev/sda3 udev vga=791
initrd /boot/initramfs-genkernel-x86-2.6.16-gentoo-r13



sinon je me souviens plus si j'ai compilé sa dans mon noyau.
Back to top
View user's profile Send private message
nykos
Guru
Guru


Joined: 08 Jun 2005
Posts: 488
Location: Strasbourg

PostPosted: Thu Oct 12, 2006 9:28 pm    Post subject: Reply with quote

je sais pas si c'est possible de changer la résolution sans le framebuffer
les pros pourront te dire ça :D
mais avec le framebuffer c'est possible, et surtout tu pourras mettre une jolie image :)
donc regarde dans ton noyau, lis un peu les tutos sur le framebuffer et je pense que tu arriveras a quelque chose de sympa
_________________
-=Nykos=-
TARGA Traveller 826T - AMD Turion 64 MT 32 1,8GHz - ATI Radeon X700 Mobility (ati-drivers)
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index French All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum