Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Problem with world update -> media-video/nvidia-glx
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Duplicate Threads
View previous topic :: View next topic  
Author Message
sunflower
n00b
n00b


Joined: 23 Dec 2005
Posts: 61

PostPosted: Mon Oct 09, 2006 7:25 pm    Post subject: Problem with world update -> media-video/nvidia-glx Reply with quote

Hi,

today I did emerge --sync and after that emerge --update --deep --newuse world, but:

Code:

Calculating world dependencies |
emerge: there are no ebuilds to satisfy "media-video/nvidia-glx".
(dependency required by "x11-libs/qt-3.3.6-r1" [ebuild])



!!! Problem resolving dependencies for kde-base/kdewebdev
!!! Depgraph creation failed.


What's wrong! Can anyone help?

Thanks!
Back to top
View user's profile Send private message
dleverton
Guru
Guru


Joined: 28 Aug 2006
Posts: 517

PostPosted: Mon Oct 09, 2006 7:52 pm    Post subject: Reply with quote

Unmerge media-video/nvidia-glx and media-video/nvidia-kernel, and install either x11-drivers/nvidia-drivers or x11-drivers/nvidia-legacy-drivers (see the NVIDIA website to find out which).
Back to top
View user's profile Send private message
godzilla
n00b
n00b


Joined: 26 Aug 2005
Posts: 29

PostPosted: Mon Oct 09, 2006 8:16 pm    Post subject: Reply with quote

I got the same problem here:
Code:

gentoo / # emerge --update --deep world -pv

These are the packages that would be merged, in order:

Calculating world dependencies /
emerge: there are no ebuilds to satisfy "media-video/nvidia-glx".
(dependency required by "x11-apps/xdriinfo-1.0.1" [ebuild])



!!! Problem resolving dependencies for net-im/ayttm
!!! Depgraph creation failed.
gentoo / # emerge nvidia-drivers -pv

These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild   R   ] x11-drivers/nvidia-drivers-1.0.8774  USE="-dlloader" 0 kB

Total size of downloads: 0 kB
gentoo / #


This happened after upgrading to Xorg 7.0

Also used folowing commands before emerge --update --deep world:
Code:

emerge nvidia-drivers
eselect opengl set nvidia


I suspect that the problem actually caused by recent switch to 2006.1 profile.
Here is my emerge --info :
Code:

Portage 2.1.1 (default-linux/x86/2006.1/desktop, gcc-3.3.6, glibc-2.3.6-r4, 2.6.14-gentoo-r5 i686)
=================================================================
System uname: 2.6.14-gentoo-r5 i686 AMD Athlon(tm) 64 Processor 3000+
Gentoo Base System version 1.6.14
Last Sync: Mon, 09 Oct 2006 18:00:08 +0000
ccache version 2.3 [disabled]
app-admin/eselect-compiler: [Not Present]
dev-java/java-config: 1.2.11-r1
dev-lang/python:     2.3.5-r2, 2.4.3-r4
dev-python/pycrypto: 2.0.1-r5
dev-util/ccache:     2.3
dev-util/confcache:  [Not Present]
sys-apps/sandbox:    1.2.17
sys-devel/autoconf:  2.13, 2.59-r7
sys-devel/automake:  1.4_p6, 1.5, 1.6.3, 1.7.9-r1, 1.8.5-r3, 1.9.6-r1
sys-devel/binutils:  2.16.1-r3
sys-devel/gcc-config: 1.3.13-r2
sys-devel/libtool:   1.5.22
virtual/os-headers:  2.6.11-r2
ACCEPT_KEYWORDS="x86"
AUTOCLEAN="yes"
CBUILD="i686-pc-linux-gnu"
CFLAGS="-O2 -march=athlon-xp -pipe -msse -msse2 -mmmx -m3dnow -mfpmath=sse -ffast-math"
CHOST="i686-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/kde/3.4/env /usr/kde/3.4/share/config /usr/kde/3.4/shutdown /usr/kde/3.5/env /usr/kde/3.5/share/config /usr/kde/3.5/shutdown /usr/lib/mozilla/defaults/pref /usr/share/X11/xkb /usr/share/config"
CONFIG_PROTECT_MASK="/etc/env.d /etc/gconf /etc/revdep-rebuild /etc/terminfo"
CXXFLAGS="-O2 -march=athlon-xp -pipe -msse -msse2 -mmmx -m3dnow -mfpmath=sse -ffast-math"
DISTDIR="/usr/portage/distfiles"
FEATURES="autoconfig distlocks metadata-transfer sandbox sfperms strict"
GENTOO_MIRRORS="http://gentoo.chem.wisc.edu/gentoo/ http://gentoo.mirrors.tds.net/gentoo ftp://ftp.belnet.be/mirror/rsync.gentoo.org/gentoo/"
LANG="en_US.utf8"
LC_ALL="en_US.utf8"
LINGUAS=""
MAKEOPTS="-j2"
PKGDIR="/usr/portage/packages"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --delete-after --stats --timeout=180 --exclude='/distfiles' --exclude='/local' --exclude='/packages'"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
SYNC="rsync://rsync.gentoo.org/gentoo-portage"
USE="x86 3dnow 3dnowext X a52 aac aalib acpi alsa arts audiofile avi berkdb bitmap-fonts bzip2 cairo cdparanoia cdr cli cpudetection crypt cscope cups curl dbus dri dts dv dvd dvdr dvdread eds elibc_glibc emboss encode esd exif fam ffmpeg firefox flac foomaticdb fortran gdbm gif gimp gimpprint gnome gpm gstreamer gtk hal icq ieee1394 imagemagick input_devices_keyboard input_devices_mouse ipv6 isdnlog java jpeg kde kernel_linux ldap libg++ lm_sensors mad mikmod mjpeg mmx mmxext mozilla mp3 mpeg multiuser mysql mysqli ncurses nls nptl nptlonly nvidia ofx ogg opengl oss pam pcre perl php png ppds pppd python qt qt3 qt4 quicktime readline real reflection ruby samba scanner sdl session spell spl sql sqlite sse sse2 ssl tcpd theora tiff truetype truetype-fonts type1-fonts udev unicode usb userland_GNU v4l v4l2 vcd video_cards_nvidia video_cards_vesa vorbis win32codecs x264 xine xinerama xml xmms xorg xv xvid zlib"
Unset:  CTARGET, EMERGE_DEFAULT_OPTS, INSTALL_MASK, LDFLAGS, PORTAGE_RSYNC_EXTRA_OPTS, PORTDIR_OVERLAY
Back to top
View user's profile Send private message
dleverton
Guru
Guru


Joined: 28 Aug 2006
Posts: 517

PostPosted: Mon Oct 09, 2006 8:32 pm    Post subject: Reply with quote

godzilla wrote:
I got the same problem here:

Did you uninstall the old driver? What does
Code:
emerge -pv virtual/opengl
say?
Back to top
View user's profile Send private message
godzilla
n00b
n00b


Joined: 26 Aug 2005
Posts: 29

PostPosted: Mon Oct 09, 2006 8:46 pm    Post subject: Reply with quote

Oops....

It seems that
Code:

emerge -Ca nvidia-glx nvidia-kernel


fixed everything !!!

Thank you !
Back to top
View user's profile Send private message
kallamej
Administrator
Administrator


Joined: 27 Jun 2003
Posts: 4830
Location: Gothenburg, Sweden

PostPosted: Tue Oct 24, 2006 8:20 pm    Post subject: Reply with quote

Moved from Portage & Programming to Duplicate Threads in favour of topic 498027.
_________________
Please read our FAQ Forum, it answers many of your questions.
irc: #gentoo-forums on irc.freenode.net
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Duplicate Threads All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum