Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Using the relakks darknet without pptpconfig
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Documentation, Tips & Tricks
View previous topic :: View next topic  
Author Message
bobert
n00b
n00b


Joined: 26 Sep 2002
Posts: 65
Location: Malaysia

PostPosted: Sun Oct 08, 2006 8:32 am    Post subject: Using the relakks darknet without pptpconfig Reply with quote

Hi guys i just started using the relakks darknet https://www.relakks.com/ and after following the guide at http://gentoo-wiki.com/HOWTO_PPTP_VPN_client_%28Microsoft-compatible_with_mppe%29 I couldn't get routing to work even after searching through all the posts on this forum and going through the suggestions on the pptpclient site's diagnosis and routing pages. I had heard people having success with the pptpconfig package but since i planned on running it on a headless linux box i didn't want to install a package with dependencies on X let alone gnome.

After spending a couple of days on this and reading reports on forums about the flaky nature of the relakks service i decided to test it on a windows xp machine at work to see if my problem was not due to the relakks network being down. I created a pptp connection as per the pptp guide on the relakks website and tried the connection. The connection was up and running in a second. Now that i was sure that it was just a problem with the routing i did

Code:
netstat -nr > route.txt


in the windows command prompt and copied it to my linux box to compare the routing setups side by side.

It seems that all the guides and howtos i've read have suggested creating a route to the pptp server over the regular interface before removing the default route and creating a new default route through the tunnel interface (usually ppp0). I'd tried that and had assumed or infered that the gateway to the tunnel would be the remote ip of the tunnel interface. It turns out that you have to create a default route through the tunnel interface pointing to the local ip address of the interface as the gateway for it to work.

Now i'm not a network guru by any means but i went back through the docs, howtos and guides i'd read and couldn't seem to see it spelled out anywhere that you need to point the default gateway to the ip of your own machine which i think an average computer user would find counter-intuitive.

So to help out anyone else who is in the same boat (ie. want to use the relakks network on your linux box without a gui) here is a quick guide.

Make sure u have the tunnel up and running and that you can ping the remote host on the other end of the ptp interface, if you can't you're gonna have to run

Code:
pon relakks debug dump logfd 2 nodetach


and check the output for any errors againt http://pptpclient.sourceforge.net/howto-diagnosis.phtml once you have a functioning tunnel to the relakks network you can modify the routes as follows:-

Code:
route add -host pptp.relakks.com gw $YOUR_GATEWAY_IP dev $NETWORK_INTERFACE
route del default
route add default gw $TUNNEL_LOCAL_IP dev $TUNNEL_INTERFACE


$YOUR_GATEWAY_IP is the current gateway ip of your network and $NETWORK_INTERFACE is the interface through which you connect regularly to the internet.

Run

Code:
/sbin/route | grep default


and you'll get

Code:
default         $YOUR_GATEWAY_IP          0.0.0.0         UG    0      0        0 $NETWORK_INTERFACE


Your $TUNNEL_INTERFACE is usually ppp0 or maybe ppp1 if you already connect to the internet through a pppoe link on ppp0. Mine is ppp0 so run

Code:
/sbin/ifconfig $TUNNEL_INTERFACE | grep inet


and you'll get

Code:
inet addr:$TUNNEL_LOCAL_IP  P-t-P:$TUNNEL_REMOTE_IP  Mask:255.255.255.255


This will hopefully give you a working internet connection through your tunnel which you can test by doing a

Code:
/sbin/tracepath yahoo.com


and checking the output for both your $TUNNEL_LOCAL_IP and $TUNNEL_REMOTE_IP which means you're connection is being routed through relakks' network.

If you don't see $TUNNEL_LOCAL_IP and $TUNNEL_REMOTE_IP in the output then you might have made a mistake somewhere and you'll have to double check your route command for mistakes.

Next you need to restore the normal routes when you bring down your tunnel.

Code:
route del default
route add default gw  $YOUR_GATEWAY_IP dev $NETWORK_INTERFACE
route del -host pptp.relakks.com


If you don't do this after you take down the tunnel you won't be able to connect to the internet.

If, like me, you have followed http://gentoo-wiki.com/HOWTO_PPTP_VPN_client_%28Microsoft-compatible_with_mppe%29 then you can do the following to automate the above commands whenever you connect to the tunnel.

Put the route command to setup the tunnel route :-

Code:
route add -host pptp.relakks.com gw $YOUR_GATEWAY_IP dev $NETWORK_INTERFACE
route del default
route add default gw $TUNNEL_LOCAL_IP dev $TUNNEL_INTERFACE


into your

Quote:
/etc/ppp/ip-up


file. I put it right at the beginning just below the

Quote:
#!/bin/bash


line because it did not work otherwise on a couple of machines.

Then put the route command to restore the routes when you bring down the tunnel:-

Code:
route del default
route add default gw  $YOUR_GATEWAY_IP dev $NETWORK_INTERFACE
route del -host pptp.relakks.com


into the
Quote:
/etc/ppp/ip-down
file.

This way when you bring up your connection with

Code:
/etc/init.d/net.ppp0 start


and take it down

Code:
/etc/init.d/net.ppp0 stop


the routes will be automatically created and restored respectively.

I hope this helps somebody out.

Cheers.
Back to top
View user's profile Send private message
bobert
n00b
n00b


Joined: 26 Sep 2002
Posts: 65
Location: Malaysia

PostPosted: Sun Oct 15, 2006 12:07 am    Post subject: Reply with quote

Okay guys the folks over at relakks just messed up my connection again. It happened right after my isp went down and my system's harddrive had a meltdown requiring that i restore from an older backup to a new drive. After my connection went up again and i managed to reconfigure pptpclient with the settings i'd used successfully before the outage but i kept getting authentication failure, Lost Carrier and other assorted errors.

It took me awhile to figure out because i thought i'd messed up my settings after the rebuilding my system but i saw from the debug output that i was getting inconsistent reponses from the pptp server each time i'd connect.

if i got

Code:

rcvd [CHAP Challenge id=0x1 <00090f71cf025680e07c48eac00a7d5c>, name = "Fortigate-800"]


on the debug output it would be followed by

Code:
rcvd [CHAP Failure id=0x1 "Authentication Fail!"]
MS-CHAP authentication failed: Authentication Fail!
CHAP authentication failed
sent [LCP TermReq id=0x2 "Failed to authenticate ourselves to peer"]
rcvd [LCP TermReq id=0x2 "Authentication failed"]
sent [LCP TermAck id=0x2]
rcvd [LCP TermAck id=0x2]
Connection terminated.


and my connection would terminate.

Now if got

Code:

rcvd [CHAP Challenge id=0xdc <63dc0d43e2e0de243fde880df099092e>, name = ""]


on the debug output i would manage to get connected but the connection would drop as the default route was established.

During troubleshooting the connection i noticed that when pinging pptp.relakks.com would give me 2 different addresses. They would alternate one after another.


PING pptp.relakks.com (82.209.164.178) 56(84) bytes of data.


PING pptp.relakks.com (83.233.79.34) 56(84) bytes of data.


by modifying the

Code:
link_ppp0="pty \"pptp pptp.relakks.com --nolaunchpppd\""


to

Code:
link_ppp0="pty \"pptp $PPTP_SERVER_IPADDRESS --nolaunchpppd\""



I found that the pptp server with the 83.233.79.34 ip would consistently fail to authenticate me but the pptp server with the 82.209.164.178 ip would authenticate me every time.

Now the reason for my problems were that the route command in my ip-up script would add the required route to the pptp server by resolving it's hostname to it's ip address then adding a route to that address. Because the ip would change every time it was looked up it would be adding a route to the other pptp server than the one i was connected to because the route command would always follow the

Code:
link_ppp0="pty \"pptp pptp.relakks.com --nolaunchpppd\""


which also performs a DNS lookup.

So i had to hardcode the ip address of the "good" pptp server "82.209.164.178" into both my call and route commands as follows.

in my
Quote:
/etc/conf.d/net
file

Code:
link_ppp0="pty \"pptp pptp.relakks.com --nolaunchpppd\""


would become

Code:
link_ppp0="pty \"pptp 82.209.164.178 --nolaunchpppd\""



and in my
Quote:
/etc/ppp/ip-up



Code:
route add -host pptp.relakks.com gw $YOUR_GATEWAY_IP dev $NETWORK_INTERFACE


would become

Code:
route add -host 82.209.164.178 gw $YOUR_GATEWAY_IP dev $NETWORK_INTERFACE


my
Quote:
/etc/ppp/ip-down


Code:
route del -host pptp.relakks.com


would become


Code:
route del -host 82.209.164.178


Now I know my solution is kludgey and would be broken if relakks decided to change the ip of their pptp server again but i'm too tired to fix it at the moment and am just glad it's working now.

I hope this will help people who have been having problems with the service and have not been getting help from relakks' non existant tech support.

Cheers.

:)
Back to top
View user's profile Send private message
rsaddey
n00b
n00b


Joined: 15 Oct 2006
Posts: 3
Location: Berlin, Germany

PostPosted: Sun Oct 15, 2006 10:04 am    Post subject: Reply with quote

bobert wrote:

I found that the pptp server with the 83.233.79.34 ip would consistently fail to authenticate me but the pptp server with the 82.209.164.178 ip would authenticate me every time.


Thanks Bobert,

you sort of saved my life (at least my sanity) :D

I was starting to pull my hairs out of my head, when my WRT54GL would just pretend to pptp to pptp.relakks.com, but nothing never actually happend. Trying to connect from W2k would just hang indefinitly as well, but XP at least gave me the (very much unexpected) authorization error.

Right now, my first PPTP hop is 500ms - I've never seen this before with Relakks - maybe it's getting rather crowded there.

Thanks again,
Reiner
Back to top
View user's profile Send private message
bobert
n00b
n00b


Joined: 26 Sep 2002
Posts: 65
Location: Malaysia

PostPosted: Sun Oct 15, 2006 11:44 am    Post subject: Reply with quote

Glad to be of help rsaddey

I notice from this

rsaddey wrote:

Trying to connect from W2k would just hang indefinitly as well, but XP at least gave me the (very much unexpected) authorization error.


that you seem to be running windows 2000 and XP and am curious if you have tried the l2tp/ipsec client that relakks has available and if you encountered similar problems with it.

I guess it says something about the relakks service that a post on a forum for an O.S. that they do not support could be of more help than their tech support to a customer using an officially supported platform.

Well they are cheap and they do give me decent bandwidth if not good latency.


Code:

PING yahoo.com (216.109.112.135) 56(84) bytes of data.
64 bytes from w2.rc.vip.dcn.yahoo.com (216.109.112.135): icmp_seq=1 ttl=55 time=1479 ms
64 bytes from w2.rc.vip.dcn.yahoo.com (216.109.112.135): icmp_seq=2 ttl=55 time=1530 ms
64 bytes from w2.rc.vip.dcn.yahoo.com (216.109.112.135): icmp_seq=3 ttl=54 time=1430 ms
64 bytes from w2.rc.vip.dcn.yahoo.com (216.109.112.135): icmp_seq=4 ttl=55 time=1511 ms
64 bytes from w2.rc.vip.dcn.yahoo.com (216.109.112.135): icmp_seq=5 ttl=54 time=1548 ms


Hope they don't screw around with us again though i'm not holding my breath.

Anyway if you have anymore problems just ping the pptp.relakks.com server and see if they changed the ip again and manually enter the ip into your client to see if it solves the problem. Or you could check here a solution if i have any.

:D
Back to top
View user's profile Send private message
rsaddey
n00b
n00b


Joined: 15 Oct 2006
Posts: 3
Location: Berlin, Germany

PostPosted: Sun Oct 15, 2006 12:53 pm    Post subject: Reply with quote

Hi Bobert,

bobert wrote:

that you seem to be running windows 2000 and XP and am curious if you have tried the l2tp/ipsec client that relakks has available and if you encountered similar problems with it.


I don't use those shrink-wrapped clients at all, just hand-crafted connects. And as for Windows, yes, l2tp indeed does work (and used to work at least since I joined Relakks - at least a month) with XP. But I used Windows solely in order to try to narrow down the current problems you managed to pin down so smartly. So I can't tell, whether a particular one of their servers (that are apparently beeing load-balanced at the DNS level) suffers from any problems. l2tp appears to be more demanding on your router and/or firewall equipment (l2tp passthrough feature) than pptp. MSKB has some articles on that and a humble SpeedTouch 585i would just give me a "certificate missing" error.

My "production" environment is a Linksys WRT54GL Linux based WLAN router. I've set up an unencrypted WLAN to let my neighbours share my internet connection. Due to recent German court rulings, it appears that I would have to be responsible in full for any faux-pas my unknown neighbours should happen to commit - unless I was able to prove otherweise. So I decided to have the WLAN router connect to Relakks and yes, it took me quite a time to set it up - mainly because only 40bit stateless encryption could be made to work and none of the preconfigured solutions allowed to set the default route to the vpn tunnel. The router is running thrird party firmware (Sveasoft's Talisman - they do charge - or DD-WRT).

As I've been unable to find any l2tp for this device (it appears as though l2tp development ceased some years ago) and taking into account that I'm a complete novice to Linux, I'll have to stick to pptp for the time being. If someone knows about a l2tp for tiny Linux boxes, I'd be glad to further investigate in that direction.

All in all, I think that Relakks appears to be the "best" anonymizer service currently available - at least it's ceratinly one of the utmost transparent ones. You'll receive a public IP, so the VPN is completely transparent, just as if you were connecting to a normal dial-in service. Thus there isn't any problem with streaming media (Mediaplayer happily uses UDP), P2P (I don't use them - so I can't really tell) or any other stateless connections. Findcom (the VPN Pro variant), for example, assigns private IPs (from the 10.x.x.x net) and thus has to resort to some kind of NAT on their servers, that turned out to block (at least some) incoming UDP streams.

Relakks appears to steadily improve, so frequent configuration changes might be expected. For example, it is not until a couple of weeks ago, that the public IP of their pptp servers ceased to match the internal gateway of the tunnel (far end within) - something the Linux pptp client was absolutely not prepared to handle, as it tried to route the vpn server through the tunnel itself.

As for the current speed, I was sort of geeting used to 38ms for the first hop (i.e. the far end of the tunnel).

Thanks again and have fun,
Reiner
Back to top
View user's profile Send private message
watusimoto
n00b
n00b


Joined: 18 Dec 2005
Posts: 40

PostPosted: Sun Oct 22, 2006 7:33 pm    Post subject: Reply with quote

Well, you guys seem to be just a bit ahead of me. I have been able to establish a connection, but it disconnects when I do something like a traceroute to verify that the connection works. I followed the instructions in the first post in this thread, and have worked through all the troubleshooting guides for PPTP.

I am pasting a bunch of stuff below. First is a log of everything I did from initiating the connection through terminating it. The second part is a dump of the relevant sections of my logfiles that show the connection going up and coming back down.

One other odd thing: when I ping pptp.relakks.com, it hangs. Pinging other hosts, such as yahoo.com, works just fine.

If anyone can give me a suggestion as to what I should do next, I'd really appreciate it.

Code:

mybox ~ # pon relakks

mybox ~ # ifconfig
eth0      Link encap:Ethernet  HWaddr 00:06:30:B4:AB:3B
          inet addr:192.168.1.99  Bcast:192.168.1.255  Mask:255.255.255.0
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:171372 errors:0 dropped:0 overruns:0 frame:0
          TX packets:205891 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:78506450 (74.8 Mb)  TX bytes:183239915 (174.7 Mb)
          Interrupt:16 Base address:0xff00

lo        Link encap:Local Loopback
          inet addr:127.0.0.1  Mask:255.0.0.0
          UP LOOPBACK RUNNING  MTU:16436  Metric:1
          RX packets:6 errors:0 dropped:0 overruns:0 frame:0
          TX packets:6 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0
          RX bytes:336 (336.0 b)  TX bytes:336 (336.0 b)

ppp0      Link encap:Point-to-Point Protocol
          inet addr:83.233.240.194  P-t-P:83.233.240.2  Mask:255.255.255.255
          UP POINTOPOINT RUNNING NOARP MULTICAST  MTU:1452  Metric:1
          RX packets:9 errors:0 dropped:0 overruns:0 frame:0
          TX packets:9 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:3
          RX bytes:114 (114.0 b)  TX bytes:126 (126.0 b)

mybox ~ # route
Kernel IP routing table
Destination     Gateway         Genmask         Flags Metric Ref    Use Iface
83.233.240.2    *               255.255.255.255 UH    0      0        0 ppp0
192.168.1.0     *               255.255.255.0   U     0      0        0 eth0
loopback        mybox           255.0.0.0       UG    0      0        0 lo
default         192.168.1.1     0.0.0.0         UG    0      0        0 eth0

mybox ~ # route add -host pptp.relakks.com gw 192.168.1.1 dev eth0
mybox ~ # route del default
mybox ~ # route add default gw 83.233.240.194 dev ppp0
mybox ~ # tracert yahoo.com
 1:  83.233.240.194 (83.233.240.194)                        1.864ms pmtu 1452
 1:  send failed
     Resume: pmtu 1452
mybox ~ # ifconfig
eth0      Link encap:Ethernet  HWaddr 00:06:30:B4:AB:3B
          inet addr:192.168.1.99  Bcast:192.168.1.255  Mask:255.255.255.0
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:171730 errors:0 dropped:0 overruns:0 frame:0
          TX packets:206297 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:78540622 (74.9 Mb)  TX bytes:183375138 (174.8 Mb)
          Interrupt:16 Base address:0xff00

lo        Link encap:Local Loopback
          inet addr:127.0.0.1  Mask:255.0.0.0
          UP LOOPBACK RUNNING  MTU:16436  Metric:1
          RX packets:8 errors:0 dropped:0 overruns:0 frame:0
          TX packets:8 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0
          RX bytes:1488 (1.4 Kb)  TX bytes:1488 (1.4 Kb)


Code:

mybox ~ # tail /var/log/syslog
Oct 22 21:09:34 [pppd] pppd 2.4.2 started by root, uid 0
Oct 22 21:09:34 [pppd] Using interface ppp0
Oct 22 21:09:34 [pppd] Connect: ppp0 <--> /dev/pts/1
Oct 22 21:09:34 [pptp] anon log[main:pptp.c:276]: The synchronous pptp option is NOT activated_
Oct 22 21:09:35 [pptp] anon log[ctrlp_rep:pptp_ctrl.c:251]: Sent control packet type is 1 'Start-Control-Connection-Request'_
Oct 22 21:09:35 [pptp] anon log[ctrlp_disp:pptp_ctrl.c:738]: Received Start Control Connection Reply
Oct 22 21:09:35 [pptp] anon log[ctrlp_disp:pptp_ctrl.c:772]: Client connection established.
Oct 22 21:09:36 [pptp] anon log[ctrlp_rep:pptp_ctrl.c:251]: Sent control packet type is 7 'Outgoing-Call-Request'_
Oct 22 21:09:36 [pptp] anon log[ctrlp_disp:pptp_ctrl.c:857]: Received Outgoing Call Reply.
Oct 22 21:09:36 [pptp] anon log[ctrlp_disp:pptp_ctrl.c:896]: Outgoing call established (call ID 0, peer's call ID 0)._
Oct 22 21:09:41 [pppd] MPPE 128-bit stateless compression enabled
Oct 22 21:09:43 [pppd] local  IP address 83.233.240.194
Oct 22 21:09:43 [pppd] remote IP address 83.233.240.2
Oct 22 21:09:43 [pppd] primary   DNS address 82.209.168.98
Oct 22 21:09:43 [pppd] secondary DNS address 82.209.168.99
Oct 22 21:10:07 [pptp] anon log[logecho:pptp_ctrl.c:676]: Echo Request received.
Oct 22 21:10:07 [pptp] anon log[ctrlp_rep:pptp_ctrl.c:251]: Sent control packet type is 6 'Echo-Reply'_
Oct 22 21:10:33 [pptp] anon log[decaps_gre:pptp_gre.c:407]: buffering packet 21 (expecting 20, lost or reordered)
Oct 22 21:10:37 [pptp] anon log[logecho:pptp_ctrl.c:676]: Echo Request received.
Oct 22 21:10:37 [pptp] anon log[ctrlp_rep:pptp_ctrl.c:251]: Sent control packet type is 6 'Echo-Reply'_
Oct 22 21:11:07 [pptp] anon log[logecho:pptp_ctrl.c:676]: Echo Request received.
Oct 22 21:11:07 [pptp] anon log[ctrlp_rep:pptp_ctrl.c:251]: Sent control packet type is 6 'Echo-Reply'_
Oct 22 21:11:36 [pptp] anon log[decaps_gre:pptp_gre.c:407]: buffering packet 27 (expecting 26, lost or reordered)
Oct 22 21:11:37 [pptp] anon log[logecho:pptp_ctrl.c:676]: Echo Request received.
Oct 22 21:11:37 [pptp] anon log[ctrlp_rep:pptp_ctrl.c:251]: Sent control packet type is 6 'Echo-Reply'_
Oct 22 21:11:37 [pptp] anon warn[decaps_gre:pptp_gre.c:324]: short read (-1): Message too long
Oct 22 21:11:37 [pppd] Modem hangup
Oct 22 21:11:37 [pptp] anon log[callmgr_main:pptp_callmgr.c:231]: Closing connection (unhandled)
Oct 22 21:11:37 [pptp] anon log[ctrlp_rep:pptp_ctrl.c:251]: Sent control packet type is 12 'Call-Clear-Request'_
Oct 22 21:11:37 [pptp] anon log[call_callback:pptp_callmgr.c:78]: Closing connection (call state)
Oct 22 21:11:37 [pppd] MPPE disabled
Oct 22 21:11:37 [pppd] Connection terminated.
Oct 22 21:11:37 [pppd] Connect time 2.1 minutes.
Oct 22 21:11:37 [pppd] Sent 1706 bytes, received 777 bytes.
Oct 22 21:11:37 [pppd] Connect time 2.1 minutes.
Oct 22 21:11:37 [pppd] Sent 1706 bytes, received 777 bytes.
Oct 22 21:11:37 [pppd] Exit.
mybox ~ #
Back to top
View user's profile Send private message
bobert
n00b
n00b


Joined: 26 Sep 2002
Posts: 65
Location: Malaysia

PostPosted: Mon Oct 23, 2006 2:00 pm    Post subject: Reply with quote

Hey watusimoto, have u read my second post? You might want to try using the ip address of pptp.relakks.com (82.209.164.178) in your route and call commands. Relakks seem to have removed their faulty pptp server as of a couple of days ago fixing the issue i described in that post but the behaviour that u describe seems to be identical to what i was getting when i was struggling with that problem.

Also pinging pptp.relakks.com usually times out for me so i think relakks have disabled responses to icmp packets on their server.

If using the ip address of the pptp server does not solve your problem try reducing your mtu/mru until your connection becomes stable. I used to use 1200 but find that any significant increase in download/upload activity will render the tunnel inactive/unresponsive or even take down the connection altogether. I am now using 1000 for my mtu/mru.

Using 1460 as described in the wiki/howto has never resulted in a usable connection for me at all so that could be your problem right there.

Also, if u manage to get a stable connection, be prepared to be disconnected or have your connection die and become unresponsive for no reason at all and you can expect to have periods where you can't reestablish a connection to the pptp server unless you change your public ip (if your on dynamic ip) by reconnecting to your ISP. This is because relakks is still a very flaky service and they don't even announce it when their server is down like it was the couple of times since i've started using it. Well they are dirt cheap so i guess u get what u pay for.

Good luck.
Back to top
View user's profile Send private message
watusimoto
n00b
n00b


Joined: 18 Dec 2005
Posts: 40

PostPosted: Thu Oct 26, 2006 10:57 pm    Post subject: Reply with quote

Bobert,

I really do appreciate your help. Alas I did follow your recommendations, replacing the string pptp.relakks.com where you specified, and I got exactly the same result.

Do you have any other ideas I could try?
Back to top
View user's profile Send private message
bobert
n00b
n00b


Joined: 26 Sep 2002
Posts: 65
Location: Malaysia

PostPosted: Fri Oct 27, 2006 1:49 am    Post subject: Reply with quote

watusimoto

Did u try lowering your mtu?

If you did and it did not solve your problem then try the following:

Use
Code:
pon relakks debug dump logfd 2 nodetach


and post the output.

You'll have to do the following in a separate terminal/window because of the nodetach option.

Run "ifconfig" to verify that your ppp0 connection is up. Now step through the route setup process running "ifconfig" after every route command and pay attention to the "RX packets: XX" and "TX packets: XX" value in the output. You need to see if the "TX packets:" value starts to increase without a corresponding increase in the "RX packets:" value.

If "TX packets:" starts to increase dramatically while your "RX packets:" stays the same then determine which route command caused it and post it here. Try verifying your results by trying to duplicate the outcome before posting. Sometimes relakks is screwy and unpredictable so your results might not be the same every time.

This phenomenon is documented on the pptpclient diagnosis page

http://pptpclient.sourceforge.net/howto-diagnosis.phtml#lots_of_data

should you want to take a look at it.

Good Luck.
Back to top
View user's profile Send private message
Obi-Lan
Apprentice
Apprentice


Joined: 21 Jan 2005
Posts: 230
Location: Riihimäki

PostPosted: Mon Nov 20, 2006 5:56 pm    Post subject: Reply with quote

I did add something like this into ip-up:

Code:

route add -host 83.233.168.3 eth1
route del default
route add default ppp0
mv /etc/resolv.conf /etc/resolv.bk
echo 'nameserver 82.209.169.71' >> /etc/resolv.conf


Its not beatiful but works.

Is there a way to find out and generate nameserver address automatically from dhcp in case relakks happens to change ip?
Back to top
View user's profile Send private message
matador
Apprentice
Apprentice


Joined: 28 Sep 2004
Posts: 174
Location: Gothenburg, Sweden

PostPosted: Wed Feb 07, 2007 7:43 pm    Post subject: Reply with quote

Hi. I'm trying to use Relakks but I'm stuck in the beginning. Some how the "PPP MPPE compression" module is missing in the "Network device support". I'm using Gentoo Sources:

Code:
uname -r
2.6.19-gentoo-r5


As I understood the WIKI kernels after 2.6.13 is already patched. What am I missing?
_________________
#267386
Checked the wiki or the faq?
Answear a post if you've got time
Back to top
View user's profile Send private message
jc999
n00b
n00b


Joined: 09 Feb 2007
Posts: 1

PostPosted: Fri Feb 09, 2007 7:20 pm    Post subject: Reply with quote

rsaddey wrote:

So I decided to have the WLAN router connect to Relakks and yes, it took me quite a time to set it up - mainly because only 40bit stateless encryption could be made to work and none of the preconfigured solutions allowed to set the default route to the vpn tunnel. The router is running thrird party firmware (Sveasoft's Talisman - they do charge - or DD-WRT).


@rsaddey

Hi, would you let me know what parameters you entered in the dd-wrt vpn-client to get it to connect to relakks? I am using dd-wrt 23 sp2 and I have not been able to get it to connect for more than a few seconds.

THX, jc
Back to top
View user's profile Send private message
watusimoto
n00b
n00b


Joined: 18 Dec 2005
Posts: 40

PostPosted: Tue Feb 20, 2007 11:13 pm    Post subject: Reply with quote

Well, I gave up on this for a while, and came back to it tonight. I followed the instructions above, and it seems to be working for me now, where it had failed earlier. I think relakks may have resolved some of their stability problems. Though about half the time I get disconnected immediately, when I do get a connection, it seems stable.

I'm still tweaking the ip-up and ip-down scripts, but I'm having much better luck.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Documentation, Tips & Tricks All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum