Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
X use flag gone?? (solved)
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Duplicate Threads
View previous topic :: View next topic  
Author Message
houtworm
Apprentice
Apprentice


Joined: 08 Mar 2003
Posts: 284
Location: Den Haag, Netherlands

PostPosted: Mon Oct 02, 2006 8:17 pm    Post subject: X use flag gone?? (solved) Reply with quote

I am trying to
emerge --newuse --update --deep world

..but now i got en error:

>>> Emerging (2 of 28) x11-libs/gtk+-2.8.20-r1 to /
* gtk+-2.8.20.tar.bz2 MD5 ;-) ... [ ok ]
* gtk+-2.8.20.tar.bz2 RMD160 ;-) ... [ ok ]
* gtk+-2.8.20.tar.bz2 SHA1 ;-) ... [ ok ]
* gtk+-2.8.20.tar.bz2 SHA256 ;-) ... [ ok ]
* gtk+-2.8.20.tar.bz2 size ;-) ... [ ok ]
* checking ebuild checksums ;-) ... [ ok ]
* checking auxfile checksums ;-) ... [ ok ]
* checking miscfile checksums ;-) ... [ ok ]
* checking gtk+-2.8.20.tar.bz2 ;-) ... [ ok ]
* Please re-emerge x11-libs/cairo with the X USE flag set

!!! ERROR: x11-libs/gtk+-2.8.20-r1 failed.
Call stack:
ebuild.sh, line 1562: Called dyn_setup
ebuild.sh, line 665: Called pkg_setup
gtk+-2.8.20-r1.ebuild, line 56: Called die

!!! cairo needs the X flag set
!!! If you need support, post the topmost build error, and the call stack if relevant.

but
#emerge --info
says

Portage 2.1.2_pre2-r1 (default-linux/amd64/2006.1, gcc-4.1.1, glibc-2.4-r4, 2.6.16-gentoo-r10 x86_64)
=================================================================
System uname: 2.6.16-gentoo-r10 x86_64 AMD Athlon(tm) 64 Processor 3200+
Gentoo Base System version 1.12.5
Last Sync: Sun, 01 Oct 2006 20:50:01 +0000
ccache version 2.4 [disabled]
app-admin/eselect-compiler: [Not Present]
dev-java/java-config: 1.3.7, 2.0.30
dev-lang/python: 2.3.5, 2.4.3-r4
dev-python/pycrypto: 2.0.1-r5
dev-util/ccache: 2.4-r6
dev-util/confcache: [Not Present]
sys-apps/sandbox: 1.2.18.1
sys-devel/autoconf: 2.13, 2.60
sys-devel/automake: 1.4_p6, 1.5, 1.6.3, 1.7.9-r1, 1.8.5-r3, 1.9.6-r2
sys-devel/binutils: 2.17
sys-devel/gcc-config: 1.3.13-r3
sys-devel/libtool: 1.5.22
virtual/os-headers: 2.6.17-r1
ACCEPT_KEYWORDS="amd64 ~amd64 ~x86"
AUTOCLEAN="yes"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-march=athlon64 -O2 -fomit-frame-pointer -pipe"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/kde/3.5/env /usr/kde/3.5/share/config /usr/kde/3.5/shutdown /usr/lib64/mozilla/defaults/pref /usr/share/X11/xkb /usr/share/config"
CONFIG_PROTECT_MASK="/etc/env.d /etc/env.d/java/ /etc/gconf /etc/java-config/vms/ /etc/revdep-rebuild /etc/terminfo"
CXXFLAGS="-march=athlon64 -O2 -fomit-frame-pointer -pipe"
DISTDIR="/usr/portage/distfiles"
FEATURES="autoconfig distlocks metadata-transfer sfperms strict"
GENTOO_MIRRORS="http://distfiles.gentoo.org http://distro.ibiblio.org/pub/linux/distributions/gentoo"
LINGUAS="nl"
MAKEOPTS="-j2"
PKGDIR="/usr/portage/packages"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --delete-after --stats --timeout=180 --exclude='/distfiles' --exclude='/local' --exclude='/packages'"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/usr/local/portage"
SYNC="rsync://<mydomain>/gentoo-portage"
USE="amd64 berkdb bitmap-fonts cli crypt cups dlloader dri elibc_glibc fortran gdbm gpm input_devices_keyboard input_devices_mouse ipv6 isdnlog kernel_linux libg++ linguas_nl ncurses nls nptl nptlonly pam pcre perl ppds pppd python readline reflection session spl ssl tcpd truetype-fonts type1-fonts udev unicode userland_GNU video_cards_ati video_cards_vesa xorg zlib"
Unset: CTARGET, EMERGE_DEFAULT_OPTS, INSTALL_MASK, LANG, LC_ALL, LDFLAGS, PORTAGE_RSYNC_EXTRA_OPTS
-------------
compiler is [6] x86_64-pc-linux-gnu-4.1.1 *


There is no X use flag?
It is really in my /etc/make/conf !
USE="3dfx 3dnow a52 aac alsa avi bash-completion \
bitmap-fonts truetype-fonts type1-fonts bzlib \
divx4linux dvd dri dvdread flac ftp gif -gnome \
gphoto2 gpm gstreamer gtk gtk2 icq java javascript \
jpeg kde kdexdeltas libwww mad -matrox mmx mozilla \
mp3 mpeg msn nls nptl nptlonly pdflib perl png python \
readline svga symlink theora truetype unicode usb win32codecs \
X xine xmms yahoo amd64"

There are use flags added and others are forgotten.
How can i get my X back?

use="X" emerge --newuse --deep --update world ..does not help either


--Kees
_________________
niemand is onbekwamer, dan een timmerman zonder hamer

Kees


Last edited by houtworm on Mon Oct 02, 2006 9:22 pm; edited 1 time in total
Back to top
View user's profile Send private message
gerdesj
Guru
Guru


Joined: 29 Sep 2005
Posts: 552
Location: Yeovil, Somerset, UK

PostPosted: Mon Oct 02, 2006 8:57 pm    Post subject: Reply with quote

If I recall correctly, this happened to me and I had to re-emerge Cairo because when it was emerged originally, it didn't have the X flag itself. After that everything else was OK

So, emerge -va cairo and make sure that it has X in the USE list.

Cheers
Jon
Back to top
View user's profile Send private message
houtworm
Apprentice
Apprentice


Joined: 08 Mar 2003
Posts: 284
Location: Den Haag, Netherlands

PostPosted: Mon Oct 02, 2006 9:13 pm    Post subject: Reply with quote

gerdesj wrote:
So, emerge -va cairo and make sure that it has X in the USE list.

Cheers
Jon


But that is just what I asked: how do i get the X use flag?
It is in make.conf, but emerge --info does not show it.
I have emerged cairo a few times but it does not help.

use=" X" emerge cairo
... doesn' t help either. I get still the error


--Kees
_________________
niemand is onbekwamer, dan een timmerman zonder hamer

Kees
Back to top
View user's profile Send private message
dleverton
Guru
Guru


Joined: 28 Aug 2006
Posts: 517

PostPosted: Mon Oct 02, 2006 9:13 pm    Post subject: Re: X use flag gone?? Reply with quote

houtworm wrote:
#emerge --info
says

Portage 2.1.2_pre2-r1 (default-linux/amd64/2006.1, gcc-4.1.1, glibc-2.4-r4, 2.6.16-gentoo-r10 x86_64)

That profile has a pretty small set of flags set by default, you might want to use default-linux/amd64/2006.1/desktop instead.

Quote:
There is no X use flag?
It is really in my /etc/make/conf !

Is that a typo? It should be make.conf

Quote:
use="X" emerge --newuse --deep --update world ..does not help either

That should be USE="X" ..., but it's not a good idea to set it on the command line, use /etc/make.conf for global settings and /etc/portage/package.use for per-package ones.
Back to top
View user's profile Send private message
houtworm
Apprentice
Apprentice


Joined: 08 Mar 2003
Posts: 284
Location: Den Haag, Netherlands

PostPosted: Mon Oct 02, 2006 9:22 pm    Post subject: Reply with quote

I think i have solved it. The USE flags from make.conf were not used because there was en error (??) in make.conf.
I have put some blank lines in it and now it worls (well.. at least emerge --info shows the X use flag :) ).
.. tomorrow I will know
_________________
niemand is onbekwamer, dan een timmerman zonder hamer

Kees
Back to top
View user's profile Send private message
desultory
Administrator
Administrator


Joined: 04 Nov 2005
Posts: 7817

PostPosted: Mon May 21, 2007 8:05 am    Post subject: Reply with quote

Moved from Portage & Programming to Duplicate Threads, refer to topic "Please re-emerge [solved]".

As noted in the handbook USE flags specified via environment variables are not retained as persistent settings so, aside from when a given USE flag setting is itself transient in nature, use one of the persistent USE flag setting methods (/etc/make.conf, /etc/portage/package.use). Also, note that USE flags are case sensitive.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Duplicate Threads All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum